#openstack-relmgr-office: ptl_sync

Meeting started by ttx at 09:02:18 UTC (full logs).

Meeting summary

  1. Heat (ttx, 09:02:22)
    1. https://launchpad.net/heat/+milestone/kilo-rc1 (ttx, 09:02:32)
    2. https://blueprints.launchpad.net/heat/+spec/convergence-push-data (ttx, 09:04:29)
    3. https://review.openstack.org/#/c/161306/ ? (ttx, 09:04:45)
    4. convergence-push-data one patch away, to be completed before EOW (ttx, 09:05:26)
    5. mistral-resources-for-heat is contrib/, not really blocking RC1 (ttx, 09:06:09)
    6. 26 bugs targeted (ttx, 09:08:40)

  2. Nova (ttx, 09:13:40)
    1. https://launchpad.net/nova/+milestone/kilo-rc1 (ttx, 09:13:46)
    2. https://blueprints.launchpad.net/nova/+spec/online-schema-changes (ttx, 09:17:30)
    3. https://blueprints.launchpad.net/nova/+spec/v3-api-policy (ttx, 09:21:19)

  3. Ceilometer (ttx, 13:00:17)
    1. https://launchpad.net/ceilometer/+milestone/kilo-rc1 (ttx, 13:00:31)

  4. Sahara (ttx, 13:10:44)
    1. https://launchpad.net/sahara/+milestone/kilo-rc1 (ttx, 13:10:50)
    2. https://blueprints.launchpad.net/sahara/+spec/add-timeouts-for-polling (ttx, 13:11:38)
    3. add-timeouts-for-polling -- one more patch, to be completed before EOW (ttx, 13:12:06)
    4. https://blueprints.launchpad.net/sahara/+spec/default-templates (ttx, 13:12:31)
    5. default-templates -- 6 easy patches, probably complete by EOW (ttx, 13:13:20)
    6. https://blueprints.launchpad.net/sahara/+spec/edp-job-types-endpoint (ttx, 13:13:34)
    7. https://review.openstack.org/#/c/166494/ looks further away (ttx, 13:14:36)
    8. edp-job-types-endpoint -- one patch almost there, one optional patch, to be completed before EOW (ttx, 13:15:10)

  5. Glance (ttx, 14:28:52)
    1. https://launchpad.net/glance/+milestone/kilo-rc1 (ttx, 14:29:03)
    2. https://blueprints.launchpad.net/glance/+spec/pass-targets-to-policy-enforcer (nikhil_k, 14:30:48)
    3. https://blueprints.launchpad.net/glance/+spec/artifact-repository (ttx, 14:31:06)
    4. artifact-repository a bit lagging, must land before next Tuesday or we'll defer (ttx, 14:34:00)
    5. https://blueprints.launchpad.net/glance/+spec/catalog-index-service (ttx, 14:34:14)
    6. catalog-index-service a bit lagging too, must land before next Tuesday or we'll defer (ttx, 14:36:08)

  6. Horizon (ttx, 14:50:06)
    1. https://launchpad.net/horizon/+milestone/kilo-rc1 (ttx, 14:50:20)
    2. https://blueprints.launchpad.net/horizon/+spec/federated-identity (david-lyle, 14:52:48)
    3. federated-identity -- late feature catch-up, ideally would merge before Tuesday next week (ttx, 14:54:55)
    4. https://blueprints.launchpad.net/horizon/+spec/django18 (ttx, 14:55:05)
    5. https://blueprints.launchpad.net/horizon/+spec/angularize-identity-tables (ttx, 14:57:17)
    6. angularize-identity-tables -- needs to be finalized before next week (ttx, 15:00:08)
    7. https://blueprints.launchpad.net/horizon/+spec/fwaas-router-insertion (ttx, 15:00:17)
    8. fwaas-router-insertion -- late feature catch-up, ideally would merge before Tuesday next week (ttx, 15:01:06)

  7. Cinder (ttx, 15:41:37)
    1. https://launchpad.net/cinder/+milestone/kilo-rc1 (ttx, 15:41:49)

  8. Neutron (ttx, 15:56:17)
    1. https://launchpad.net/neutron/+milestone/kilo-rc1 (ttx, 15:56:26)
    2. https://blueprints.launchpad.net/neutron/+spec/subnet-allocation (ttx, 15:56:54)
    3. subnet-allocation -- should land before next 1:1, reconsider if not (ttx, 15:58:12)
    4. https://blueprints.launchpad.net/neutron/+spec/hyper-v-ovs-agent (ttx, 15:58:23)
    5. hyper-v-ovs-agent -- needs to fully land by next Tuesday (ttx, 15:59:45)
    6. https://blueprints.launchpad.net/neutron/+spec/restructure-l3-agent (ttx, 15:59:54)
    7. restructure-l3-agent -- 4 patches left, finalization of a partially merged feature. should land before next 1:1, reconsider if not (ttx, 16:00:53)
    8. https://blueprints.launchpad.net/neutron/+spec/ipv6-router (ttx, 16:01:08)
    9. ipv6-router -- needs to fully land by next Tuesday (ttx, 16:02:03)
    10. https://blueprints.launchpad.net/neutron/+spec/multiple-ipv6-prefixes (ttx, 16:02:18)
    11. multiple-ipv6-prefixes -- related to previous one, needs to fully land by next Tuesday (ttx, 16:02:52)
    12. https://blueprints.launchpad.net/neutron/+spec/netscaler-lbass-v2-driver (ttx, 16:03:04)
    13. netscaler-lbass-v2-driver -- needs CI up, must merge before EOW (ttx, 16:03:54)
    14. https://blueprints.launchpad.net/neutron/+spec/radware-lbaas-driver (ttx, 16:04:03)
    15. radware-lbaas-driver -- needs CI up, must merge before EOW (ttx, 16:04:17)

  9. Trove (ttx, 16:14:46)
    1. https://launchpad.net/trove/+milestone/kilo-rc1 (ttx, 16:15:01)
    2. https://blueprints.launchpad.net/trove/+spec/db2-plugin-for-trove (ttx, 16:15:54)
    3. db2-plugin-for-trove -- must land before EOW (ttx, 16:16:56)
    4. https://blueprints.launchpad.net/trove/+spec/implement-vertica-cluster (ttx, 16:17:03)
    5. implement-vertica-cluster -- must land before EOW (ttx, 16:17:40)
    6. ACTION: SlickNik to clean up RC1 bugs to make sure they are true release blockers (SlickNik, 16:19:41)

  10. Keystone (ttx, 16:51:52)
    1. https://launchpad.net/keystone/+milestone/kilo-rc1 (ttx, 16:52:03)
    2. https://blueprints.launchpad.net/keystone/+spec/model-timestamps (ttx, 16:52:37)
    3. domain-config-ext -- to be fully merged before Tuesday next week (ttx, 16:57:04)
    4. https://blueprints.launchpad.net/keystone/+spec/idp-id-registration (ttx, 16:58:01)
    5. idp-id-registration -- to be completed before EOW (ttx, 16:58:33)
    6. https://blueprints.launchpad.net/keystone/+spec/ecp-wrapped-saml-assertions (morganfainberg, 17:05:29)
    7. ecp-wrapped-saml-assertions -- need to land before next Tuesday (ttx, 17:06:15)

  11. Swift (ttx, 17:15:13)
    1. http://goo.gl/uRzLBX (notmyname, 17:15:57)
    2. still shooting for april 10 as a guideline for swift rc1 (ttx, 17:20:07)


Meeting ended at 17:21:51 UTC (full logs).

Action items

  1. SlickNik to clean up RC1 bugs to make sure they are true release blockers


Action items, by person

  1. SlickNik
    1. SlickNik to clean up RC1 bugs to make sure they are true release blockers


People present (lines said)

  1. ttx (357)
  2. morganfainberg (80)
  3. mestery (55)
  4. johnthetubaguy (40)
  5. david-lyle (33)
  6. asalkeld (26)
  7. notmyname (18)
  8. nikhil_k (17)
  9. eglynn (16)
  10. SergeyLukjanov (16)
  11. SlickNik (14)
  12. openstack (8)
  13. thingee (3)


Generated by MeetBot 0.1.4.