14:00:49 <seanhandley> #startmeeting publiccloud-wg
14:00:50 <openstack> Meeting started Wed Aug 30 14:00:49 2017 UTC and is due to finish in 60 minutes.  The chair is seanhandley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <openstack> The meeting name has been set to 'publiccloud_wg'
14:01:11 <seanhandley> Can folks please add their names to the participants on the Etherpad:
14:01:13 <seanhandley> #link https://etherpad.openstack.org/p/publiccloud-wg
14:02:12 <seanhandley> Hopefully Howard will be back shortly
14:02:49 <seanhandley> Are you joining us adriant ?
14:02:51 <tobberydberg> Is it vacation time?
14:03:13 <seanhandley> Yeah, I guess school Summer holidays for most people in August
14:03:47 <seanhandley> #topic Review Action Points
14:03:49 <tobberydberg> ok ok
14:04:12 <seanhandley> So there were no APs last meeting but some from before that still need attention
14:04:14 <hogepodge> o/
14:04:22 <seanhandley> hi Chris o/
14:04:30 <tobberydberg> welcome!
14:04:34 <seanhandley> Glad you could join us :)
14:04:42 <seanhandley> Etherpad is here: https://etherpad.openstack.org/p/publiccloud-wg
14:05:18 <hogepodge> Thank you!
14:05:23 <lsell> Sorry I'm late...also joining from the Foundation staff team with Chris and Anne
14:05:50 <seanhandley> no worries - happy to have you all here with us :)
14:06:25 <seanhandley> One previous AP that I need to work on is an initial spec for how the passport tokens might work, but given recent discussion we should probably save that for the time being
14:06:42 <seanhandley> So I think we should move straight on to point 2
14:06:47 <seanhandley> #topic Passport Scheme
14:06:53 <tobberydberg> agree
14:07:12 <seanhandley> So, welcome annabelleB hogepodge and lsell
14:07:27 <seanhandley> I'm going to be proxying Flanders a little here, since it's so late at night in Australia
14:07:51 <seanhandley> I'll dig out the slides he shared via email
14:07:51 <pilgrimstack> o/
14:08:14 <seanhandley> #link https://docs.google.com/presentation/d/1Y2_TiSjElnPdNvVtIsco2_PVTtfKdZDMtvL5mmW6E7A/edit#slide=id.g1fc89766ca_0_2
14:08:19 <tobberydberg> nice to have you here pilgrimstack =)
14:08:37 <seanhandley> hey zhipeng o/
14:08:45 <tobberydberg> Please put your name at the etherpad
14:08:49 <zhipeng> hey seanhandley o/
14:09:00 <seanhandley> You too lsell and pilgrimstack ^
14:09:39 <seanhandley> Has everyone seen the slides that Flanders put together about the passport scheme ?
14:09:56 <yankcrime> o/
14:10:09 <seanhandley> hey yankcrime o/
14:10:18 <tobberydberg> yes, have seen that =)
14:10:23 <yankcrime> hi!
14:10:58 <seanhandley> So
14:11:16 <seanhandley> the goal is to launch the initial simple version of this scheme at Sydney
14:11:29 <seanhandley> This will take the form of a page at openstack.org/passport
14:11:41 <seanhandley> which will list participating public clouds
14:11:51 <seanhandley> the listing will hook up to those cloud's freemium account pages
14:12:10 <seanhandley> and we'll have some rough guidelines for the content of those pages themselves to keep it all consistent and sane
14:12:25 <zhipeng> sounds about that
14:13:04 <pilgrimstack> sounds good to me
14:13:15 <lsell> I'm definitely on board with this approach, because from Foundation perspective, we want to put a spotlight on OpenStack public clouds, and this gives us a tangible program to promote
14:13:26 <lsell> It will also help us gauge interest to see how we want to carry the program forward
14:14:01 <seanhandley> indeed
14:14:17 <seanhandley> One thing I'll add to the etherpad is we want some analytics data from those freemium account pages
14:14:27 <seanhandley> and that needs to be fed back to the foundation
14:14:53 <seanhandley> So how will that be achieved technically? Does the Foundation have a set of scripts it wants public clouds to drop into their pages?
14:16:02 <annabelleB> That’s one why to do it, but that can get a bit messy when we’ve tried that in the past. I might propose that we get the PCs to send us a weekly report? Pros and cons to both approaches, but the later requires them to stay active with us?
14:16:09 <hogepodge> It's not to say the federated billing isn't important or a goal, it just puts the program front in center in a way that encourages early participation.
14:16:16 <lsell> That's a good question. I was originally thinking we might track it like we track the outbound links in our commercial marketplace, which would basically give us visibility into how people are going from the o.o/passport landing page out to the providers
14:16:56 <annabelleB> Yes, we can see the exits on our side, we just can’t see any further behavior once they’re on the landing page
14:16:58 <lsell> It would also be nice to get data back from providers, weekly might be a bit of a high bar, but regularly would be nice :)
14:17:45 <seanhandley> ok, that makes sense
14:17:50 <zhipeng> the bottom line is that this analytics won't create security holes in participating PCs
14:17:59 <zhipeng> or legal ones
14:17:59 <seanhandley> so analytics on openstack.org for the outbound links
14:18:13 <lsell> I also want to make sure that asking providers to launch a new landing page is feasible if they have existing freemium offerings they want to promote via the program. Asking them to launch a new landing page with tracking in two months might be a hurdle, but y'all would probably know best
14:18:14 <tobberydberg> With the way we thought the scheme to work we will get some initial feedback at which cloud the code is registered...
14:18:17 <seanhandley> then the expectation is for the public clouds to engage with the foundation re: signups
14:18:56 <seanhandley> it'll be easier to track when we introduce a technical solution with codes
14:19:01 <pilgrimstack> analytics is too far away from the first goal I think, let's keep that for steps 3 or 4 I think
14:19:08 <seanhandley> because those codes will be redeemed via a service the foundation is in control of
14:19:28 <seanhandley> but for now, it has to be more of a manual sharing of info between PCs and the foundation itself
14:19:46 <seanhandley> I think the Foundation wants to see interest pilgrimstack
14:19:56 <seanhandley> so it's clear if the passport scheme is viable
14:20:08 <seanhandley> is that correct folks?
14:20:31 <pilgrimstack> seanhandley: Yep, The first proposal from lsell should be enought to start
14:20:38 <zhipeng> agree
14:20:40 <seanhandley> ok
14:20:47 <seanhandley> let's move on then
14:20:51 <zhipeng> let's start with bare minimum and build upon that
14:20:52 <tobberydberg> +1
14:20:55 <pilgrimstack> +1
14:21:27 <seanhandley> lsell: Regarding making these public clouds create new freemium pages on their domains
14:21:30 <rmart04> +1
14:21:58 <pilgrimstack> so what this landing page should do ?
14:22:08 <seanhandley> Great question pilgrimstack
14:22:16 <tobberydberg> Regarding that, last meeting we had a call for PCs to signup to commit to do that before Sydney
14:22:27 <lsell> Ah ok, that's good to know
14:22:27 <tobberydberg> Also, what it should consist of
14:22:33 <pilgrimstack> register a new account and create a openstack tenant ?
14:22:44 <seanhandley> I can see the value in having a specific freemium page that mentions the scheme
14:22:48 <pilgrimstack> + Provisionning credit of course
14:22:52 <tobberydberg> look a little bit further down at the ether..
14:22:54 <seanhandley> it reinforces the customer UX
14:22:59 <lsell> I can definitely see the value...I was just worried because if I went to my web team right now with a new project that needed to be launched before Sydney they might shoot me :)
14:23:09 <lsell> That said..this passport program page is in the queue, so no worries :)
14:23:20 <seanhandley> hehe, well that's good then :)
14:24:01 <seanhandley> Regarding openstack.org/passport - are we willing to launch it without any public clouds on it and a "Coming Soon" sort of message?
14:24:07 <zhipeng> i think for start we could just provide a summary of the participating PC's current promo schems at the moment
14:24:18 <zhipeng> of course those are related to Open Passport
14:24:21 <seanhandley> or do we only want it world visible once we have agreed participation from a number of clouds?
14:24:31 <zhipeng> we could indicate that by Vancouver we want to have a single entrance
14:24:37 <zhipeng> and federate billing
14:25:16 <lsell> I would suggest we wait and launch it once we have it set up, and not make promises for the future until we start making progress in that direction...
14:25:27 <seanhandley> Ok
14:26:09 <seanhandley> So one thing we should discuss is what the guidelines for the freemium pages should be
14:26:14 <lsell> Just logistically, we're probably not going to be able to focus on building out a page until we get through the PTG, but I also think it's something we can really "launch" at Sydney if that makes sense...work with all of the participating companies to put together a press release, promote, advertise, etc.
14:27:22 <seanhandley> I guess the Freemium page should have consistent branding at least - maybe even an OpenStack-Powered style image somewhere
14:27:41 <zhipeng> yes agree
14:27:49 <lsell> Yes, that would be nice
14:28:05 <rmart04> sounds good
14:28:37 <seanhandley> "OpenStack Passport Partner" or something :)
14:29:04 <seanhandley> We're not going to get very far by making stipulations about how their freemium accounts should work at this stage
14:29:11 <seanhandley> because they'll all be slightly different
14:29:14 <tobberydberg> +1
14:29:59 <pilgrimstack> +1
14:30:00 <seanhandley> so I don't know what other guidelines to enforce for those freemium pages, really.
14:30:03 <seanhandley> Any ideas?
14:30:16 <lsell> Well, I am curious how much you think the sign up process/requirements differ among each provider...our team has signed up for a couple of different trial programs, and some seem super easy while others are a bit more cumbersome.
14:31:14 <pilgrimstack> This should include the quickest steps to register an account and start with a tenant with some creadit
14:31:45 <tobberydberg> Should we really interfere with how each cloud would like to design the signup process?
14:31:57 <zhipeng> at the first stage the signup should be something like an intent of participation, should be enough
14:31:57 <zhipeng> when we work out the federated system, then we could actually enforce freemium setups and so forth
14:31:57 <zhipeng> pilgrimstack yes that makes sense
14:31:57 <zhipeng> so for guideline, at the moment may each PC should have a dedicated promo page for open passport
14:32:03 <zhipeng> and have the logo on the web page
14:32:06 <lsell> I don't think we can interfere, but I do want to make sure we're promoting good experiences
14:32:14 <pilgrimstack> @OVH this means creating an OVH account, ordering a public cloud project (the tenant) and inject the credit
14:32:24 <zhipeng> signup left to each provider at the moment
14:32:28 <tobberydberg> ok lsell agree with that
14:33:02 <seanhandley> I guess this page could at least give simple instructions for how to sign up
14:33:09 <seanhandley> and then a button to click to begin that process
14:33:21 <tobberydberg> Yes, bare minimum
14:33:35 <seanhandley> then longer term we can make expectations for signup flow
14:33:41 <pilgrimstack> seanhandley: as a very first step I think it's easy for everybody
14:33:47 <zhipeng> or each PC have a button so after clicking it goes to the specific program ?
14:34:04 <seanhandley> ok - so the freemium page just gives clear instructions - it doesn't change any established UX
14:34:19 <lsell> +1
14:34:26 <tobberydberg> +1
14:34:32 <seanhandley> Simple enough!
14:34:43 <lsell> we can just distribute a logo/graphic and some language to use on each landing page
14:34:57 <zhipeng> lsell +1
14:34:58 <rmart04> +1 (I’d expect providers are already trying to streamline their setup processes as best they can!)
14:34:59 <seanhandley> Perfect lsell
14:35:00 <seanhandley> +1
14:35:10 <lsell> agree about not having requirements for sign up process, but i think this team does need some criteria or grounds to reject a provider if it's just a terrible experience....
14:35:20 <annabelleB> +1
14:35:34 <tobberydberg> +1
14:35:38 <seanhandley> +1
14:35:39 <hogepodge> +1
14:36:03 <seanhandley> Do we have a metric for how terrible the UX is?
14:36:07 <seanhandley> Or will this be a value judgement?
14:36:10 <zhipeng> no dedicated open passport landing page ?
14:36:10 <zhipeng> if a provider just randomly point it to something
14:36:10 <zhipeng> then it should get rejected
14:36:22 <lsell> so as we're reaching out to our public cloud provider database, we can say "here's how you participate, but please note we'll be testing your program to ensure it meets quality..." (something better worded than that)
14:37:08 <seanhandley> Ok, that needs defining
14:37:10 <annabelleB> I don’t think they need to have a dedicated passport page, but they need to have a clear “Sign up for a free trial here” page
14:37:31 <seanhandley> and it's clear someone will need to act as a gateway for who we accept and who we don't accept
14:37:56 <zhipeng> i'm thinking David ? :P
14:38:16 <hogepodge> I would suggest a Foundation staff member along with one or two members of this working group, to make sure it's community driven.
14:39:00 <seanhandley> Ok. I'm happy to help, as I'm sure are my co-chairs zhipeng and tobberydberg :)
14:39:05 <lsell> Agree, Foundation can be neutral because you don't want it to turn into a political or competitive thing, but we definitely need this team to weigh in and help make a judgment call
14:39:15 <rmart04> I’d hope that if PC’s are spending the time to get involved in this process they aren’t going to be sending people in circles once they try to signup but agree that it should be well defined…
14:39:36 <tobberydberg> Some page that meets the requirements for a good UX, mentioning something like "OpenStack Passport Partner" or logo etc
14:39:54 <seanhandley> We're nearly 40 mins in so let's think of some action items :)
14:40:36 <seanhandley> lsell hogepodge annabelleB: How were you thinking we'd reach out to people about the scheme?
14:40:57 <seanhandley> Email?
14:41:08 <seanhandley> when I say people, I mean public clouds
14:41:21 <tobberydberg> I believe that most important is to get some basics up describing what we are saying here, so that it's clear for all whats the latest
14:41:45 <zhipeng> ++
14:41:55 <tobberydberg> seanhandley: of course happy help out there as well
14:42:07 <zhipeng> a mission statement paragraph on PCWG wiki ?
14:42:17 <tobberydberg> ...and with getting that first version up...
14:43:09 <lsell> Danny Carreno on Foundation team has a database of all the public cloud providers we have relationships with (as foundation sponsors, in the marketplace, etc.). I think we should basically draft an email in an etherpad that he can send to all of the providers to start recruiting. We just need to figure out the immediate call to action and deadline for them to participate
14:43:40 <tobberydberg> +1
14:43:44 <seanhandley> +1
14:44:01 <tobberydberg> And, a good desciption of what they are supposed to signup for =)
14:44:13 <rmart04> +1
14:44:35 <lsell> I believe there are about 25 providers, and I would be very happy if we even just had 4-5 on board for launch...but it's a good practice to give everyone a heads up. I have a feeling there are some public cloud folks who don't even know about this working group
14:44:52 <yankcrime> is the foundation's long-term expectation that customers would continue to buy credit via the passport scheme to use with participating public cloud providers?
14:45:15 <hogepodge> Would announcing a cfp on a mailing list be a good way to make sure that everyone has a chance to hear?
14:45:17 <lsell> Not necessarily, no
14:45:29 <pilgrimstack> when we deal OVH vouchers, we have 2 kind of vouchers. 1. No Credit Card required but we delete the ressource at the end, 2. Credit Card required and the user can keep his ressources after the credit expiration
14:45:41 <tobberydberg> AP: seanhandley zhipeng and myself to have that description up by next meeting ??
14:45:41 <seanhandley> #action Draft an email inviting a public cloud to participate in the scheme https://etherpad.openstack.org/p/passport-scheme-email-draft
14:45:42 <lsell> (my no was for yankcrime)
14:45:44 <seanhandley> #link https://etherpad.openstack.org/p/passport-scheme-email-draft
14:45:58 <lsell> +1 mailing list
14:46:01 <seanhandley> tobberydberg: sounds good :)
14:46:05 <yankcrime> thanks lsell
14:46:22 <pilgrimstack> do you also have this both kind of vouchers?
14:46:33 <zhipeng> let's draft the email first, then hit ml and individual PCs at the same time
14:46:43 <tobberydberg> #action seanhandley zhipeng and myself to have description of passport up by next meeting
14:46:53 <seanhandley> +1 zhipeng
14:47:07 <seanhandley> I'd imagine a lot of the public clouds don't follow the mailing lists very closely
14:47:19 <seanhandley> or perhaps their tech teams do and their management teams don't
14:47:53 <yankcrime> for sure they don't, i can think of at least one that will be unaware of this passport work (but which will want to participate)
14:48:03 <tobberydberg> They don't, and hard to do as well... Think the best way is via lsell and the DB of PCs
14:48:26 <lsell> Should our goal be to distribute the email early next week? Monday is a holiday in the US, but we could go Tuesday or Wednesday
14:48:34 <pilgrimstack> to simplify my question, will you take the credit card of the user before opening the tenant ? because that's a big question for us
14:48:57 <lsell> that is a good question
14:49:23 <seanhandley> I don't think it matters pilgrimstack - not at this stage
14:49:34 <hogepodge> I prefer to not require a credit card, because it's a real barrier to entry. I understand the desire to convert users to paying customers.
14:49:35 <seanhandley> credit card verification is a reasonable anti fraud measure
14:49:40 <seanhandley> particularly with free accounts
14:49:44 <hogepodge> There's that too.
14:49:53 <zhipeng> i think if we offer promo code, credit card should not be required
14:50:04 <tobberydberg> Think that will have to be left for each PC
14:50:09 <seanhandley> hogepodge: You should see how many of our signups drop off at credit card entry stage :D
14:50:12 <yankcrime> hogepodge: too many bad actors out there to do otherwise
14:50:16 * yankcrime nods
14:50:25 <zhipeng> and seanhandley do we require SSO with openstack foundation id ?
14:50:27 <seanhandley> ok back to what you said lsell
14:50:43 <seanhandley> I think aiming to mail out next week could work just fine
14:51:00 <seanhandley> I think there'll need to be some collaboration on the etherpad link I shared above
14:51:09 <seanhandley> and some communication between the foundation and this WG
14:51:09 <lsell> OK, we'll also try to work on a proposed timeline between now and Sydney in the same etherpad
14:51:29 <seanhandley> should I contact you regarding the mailout next week lsell ?
14:51:46 <lsell> Yes, that would be great. I want to get buy in on the email and timeline from this group before we pull the trigger
14:52:05 <seanhandley> if the text is ready then the Foundation can mail out to its list - then the WG can announce to the mailing lists ?
14:52:10 <seanhandley> perfect
14:52:20 <lsell> yes, that sounds great
14:52:41 <tobberydberg> We don't need a clear description of the "OpenStack Passport" before sending the email?
14:52:42 <seanhandley> I'll get in touch with you Monday via your foundation address :-)
14:52:52 <seanhandley> #action Sean to contact Lauren re: mailout text
14:53:00 <seanhandley> tobberydberg: We definitely do :)
14:53:14 <yankcrime> tobberydberg i think we do, as well as clear goals / aims
14:53:17 <seanhandley> tobberydberg: And you're on vacation
14:53:20 <lsell> tobberydberg ideally this email will be a forcing function to get these descriptions documented
14:53:35 <tobberydberg> ok....that basically count me out, just so you know, since I'm not back from vacation until Tuesday next week
14:53:53 <lsell> we can also push it back a week, i'm just cognizant that it's almost September (yikes!) so we basically have two months
14:54:17 <lsell> how about we plan for the following Monday to distribute emails then?
14:54:32 <seanhandley> Monday 11th?
14:54:43 <seanhandley> Sound better tobberydberg ?
14:54:52 <lsell> Yes. We'll be at the PTG, but it shouldn't be hard to just hit send if we get the content worked out next week
14:54:55 <tobberydberg> Like that better yes
14:55:01 <seanhandley> Ok
14:55:18 <seanhandley> Once again, I've made an etherpad for drafting that: https://etherpad.openstack.org/p/passport-scheme-email-draft
14:55:22 <tobberydberg> we can work out the email in parallel
14:55:48 <lsell> perfect
14:56:22 <seanhandley> ok
14:56:23 <tobberydberg> (of topic ... with everything in the going here ... meeting every week until Sydney? )
14:56:35 <seanhandley> we're nearly out of time and I feel like we still have lots to talk about
14:57:04 <lsell> i'm fine with that, but next week i will be on a plane at this same time, just as a heads up
14:57:23 <seanhandley> no problem lsell
14:57:41 <seanhandley> #openstack-publiccloud is probably the best place for this
14:57:58 <tobberydberg> +1
14:57:58 <seanhandley> and +1 to weekly meetings about it, even if it's just a 10 minute catch up
14:58:01 <hogepodge> I can make next week (my plane is in the afternoon).
14:58:10 <seanhandley> We still need to decide on the agenda for the fishbowl at OpenStack Days UK next month but we can save that for next WG meeting in 2 weeks
14:58:25 <lsell> oh, and i'll be at openstack days UK!
14:58:36 <seanhandley> Awesome :D
14:58:38 <tobberydberg> #action tobberydberg to suggest weekly meetings instead of bi-weekly metings
14:59:14 <tobberydberg> Nice to here that lsell =)
14:59:19 <seanhandley> Ok, we're out of time - there's usually another meeting right after this one
14:59:32 <lsell> I also just want to say a HUGE thank you to all of you...I really love these ideas, and you've done an amazing job putting it together. I know you have super busy day jobs, and we really appreciate it
14:59:40 <tobberydberg> Good work seanhandley!
14:59:42 <seanhandley> I'll be around for a while in #openstack-publiccloud if anyone wants to talk more about this right away
15:00:02 <seanhandley> Thanks lsell - I'm really excited about the scheme
15:00:08 <tobberydberg> I can stay for a couple of minutes
15:00:15 <seanhandley> and I'm really pleased that the Foundation is getting behind it
15:00:31 <seanhandley> thanks again lsell hogepodge and annabelleB for joining us today
15:00:32 <tobberydberg> Agree with seanhandley!
15:00:42 <zhipeng> lsell we could take this offline, but quick question on our EU meetup series
15:00:47 <annabelleB> absolutely! looking forward to working with you all
15:00:49 <zhipeng> could foundation do a promotion on that ?
15:01:00 <seanhandley> #endmeeting