14:01:53 <tobberydberg> #startmeeting publiccloud_wg
14:01:53 <openstack> Meeting started Thu Jun  7 14:01:53 2018 UTC and is due to finish in 60 minutes.  The chair is tobberydberg. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:57 <openstack> The meeting name has been set to 'publiccloud_wg'
14:02:03 <tobberydberg> Hi aprice !
14:02:27 <aprice> Hello!
14:02:29 <tobberydberg> So, who's around?
14:03:23 <mnaser> o/
14:03:33 <mnaser> (looks like my conflict is no longer one..)
14:03:43 <tobberydberg> whoop whoop =)
14:04:05 <tobberydberg> https://etherpad.openstack.org/p/publiccloud-wg
14:04:12 <tobberydberg> agenda ^^^
14:04:48 <tobberydberg> I hope that a few more pops in during the meeting here
14:05:25 <tobberydberg> #topic 1. Recap Vancouver Summit
14:06:18 <tobberydberg> Well .. all of you here were in Vancouver so probably pretty aware of what happened there ... but will mention a few things for the record
14:07:04 <tobberydberg> I think that we had pretty good interest around all our Forum sessions in general
14:07:34 <tobberydberg> A lot of PTLs and cores interesting in the "missing features list"
14:08:07 <tobberydberg> Got some feedback how we can do that even better, which was good
14:08:26 <tobberydberg> #link to that session: https://etherpad.openstack.org/p/YVR-forum-missing-features-pc
14:08:41 <mnaser> ++
14:08:52 <mnaser> it was a great session
14:08:54 <tobberydberg> Got some more comments to the items at launchpad as well
14:09:16 <tobberydberg> Yea, I was surprised
14:09:19 <pilgrimstack> hi
14:09:25 <tobberydberg> welcome pilgrimstack
14:09:46 <pilgrimstack> double meeting once again for me, I'm partially with you guys, sorry
14:09:54 <pilgrimstack> hi tobberydberg
14:09:59 <tobberydberg> Also, a lot of interest around the passport, which is good and motivating to take the next step there
14:10:37 <tobberydberg> Forum session #link for that: https://etherpad.openstack.org/p/YVR-forum-passport-program
14:11:56 <tobberydberg> One thing that became pretty clear was that we need to come to a conclusion on our way forward, define the use case, then choose technique for how to solve the problem
14:12:39 <mnaser> indeed
14:12:49 <mnaser> i feel like we havent progressed much a little bit since then :(
14:13:18 <tobberydberg> no, basically nothin
14:14:37 <tobberydberg> that leads me into the next topic ... if we don't have any questions
14:15:33 <mnaser> i just hope that we can move with a potential target/solution
14:16:09 <tobberydberg> thats the next topic - so good =)
14:16:18 <tobberydberg> #topic 2. Passport program - way forward
14:17:07 <tobberydberg> So, we have an "old" spec that was created after the OpeStack Days UK
14:17:12 <tobberydberg> #link Passport program - way forward
14:17:20 <tobberydberg> oops
14:18:16 <tobberydberg> #link https://git.openstack.org/cgit/openstack/publiccloud-wg/tree/doc/source/passport_program.rst
14:19:52 <tobberydberg> This was written before the programs release and based on the discussions that took place there. My suggestion is that we rewrite this and propose the "new" definition (use case) for the Passport Program
14:20:14 <aprice> +1
14:20:27 <tobberydberg> Then we can collect the feedback there, discussion the use case spec there so it feels more official
14:20:33 <aprice> and I think that will transition nicely into revamping the website language per mnaser's feedback
14:21:22 <tobberydberg> Yes, absolutely. The wording feedback should be reflected in the definition in the spec as well
14:21:58 <aprice> agreed
14:22:45 <tobberydberg> I hope to be able to pull that off until next meeting in 2 weeks...might need help though, have pretty much on the agenda upcoming weeks
14:22:55 <aprice> im happy to help with that
14:23:03 <tobberydberg> Awesome, thanks!
14:23:13 <mnaser> thank you aprice
14:23:50 <tobberydberg> I setup an etherpad and post a draft there and then we (and everyone that wants to help put) can collaborate there
14:24:29 <tobberydberg> #action tobberydberg to setup etherpad for passport spec draft and post draft in 2 weeks
14:24:42 <aprice> sounds good!
14:25:19 <tobberydberg> What do we want in that spec? Do we want tech solution at all?
14:25:34 <tobberydberg> Or just the use case we are trying to solve?
14:25:47 <aprice> I think that it should start with the use case and goal of the program
14:25:58 <tobberydberg> +1
14:26:00 <aprice> and once we get folks to weigh in, we can dig into the technical specs
14:26:14 <tobberydberg> sounds good
14:27:33 <tobberydberg> I'll talk to Darcy and Howard as well so that they know what is going on here
14:28:56 <tobberydberg> A lot of the good use of the PP is a little bit on hold on the coupon solution .... thinking about the meetup group handouts etc
14:29:08 <tobberydberg> So, would be really neat to have that in place to Berlin
14:29:41 <aprice> yeah, the program came up again in the user community leadership forum session
14:30:01 <mnaser> i think handouts are a bit hard
14:30:07 <mnaser> because as a provider i don't know where they'll end up
14:30:28 <mnaser> heck, they might end up on some online forum with someone signing up and using it to mine crypto :)
14:30:38 <mnaser> so there's a it of a harder way of tracking things of whats going on
14:30:43 <tobberydberg> single coupon codes
14:30:51 <tobberydberg> not worse than offer trial
14:30:57 <tobberydberg> one code only valid once
14:31:01 <jamesmcarthur> Right - I think the idea was a one time use.
14:31:12 <mnaser> i guess it comes down to is it self-serve or is it vetted
14:31:26 <mnaser> because a coupon feels to me like it would be self-serve making it harder to know about bad stuff(tm) only after the fact
14:31:35 <mnaser> i
14:31:50 <mnaser> i'd be okay with it as long as we have some sort of clear agreement with those who hand them out i guess
14:32:07 <tobberydberg> Agreed
14:32:23 <tobberydberg> Should make sense where to hand them out
14:32:45 <mnaser> ++
14:33:32 <tobberydberg> Liked the feedback from the us meetup group
14:33:42 <tobberydberg> they put in a lot of work into that
14:34:44 <jamesmcarthur> you could also capture user info and ask them to opt-in to communications so you could follow up after they use the coupon code
14:34:52 <mnaser> jamesmcarthur: that is a good idea too
14:34:56 <tobberydberg> I totally agree with them, at the high level, that you should get a good experience of using openstack no matter what member you pick
14:35:19 <tobberydberg> ++ jamesmcarthur
14:36:41 <tobberydberg> but, that's pretty hard ... but I believe that we should put together a list of requirements that you need to fulfil to be in the program
14:36:59 <tobberydberg> Know we had, but we haven't been good at following up o them
14:38:03 <tobberydberg> Filtering on foundation homepage is one thing that can make the fit better, but the feeling of openstack is more than that
14:38:34 <tobberydberg> We talked about "Powered" requirement. Thoughts around that?
14:44:51 * mnaser shrugs
14:45:10 <mnaser> i don't recall this, i recall discussing the idea of the requirement of being a corporate member
14:45:48 <aprice> mnaser: i can clarify
14:46:18 <aprice> to be considered a powered cloud, there are a set of requirements. To date, one of those has been to be a Foundation corporate member, but we have worked with providers who are unable to fulfill that requirement
14:46:38 <aprice> so that's just one of the criteria in addition to testing that Chris Hoge from our team runs.
14:46:46 <mnaser> oh i see
14:47:41 <aprice> since we collect so much information on the Powered clouds for the public cloud marketplace, the idea was to encourage the Passport members to be Powered so that the criteria we collect (what version of OpenStack they're running among many) are options for filter on the passport page
14:47:44 <tobberydberg> Yups, we discussed this and the corporate member part is the part that doesn't make sense in this case
14:48:40 <mnaser> ++
14:48:44 <mnaser> maybe as an intermediate
14:48:48 <tobberydberg> the rest would be perfect for PP members ... both when it comes to Chris tests and the information that is collected about the clouds
14:48:53 <mnaser> maybe we can add something like
14:49:03 <mnaser> "passport enabled" as a field for starters
14:49:05 <mnaser> that you can filter on
14:51:08 <aprice> yeah, and I think that this goes back to the goal of the program which we need to figure out. because i think that once we agree on that direction, we will have a better sense of how we want to filter / represent participants
14:51:08 <tobberydberg> in the markeplace you mean=
14:51:41 <mnaser> yes tobberydberg
14:51:55 <tobberydberg> Did you and danny get a task to look into this aprice?
14:51:57 <mnaser> so looking through the marketplace, we can have users maybe filter based on those that are part of passport program
14:52:34 <aprice> tobberydberg: to look into which piece?
14:52:55 <tobberydberg> thats a good idea to internally market at o.o the program as well
14:53:08 <pilgrimstack> my input about "Powered" or not: in the best situation, that would be great and assure the community that we offer an similar experience (at least on the APIs) to the use, the fact is we (OVH) were certified, and now we don't pass the current requirement
14:53:32 <tobberydberg> "something" regarding the requirements etc fo be part of powered... Let me see if I have more notes around that
14:53:52 <tobberydberg> Might be that I don't remember correct
14:53:56 <pilgrimstack> so if the passport program requires a powered certification, we'll lose some public cloud actors
14:54:27 <aprice> tobberydberg: ah yes, he and I can look into that today.
14:55:22 <tobberydberg> yep, now ... we do the same from time to time ... and all tests are not really applicable for a public cloud either - admin things and ceilometer stuff
14:55:51 <tobberydberg> not sure about how the latest tests and how those looks though
14:56:02 <tobberydberg> thanks aprice
14:56:48 <aprice> i think that's a bigger convo and jamesmcarthur and I can talk to Chris about how that's planning to evolve.
14:57:13 <tobberydberg> Need to very soon run into a meeting here. If someone wan't to continue discuss this at some other time soon, let me know and we can schedule something
14:57:27 <tobberydberg> awesome aprice
14:57:56 <aprice> ill see if Chris and Danny can join the next PCWG meeting so we can have a bigger discussion
14:58:11 <jamesmcarthur> tobberydberg: can you send us the exact things you think are not appropriate for Public Cloud?
14:58:11 <tobberydberg> ++ aprice
14:58:47 <jamesmcarthur> I'd like to make sure Chris and Danny are armed with that before the next meeting.
14:59:27 <tobberydberg> I can look into that jamesmcarthur ... unfortunately I haven't been taking notes of it, but lets see what I can find
14:59:54 <tobberydberg> Thanks for today folks! Need to run here! Lets talk more soon!
15:01:22 <tobberydberg> #endmeeting