14:01:29 <sbadia> #startmeeting Puppet-Openstack
14:01:30 <openstack> Meeting started Mon Nov 17 14:01:29 2014 UTC and is due to finish in 60 minutes.  The chair is sbadia. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:33 <openstack> The meeting name has been set to 'puppet_openstack'
14:01:42 <sbadia> #chairs sbadia crinkle
14:01:46 <nibalizer> o/
14:01:53 <sbadia> nibalizer: \o
14:02:04 <sbadia> #topic Juno branching
14:02:30 <sbadia> To summarize, we had some discutions the last week about juno branching in our modules
14:02:47 <sbadia> (a thread on puppet-openstack ML)
14:03:12 <sbadia> we still miss some packages in debian and redhat for testing juno (before branching)
14:03:31 <sbadia> and some udpate of configuration files are still in progress (reviews)
14:03:43 <sbadia> (sorry missed the agenda…)
14:03:51 <sbadia> #link https://wiki.openstack.org/wiki/Meetings/PuppetOpenStack
14:04:31 <crinkle> I remember EmilienM saying that we want to have integration tests ready before the juno release
14:04:41 <sbadia> yep, +1
14:05:20 <nibalizer> so how long between the branch and the release?
14:05:33 <nibalizer> because integration tests (or at least my version of it) is still not ready
14:05:47 <sbadia> it was just to talk about it, but so we have some sticking points before
14:05:55 <sbadia> (packaging)
14:05:57 <crinkle> i thought the branch and the release would happen at the same time?
14:06:11 <nibalizer> okay
14:06:16 <crinkle> but not sure
14:06:17 <nibalizer> crinkle: thats what i thought too
14:06:30 <sbadia> there is no time constraints
14:06:35 <sbadia> > 6months :-D
14:06:39 <sbadia> <
14:06:43 <crinkle> i think there are packages for rhel 7 and ubuntu, not sure about rhel 6
14:07:03 <sbadia> gchamoul: an idea about rhel6 ?
14:08:02 <sbadia> anyway here is the pending review for juno conf files
14:08:06 <sbadia> #link https://review.openstack.org/131566
14:08:16 <sbadia> #link https://review.openstack.org/131576
14:08:24 <sbadia> #link https://review.openstack.org/131572
14:08:26 <gchamoul> I don't we will support Juno on RHEL6
14:08:34 <gchamoul> know !
14:08:40 <crinkle> oh okay
14:08:57 <gchamoul> we are discussing about that internally
14:09:04 <gchamoul> but don't have any clue
14:09:41 <sbadia> gchamoul: okay
14:11:31 <sbadia> #action take a look about params updates in juno (if everything was covered by previous review)
14:11:37 <sbadia> ok, next point?
14:11:51 <crinkle> sure
14:12:06 <sbadia> #topic Service validation
14:12:21 <nibalizer> i think EmilienM may be in a plane
14:12:37 <gchamoul> nibalizer: right he is !
14:12:45 <sbadia> EmilienM just submitted a new interseting patchset
14:12:52 <sbadia> Yep indeed :-)
14:13:55 <sbadia> #link https://review.openstack.org/126458
14:14:06 <sbadia> comment are welcome…
14:15:04 <sbadia> ok :) everyone sleep
14:15:13 <crinkle> haha
14:15:34 <crinkle> I think I like the hash approach
14:15:43 <crinkle> would be interested in mgagne's thoughts
14:16:06 <sbadia> yep me too!
14:16:15 <sbadia> arg mgagne isn't here…
14:16:57 <sbadia> ok, we will discuss in the review then…
14:17:20 <sbadia> can I add a topic about service_ensure patchs ?
14:17:34 <crinkle> sure
14:18:01 <sbadia> #Topic manage_service (bug 1359823)
14:18:02 <uvirtbot> Launchpad bug 1359823 in puppet-swift "Possibility to disable service management" [Undecided,In progress] https://launchpad.net/bugs/1359823
14:18:18 <sbadia> #link https://review.openstack.org/#/c/115659/
14:20:01 <crinkle> I had a comment on one of those...
14:20:13 <sbadia> to summarize, we have some patch already merged about 1359823
14:20:30 <sbadia> but indeed your comment, and spredzy comment are interesting
14:20:55 <crinkle> I'm in agreement with spredzy
14:20:55 <spredzy> hey everyone, sorry no backlog on this room, sbadia could you paste a litle bit of context please :)
14:21:09 <sbadia> spredzy: sure!
14:22:42 <spredzy> sbadia, thanks
14:23:31 <sbadia> patchs in ceilometer, glance, heat and neutron are already merged
14:23:37 <spredzy> Hmm if mgagne is not here it will be hard to have its point of view on this one
14:23:55 <crinkle> shoot, I should have commented on all of them instead of just one
14:24:08 <spredzy> If a new set of patchset needs to be done it doesn't seems like a problem to me, but as a user I expect $manage_service to do what it does on the whole puppet community
14:24:13 <sbadia> mmagr isn't here too :(
14:24:19 <crinkle> I feel really strongly that manage_service == false is absolutely not the same as ensure => stopped
14:24:22 <spredzy> sbadia, on a place I think
14:24:37 <spredzy> $manage_service != $ensure_service
14:24:43 <gchamoul> sbadia: he is on a plane too !
14:24:44 <nibalizer> crinkle: i agree with that position
14:25:26 <sbadia> so :-/ ok
14:25:30 <crinkle> I can propose patches to fix the ones that have already been merged
14:26:22 <crinkle> I don't quite understand mgagne's point about HA setup
14:26:34 <sbadia> me too :/
14:26:58 <crinkle> maybe we can discuss with him later in #puppet-openstack
14:27:01 <sbadia> we can re-discuss with martin and mathieu on the ml before
14:27:04 <sbadia> yep!
14:27:06 <sbadia> ok
14:27:08 <crinkle> ok
14:27:36 <sbadia> #action sbadia shoot a mail on the ML about manage_service issue
14:27:50 <sbadia> next topic then
14:28:02 <sbadia> #Topic Integration testing
14:28:12 <sbadia> nibalizer: need some help?
14:28:15 <nibalizer> hi
14:28:23 * crinkle can review that patch
14:28:26 <nibalizer> so the problem is that beaker doesn't work
14:28:27 <nibalizer> yet
14:28:29 <nibalizer> https://review.openstack.org/#/c/134371/
14:28:40 <nibalizer> is (i hope) the last patch to make beaker + nodepool play nice
14:29:09 <nibalizer> hopefully after that we can land https://review.openstack.org/102020
14:29:25 <nibalizer> then this as well but not as relevant here https://review.openstack.org/126086
14:29:40 <nibalizer> the other thing though is we'll need to add integration testing lines to each project in zuul
14:29:48 <nibalizer> which is kinda heavy in reviews for infra and will be slow
14:30:07 <sbadia> oh I didn't see the patches on infra!
14:30:15 <spredzy> to avoid the mess I introduced with the policy.json patch, we (w/ mathieu) had the idea of trying to set up a all-in-one maniest on top of which we would run is_expected.to compile, to make sure we don;t ahve duplicaate ressource error. Its basic its a begining but would allow us to detec those issue earlier
14:30:15 <sbadia> ok! thx spencer!
14:31:17 <sbadia> spredzy: in each module?
14:31:38 <nibalizer> sbadia: so yea its in progress and im consistently poking it
14:31:40 <sbadia> it costs nothing :)
14:31:57 <crinkle> nibalizer: thanks :)
14:32:02 <sbadia> long road!
14:32:04 <nibalizer> after we get int tests working at all we can discuss further/do work to make them global
14:32:07 <sbadia> yes thanks nibalizer !
14:32:10 <nibalizer> np np
14:32:18 <spredzy> sbadia, there idea was to have that on infra or something (just rought idea so far), and the test will be run for each commit
14:32:34 <spredzy> still need to work out the specifics
14:32:58 <crinkle> typically that stuff would go in spec/spec_helper_acceptance.rb in the module
14:33:14 <crinkle> but that could potentially call out to something in infra i guess
14:33:35 <crinkle> or not spec_helper_acceptance but the tests themselves i think
14:34:23 <nibalizer> so i think thats it for integration?
14:34:50 <crinkle> sure
14:36:08 <crinkle> sbadia: next?
14:36:13 <sbadia> ok :)
14:36:31 <sbadia> crinkle: do you want to talk about aviator (recents patchset)?
14:36:39 <crinkle> sure
14:36:50 <sbadia> #topic Aviator
14:37:00 <crinkle> #link https://review.openstack.org/#/c/134843/
14:37:06 <crinkle> #link https://review.openstack.org/#/c/134844/
14:37:14 <crinkle> oops i guess the first one is failing lint
14:37:25 <crinkle> i've started a mailing list discussion
14:37:36 <sbadia> not a big deal for the lint :)
14:37:39 <crinkle> it seems like the leaning is to go with openstackclient over aviator
14:38:03 <crinkle> i think nibalizer's point about it being better maintained is pretty key
14:38:23 <crinkle> and the developers are really open to working with us to make it usable
14:38:30 <crinkle> since they want people to start using it
14:38:38 <dvorak> my only concern with using openstackclient instead of aviator, is we'll probably be giving up some amount of performance if we don't use the API directly.
14:39:36 <dvorak> just a point to consider.  I think there are some things can be be done to alleviate that if you're dealing with a single tool though.  like token caching and such
14:40:02 <crinkle> i hadn't thought of that
14:40:29 <crinkle> i'm not sure how to measure or evaluate that
14:40:42 <dvorak> you'll likely always have the fork/exec/parse overhead unless openstackclient can be run as a daemon
14:41:11 <dvorak> well, I know for us, getting a token can take a measurable amount of time, and every cli invocation gets a new token
14:41:40 <xingchao> I think performance loss can be ignored in this scene
14:42:05 <dvorak> I don't think it's even a loss compared to the current implementation, it's just a loss compared to direct API access
14:42:17 <crinkle> right
14:42:32 <dvorak> and it'd be easier to work with the openstackclient team to implement featuers to alleviate it, than to work with all the other client teams
14:42:46 <crinkle> ++
14:42:57 <nibalizer> does openstackclinet have a real team?
14:43:12 <nibalizer> or is it part time volunteers from all the projects?
14:43:15 <crinkle> i think the team is dtroyer + stevemar
14:43:22 <crinkle> who are keystone people i think
14:43:22 <dvorak> no idea here, I'd never actually heard of it until crinkle pointed it out
14:43:47 <sdague> I think crinkle is right, dtroyer + stevemar mostly
14:44:12 <stevemar> o/ yep, a few other occasional folks too
14:44:15 <nibalizer> ok
14:44:23 <crinkle> \o
14:45:08 <nibalizer> so you can read my ML post about this for my opinon but tl;dr i think openstackclient
14:45:13 <crinkle> stevemar: could you comment on dvorak's performance concern?
14:45:54 <nibalizer> but i also want to re-itrate what i said before about how maybe democracy isn't the best tool, and the people (or just crinkle ) who have been building the providers should make the call
14:46:44 <dvorak> just to clarify, I'm not saying not to use openstackclient, I think there is clearly a good argument for it.  I just wanted to point out one downside that I hadn't seen mentioned yet.
14:47:03 <crinkle> sure
14:47:12 <stevemar> dvorak, can you re-iterate your concerns surrounding performance, i just logged on
14:47:16 <nibalizer> dvorak: that was clear to me, thanks for bringing it up
14:48:06 <stevemar> nibalizer, ++ it should be up to the folks building the providers
14:48:18 <dvorak> stevemar: I was just pointing out that having puppet have integrated native API access is likely to be faster than interfacing with an external CLI tool.  If it's internal, you don't have the overhead of fork/exec/parsing the script.  You can also cache tokens across requests.
14:48:42 <dvorak> I imagine there are changes that could be made to openstackclient to alleviate most of those issues
14:49:47 <stevemar> caching should be possible, especially if you create a single interactive session (like neutrons CLI)
14:49:48 <dvorak> or maybe OSC already does all of that.  I'll admit ignorance here.
14:50:17 <dvorak> nod, if the puppet interface is written to use it in that mode, then I think that addresses almost all of my concerns
14:50:57 <stevemar> dvorak, then you can feed it commands, dtroyer had something in the works for that i believe
14:51:13 <dvorak> right now our puppet runs spend a lot of time making calls out to openstack CLI commands, so anything that makes that faster makes me happy :)
14:52:26 <crinkle> #info possible performance considerations with openstackclient, should use its caching features
14:52:47 <nibalizer> anything else on this? I have some stuff for open discussion
14:53:01 <nibalizer> which is to say me-- for not putting it on the agenda
14:53:09 <sbadia> ok for me :)
14:53:18 <crinkle> i'll continue to monitor the mailing list discussion and write a new spec for using openstackclient
14:53:31 <nibalizer> ya the ML is the right place to have this discussion
14:53:53 <sbadia> #topic open discussions
14:54:14 <nibalizer> i've proposed 2 changes to infra
14:54:23 <nibalizer> https://review.openstack.org/#/c/134835/ and https://review.openstack.org/#/c/134834/
14:54:46 <nibalizer> they together add the ability for zuul/infra to publish to forge using puppet-blacksmith
14:55:42 <nibalizer> this might be more valuable for -infra than this team
14:56:03 <nibalizer> since we really we only push to forge for major relases?
14:56:14 <nibalizer> do we up the forge releases when we backport stuff?
14:56:17 <crinkle> we push on minor releases
14:56:29 <crinkle> how would we share forge credentials?
14:56:39 <nibalizer> well in this system you'd have to give them to infra
14:56:46 <nibalizer> and it actually is worse
14:57:01 <nibalizer> puppet-blacksmith is too stupid to take a config file as a config option right now
14:57:21 <nibalizer> so we need to patch it so it can so the trusted node can switch back and forth between the -infra credintals and puppet/stackforge creds
14:57:43 <nibalizer> i was looking into that late last night and didn't do it
14:57:45 <crinkle> :/
14:57:45 <nibalizer> but it looks reasonable
14:58:10 <nibalizer> are you :/ about blacksmith being stupid or giving your creds to infra?
14:58:22 <crinkle> the switching back and forth sounds hacky
14:58:31 <sbadia> yep ^^
14:58:43 <clarkb> nibalizer you would not give infra your creds
14:58:51 <nibalizer> well the trusted node would have a .puppetforge-infra.yaml and .puppeforge-stackforge.yaml
14:58:55 <clarkb> (we dont want them)
14:59:02 <nibalizer> and the job would know
14:59:16 <clarkb> ideally you would give our user enough perms to upload for you
14:59:28 <nibalizer> yea i think those are equivalent?
14:59:37 <crinkle> i think the next meeting is about to kick us out, maybe continue this in #opsntack-infra?
14:59:47 <nibalizer> if thats acceptable to clarkb
14:59:47 <crinkle> spellfail
14:59:53 <nibalizer> i kno whe has not had burrito yet
15:00:04 <crinkle> or #puppet-openstack
15:00:08 <sbadia> crinkle: +1
15:00:15 <nibalizer> thanks everyone!
15:00:20 <sbadia> thanks everyone
15:00:23 <mfisch> thx
15:00:28 <crinkle> o/
15:00:29 <sbadia> #endmeeting