14:00:58 <crinkle> #startmeeting puppet-openstack
14:00:59 <openstack> Meeting started Mon Jan 12 14:00:58 2015 UTC and is due to finish in 60 minutes.  The chair is crinkle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:03 <openstack> The meeting name has been set to 'puppet_openstack'
14:01:32 <crinkle> #topic Vancouver summit
14:01:36 <crinkle> EmilienM: ?
14:01:39 <EmilienM> #link https://etherpad.openstack.org/p/puppet-vancouver-summit-proposal
14:01:49 <EmilienM> I started an etherpad
14:02:30 <EmilienM> I would like to submit a talk with someone
14:02:39 <EmilienM> about a deployment use-case with our Puppet modules
14:02:47 <EmilienM> show our efforts
14:03:00 <mfisch> morning
14:03:03 <EmilienM> the status, what you can do, how to contribute, etc
14:04:08 <EmilienM> crinkle: though it's maybe a bit too early to talk about design dessions
14:04:13 <EmilienM> sessions*
14:04:36 <mfisch> EmilienM: thats a good idea for a talk
14:05:01 <EmilienM> it's a mix between ops/dev talk
14:05:35 <crinkle> mfisch: might be a good person to give that talk with :)
14:05:54 <EmilienM> indeed, why not!
14:06:26 <mfisch> I need to discuss with my team but its possible yes
14:06:29 <mfisch> just cannot commit yet
14:06:29 <mdorman> i’d be happy to be a part of that too
14:06:43 <EmilienM> #action EmilienM to start an abstract on the etherpad
14:06:57 <spredzy> hello all
14:07:40 <crinkle> I'm happy to help too I just don't have a real deployment to talk about
14:07:43 <EmilienM> mdorman: ok. We will figure that out.
14:07:49 <mdorman> kk
14:08:17 <EmilienM> mdorman: mfisch crinkle : I just created the etherpad to be sure we don't overlap much about Puppet submissions
14:08:29 <EmilienM> and try to submit them efficiently, and together
14:08:35 <mdorman> sounds good.
14:08:46 <EmilienM> cool. We'll follow up on IRC later
14:08:52 <EmilienM> crinkle: done.
14:08:58 <crinkle> mmk
14:09:09 <crinkle> #topic Ops midcycle
14:09:34 <crinkle> I'm not sure if I will be there, but I know there will be a puppet session
14:09:49 <crinkle> mfisch has volunteered to moderate it
14:09:57 <crinkle> it would be good to come up with topics beforehand I think
14:10:00 <mfisch> EmilienM: will you be coming?
14:10:31 <EmilienM> mfisch: where is it?
14:10:40 <EmilienM> and when? sorry I missed the infos
14:10:40 <crinkle> philadelphia
14:10:42 <mfisch> Philadelphia, US
14:10:53 <mfisch> east coast-ish
14:10:53 <crinkle> #link https://etherpad.openstack.org/p/PHL-ops-meetup
14:10:57 <EmilienM> thanks
14:11:20 <EmilienM> hum. I don't think I'll go, I'm not OPS but I'll forward it to my OPS team.
14:12:07 <EmilienM> but +1 to let mfisch moderating it :-)
14:12:32 <mfisch> But yes we do need an agenda
14:12:57 <crinkle> should we try to start one now or send to the mailing list?
14:13:01 <spredzy> crinkle, if you don't ago is anyone from PL going ?
14:13:14 <crinkle> spredzy: possibly one of our ops people
14:13:44 <mfisch> WIth an ops focus some discussion on things that are problems for ops is high on my agenda
14:14:15 <spredzy> crinkle, who ever that person is, probably add him/her in the loop for the agenda might be a good idea
14:14:25 <crinkle> sure
14:15:41 <crinkle> #action Ask mailing list for help preparing ops midcycle agenda
14:16:14 <xingchao> hi,all
14:16:22 <crinkle> hello
14:16:59 <crinkle> #topic openstackclient patches
14:17:14 <crinkle> We merged all the major work but it ended up wreaking a bit of havoc
14:17:35 <crinkle> Three patches still to do bugfixes, then all those patches should be backported:
14:17:45 <EmilienM> yeah
14:17:47 <crinkle> #link https://review.openstack.org/145861
14:17:57 <crinkle> #link https://review.openstack.org/145986
14:18:07 <crinkle> #link https://review.openstack.org/145987
14:18:17 <EmilienM> xingchao: could you review/merge them please?
14:18:27 <EmilienM> since you're the only one core around today
14:19:05 <fc__> hi all ... very late
14:19:15 <EmilienM> or fc__ ...
14:19:22 <crinkle> hello
14:19:28 <spredzy> sbadia, ^^
14:19:40 <xingchao> EmilienM: Ok, I will review them. sorry for absent recent meeting :(
14:19:47 <mfisch> crinkle: once those are merged and stable can you update the progres on the ML?
14:19:53 <sbadia> hi, late also :s
14:19:57 <EmilienM> seems like some people woke up after my last e-mail :-)
14:19:57 <crinkle> mfisch: sure
14:20:02 <mfisch> we'd like to move our trees forward but were waiting for less chaos
14:20:07 <mdorman> +1
14:20:37 <EmilienM> great. Enough core people to have a look at the backports. Please review them, they are blockers
14:20:59 <crinkle> #action crinkle will update the mailing list when openstackclient patches are merged and stable
14:21:59 <crinkle> #info Next steps are updating the patches to allow keystone v3 (richm) and updating the rest of the modules to use openstackclient (crinkle)
14:22:10 <EmilienM> wouhouuuuu
14:23:04 <crinkle> Anything else to discuss on that topic?
14:23:25 <EmilienM> nop
14:23:46 <crinkle> mmk
14:23:53 <crinkle> #topic rabbitmq
14:24:26 <crinkle> puppet labs just released a 5.0.0 of the rabbitmq module that contains a security fix
14:24:38 <crinkle> I would really like to get the modules to be using that
14:24:43 <EmilienM> crinkle: any pointer?
14:24:57 <crinkle> EmilienM: pointer?
14:25:03 <EmilienM> crinkle: URL
14:25:14 <EmilienM> crinkle: what does it change?
14:25:23 <crinkle> ah I don't think there is a cve yet for the security fix
14:25:29 <EmilienM> if it's the way to setup RabbitMQ server, I would argue to drop this code
14:25:39 <crinkle> there are some api changes that make it incompatible with nova::rabbitmq and cinder::rabbitmq
14:25:47 <EmilienM> and just manage RabbitMQ resources (users/permissions/vhosts)
14:26:01 <crinkle> #link https://github.com/puppetlabs/puppetlabs-rabbitmq/blob/master/CHANGELOG.md
14:26:05 <EmilienM> crinkle: server side?
14:26:16 <EmilienM> thx for URL
14:26:25 <crinkle> I don't know the best way to deprecate those clases
14:26:47 <crinkle> classes
14:27:01 <EmilienM> crinkle: 5.0.0 changes are for server or resources?
14:27:16 <crinkle> mainly for the server setup
14:27:25 <crinkle> so it wouldn't really affect the rabbitmq_user and such
14:27:27 <EmilienM> ok so my position here is to drop this code
14:27:35 <EmilienM> because it's not up to our modules to setup rabbitmq server
14:27:51 <EmilienM> we already had this discussion I think
14:28:12 <crinkle> we did but I'm wondering if we can just drop it or if we have to go through a deprecation cycle first
14:28:14 <spredzy> Agree with EmilienM about not up to the puppet-openstack modules to set up rabbit
14:28:32 <spredzy> crinkle, that would be one way to go
14:28:36 <EmilienM> deprecation first
14:28:36 <EmilienM> communicate on the ML
14:28:40 <EmilienM> and drop the code in next cycle
14:29:03 <EmilienM> iirc, bogdando was working on it.
14:29:18 <crinkle> on the other hand given that the release contains a security fix maybe we could sidestep the deprecation ocycle
14:29:36 <spredzy> crinkle, defined sidestep please
14:29:36 <bogdando> hello
14:29:43 <spredzy> define*
14:29:46 <crinkle> bogdando: is still working on it, I don't think all his latest patches are in this release though
14:30:06 <crinkle> spredzy: just dropping it as opposed to notifying and then dropping in six months?
14:30:13 <EmilienM> spredzy: esquiver!
14:30:17 <bogdando> crinkle, EmilienM I submitted a patch which allow rabbitmq not being installed from nova anymore
14:30:27 <EmilienM> good.
14:30:40 <crinkle> bogdando: link?
14:30:44 <spredzy> crinkle, EmilienM thx
14:31:19 <bogdando> #link: https://review.openstack.org/144745
14:32:11 <crinkle> so I think we'd rather drop that class entirely instead of modifying it
14:33:13 <EmilienM> crinkle: I would drop the class and use https://github.com/stackforge/puppet-openstacklib/blob/master/manifests/messaging/rabbitmq.pp
14:33:47 <EmilienM> crinkle: I mean, keep nova::rabbitmq but using openstacklib
14:34:31 <crinkle> okay, my only concern is whether we can do that on master now or if we need to add a notify{} to it and then fix it in six months
14:34:49 <EmilienM> crinkle: I would warning
14:35:02 <crinkle> okay
14:35:44 <crinkle> #action crinkle will submit patches to puppet-nova and puppet-cinder to add deprecation warning for setting up the rabbitmq server
14:36:13 <EmilienM> crinkle and bogdando : just make sure you're sync on this one
14:36:29 <EmilienM> crinkle: also, change the way to create resources to use openstacklib.
14:36:36 <crinkle> yes
14:37:41 <bogdando> crinkle, EmilienM so, looks like the new versions of rabbitmq module install should go to this messaging/rabbitmq.pp as well?
14:38:17 <crinkle> yes openstacklib should be updated to use the new module version
14:38:20 <EmilienM> bogdando: there is no change AFIK since it only affect server configuration
14:38:25 <EmilienM> crinkle: isn't?
14:38:25 <bogdando> If we want remove rabbitmq_class we should first deprecate it and keep with False option, IMHO
14:38:51 <spredzy> crinkle, bogdando isn't the prupose by the end of next sprint being to not manage rabbitmq via puppet-modules anymore ?
14:38:58 <crinkle> bogdando: makes sense
14:39:07 <spredzy> so class rabbitmq shouldn't be moved to message/rabbitmq.pp
14:39:30 <spredzy> sprint -> cycle
14:39:32 <spredzy> sorry
14:39:35 <EmilienM> openstacklib/messaging/rabbitmq.pp is only for users/permissions/vhosts resources
14:39:40 <bogdando> spredzy, yes, it should. I suggest 1st to deprecate this param and provide a new value for it (false)
14:40:05 <crinkle> +1
14:40:10 <spredzy> ack
14:41:21 <crinkle> #action also modify the rabbitmq class to not require setting up the server (bogdando - https://review.openstack.org/144745)
14:41:49 <crinkle> anything else on rabbitmq?
14:42:21 <spredzy> nop
14:42:43 <crinkle> #topic puppet-group members
14:42:46 <crinkle> EmilienM:
14:42:54 <EmilienM> #link https://groups.google.com/a/puppetlabs.com/forum/#!topic/puppet-openstack/t8hYgzceOdM
14:43:12 <EmilienM> so I would like to drop people not involved from the list: https://review.openstack.org/#/admin/groups/134,members
14:43:47 <EmilienM> I like hogepodge words
14:44:03 <EmilienM> people not involved lately, may come back later but for now, we need to update the list
14:44:09 <mdorman> +1
14:44:16 <mfisch> +1
14:44:33 <mfisch> especially for people who did not even reply to the email
14:44:51 <EmilienM> so the first step is to drop some people, and the next step would be to promote some others that contributed well in the last cycle
14:45:00 <EmilienM> mfisch: indeed :D
14:45:41 <EmilienM> let me quote chris words "I’d like to think of being a core developer as more of a responsibility than as a reward. If you’re not able to contribute to reviews, coding, planning meetings, and other community efforts, there should be no shame in stepping down and no barriers for reentry when you can commit yourself again."
14:46:13 <EmilienM> sbadia: crinkle xingchao fc__ : since you are the 4 core here, can you vote?
14:46:41 <crinkle> +1
14:47:02 <sbadia> +1 too
14:47:28 <sbadia> :)
14:47:33 <EmilienM> ok, sounds like everyone (core and non-core) agree with it.
14:47:41 <xingchao> +1 other openstack team also follow this rule
14:48:21 <EmilienM> #action EmilienM to update the list and communicate on the ML about the update
14:48:23 <EmilienM> crinkle: done.
14:48:52 <crinkle> #topic open discussion
14:48:58 <crinkle> any other topics to bring up?
14:49:17 <EmilienM> dprince: hey
14:49:26 <dprince> EmilienM: hello
14:49:33 <EmilienM> I think Dan wanted to give an update about Heat/Puppet integration
14:50:13 <dprince> sure, the update is that things are (slowly) progressing. Patches have started to land in the TripleO Heat Templates.
14:50:32 <dprince> we are tracking progress on this etherpad: https://etherpad.openstack.org/p/puppet-integration-in-heat-tripleo
14:50:41 <EmilienM> #link https://etherpad.openstack.org/p/puppet-integration-in-heat-tripleo
14:51:19 <dprince> there are good notes there about how this work, etc. But today we are very close to having a working devtest_overcloud.sh which can use Puppet.
14:51:31 <EmilienM> dprince: this is awesome
14:51:32 <dprince> devtest_overcloud.sh is a script we use in TripleO to dev/test things
14:51:52 * dprince figures this probably doesn't mean much here... it is a TripleO thing
14:52:06 <EmilienM> it's okay
14:52:17 <dprince> One thing I would mention is I'm really liking the ability to deploy to baremetal w/ Heat and Puppet
14:52:21 <EmilienM> it's another interesting use-case here
14:52:44 <dprince> Heat gives you the ability to use OpenStack APIs to create the basic deployment resources, via Ironic, Neutron, etc.
14:52:51 <dprince> And PUppet is great for the configuration side.
14:54:11 <dprince> I've already got some good feedback from nibalizer, and EmilienM on the reviews. But more thoughts would be appreciated.
14:54:27 <crinkle> awesome
14:54:33 <dprince> As an example this is what a puppet storage node ended up looking like: https://review.openstack.org/#/c/146129/2/puppet/overcloud_storage.pp,cm
14:54:35 <EmilienM> dprince: xingchao is very familiar with puppet-swift AFIK
14:54:45 <EmilienM> fc__ to
14:55:02 <EmilienM> I would ask them to have a look at the manifests if they want/can
14:55:11 <dprince> EmilienM: ++ that would be cool
14:56:07 <dprince> As much as possible I'm trying to keep the manifests themselves to just 'include' statements, and then do everything else in Hiera
14:56:31 <dprince> I'm missing some Heat features to be able to do some conversions however... so I need to do a bit of that on the puppet side for now.
14:56:40 <EmilienM> +1
14:56:52 <dprince> Eventually, when some of the Heat features land I think we'll end up in a much better place...
14:56:53 <EmilienM> exactly how people should use the modules
14:57:02 <EmilienM> good progress, thanks for the update
14:57:10 <crinkle> we're about out of time, any other updates?
14:57:25 <EmilienM> dprince: don't hesitate to poke us on IRC if you need reviews
14:57:39 <dprince> EmilienM: cool, thanks
14:58:42 <EmilienM> crinkle: I think we are done :-)
14:58:47 <crinkle> woot
14:58:52 <crinkle> #endmeeting