14:00:01 <EmilienM> #startmeeting puppet-openstack
14:00:02 <openstack> Meeting started Mon Jan 19 14:00:01 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'puppet_openstack'
14:00:25 <EmilienM> #topic Review past actions
14:01:00 <EmilienM> puppet-group members list has been updated and the communication has been done
14:01:28 <fc__> ohai _o/
14:01:28 <EmilienM> bogdando: can you give a status about RabbitMQ server class deprecation?
14:01:35 <sbadia> pacemaker provider for HA services merged
14:01:41 <sbadia> #link https://review.openstack.org/136708
14:01:43 <EmilienM> sbadia: wait a sec :-)
14:01:51 <sbadia> sorry :)
14:02:23 <EmilienM> so it seems like crinkle and bogdando worked on https://review.openstack.org/#/c/144745/ and it has been merged
14:02:41 <EmilienM> that means from now, you can avoid installing RabbitMQ server and if you install it, you have a pretty deprecation message.
14:03:04 <EmilienM> openstackclient patches have been merged and backported
14:03:26 <EmilienM> I tested them and found a bug (already fixed & backported when running SSL)
14:03:34 <sbadia> (in juno)
14:03:38 <EmilienM> #link https://bugs.launchpad.net/puppet-keystone/+bug/1412309
14:03:40 <bogdando> hello
14:03:51 <EmilienM> bogdando: hey
14:03:55 <sbadia> hi
14:04:24 <bogdando> the status of rabbitmq server class is - 	Nova patch for rabbitmq class was merged https://review.openstack.org/144745 ; 	Cinder patch on review (cherry-picked from nova) https://review.openstack.org/#/c/147420/
14:04:34 <EmilienM> great thing. Thanks
14:04:40 <bogdando> I found no more links to this class
14:04:41 <EmilienM> they will be part of regular reviews
14:05:11 <bogdando> and please, since we have now pacemaker provider for HA services merged, it would make sense to merge its spec as well
14:05:19 <EmilienM> +1
14:05:24 <EmilienM> I already +2
14:05:27 <bogdando> which is  https://review.openstack.org/#/c/104861/
14:05:28 <EmilienM> sbadia: can you have a look?
14:05:39 <bogdando> I addressed Collen's comments
14:05:41 <sbadia> EmilienM: yup, sure
14:05:56 <EmilienM> great
14:06:06 <bogdando> so, thats it from me
14:06:07 <EmilienM> crinkle has some actions to send emails to ML
14:06:18 <EmilienM> about OPS mid-cycle for example
14:06:28 <EmilienM> mfisch: do you know something?
14:06:46 <dvorak> I thnk he's out, it's a holiday for us
14:07:11 <EmilienM> oh yes. Makes sense
14:07:14 <EmilienM> dvorak: thx
14:07:29 <dvorak> I just happened to be sitting at my computer when the reminder popped up about the meeting :)
14:07:37 <EmilienM> #topic Vancouver summit
14:08:13 <EmilienM> #action EmilienM to continue the work on a proposal with mfisch and mdorman https://etherpad.openstack.org/p/puppet-vancouver-summit-proposal
14:08:26 <EmilienM> if someone has some actions/comments, it's time now
14:08:57 <EmilienM> okay
14:09:15 <EmilienM> #topic Pacemaker work
14:09:19 <EmilienM> bogdando: o/
14:09:50 <bogdando> EmilienM, o/
14:09:59 <EmilienM> bogdando: so your first patch has been merged
14:10:04 <EmilienM> #link https://review.openstack.org/136708
14:10:12 <EmilienM> what's coming next?
14:11:05 <bogdando> since we have now pacemaker provider for HA services merged, it would make sense to merge its spec as well, which is  https://review.openstack.org/#/c/104861/
14:11:36 <AmirBaleghi> #tehlug
14:11:38 <EmilienM> bogdando: yes, it will be reviewed asap. What's next in term of puppet?
14:12:11 <bogdando> and according to the spec, the next steps are Create a basic HA wrapper classes shipped with a generic OCF scripts for	160
14:12:11 <bogdando> the cluster resources definition and an option to specify a custom OCF	161
14:12:11 <bogdando> scripts as well.
14:13:14 <EmilienM> bogdando: great. Are you going to work on it? Do you need any help?
14:13:34 <bogdando> I guess these should be a separated action items. But there would be issues with generic OCF scripts
14:14:12 <EmilienM> #action bogdando to create a basic HA wrapper class with generic OCF scripts
14:14:50 <bogdando> bogdando, well, I'm not sure I will be able to make this items for now. May be then we will do the same for Fuel 7.x release, I will be able to participate as well
14:15:04 <EmilienM> ok
14:15:19 <EmilienM> bogdando: anything alse to add ?
14:15:29 <bogdando> But I hope the docs + examples provided for provider should be enough for every one to strat it rigth now
14:15:56 <EmilienM> ok
14:16:30 <bogdando> actually, we could add the docs part from step 3 to make it even more simple task
14:16:50 <EmilienM> bogdando: can you create an #action?
14:16:59 <bogdando> ok
14:17:18 <bogdando> #action bogdando Describe in documentation how HA provider could be used with Puppet modules
14:17:29 <EmilienM> awesome
14:17:34 <EmilienM> sbadia: do you see any topic else?
14:17:58 <sbadia> hum, no for this topic
14:18:11 <EmilienM> #topic keystone v3
14:18:36 <EmilienM> #link https://review.openstack.org/#/c/146926/
14:18:52 <EmilienM> Rich and I are working on first domain support in puppet-keystone
14:18:58 <EmilienM> it's WIP, but we make good progress
14:19:40 <EmilienM> sbadia: my question was more "do you see another topic I did not mention yet ?" :-)
14:20:21 <sbadia> EmilienM: no, I've just a topic, but for open questions
14:20:28 <EmilienM> ok
14:20:40 <EmilienM> #topic open-discussion
14:21:13 <EmilienM> sbadia: go ahead!
14:21:40 <bogdando> I have a question
14:21:46 <AmirBaleghi> hello every one
14:21:59 <bogdando> which exactly docs should I use for my action items?
14:22:12 <AmirBaleghi> I have one question too
14:22:38 <EmilienM> bogdando: in the repo itself, take a look at other puppet modules how they work
14:22:44 <EmilienM> usually a README is good
14:23:24 <EmilienM> bogdando: take a look at https://github.com/stackforge/puppet-neutron/blob/master/README.md
14:23:39 <EmilienM> you have some doc there, and you may want to do the same for your patches in puppet openstack extras
14:24:46 <bogdando> EmilienM, unterstood
14:24:48 <EmilienM> ok
14:24:58 <AmirBaleghi> do u have problem with neutron in dnsmasq ? my dns server hang after some hours and I should be restart it . after restart all is ok but it repeat after ....
14:25:18 <EmilienM> AmirBaleghi: how is it related to puppet modules?
14:25:35 <AmirBaleghi> no i do think
14:25:46 <EmilienM> AmirBaleghi: sounds like you may want to go to another channel for asking support
14:25:54 <AmirBaleghi> i don't use puppet
14:25:55 <EmilienM> AmirBaleghi: #openstack is a good one for that
14:26:04 <EmilienM> AmirBaleghi: we are in the middle of a meeting right now.
14:26:26 <AmirBaleghi> aha... ok ... thanks...
14:26:55 <EmilienM> 2 minutes left for questions / open discussion
14:27:05 <EmilienM> then I think we can close the meeting for today
14:27:16 <sbadia> ok for me
14:27:52 <EmilienM> ok
14:28:25 <EmilienM> thank you guys, have a great time
14:28:39 <EmilienM> #endmeeting