14:04:43 <crinkle> #startmeeting puppet-openstack
14:04:44 <openstack> Meeting started Mon Jan 26 14:04:43 2015 UTC and is due to finish in 60 minutes.  The chair is crinkle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:47 <openstack> The meeting name has been set to 'puppet_openstack'
14:05:07 <crinkle> #topic Review last week's Action items
14:05:31 <crinkle> EmilienM: update on vancouver proposal?
14:05:40 <EmilienM> crinkle: yep
14:05:55 <EmilienM> mfisch, mdorman and I are proposing a talk
14:06:30 <EmilienM> #action Emilien to update https://etherpad.ring.enovance.com/p/vancouver-summit-proposal-upgrades with a new proposed talk
14:06:42 <EmilienM> oops wrong link
14:07:26 <EmilienM> #undo
14:07:39 <EmilienM> #action Emilien to update https://etherpad.openstack.org/p/puppet-vancouver-summit-proposal with a new proposed talk
14:07:54 <EmilienM> crinkle: it's about puppet openstack modules and real use-cases
14:08:08 <crinkle> sounds good
14:08:33 <crinkle> bogdando: around?
14:08:57 <EmilienM> crinkle: reading http://eavesdrop.openstack.org/meetings/puppet_openstack/2015/puppet_openstack.2015-01-12-14.00.html - you had to send communications to ML - any update?
14:10:06 <crinkle> I did not send an update on the mailing list, will do
14:10:17 <EmilienM> cool
14:10:36 <EmilienM> #link Talk #1 with mfisch mdorman & emilien https://etherpad.openstack.org/p/xfrye9phZc
14:12:15 <crinkle> #topic open discussion
14:12:51 <crinkle> anything else to bring up?
14:13:28 <EmilienM> crinkle: I have something
14:13:28 <spredzy> One thing
14:13:40 <spredzy> Few weeks ago EmilienM mentionned trello/story board in the ML
14:13:48 <EmilienM> dprince: ping
14:14:13 <spredzy> are people using any one of those ? If so would you guys agree we mode action items to a card / item on those software ?
14:14:18 <dprince> EmilienM: hi
14:14:24 <spredzy> So it is easier to get in an oingoing effort
14:14:42 <EmilienM> dprince did some interesting work on https://review.openstack.org/#/c/147954/ - we need a review from core team and if merged, follow this way to patch all other modules
14:14:46 <spredzy> be able to take a part of an effort, follow it, etc...
14:14:58 <crinkle> one thing at a time
14:15:00 <EmilienM> spredzy: ML showed us low interesting on this
14:15:07 <EmilienM> interest*
14:15:23 <EmilienM> if we setup an tool like this and we are only 3 at using it, it's not useful I think
14:15:24 <dprince> EmilienM: yes, once that lands (and we agree on a good pattern) I'm up for pushing this around to other modules as well
14:15:43 <dvorak> I think it's the sort of thing that's not very interesting in the abstract :)
14:15:43 <crinkle> storyboard seems too unstable at the moment and trello was controversial
14:16:28 <EmilienM> +1 for storyboard == not we currently need
14:16:58 <spredzy> crinkle, can't we start with a 'controversial' tool and later eventually move into storyboard ? I mean there are several effort moving forward in //, and it will be good to have a grasp on what's going on, a global overview, avancement etc..
14:17:00 <spredzy> be ableto jump in
14:17:14 <spredzy> currently, this is a litle bit hard I think
14:19:01 <dvorak> +1 for trying out Trello
14:20:13 <EmilienM> shall we vote?
14:20:17 <sbadia> seem's the only solution no, so +1 too
14:20:30 <spredzy> +1
14:20:34 <spredzy> :)
14:21:04 <crinkle> #startvote Should we try out Trello?
14:21:05 <openstack> Begin voting on: Should we try out Trello? Valid vote options are Yes, No.
14:21:06 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:21:20 <spredzy> #vote Yes
14:21:28 <sbadia> #vote Yes
14:21:32 <EmilienM> #vote No
14:21:44 <EmilienM> usually, only core people can vote
14:21:50 <EmilienM> it's like this in OpenStack projects
14:21:59 <crinkle> :/
14:22:22 <sbadia> hum…
14:22:43 <sbadia> but for this decision not only core people will use trello
14:23:06 <EmilienM> it's up to you guys, I just "say it"
14:23:13 <xingchao> #vote No
14:23:36 * crinkle abstains
14:24:10 <crinkle> EmilienM: since it was your idea I'm not going to vote against you
14:24:21 <EmilienM> crinkle: I'm voting against my idea :-)
14:24:29 <crinkle> right
14:24:29 <EmilienM> I don't think it's a good idea, since we are not enough.
14:24:36 <EmilienM> crinkle: feel free to vote
14:24:42 <crinkle> #vote No
14:25:10 <EmilienM> look at how much we are in meetings, on IRC, and in contributions - to use trello we have to be at least ~9 guys working full time
14:25:28 <spredzy> I think this can be a part of why we are so little
14:25:35 <sbadia> but it's not the case
14:25:36 <spredzy> its hard to have an overview of whats going on
14:25:41 <EmilienM> I thought it was a good idea but in fact I reverted by position. though we can start using it, it's costless
14:26:06 <spredzy> who's working on what, how can I help someone taking a simple item, etc...
14:26:11 <spredzy> encouraging participation
14:26:12 <EmilienM> we can setup one and see how it works
14:26:23 <EmilienM> spredzy: we have LP for it
14:26:27 <EmilienM> bugs/BP
14:27:15 <spredzy> LP doesn't allow one to work in a worflow maneer but still fair point for the bugs
14:27:42 <crinkle> seems like we're still undecided, let's move on and take it to #puppet-openstack later
14:27:49 <spredzy> +1
14:27:50 <sbadia> crinkle: +1
14:27:56 <crinkle> back to dprince's patch?
14:29:12 <crinkle> EmilienM: dprince can you explain why EmilienM's comment about constructing identity_uri won't work?
14:30:06 <dprince> crinkle: sure, I suppose my thought is that this just duplicates the legacy behaviour already in python-keystoneclient's auth_token middleware
14:30:32 <dprince> crinkle: this behavior logs a deprecation warning... to encourage users to actually start setting identity_uri
14:30:45 <EmilienM> that would make sense
14:31:07 <dprince> crinkle: so the goal here would be to encourage the same things while not duplicating I guess
14:31:14 <EmilienM> crinkle: what is doing is the root cause of many troubles if you miss it
14:32:11 <crinkle> sounds good to me
14:33:26 <EmilienM> ok, dprince and I will take care of this
14:33:42 <EmilienM> #action dprince & emilien to patch other modules with identity_uri support
14:33:48 <sbadia> yep seems good
14:33:50 <sbadia> thanks!
14:34:07 <crinkle> okay
14:34:09 <crinkle> anything else?
14:34:10 <EmilienM> crinkle: for trello, if spredzy thinks that could bring new contributors, we can let him set it up and see how it works
14:34:38 <EmilienM> again it's costless
14:34:41 <spredzy> I can take the action, I'd be pleased
14:34:48 <EmilienM> spredzy: go ahead
14:34:52 <sbadia> spredzy: go ahead
14:35:11 <spredzy> #action spredzy sets up trello, and make every action of this meeting a card
14:35:13 <crinkle> #action spredzy will set up a trello to try out
14:35:15 <crinkle> oops
14:35:23 <EmilienM> \o/
14:35:31 <EmilienM> spredzy: thanks!
14:35:34 <sbadia> héhé, /kill clone msg :)
14:36:01 <crinkle> okay, let's wrap up
14:36:05 <crinkle> #endmeeting