14:05:04 <crinkle> #startmeeting puppet-openstack
14:05:04 <openstack> Meeting started Mon Feb 16 14:05:04 2015 UTC and is due to finish in 60 minutes. The chair is crinkle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:08 <openstack> The meeting name has been set to 'puppet_openstack'
14:05:33 <crinkle> #topic Review last week's action items
14:05:56 <crinkle> sbadia: what's the status on the rspec-puppet tests?
14:06:19 <sbadia> for master branch and juno all is pin on 1.0.1
14:06:37 <sbadia> and for the upgrade to 2.x it's still a work in progress
14:07:14 <sbadia> on all modules
14:07:16 <sbadia> I ran out of time last week
14:07:30 <crinkle> I was working on doing the same for the puppetlabs modules and ran into this issue with it https://github.com/rodjek/rspec-puppet/pull/249#issuecomment-70575242
14:07:37 <sbadia> but it should be better this week
14:07:47 <crinkle> where basically modern beaker-rspec is incompatible with rspec-puppet 2.0
14:08:20 <crinkle> but that might not be an issue for us as long as we're okay with using an older version of beaker-rspec for now
14:08:46 <sbadia> I've not played with puppet-nova for the moment
14:08:52 <sbadia> but ack for the issue!
14:09:06 <sbadia> (we only use for the moment beaker in puppet-nova)
14:09:27 <crinkle> nibalizer is working on getting it into the rest of them
14:09:46 <sbadia> oh nice!
14:10:12 <sbadia> about rspec-puppet 2.x I've for the moment only pushed on ceilo
14:10:15 <sbadia> https://review.openstack.org/#/c/155704/
14:11:40 <sbadia> nothing else for me :)
14:11:51 <sbadia> #link https://github.com/rodjek/rspec-puppet/pull/249#issuecomment-70575242
14:12:04 <sbadia> #action sbadia continue the work on rspec-puppet 2.x support
14:12:17 <sbadia> thx crinkle for the pointer
14:12:52 <crinkle> okay, next action item was adding future parser tests to jenkins
14:13:08 <crinkle> nibalizer added a job to do syntax checking with the future parser https://review.openstack.org/#/c/154067/
14:13:11 <sbadia> for the others actions, nibalizer created the job
14:13:33 <crinkle> we still need jobs to do future parser checking with rspec when that's ready
14:13:40 <crinkle> and possibly the lint checks that dvorak suggested
14:13:48 <sbadia> yes +1
14:13:50 <dvorak> the lint checks for merged for glance
14:14:10 <dvorak> I'll try to work on getting the other modules done in idle time
14:14:23 <crinkle> don't we still need a job to run them? or does it just run on the regular lint check?
14:14:29 <dvorak> the latter
14:14:36 <crinkle> okay cool
14:15:03 <dvorak> it's really just a Gemfile change to get us on a newer puppet-lint + some extra puppet-lint modules + fixups so the tests pass
14:15:51 <sbadia> yep, nothing hard, but a bit time consuming
14:15:52 <crinkle> next action item was to review minor releases in a few weeks, but we're not there yet
14:16:26 <crinkle> next was dvorak emailing the mailing list about different package support
14:16:35 <crinkle> i didn't see a whole lot of discussion on that
14:17:03 <dvorak> I did that, but didn't get much response. I've been working on putting together a proof of concept implementation of virtualenv support for the designate module and that's coming along well
14:17:23 <crinkle> cool
14:17:30 <dvorak> I think that if people agree with the idea, most of the new code to support it could live in openstacklib
14:18:09 <crinkle> looking forward to seeing it
14:18:23 <dvorak> The biggest changes really are more around the fact that you have to handle config files and startup scripts more explicitly, instead of assuming they come from upstream
14:18:40 <dvorak> I hope to have something up for review this week
14:19:25 <sbadia> cool :)
14:19:57 <crinkle> next was spredzy adding gerrit support to modulesync
14:20:06 <crinkle> we've made a lot of progress there, should be ready to merge soon
14:20:51 <spredzy> crinkle, I stumbled across a blocker this morning
14:20:56 <sbadia> the pull of changeset is a bit harder than expected, but yep
14:21:03 <sbadia> ah sorry, spredzy is here :)
14:21:05 <spredzy> will explain it on #puppet-openstack after the meeting
14:21:09 <crinkle> okay
14:21:21 <crinkle> #topic open discussion
14:21:42 <crinkle> anything else to bring up?
14:22:40 <crinkle> going once
14:22:54 <sbadia> hum, nothing in mind right now :-s
14:23:04 <spredzy> nothing on my side either atm
14:23:25 <crinkle> #endmeeting