13:59:51 <crinkle> #startmeeting puppet-openstack
13:59:51 <openstack> Meeting started Mon Mar 16 13:59:51 2015 UTC and is due to finish in 60 minutes.  The chair is crinkle. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:55 <openstack> The meeting name has been set to 'puppet_openstack'
14:00:39 <crinkle> #topic Gerrit Review Days (gchamoul)
14:00:45 <crinkle> gchamoul:
14:00:50 <gchamoul> yes !
14:01:52 <mfisch> curious what this is
14:02:04 <mfisch> crinkle: can you also post the etherpad for this meeting?
14:02:21 <crinkle> mfisch: do you have the link handy?
14:02:33 <EmilienM> #link https://etherpad.openstack.org/p/puppet-meeting-agenda-march16
14:02:34 <gchamoul> so like the Bug Triage day, I think it could be interesting to get a Gerrit Review Days in order to relieve the number of reviews in the pip
14:03:21 <mdorman> (sorry late)
14:03:43 <mfisch> As I've said on both accounts I'll unlikely ever have a day to work on one thing, but during a day I could certainly try to do a bunch of reviews
14:03:45 <EmilienM> I think review and bug triage is different
14:04:14 <EmilienM> gchamoul: so which one are you mentioning? only reviews ?
14:04:27 <gchamoul> a regular day where we will be focused on the Gerrit Puppet OpenStack Inbox
14:05:22 <gchamoul> EmilienM: only Reviews!
14:05:24 <gchamoul> yes
14:06:00 <EmilienM> I would be in favor to have also a bug triage thing sometimes
14:06:23 <gchamoul> yes of course
14:06:34 <mfisch> reviews at least get some attention, bugs get 0
14:06:43 <EmilienM> mfisch: +1
14:07:31 <crinkle> at the ops meetup we talked about using time at the end of these meetings to do review and bug triage i believe
14:07:34 <mfisch> I think we had a proposal to use the end of this meeting to look at bugs, what about also looking at reviews that need attention?
14:07:43 <mfisch> great minds think alike per usual
14:07:45 <crinkle> :)
14:07:48 <EmilienM> hehe
14:07:50 <EmilienM> +1 for it
14:08:05 <mdorman> i feel like those could be combined… with a slight emphasis on bugs over reviews
14:08:09 <EmilienM> not sure most of us can spend one day in a week for that
14:08:21 <mfisch> I dont object to your idea gchamoul just isnt feasible for me honestly to spend a day on it
14:08:31 <mdorman> +1
14:08:31 <mfisch> I figure mdorman is in the same boat and I know dvorak is
14:08:37 <EmilienM> mfisch: +1
14:08:39 <mfisch> #operator-problems
14:08:51 <crinkle> gchamoul: how does using meeting time for this sound? perhaps just as a start
14:08:59 <mfisch> +1 as a start
14:09:01 <gchamoul> mfisch: I understand!
14:09:10 <gchamoul> crinkle: fine to me!
14:09:38 <crinkle> #agreed start using the end of meetings for review and bug triage
14:10:44 <crinkle> #topic New Meeting Time
14:11:00 <crinkle> #link https://doodle.com/wuhsuafq5tibzugg
14:11:59 <EmilienM> Tuesday - 1500 to 1600 UTC or Thursday - 1600 to 1700 UTC
14:12:11 <crinkle> we should also look at what times are actually available
14:12:19 <mfisch> To find those times I looked at the wiki
14:12:24 <mfisch> but there's no simple matrix
14:12:51 <crinkle> there's an ics somewhere
14:13:27 <sbadia> and this meeting slot are compatible with actual slot on #openstack-meeting / #openstack-meeting-alt ?
14:14:00 <mfisch> some had to be in -3
14:14:33 <sbadia> crinkle: yep in openstack-infra/irc-meetings/
14:15:00 <sbadia> but seems an export of the wiki page :s
14:15:21 <mdorman> fwiw i have the meetings ics up in outlook right now
14:15:55 <mdorman> hrrm it only has one meeting on it, that can’t be right.  nevermind.
14:17:17 <crinkle> it looks like 1600 thursdays in #openstack-meeting and #openstack-meeting-alt is free
14:17:24 <crinkle> er not alt
14:17:26 <mfisch> Is everyont okay in theory with moving the meeting?
14:17:26 <crinkle> -3
14:17:34 <crinkle> that too ^
14:17:39 <mdorman> i am
14:17:40 <EmilienM> mfisch: +1
14:17:43 <mfisch> I think we decided that optimizing for .eu and .us was okay given the attendance
14:19:14 <crinkle> +1
14:19:48 <sbadia> +1 too if the attendance is better :)
14:20:02 <Hunner> Were the times on the doodle adequate? Running it again wouldn't be great...
14:21:17 <EmilienM> mfisch: can you run this time (16->17) ?
14:21:29 <xarses> the current time is hard for me to attend, only here because of the US daylight savings offset
14:21:48 <mfisch> run?
14:21:50 <mfisch> attend?
14:21:55 <EmilienM> mfisch: attend
14:22:00 <EmilienM> mfisch: or you can run it :P
14:22:04 <mfisch> lets see its approx 1400 now?
14:22:07 <mfisch> 14:22?
14:22:16 <Hunner> Yep
14:22:23 <mfisch> yes
14:23:06 <crinkle> so 1600 thursdays in #openstack-meeting?
14:23:19 <EmilienM> +1
14:23:20 <sbadia> utc ok!
14:23:24 <mdorman> i like it
14:23:40 <Hunner> +1
14:23:57 <mfisch> next week lets cover abolishing DST
14:24:14 <mgagne> I'm not sure why 1600 thursday is proposed when tuesday 1500 has more vote
14:24:16 <mdorman> :)
14:24:23 <gchamoul> +1
14:24:34 <EmilienM> mgagne: because you just voted maybe?
14:24:35 <xarses> owich, -1 for Thursday
14:24:43 <EmilienM> and we are looking at it for 15 min
14:24:51 <EmilienM> it was 7/7 before
14:24:56 <xarses> tuest +1
14:25:15 <xarses> Tuesday even
14:25:29 <crinkle> we could do 1500 in #openstack-meeting-4
14:26:09 <EmilienM> I think time is running out, we have more interesting topics coming out
14:26:09 <Hunner> mfisch: You were the only one present that voted against 1500 Tuesday... completely not possible?
14:26:17 <EmilienM> let's continue by mailing list or IRC later?
14:26:26 <sbadia> EmilienM: +1
14:26:30 <crinkle> +1
14:26:30 <gchamoul> ack
14:26:45 <EmilienM> crinkle: we can go ahead I think.
14:26:47 <crinkle> #action follow up on mailing list
14:27:10 <crinkle> #topic Big Tent plans
14:27:39 <EmilienM> that's the interesting topic
14:28:07 <crinkle> first, do we want to do this? are there questions people want answered before we pursue this?
14:28:36 <mdorman> one thing i thought about this morning is what’s teh worst case scenario here?  if we shift to be an OS project and then somehow we fail.
14:28:37 <mfisch> I think its a great idea
14:28:48 <mdorman> basically we get demoted back to stackforge,right?   probably the biggest pain is moving repos?
14:28:59 <mdorman> (i really like the idea, too, btw.)
14:29:04 <mgagne> crinkle: I think it's not just related to Puppet but the whole concept of big tent + integrated release
14:29:13 <mfisch> not sure how you're deemed to fail
14:29:20 <mfisch> we're used more than probably 10 official projects
14:29:32 <mgagne> you can't fail, ceilometer is still in
14:29:36 <mfisch> lol
14:29:38 * mgagne hides
14:29:40 <mfisch> I was thinking the same
14:29:44 <EmilienM> mgagne: no troll or I cann jd__
14:29:46 <EmilienM> call*
14:30:10 <EmilienM> it's out of topic I guess
14:30:25 <mgagne> I'm more or less worried by the fact that most contributors happen to be operators
14:30:29 <jd__> I don't think you can fail at big tent
14:30:36 <EmilienM> crinkle: maybe should be run a classic vote?
14:30:37 <mdorman> haha ok fair enough
14:30:45 <mdorman> anyway i’m very much in favor of the idea
14:30:50 <mfisch> mgagne: does RH count as an op?
14:30:52 <mgagne> and as time passes, some will probably move to something else once their deployment methods is ironed out
14:30:53 <jd__> considering the work done you probably deserve to apply this project IMHO
14:31:00 <crinkle> EmilienM: i think we're still discussing pros/cons
14:31:01 <EmilienM> jd__: thanks!
14:31:14 <mfisch> mgagne: yes that is likely to happen, people will move on just like people moved on from nova-network and ceilometer
14:31:44 <mfisch> we've already lost a bunch of contribs but we gain new ones
14:31:50 <mgagne> mfisch: AFAIK, there is a more solid core (and enterprise investments) in those projects than ours
14:32:22 <mfisch> thats a good point b/c my company's goal is openstack, not puppet
14:32:25 <xarses> mfisch: people still use nona-network and ceilometer =/
14:32:40 <mfisch> but OoO is still alive despite HP bailing
14:32:47 <crinkle> there are a number of companies with enterprise investment in puppet
14:33:27 <mgagne> right, I guess that we could get more backing by being an "official' openstack project
14:33:49 <mfisch> mgagne: for some folks getting ATC or stackalytics points is worth an upstream push
14:34:04 <mfisch> I get ATC with BS doc changes when I dont have a real fix
14:34:18 <mdorman> +1 to last 3 comments, i think being a real project will increase involvement activity
14:34:29 <mgagne> mfisch: I'm not interested in people contributing only for an ATC badge
14:34:32 <Hunner> People will not argue that puppet modules add value to many openstack deplyoments... openstack is not useful if you can't deploy it :P
14:34:37 <richm> I think one big reason for being an official openstack project is getting more integration from the various projects i.e. getting visibility into each project that, yes, it will need to be installed by someone who is not a developer and it needs to have some features that will make it more easily deployable/installable via puppet
14:34:56 <mfisch> +1
14:35:02 <crinkle> mgagne: the ATC badge will be important for scheduling design summit sessions
14:35:05 <mfisch> getting space at the conference will be nice too
14:35:14 <crinkle> after vancouver we won't get a session if we're not a real project
14:35:19 <richm> and perhaps more early cooperation from the various projects about what features need to be installable via puppet and how that will work
14:35:24 <EmilienM> richm: great comment
14:35:30 <mfisch> +1
14:35:40 <mgagne> crinkle: I'm more interested in the long term success of the project
14:35:44 <mfisch> early warning on deprecation discussions at a minimum is nice
14:35:57 <EmilienM> crinkle: really?
14:35:57 <crinkle> mgagne: i think the design sessions are important to the long term success
14:36:25 <mfisch> if we have a PTL and we're on openstack-dev projects I think also will be more likely to reach out to us and ask "will this break the puppet guys/gals?"
14:36:44 <mdorman> imo getting space at teh summits i think is almost in an of itself a good enough reason to become a real project
14:36:54 <mfisch> mgagne: I'd like to know more about your concerns
14:38:02 <mgagne> crinkle: what I meant is that mfisch mentioned that some people woulc be using our official project status to push typo bugfixes to get ATC badge. And I fear those people won't be investing in the long term success of our project but only to save money on the badge.
14:38:39 <mgagne> crinkle: but I guess we are not different from any other projects anyway
14:38:39 <crinkle> mgagne: i think what he meant is that current contributors who do a lot of work with puppet also need to do a trivial "openstack" change to get ATC
14:38:43 <mfisch> I'm sure its possible
14:38:48 <Hunner> I wouldn't be surprised if the threshold for ATC goes up, but that's beside the point
14:38:52 <mgagne> crinkle: oh, now I understand
14:38:55 <mfisch> yes, what crinkle said
14:38:57 <crinkle> if we moved under the big tent then the current contributors would get ATC
14:38:59 <mfisch> sorry for the confusion
14:39:02 <mgagne> crinkle: +1 for puppet under the big tent
14:39:17 <mfisch> I'd still like to raise this on the ML before we make it official
14:39:23 <crinkle> +1
14:39:49 <mgagne> +1
14:39:55 <EmilienM> +1
14:39:58 <gchamoul> +1
14:40:01 <sbadia> +1
14:40:05 <crinkle> okay
14:40:08 <Hunner> Do we need to discuss who is in for vote? Or just "Announce and go ahead"?
14:40:38 <Hunner> (Not sure what "make it official" is)
14:41:00 <mfisch> Hunner: it means moving forward with the process, probably first step is voting on a PTL to drive it
14:41:01 <crinkle> i think "make it official" just means start going down the path toward applying
14:41:09 <Hunner> ah
14:41:16 <EmilienM> maybe we should ask ttx for that
14:41:26 <crinkle> #action discuss big tent further on mailing list
14:41:34 <EmilienM> crinkle: which ML ? :)
14:41:38 <mfisch> next topic
14:41:43 <sbadia> EmilienM: -> []
14:41:57 <sbadia> yep, the next meeting is in 20min :-s
14:41:59 <mfisch> lets discuss ML topic
14:42:02 <crinkle> #topic moving mailing lists
14:42:14 <crinkle> so this could be done whether or not we decide to big tent
14:42:20 <crinkle> but it would be a step toward big tent
14:42:20 <EmilienM> we just have to decide a tag
14:42:21 <mfisch> I'm +1 on moving MLs. However, we probably need to cross-post for awhile
14:42:27 <crinkle> that's fine
14:42:38 <mfisch> #puppet?
14:42:41 <mdorman> agreed
14:42:41 <gchamoul> yes +1
14:42:46 <crinkle> i think puppet-openstack
14:42:47 <EmilienM> puppet-openstack ?
14:42:51 <EmilienM> crinkle: +1
14:42:52 <mfisch> wfm
14:42:52 <crinkle> it's our channel and our current mailing list
14:42:55 <mgagne> mfisch: just do a hard-cut otherwise people won't move
14:42:55 <gchamoul> puppet-openstack, yeah!
14:42:59 <sbadia> +1 for puppet-openstack
14:42:59 <mdorman> puppet-openstack would be more discriptive
14:43:11 <crinkle> does anyone have concerns with moving? last time we discussed not wanting to filter
14:43:21 <crinkle> mailman will actually filter tags for you i learned
14:43:25 <mfisch> mgagne: can we shutdown the old list and have it send a bounce message pointing at the new one?
14:43:35 <sbadia> we can share sieve filters, and we go ahead :)
14:43:44 <mgagne> mfisch: ML is owned by puppetlabs organization
14:43:44 <EmilienM> mfisch: we should ask to crinkle/puppetlabs, they own the ML
14:43:58 <crinkle> i can try to track that down
14:44:13 <mfisch> #action crinkle to find out about shutting down/redirecting old ML
14:44:19 <sbadia> (binded on a google group)
14:44:26 <crinkle> but i think we wouldn't shut it down for several months anyway
14:44:43 <mfisch> +1
14:45:11 <crinkle> so, agreed to move to openstack-dev mailing list (cross posting to puppet-openstack@puppetlabs for a while)?
14:45:19 <sbadia> +1
14:45:26 <EmilienM> +1
14:45:31 <xarses> +1
14:45:42 <mdorman> yup
14:45:44 <mgagne> crinkle: no new topic on old ML, only replies to existing threads?
14:45:49 <mfisch> #action announce the switch on the old ML
14:45:50 <jd__> yay more mails
14:45:54 <mfisch> #action setup new ML + tags
14:46:01 <sbadia> jd__: :-D
14:46:01 <crinkle> mgagne: +1
14:46:14 <crinkle> #agreed move to openstack-dev
14:46:20 <crinkle> agreed on puppet-openstack as tag?
14:46:24 <mgagne> crinkle: no
14:46:24 <mfisch> yes
14:46:25 <EmilienM> +1
14:46:26 <gchamoul> ack
14:46:28 <sbadia> yep
14:46:30 <mgagne> crinkle: 	•	openstack is redundant with [openstack-dev]
14:46:57 <mfisch> are all other projects just one word names?
14:47:02 <crinkle> i'm worried [puppet] would get confused with the puppet stuff infra does
14:47:09 <Hunner> I agree with mgagne. People can find #puppet-openstack (irc) easily; it doesn't need to be the tag
14:47:17 <mgagne> mfisch: other projects don't include -openstack in their tags =)
14:47:34 <mfisch> crinkle: why dont we ask infra for an opinion?
14:47:35 <mgagne> crinkle: they have their own tag already [infra]
14:48:02 <mdorman> i think the infra stuff would come down to a matter of filter accuracy
14:48:05 <mfisch> if its all already 1 word tags then why break the paradigm I guess, of course our IRC channel breaks it already
14:48:09 <crinkle> okay +1 to just puppet
14:48:15 <mgagne> crinkle: and EmilienM already used the [puppet] so I call prior art: http://lists.openstack.org/pipermail/openstack-dev/2015-March/059017.html
14:48:25 <mfisch> lol
14:48:28 <EmilienM> mgagne: it was a mistake Sir
14:48:39 <EmilienM> but I'm fine
14:48:46 <mgagne> EmilienM: nothing better than a mistake to make it permanent :D
14:48:52 <crinkle> agreed on puppet as tag?
14:48:54 <gchamoul> lol
14:48:55 <EmilienM> crinkle: let's go
14:48:58 <Hunner> +1 just puppet
14:49:01 <gchamoul> +1
14:49:09 <mfisch> +1
14:49:11 <EmilienM> +1
14:49:18 <crinkle> #agreed use [puppet] as openstack-dev ml tag
14:49:19 <sbadia> ok +1
14:49:19 <mdorman> +1
14:49:30 <mfisch> I assume french will be the official language of the new project?
14:49:43 <mgagne> it's already the case :D
14:49:46 <mfisch> lol
14:49:46 <Hunner> I always wanted to learn French...
14:49:50 <crinkle> #topic Review Groups
14:49:58 <crinkle> mfisch: want to explain?
14:49:58 <xarses> I was hoping for Italian
14:50:23 <mfisch> ok so this is an idea I have from how we operate
14:50:36 <mfisch> we have people who are neutron experts (for example) and they review all neutron changes
14:50:52 <mgagne> a subject matter expert ?
14:50:58 <mfisch> when I push up a change set that might be very service specific like a change to how OVS works it might be nice to have a group that gets auto-added to the review
14:51:06 <mfisch> no special powers for the group other than that
14:51:09 <mfisch> yes mgagne
14:51:18 <mfisch> neutron is the canonical example here since its complex
14:51:26 <EmilienM> mfisch: not sure if it's doable in Gerrit, maybe we will have to write a bot or something
14:51:26 <Hunner> This would be to help newbies who don't know who to ping, yeah?
14:51:33 <mfisch> yes Hunner
14:51:45 <mfisch> maybe even reduce the amount of adding random people to the reviews which I do now
14:51:51 <mgagne> neutron is a broad subject too, I only know a couple of plugins/mechanisms
14:52:01 <Hunner> But theoretically "experts" are already watching reviews to their favorite projects...
14:52:11 <mfisch> They should be I figure
14:52:11 <EmilienM> Hunner: +1
14:52:13 <mgagne> Hunner: +1
14:52:16 <mfisch> maybe we can just encourage that
14:52:28 <mfisch> I'm fine with starting at that level
14:52:34 <mdorman> that might be better, since it sounds like the effort to do it automatically might be big
14:52:40 <EmilienM> the idea is fine though, I just don't see how to make it
14:52:53 <mfisch> I'll email the ?? ML about this and ask people to watch branches and provide a link on how to do it
14:52:59 <crinkle> i think it wouldn't necessarily need to be "automatically", maybe just a list of people in a wiki for people to add
14:53:14 <EmilienM> +1 for wiki
14:53:19 <mdorman> good idea
14:53:25 <Hunner> Perhaps we should just document who to ping, and let users / us add pings to unreviewed?
14:53:27 <mgagne> crinkle: +1 if we can make our wiki page a one-stop page
14:53:29 <gchamoul> EmilienM: I think we can do it via git hooks and gerrit command line
14:53:38 <mfisch> wiki gets stale pretty fast
14:53:43 <Hunner> crinkle: +1
14:53:58 <EmilienM> mfisch: like bugs, reviews, etc :)
14:53:58 <gchamoul> that's what I am doing when I send a patch ...
14:54:33 <mgagne> mfisch: they do. I'm +/- hoping for a way to make it a "nice" place to go instead of a bunch of outdated info that's too complex to maintain or refresh
14:55:13 <mfisch> I dont if we have a resolution on this besides a ML thread
14:55:38 <crinkle> #action mfisch to discuss review groups on ML
14:56:12 <crinkle> #topic open discussion
14:56:21 <crinkle> anything else in these last three minutes?
14:56:36 <mfisch> we have plenty more but not enuogh time so I say call it
14:56:52 <EmilienM> 3 min
14:56:52 <mdorman> to the ML!
14:57:08 <mfisch> the committe has voted to have more discussions!
14:57:10 <EmilienM> crinkle: I would talk about which projects go under the big tent
14:57:18 <EmilienM> but on ML of course..
14:57:21 <mfisch> +1
14:57:36 <EmilienM> and define which modules we support officially
14:57:42 <EmilienM> and the one "incubated"
14:57:45 <Hunner> Definitel.
14:58:13 <crinkle> okay let's head to the list
14:58:15 <crinkle> #endmeeting