14:59:59 <crinkle> #startmeeting puppet-openstack
15:00:00 <openstack> Meeting started Tue Mar 24 14:59:59 2015 UTC and is due to finish in 60 minutes.  The chair is crinkle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:04 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:11 <crinkle> morning
15:00:14 <sbadia> hi
15:00:26 <EmilienM> o/
15:01:31 <mgagne> o/
15:01:53 <xingchao> hi
15:01:57 <crinkle> #topic should we elect a PTL?
15:02:22 <mgagne> yes
15:02:26 <crinkle> I think it would be good to have an actual PTL, whether or not we "big tent"
15:02:32 <mdorman> so that is basically teh first step to becoming acore project right?
15:02:37 <EmilienM> I think so
15:02:39 <mdorman> +1 on that too
15:02:47 <crinkle> we have to have some sort of agreed-upon leadership
15:02:55 <mgagne> I think it would make our project a bit more "official" and serious
15:03:30 * EmilienM agrees with mgagne
15:04:03 <mdorman> so people would need ot nominate themselves on teh ML, an then somehow we vote after that, yes?
15:04:03 <sbadia> it is therefore based on a person? :-) (horizontal hierarchy suits me)
15:04:42 <crinkle> https://wiki.openstack.org/wiki/PTL_Guide
15:04:43 <mgagne> mdorman: I think it's the suggested/preferred method by OpenStack
15:04:49 <EmilienM> sbadia: I think we keep horizontal model, like do other projects
15:05:24 <crinkle> the PTL would mainly have final say in disputes, not necessarily push us in any one direction
15:05:27 <crinkle> is how I read that
15:05:37 <sbadia> hum ok, if it's to look like other projects
15:05:40 <mgagne> yep, that's how I see it
15:05:54 <crinkle> sbadia: I think we should do it for reasons other than to look like other projects
15:06:00 <crinkle> so if you disagree we should discuss it
15:06:50 <sbadia> yep, I'll prepare an email (my ideas are not yet ready)
15:07:08 <crinkle> okay
15:07:19 <crinkle> #action sbadia will bring up concerns on the mailing list
15:07:26 <sbadia> :D
15:07:29 <Hunner> Seems like there is lots of organizing involved for the PTL too, not just resolving disputes
15:07:31 <mgagne> it's also a way to a single point of contact in case someone from openstack wishes to ask questions about our project
15:08:09 <mgagne> Hunner: IMO, it's also the one that makes sure tasks get done (by someone): release, bug triage, reviews, etc.
15:08:13 <EmilienM> I think there is no hierarchy in our goals - we just need to scale up our work, we have a lot of things to improve and a PTL could help
15:08:13 <EmilienM> ie: release management / bug triage
15:08:29 <mgagne> PTL doesn't have to do everything by him/herself
15:09:41 <EmilienM> hopefully
15:10:12 <mgagne> it HAS to be this way otherwise PTL will burn him/herself at the task
15:10:29 <mgagne> and we don't want that
15:10:48 <Hunner> Seems like there should be an openstack-puppet specific mandate for the PTL to limit burn-out then
15:10:59 <mgagne> :D
15:11:00 <Hunner> or a blueprint or something :P
15:11:07 <Hunner> Can you make blueprints for PTLs?
15:12:14 <mdorman> maybe as part of our ML discussion we aim to build a ‘job description’ for the PTL.  outlining specific responsibilities that person needs to do, as well as those that fall on the group at large
15:12:22 <crinkle> ++
15:12:27 <EmilienM> Hunner: everything is already documented I think
15:12:28 <EmilienM> crinkle gave the link: https://wiki.openstack.org/wiki/PTL_Guide
15:12:29 <Hunner> I don't think the ptl_guide has enough info for scope
15:12:34 <Hunner> mdorman: +1
15:12:45 <sbadia> yep +1
15:13:19 <EmilienM> yes, so we can define this text on puppet openstack specs, using gerrit
15:13:20 <mgagne> we are a community and everyone should be able to contribute to the expectation of a potential PTL. lets take it to the ML as suggested by mdorman
15:13:45 <Hunner> Okay, should we have a target date for "job description" and PTL choosing? Or should they be organic?
15:13:47 <xingchao> mgagne: +1
15:14:13 <mdorman> i say target by next week’s meeting to have that wrapped up.  so at meeting next week we can open up PTL nominations
15:14:20 <mdorman> (imo)
15:14:28 <EmilienM> so people can review inline as a regular blueprint
15:14:45 <mdorman> EmilienM:  i like it
15:15:13 <mgagne> can we use the ML instead? I feel this could be something that could rapidly evolve over time
15:15:28 <mgagne> I feel spec are too formal for this kind of discussion
15:15:36 <crinkle> I agree with mgagne
15:15:44 <mdorman> i’m fine either way
15:16:30 <EmilienM> ok with ML
15:16:34 <sbadia> ok for me too
15:16:35 <mgagne> lets start small so future PTL doesn't feel overwhelm by the amount of tasks and responsibility =)
15:17:25 <xingchao> how did other openstack project elect PTL?
15:17:28 <mfisch> sorry I'm late
15:17:32 <Hunner> +1 ; we can always add more later
15:17:50 <EmilienM> mgagne: who run the thread?
15:17:51 <EmilienM> xingchao: if more than one person apply, there is an election - otherwise no election
15:18:38 <mfisch> I actually think we should ask people to vote regardless, I know that sounds kind of crazy
15:18:57 <mgagne> mfisch: we need more than one candidate to vote =)
15:19:23 <mdorman> well if there’s only one nominee, then it’s just ‘thums up/thumbs down’ vote
15:19:30 <mdorman> as long as up > down, they’re elected
15:19:50 <xingchao> EmilienM: got it
15:20:00 <mfisch> I guess I want to avoid someone nominating themselves and it becoming PTL by fiat without discussion or reflection
15:20:13 <Hunner> "Elections will be held using CIVS and a Condorcet algorithm (Schulze/Beatpath/CSSD variant). Any tie will be broken using Governance/TieBreaking."
15:20:20 <Hunner> Sounds complicated :o
15:20:34 <dvorak> sure, I think thumbs up/down is fine.  The number of candidates is pretty small and likely uncontraversial
15:20:40 <Hunner> But job description first. By next meeting? Or two, to give time?
15:20:58 <dvorak> and yeah, actual voting if we have more than one candidate
15:20:59 <EmilienM> Hunner: that's when you have more than one person applying
15:21:14 <mgagne> Hunner: I think we can ask others about vote system if we need assistance
15:21:15 <Hunner> EmilienM: Yeah, I know :)
15:21:39 <Hunner> mgagne: I assume it's more or less "thumbs up/down with a fancy name" :)
15:21:54 <mdorman> i think job description by next meeting.
15:21:55 <dvorak> it's a variant of ranked voting, like IRV
15:22:12 <dvorak> we probably should have done it for the meeting time :)
15:22:12 <mgagne> Hunner: I don't know the exact algorithm but I guess there's more to it =)
15:22:43 <mfisch> its easy to setup
15:23:00 <crinkle> it seems like we have a lot to discuss on the mailing list, let's take it there
15:23:04 <mgagne> yep
15:23:13 <mdorman> +1 let’s move on
15:23:13 <Hunner> We should probably just add "voting method" to next weeks agenda
15:23:22 <Hunner> or yeah, ml
15:23:34 <dvorak> well, or worry about it more than one person self-nominates :)
15:23:40 <crinkle> #topic review/bug triage
15:23:56 <crinkle> this was mfisch's idea to start doing, mfisch how do you propose we go about this?
15:24:32 <dvorak> My thought was that we'd just have a dedicated time in the schedule each week for people to bring up specific bugs or reviews that need discussion or attention
15:24:45 <mfisch> doesnt puppet labs do somthing similar?
15:25:01 <crinkle> anyone have specific bugs or reviews we should look at?
15:25:05 <mdorman> i think we should just try to reserve the last 15-20 mins of the meeting time for that purpose.
15:25:05 <crinkle> yes we do something similar
15:25:19 <dvorak> I would have, but sbadia took care of mine for me :)
15:25:28 <mgagne> I suggest we close all released bugs and I propose myself for the task
15:25:39 <crinkle> mgagne: ++
15:25:42 <Hunner> mfisch: Yeah, in a google hangout or bluejeans video chat.
15:25:59 <EmilienM> mgagne: +1 - thanks a lot
15:26:05 <sbadia> dvorak: ;-)
15:26:08 <Hunner> mfisch: In PL we ask for any proposed reviews to look at, and if no one has anything then we just pick a module and start going down the review list
15:26:14 <crinkle> mdorman: should we change the topic to "open discussion" and do triage later?
15:26:58 <mdorman> that’s how the meeting flow makes sense to me.  are we done with everything else that was on the agenda for today?
15:27:14 <crinkle> yep https://wiki.openstack.org/wiki/Meetings/PuppetOpenStack#New_Items
15:27:27 <mdorman> but i have no strong preference.  i mean if it makes more sense to triage first, that’s fine.
15:27:36 <mfisch> other stuff first
15:27:39 <crinkle> okay
15:27:43 <crinkle> #topic open discussion
15:27:45 <mfisch> but now we're having a meta discussion on triage
15:27:51 <crinkle> haha
15:27:58 <dvorak> both of them are potentially unlimited topics, so just depends  on preference I think
15:27:59 <mdorman> i’m just imagining that we tell people who wnat to discuss bugs to drop in at the last 20 min (or whatever)
15:28:22 <mdorman> dvorak:  yeah that’s kinda what i’m thinking.  both would need to be time-bound
15:29:01 <dvorak> mdorman: what I've seen done on the puppet triage calls is that they start off asking if anyone is there to talk about something specific so that people that don't normally attend don't have to sit through the whole thing
15:29:04 <EmilienM> dvorak: that would be great yes
15:29:24 <dvorak> specific = specfic bug or review
15:29:46 <mdorman> yeah maybe that’s a good way to approach it
15:29:48 <dvorak> at least that's my recollection from the 2-3 I've been to :)
15:30:03 <mdorman> i guess we can just pick something to try, and can always adjust later
15:30:08 <dvorak> +1
15:31:38 <EmilienM> +1
15:31:47 <crinkle> I'm not sure I see what the resolution is
15:32:17 <mdorman> at teh end of the regular agenda, ask if anybody has any specific bug/review to call out
15:32:19 <mfisch> I'd like to also pick a module and walk through bugs and reviews
15:32:25 <mfisch> especially bugs since they get 0 attention now
15:32:38 <mdorman> and if no, then move to on open discussion / general bug review
15:33:35 <mfisch> my original intention was just for bug review TBH, but reviews also makes sense
15:34:08 <Hunner> "flexible" is the word :)
15:34:36 <mdorman> yeah we don’t need tons of structure on this
15:34:40 <mfisch> +1
15:34:43 <Hunner> If there are high-profile reviews or bugs that we can't reach a conclusion on during the normal week, those are often the target of discussion during triage
15:35:07 <mgagne> +1
15:36:01 <crinkle> that sounds good to me
15:36:11 <crinkle> are there any reviews or bugs to call out today?
15:37:10 <mdorman> this one is not all that important, but i have been struggling to get tests on https://review.openstack.org/#/c/158898/ to work right
15:38:03 <mdorman> so have been meaning to ask for suggestions/help on that.
15:38:19 <mgagne> mdorman: I can take a look at time after the meeting
15:38:29 <mdorman> that’d be great, thanks.
15:38:57 <mdorman> this is the core problem : https://review.openstack.org/#/c/158898/3..4/spec/classes/nova_compute_libvirt_spec.rb  when operatingsystemmajrelease is integer, some stuff fails, but when it’s a string, different stuff fails.
15:39:09 <Hunner> mdorman: It looks like it's because the test has :provider => nil, but the params.pp would set it to init?
15:40:24 <Hunner> operatingsystemmajrelease would normally just be a string, since it's a fact... though now newer facters can return structured data, though that may still be only string types
15:40:32 <mgagne> mdorman: AFAIK, facts are always a string
15:41:35 <mdorman> yeah it’s related to the change from “everything is a string” to structured data stuff, i believe
15:42:12 <mdorman> anywya we can take it off line
15:42:14 <Hunner> `puppet apply -e "notice(inline_template('<%= @operatingsystemmajrelease.inspect %>'))"` says it's a string
15:42:35 <Hunner> mdorman: Oh, sorry, is that not what this time is for?
15:43:09 <mgagne> we can take it to our own channel =)
15:43:16 <mdorman> i just did not want to consume all the time if others had topics
15:43:28 <dvorak> well, sounds like we have plenty of people willing to help out, don't need to solve it during the meeting
15:43:37 <Hunner> I mean, the topic is still open discussion, but I assumed after open time was review time... though I guess it could always finish up in #puppet-openstack
15:44:37 <mdorman> (that and i have not eaten breakfast yet, which i am going to do after this meeting is done. :)
15:44:39 <mfisch> any objections to adding a module to the agenda to do some review/bug triage on?
15:44:55 <mfisch> or do people want to pick next week's during this meeting
15:45:20 <crinkle> if someone suggested one or two and just added it to the agenda i think that would be fine
15:45:26 <mgagne> yep
15:45:57 <mfisch> k
15:46:34 <mdorman> +1
15:48:03 <mfisch> Are we still in open time?
15:48:13 <EmilienM> +1
15:48:22 <crinkle> I think we're in open discussion/review/bug time
15:48:30 <EmilienM> mfisch: yes I guess so
15:48:39 <mfisch> I'd like to request that someone send out the meeting notes to the ML along with the pointer to next week agenda
15:48:55 <crinkle> I will do that
15:49:26 <mfisch> thanks
15:49:50 <sbadia> good idea!
15:49:52 <sbadia> thanjs
15:50:04 <EmilienM> crinkle: thanks
15:50:04 <EmilienM> crinkle: that could be something in PTL tasks description :)
15:50:25 <mfisch> Yes, agree
15:50:29 <Hunner> EmilienM: Sounds like you should send the first ML post about the task description :)
15:50:50 <mfisch> the PTL should be driving for sure but crinkle can manage for a few weeks i Think
15:50:51 <crinkle> I think sbadia was going to start that discussion
15:51:05 <sbadia> ok :)
15:52:24 <EmilienM> Hunner: I was wondering who took this action
15:52:24 <EmilienM> I'm fine with it okay
15:52:26 <EmilienM> sbadia: if so, can you create an #action ?
15:52:40 <crinkle> EmilienM: i already created an #action i believe
15:52:49 <sbadia> EmilienM: I've already an action about that :)
15:52:58 <mfisch> action: someone to make an action
15:53:04 <sbadia> mfisch: :D
15:53:11 <sbadia> mfisch: -2
15:53:23 <crinkle> are there any other reviews or bugs that people want to look at today? there's not enough time to dive into a module
15:55:56 <sbadia> seems no :)
15:56:12 <dvorak> I think I missed open discussion, but I do have one other thing to bring up if we're done with bug/review time
15:56:28 <crinkle> dvorak: go for it
15:57:04 <dvorak> Tim sent out an email last night about planning for the Ops Summit in Vancouver.  Do we expect we'll get time to meet outside of that, or should we be pushing to be included in that?
15:57:39 <crinkle> last time we had a design session and an ops session, i think we should try to do the same this time
15:57:42 <mdorman> i think we should propose a working group sesion
15:57:49 <mfisch> I was going to ask him directly
15:58:02 <mfisch> we need official space/time unlike in Philly
15:58:19 <dvorak> yes.  I put a comment to that effect on the planning etherpad, but I wasn't sure of the status
15:58:23 <crinkle> i think we're about to get kicked out and i have a standup to go to
15:58:26 <EmilienM> it was about concerns
15:58:26 <EmilienM> but okay :)
15:58:34 <crinkle> i will add this to the agenda for next week
15:58:39 <dvorak> that works
15:58:40 <crinkle> #endmeeting