15:00:01 <EmilienM> #startmeeting puppet-openstack
15:00:02 <openstack> Meeting started Tue Apr 14 15:00:01 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:09 <gchamoul> o/
15:00:17 <gchamoul> hi everybody!
15:00:44 <EmilienM> #topic Review past action items
15:00:59 <EmilienM> "mgagne to start thread on defaults for new config file parameters"
15:01:07 <crinkle> morning
15:01:09 <EmilienM> mgagne: should we postpone it (again) ?
15:01:15 <Hunner> Congrats EmilienM :)
15:01:27 <EmilienM> Hunner: thanks :-)
15:01:35 <mgagne> EmilienM: yes, I don't think I'll have time to work on it for a couple of weeks
15:01:52 <EmilienM> mgagne: ack
15:02:07 <EmilienM> "spredzy to structure w/ the community what exactly will be created and propose a plan on next meeting"
15:02:12 <EmilienM> spredzy: same question ^
15:02:29 <spredzy> EmilienM, postpone. Didn't have time to work on it this week.
15:02:35 <EmilienM> spredzy: ack
15:02:48 <EmilienM> EmilienM Adding the Puppet modules to OpenStack => https://review.openstack.org/#/c/172112/
15:03:07 <EmilienM> I don't know the exact process of it, but it's at least WIP
15:03:28 <EmilienM> also, we will have to figure out the moving of our modules from Stackforge to OpenStack namespaces
15:03:36 <Hunner> They don't like the name? That's odd...
15:03:44 <EmilienM> and the impact..
15:04:03 <EmilienM> Hunner: moving under the big tents implies to use github/openstack (afik)
15:04:07 <mgagne> have they proposed an alternative or provided a reason?
15:04:21 <sbadia> EmilienM, ah, anne made a comment about the naming
15:04:27 <gchamoul> Hunner, mgagne: trademark issue!
15:04:40 <mgagne> right
15:04:47 <EmilienM> there is two topics here, naming and moving from stackforge
15:04:48 <gchamoul> for the sbadia proposition to use Puppet as a Name
15:04:50 <mgagne> can we ask puppetlabs about it?
15:05:17 <EmilienM> crinkle: can you take this action? I'm not sure if it's doable
15:05:22 <Hunner> "PuppetModules"? "AutomationPuppet"?
15:05:38 <Hunner> Assuming AutomationChef will want one too
15:06:08 <EmilienM> Hunner: that would require further discussion with the community I think
15:06:25 <crinkle> I'm not sure Puppet is descriptive enough, and Puppet Labs is already using it to mean puppet the language
15:06:59 <EmilienM> well, here we go (naming)
15:07:13 <gchamoul> sbadia: what's the matter with PuppetOpenstack?
15:07:18 <mdorman> heh
15:07:39 <EmilienM> I'll run a discussion around it by the mailing list, implying us, Puppet folks and TC so we can have an open-discussion
15:07:39 <Hunner> Two hardest things in CS: Cache invalidation and naming things
15:08:03 <mgagne> alright, lets move it to the ML
15:08:07 <EmilienM> mgagne: thanks
15:08:13 <sbadia> gchamoul, nothing, it's just to be coherant with the rename (Puppet-OpenStacl => OpenStack/Puppet) I mean wiki side, but indeed it's a problem
15:08:28 <EmilienM> #action EmilienM to run discussion about Puppet OpenStack naming
15:08:32 <gchamoul> sbadia: i got it now ..
15:08:45 <gchamoul> sbadia: thx
15:08:50 <EmilienM> sbadia: can I go ahead?
15:08:51 <sbadia> Hunner, :D
15:08:59 <sbadia> EmilienM, yep sure
15:09:15 <EmilienM> "gael,sbadia puppet-rspec 2.x mostly ok (final check in progress) => https://trello.com/c/eHXc1Ryd/4-investigate-the-necessary-change-to-be-rspec-puppet-2-0-0-compliant"
15:09:39 <EmilienM> that's a great work sbadia & gchamoul - thanks a lot !
15:09:48 <EmilienM> we have an item for it later
15:09:50 <sbadia> puppet-rspec 2.0.0 is ok, thanks a lot gchamoul !
15:09:52 <EmilienM> "gael,sbadia adding a check for parameter documentation on our modules => ok https://trello.com/c/tC7ZhPtN/10-add-puppet-lint-param-docs-plugins-to-puppet-lint"
15:10:00 <sbadia> 2.0.1 unpin rspec 3.x
15:10:09 <EmilienM> also done
15:10:17 <Hunner> ~> 2.0.0 then?
15:10:25 <sbadia> Hunner, yep
15:10:28 <gchamoul> yes
15:10:40 <EmilienM> and last action so far: "crinkle to send email about PTL: http://lists.openstack.org/pipermail/openstack-dev/2015-April/061251.html"
15:10:46 <EmilienM> which is also done.
15:11:05 <EmilienM> #topic Summit organization
15:11:12 <sbadia> for documentation things the check is present everywhere, but in some module there are only the parameter doc (and no doc)
15:11:36 <EmilienM> sbadia: oops, sorry maybe i ran too fast
15:11:42 <sbadia> np :)
15:11:47 <sbadia> EmilienM, congrats :)
15:12:01 <EmilienM> #info OPS meetup should happen on Wednesday 9:50 - 10:30 in Big Room 2 - needs to be confirmed
15:12:11 <EmilienM> #link https://etherpad.openstack.org/p/liberty-summit-ops-puppet
15:12:18 <EmilienM> it's empty right now :)
15:12:39 <EmilienM> #action EmilienM to runs a thread on OpenStack OPS Mailing list and try to find some topics
15:12:53 <EmilienM> feel free to feed it of course :)
15:13:20 <EmilienM> about design sessions, I asked for a room for one day. I'm still waiting for approval
15:13:31 <EmilienM> I'll let you know as soon I got it
15:13:43 <EmilienM> I also created an etherpad:
15:13:49 <EmilienM> #link https://etherpad.openstack.org/p/liberty-summit-design-puppet
15:14:09 <EmilienM> same thing, we will feed it the next weeks
15:14:36 <EmilienM> something else about sessions so far?
15:15:00 <sbadia> nothing for me right now
15:15:23 <spredzy> nop
15:15:28 <EmilienM> before ending this topic, I would like to propose a diner + something during the summit, with all Puppet OpenStack contributors in Vancouver
15:15:40 <gchamoul> :'(
15:15:47 <EmilienM> anyone is welcome to join
15:15:50 <mdorman> that’d be cool.  we talked about doing that in paris but i’m not sure it actually happened
15:16:09 <sbadia> yep cool idea!
15:16:12 <EmilienM> I'm just open to early feedback here and now, so I can run a real discussion and maybe organize it
15:16:25 <EmilienM> I did not want to pollute the ML
15:16:48 <gchamoul> ML polution is bad! ;-P
15:17:43 <EmilienM> I think I won't pollute the ML with a big thread. I'll send one single mail with an etherpad link where we discuss on it
15:17:47 <EmilienM> what do you think?
15:17:51 <spredzy> +1
15:17:57 <EmilienM> so everyone can join
15:18:07 <gchamoul> +1
15:18:17 <Hunner> Yup
15:18:23 <sbadia> ok for a mail + etherpad
15:18:26 <mdorman> +1
15:18:43 <EmilienM> #action EmilienM to run a thread about Summit diner with Puppet OpenStack folks
15:18:53 <EmilienM> s/thread/single-mail/ :-)
15:19:05 <EmilienM> #topic blockers to make a Kilo release
15:19:28 <EmilienM> well, I think it's fair if we don't make a release in the same time as other projects this time
15:19:52 <EmilienM> I plan to follow OpenStack releases for Liberty.
15:20:03 <EmilienM> I would like to raise here our blockers
15:20:11 <EmilienM> I think Keystone v3 API support is one of them
15:20:56 <Hunner> Which is part of why we didn't go with aviator, yeah?
15:21:05 <EmilienM> anyone running Kilo ?
15:21:10 <EmilienM> Hunner: yes
15:22:02 <EmilienM> crinkle: are you aware about any blocker else ?
15:22:14 <EmilienM> which is a big one btw...
15:22:35 <crinkle> I don't know of any, but I'm sure there are config changes that we should find and fix
15:23:26 <EmilienM> ok. I think we should first ask to our community if someone is running Kilo
15:23:30 <EmilienM> and get the feedback
15:24:06 <EmilienM> in // I'll work on reading doc/release notes to check if new params are missing ( I have the bandwidth)
15:24:27 <EmilienM> someone wants to make it otherwise?
15:25:12 <EmilienM> #action Investigate Kilo updates and new eventual parameters for OpenStack services
15:25:44 <EmilienM> #action EmilienM to ask ML if someone is running Kilo and ask for feedback
15:25:56 <EmilienM> the first action has no name, because It's open to everyone
15:26:20 <EmilienM> anything else  on Kilo ?
15:26:36 <EmilienM> #topic TripleO CI integration
15:26:47 <sbadia> EmilienM, yep we can fill a card in trello (for the first)
15:27:03 <EmilienM> sbadia: I'll do that
15:27:22 <EmilienM> #action EmilienM to create a Trello card about Investigate Kilo param updates
15:27:28 <EmilienM> so lately (previous meetings), we talk about an eventual proposal to add non-voting jobs into Puppet OpenStack gate
15:27:36 * EmilienM waves on dprince
15:28:04 <EmilienM> dprince: can you give us a short history and maybe a proposal?
15:28:39 <dprince> hi, so yeah, we've got what might be a really great CI feedback loop for the puppet modules in TripleO right now with the fedora puppet job
15:29:16 <dprince> it currently uses RDO trunk packages (built via delorean) so it is using fairly recent builds of things (although not up to the minute yet)
15:29:52 <EmilienM> the only one (limitation) today is that we focus on specific drivers (ML2/OVS for neutron, RBD for Cinder, Swift for Glance, etc)
15:29:59 <EmilienM> but that would be a first stage
15:30:13 <dprince> I wrote up a wiki page here which describes the job details: https://wiki.openstack.org/wiki/TripleOPuppetCI
15:30:19 <EmilienM> #link https://wiki.openstack.org/wiki/TripleOPuppetCI
15:30:33 <EmilienM> dprince: also, is it possible one day we could be blocked by packaging issue?
15:30:42 <Hunner> Shiny
15:30:44 <dprince> EmilienM: use, the job is a bit prescribe, but we can make it more flexible to increase coverages I think
15:31:01 <dprince> EmilienM: yes, always a possiblity
15:31:10 <EmilienM> coverage for more use-cases would be a step forward, I would like to have a job now and see how it works
15:31:12 <spredzy> dprince, my concern is coverage. If someone is adding a feature, how can a user make the CI test this specific feature ?
15:31:16 <EmilienM> if it really helps, etc
15:31:20 <dprince> EmilienM: this week for example we got bit by a qemu package regression (it broke cinder)
15:31:41 <EmilienM> spredzy: we can't without coverage, but at least we can have a first iteration to Functional CI :-)
15:31:57 <sbadia> yep :)
15:32:02 <EmilienM> dprince: ok so maybe if we go that way, we may want to use stable packaging?
15:32:11 <dprince> EmilienM: but for OpenStack packages I'm finding that taking a Delorean snapshot and running with it for two weeks gives us good stability. Then we bump the Delorean URL (to a fresher version of the trunk packages) and run with it again
15:32:44 <EmilienM> dprince: that sounds like a great idea
15:32:46 <dprince> EmilienM: so what we get is some stability, at the cost of our packages being slightly older than upstream
15:33:00 <EmilienM> it's fair...
15:33:01 <dprince> EmilienM: I'd eventually like to get to true "upstream packages" but that effort is ongoing
15:33:28 <EmilienM> is anyone against this work? anyone with feedback (good/bad) ?
15:33:29 <dprince> what we have today is upstream enough... or as upstream as you want it to be with some level of stability
15:33:49 <Hunner> +1 sounds really good to start with nonvoting and vet it
15:33:54 <crinkle> ++
15:34:01 <gchamoul> dprince: so right now, only f21 and centos7.x, right?
15:34:13 <dprince> gchamoul: no centos7 yet, but it is in the works
15:34:21 <gchamoul> ack cool!
15:34:34 <dprince> gchamoul: just shuffling around some of the infra jobs
15:34:52 <EmilienM> dprince: are you interested to patch OpenStack infra to gate our modules with non-voting tag ?
15:35:13 <dprince> EmilienM: sure, I can propose this
15:35:18 <EmilienM> #action dprince to patch OpenStack infra to gate Puppet OpenStack modules (non-voting for now)
15:35:27 <EmilienM> dprince: thanks! that's exiting
15:35:35 <sbadia> thanks!
15:35:36 <EmilienM> anything else on tripleo/puppet/ci?
15:35:37 <dprince> The only thing I want to check on is capacity, how many jobs does puppet require a day for example?
15:36:00 * dprince can compute this himself... just wanted to ask if anybody had an idea
15:36:03 <EmilienM> dprince: I'll provide you the information, I'll check our stats
15:36:25 <dprince> EmilienM: cool, thank
15:36:30 <EmilienM> #action EmilienM to investigate how many patches are sent per day in our modules and sends the info to dprince
15:36:48 <EmilienM> nibalizer is not around
15:36:52 <EmilienM> I wanted to talk about Beaker integration
15:37:04 <EmilienM> crinkle: do you have updates on this? Should I create a topic if so?
15:37:16 <crinkle> I don't have any information
15:37:18 <EmilienM> o
15:37:19 <EmilienM> ok
15:37:26 <EmilienM> next time
15:37:32 <EmilienM> #topic Rspec 3.x work
15:37:41 <EmilienM> sbadia, gchamoul : status, any blockers?
15:38:18 <sbadia> no blockers, expect the one with beaker
15:38:27 <sbadia> but I've not checked recently
15:38:58 <EmilienM> sbadia: ok. I'll definitely make sure we update this topic at next meeting
15:38:59 <gchamoul> no blockers
15:39:02 <EmilienM> gchamoul: ack
15:39:11 <EmilienM> #topic Bug triage sessions
15:39:45 <EmilienM> should we organize a weekly/monthly triage session? (patches, bugs, etc)
15:40:07 <gchamoul> that's what I proposed some weeks ago!
15:40:09 <vinsh_> New meeting attendee here.. long time lurker.  Can someone share where(etherpad/blueprints) the main focus areas are for puppet-openstack?  Want to follow that with this meeting.
15:40:24 <gchamoul> +1
15:40:39 <EmilienM> gchamoul: that's why I'm raising it here :)
15:40:52 <gchamoul> Vinsh: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20150414
15:40:56 <Hunner> Video based? I think irc may be difficult
15:40:57 <Vinsh> Or a weekly rspec helper session? :)
15:41:04 <Vinsh> thx.
15:41:19 <EmilienM> mfisch: any thoughts? I also remember you were asking
15:41:33 <sbadia> Vinsh, and https://trello.com/b/4X3zxWRZ/on-going-effort
15:41:42 <Vinsh> perfect. thanks.
15:41:43 <crinkle> i think mfisch is afk
15:41:53 <EmilienM> of course it would be something were everyone is welcome and there is no required attendance.
15:42:26 <gchamoul> mfisch and dvorak are in team building I think this week!
15:42:41 <Vinsh> they are presenting at "openstack live"
15:42:56 <EmilienM> I'll do deep in Launchpad and see if we really have a ton of bugs and if so, it could deserve a dedicated session. Otherwise we can keep our weekly meetings and add items to the regular agenda
15:43:01 <gchamoul> Vinsh: oh yes right!
15:43:19 <EmilienM> mgagne: you are the LP guy, what do you think about the status of our LP?
15:43:45 <EmilienM> mgagne: translation: you know more than me about that now :-)
15:44:20 <mgagne> EmilienM: what kind of status? bugs? or the use we are making of it?
15:44:27 <gchamoul> EmilienM: sbadia and I were talking about something similar to the weekly puppetlabs hangouts
15:44:30 <EmilienM> mgagne: both
15:44:50 <EmilienM> actually, any feedback is welcome about that.
15:44:55 <gchamoul> sbadia: remember ?
15:45:02 <mgagne> EmilienM: bugs should be up to date atm, I can do an other pass at targeting committed bug to next milestone
15:45:15 <sbadia> gchamoul, yep :)
15:45:17 <EmilienM> mgagne: I'm asking more about "do we have a lot of bugs pending" ?
15:45:28 <EmilienM> if not, I'm not sure we need a triage session
15:45:32 <mgagne> EmilienM: I don't know, I'll have to check
15:45:46 <mgagne> 73 https://bugs.launchpad.net/openstack-puppet-modules/+bugs?search=Search&field.status=New - 204 https://bugs.launchpad.net/openstack-puppet-modules/+bugs
15:45:52 <mgagne> damn
15:45:58 <mgagne> 73 New - 204 Open
15:46:02 <EmilienM> mgagne: please let me know, so we can decide if we create a triage session or not
15:46:03 <mgagne> 19 inprogress
15:46:18 <EmilienM> well, that's big
15:46:32 <mgagne> yes, we would use a triage session
15:46:33 <EmilienM> mgagne: does it make sense if I run a triage session before the summit ?
15:46:36 <EmilienM> ok
15:46:58 <EmilienM> #action EmilienM to runs a bug triage session and discuss with sbadia, gchamoul  & others about the way to make it
15:47:01 <mgagne> but looks like fix committed count as open
15:47:12 <mgagne> I'll have to filter then out
15:47:14 <mgagne> them*
15:47:18 <EmilienM> mgagne: that make us think we should do a release :)
15:47:40 <Hunner> A google hangout and etherpad is kind of how puppetlabs does triages
15:47:44 <mgagne> EmilienM: I wouldn't do a release solely based on bug fixed count =)
15:48:02 <sbadia> Hunner, yep, +1
15:48:09 <EmilienM> Hunner: cool, we will discuss about tools after the meeting if you want
15:48:11 <EmilienM> mgagne: +1
15:49:00 <EmilienM> anything else on LP ?
15:49:15 <mgagne> nothing that I can think of
15:49:20 <EmilienM> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
15:49:21 <mgagne> mostly related to releases themselves
15:49:34 <mgagne> like icehouse and juno
15:49:52 <EmilienM> mgagne: indeed
15:50:12 <EmilienM> mgagne: time is running out, I'll continue this topic later on IRC
15:50:15 <mgagne> sure
15:50:18 <EmilienM> thanks
15:50:22 <EmilienM> deprecate puppet-openstack, this patch https://review.openstack.org/#/c/101704/ should be reviewed
15:50:41 <Hunner> woot!
15:50:52 <gchamoul> yes!
15:50:55 <EmilienM> if you have some relevant bugs/patches that need an eye, please raise it here. We have 9 min left
15:51:18 <gchamoul> EmilienM, mgagne: https://review.openstack.org/106144
15:51:23 <gchamoul> hrmm ... :D
15:51:38 <mgagne> gchamoul: I see neutron_agent_ovs got introduced
15:51:42 <mgagne> what about linuxbridge?
15:52:03 <EmilienM> mgagne: I think gchamoul was waiting for approval on OVS and patch LB after this
15:52:04 <mgagne> I don't want linuxbridge to be a 2nd class citizen
15:52:09 <mgagne> alright
15:52:09 <EmilienM> gchamoul: tell me if I'm wrong
15:52:11 <mgagne> just making sure
15:52:24 <mgagne> because linuxbridge isn't broken, less incentive to update it
15:52:32 <gchamoul> mgagne: I will take over the Emilien patch on linuxbridge
15:52:37 <EmilienM> thanks guys
15:52:52 <EmilienM> LB is very important too
15:53:00 <gchamoul> of course!
15:53:01 <EmilienM> and there is no priority between OVS & LB
15:53:03 <mgagne> don't start me on that one =)
15:53:04 <crinkle> I don't expect it to get fully reviewed here but I would like people to look at and test out https://review.openstack.org/#/c/172579/ and https://review.openstack.org/#/c/172580/ when they have the time
15:53:16 <EmilienM> mgagne: lol. No time for trolling now :P
15:53:34 <mgagne> gchamoul: approved
15:53:54 <EmilienM> crinkle: I love your commit messages, they are longer than the patch :)
15:54:01 <gchamoul> lol
15:54:05 <gchamoul> mgagne: thx
15:54:22 <EmilienM> #link https://review.openstack.org/#/c/172579/
15:54:25 <EmilienM> #link https://review.openstack.org/#/c/172580/
15:54:50 <EmilienM> #action gchamoul to patch puppet-neutron to follow https://review.openstack.org/106144 for LB driver
15:55:11 <gchamoul> ack
15:55:13 <EmilienM> #link https://review.openstack.org/#/c/101704/
15:55:55 <EmilienM> well seems like we're almost done
15:56:07 <sbadia> just in time
15:56:17 <EmilienM> anything else?
15:56:40 <gchamoul> EmilienM: yes
15:56:52 <EmilienM> gchamoul: ?
15:56:57 <gchamoul> EmilienM: I think we have some kilodeprecationm patches in review https://review.openstack.org/#/q/owner:%22Mike+Dorman%22+status:open,n,z
15:57:17 <EmilienM> gchamoul: nice one
15:57:20 <gchamoul> crinkle has already +2s
15:57:26 <EmilienM> I'll review them and +A if it's good.
15:57:43 <gchamoul> just need another tiger's eyes
15:58:12 <EmilienM> seems like we are really done now
15:58:14 <EmilienM> I close the meeting, thanks everyone, see you on IRC
15:58:25 <EmilienM> #endmeeting