15:00:07 <EmilienM> #startmeeting puppet-openstack
15:00:07 <openstack> Meeting started Tue May 12 15:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:15 <EmilienM> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20150512
15:00:20 <crinkle> o/
15:00:22 <EmilienM> roll call, who is here today?
15:00:30 <spredzy> hello
15:01:23 <EmilienM> let's start!
15:01:30 <EmilienM> #topic CI status
15:01:37 <EmilienM> as usual, a quick status on CI
15:01:47 <EmilienM> I updated the spreadsheet
15:01:50 <EmilienM> #link https://docs.google.com/spreadsheets/d/1i2z5QyvukHCWU_JjkWrTpn-PexPBnt3bWPlQfiDGsj8/edit#gid=0
15:02:11 <EmilienM> beaker: the centos jobs are now here, and I'm working on it this week to have them green
15:02:29 <EmilienM> crinkle, sbadia: I'll probably poke you to review them
15:02:50 <EmilienM> sbadia: can we have a status on puppet4 ?
15:03:15 <sbadia> still missing nova, neutron and swift
15:03:31 <sbadia> but my free time for the moment is near 0 :(
15:03:41 <EmilienM> sbadia: It seems like some time we did not make progress on it. Would you need some help from the community ?
15:03:55 <sbadia> I can finish nova today, but if somone would help on other it would be nice
15:04:00 <EmilienM> sbadia: I guess it's the same status for "Backport RSpec3.x to stable branches"
15:04:12 <sbadia> yep
15:04:20 <EmilienM> is anyone here willing to help sbadia on Backport RSpec3.x to stable branches and Puppet4 work ?
15:05:03 <EmilienM> sbadia: seems like not (yet) - maybe can you raise something on the mailing list?
15:05:16 <sbadia> ok
15:05:19 <EmilienM> I'm pretty sure we can have some help
15:05:42 <EmilienM> #action sbadia asks on ML to get some help on rspec & puppet4 work
15:05:44 <Hunner> o/
15:05:59 <EmilienM> Hunner: willing to help? :)
15:06:41 <gchamoul> o?
15:06:42 <Hunner> I can help with auxiliary project, but I'm pretty swamped ATM :/
15:07:07 <Hunner> (rspec-puppet support for puppet 4 functions is on my to-do list, for example)
15:07:10 <EmilienM> Hunner: I'm just asking, feel free to say no.
15:07:29 <EmilienM> Any help need to be synced with what sbadia is doing, so please reach him before starting something
15:08:06 <EmilienM> and a last information about CI is spredzy and I are going to push testing on puppet-tripleo (rspec + beaker)
15:08:22 <EmilienM> spredzy: if you still feel we can make it :P
15:08:33 <EmilienM> #action EmilienM push beaker tests to puppet-tripleo
15:09:16 <spredzy> EmilienM, sure thing
15:09:19 <EmilienM> cool
15:09:27 <EmilienM> let's move
15:09:32 <EmilienM> #topic Summit
15:09:39 <EmilienM> #link https://etherpad.openstack.org/p/liberty-summit-design-puppet
15:09:48 <EmilienM> #link https://etherpad.openstack.org/p/YVR-ops-puppet
15:10:08 <EmilienM> if you have a session to propose, make sure to do it before Thursday
15:10:16 <EmilienM> so I can work on schedule this week-end
15:10:24 <EmilienM> we have free slots I think
15:11:04 <EmilienM> also, crinkle and I will attend a session with os-infra about CI
15:11:17 <EmilienM> we try to bring consistency in puppet modules functional testin
15:11:22 <EmilienM> feel free to join of course
15:11:45 <mfisch> we have free slots but we also have people with other stuff to do
15:11:51 <mfisch> mike and I both have talks that day
15:11:52 <EmilienM> is someone willing to lead "Handling of config file values along with parameter defaults" session ?
15:12:06 <EmilienM> mfisch: sorry, but we can't satisfy everyone ;-)
15:12:13 <EmilienM> I already managed to have a room for a full day
15:12:16 <mfisch> EmilienM: yeah we just need to be cognizant of that
15:12:35 <EmilienM> mfisch: we will do our best to do so. Feel free to bring any suggestion
15:12:59 <EmilienM> mfisch: let me know in PM your schedule asap, please
15:13:10 <mfisch> I think for me earlier is better
15:13:18 <EmilienM> nobody to lead the default parameters session?
15:13:21 <mfisch> I was thinking we'd spend 5 mins and try to plan out the sessions a bit
15:13:37 <EmilienM> if nobody is volunteer, I'll take it. It's a really important topic
15:13:52 <EmilienM> mfisch: right now? or next week?
15:14:02 <mfisch> next week
15:14:11 <EmilienM> mfisch: sounds good to me
15:14:48 <EmilienM> ok, putting my name in the meantime
15:15:32 <EmilienM> mfisch: there is also the OPS session
15:15:43 <mfisch> yep
15:16:05 <EmilienM> crinkle: should we organize it too with some kind of agenda?
15:16:11 <EmilienM> it's 40 minutes
15:16:20 <mfisch> that one has always been more of a chat session
15:16:23 <mfisch> what are prople doing
15:16:25 <EmilienM> yeah
15:16:27 <mfisch> what do people have issues with
15:16:35 <mfisch> the reason is that thats a more general audience than our full day stuff
15:16:40 <EmilienM> and etherpad will be good to track the feedback
15:16:52 <EmilienM> I would be very happy to have the OPS session *before* Design
15:17:02 <mfisch> when is the design?
15:17:02 <EmilienM> but it's opposite now. So we have to deal with that
15:17:06 <EmilienM> Tuesday.
15:17:06 <mfisch> thursday?
15:17:13 <mfisch> everything is on Tuesday
15:17:34 <EmilienM> anything else about Summit ?
15:17:55 <EmilienM> I suggest you to learn bowling until next week.
15:18:04 <mfisch> lol
15:18:17 <EmilienM> let's move on
15:18:25 <EmilienM> #topic puppet-group in Stackalytics
15:18:28 <EmilienM> mfisch: go ahead
15:18:36 <mfisch> ok
15:18:39 <mfisch> thanks
15:18:52 <mfisch> so we used to use puppet-group in stackalytics to see all our contribs
15:18:58 <mfisch> it amalgamated all the puppet modules
15:19:13 <mfisch> now, not only is it missing modules, but there's an official puppet grouping already
15:19:22 <mfisch> so I'd like to remove it
15:19:30 <mfisch> rather than keeping it up to date
15:20:08 <EmilienM> mfisch: do you mean infra modules?
15:20:16 <mfisch> no, let me find it
15:20:32 <EmilienM> we have http://stackalytics.com/?module=puppetopenstack-group
15:20:42 <mfisch> yes thats it
15:20:48 <mfisch> project type - openstack
15:20:52 <mfisch> module PuppetOpenStack official
15:20:58 <EmilienM> w00t nice
15:21:04 <EmilienM> I did not know we were in OpenStack yet
15:21:08 <mfisch> so lets remove the other one
15:21:14 <EmilienM> oh it's not removed?
15:21:27 <mfisch> no thats what I'm asking
15:21:31 <EmilienM> mfisch: +1
15:21:33 <mfisch> puppet-group is still there, would like to remove
15:21:34 <mfisch> ok
15:21:39 <mfisch> I'll add you guys to the review
15:21:54 <EmilienM> #action mfisch to cleanup http://stackalytics.com Puppet groups
15:22:00 <EmilienM> mfisch: thanks for that
15:22:28 <EmilienM> let's move on
15:22:39 <EmilienM> #topic msync-configs workflow
15:22:44 <EmilienM> sbadia, spredzy: o/
15:23:14 <spredzy> so the idea was to automatically generate msync review once a msync path has been merged
15:23:41 <spredzy> in a post-merge hook fashion so every change will be enforce automatically
15:23:44 <EmilienM> and reviewers will use the usual workflow to review them, right?
15:23:49 <spredzy> yes
15:23:57 <Hunner> ooo interesting
15:23:58 <EmilienM> spredzy: can you give us the use cases ?
15:23:58 <spredzy> the hook will just submit the review
15:24:02 <sbadia> the default config is now updated, but under review (thx martin)
15:24:09 <EmilienM> (I'm doing the innocent guy)
15:24:30 <spredzy> EmilienM, imagine you change the version of rspec-puppet in the mysnc repo and the change is merged
15:24:49 <sbadia> but I've potentially a problem (the push part use a gerrit account) and if we push from a gerrit job, we have an account for that ?
15:24:50 <EmilienM> spredzy: that's something that will help to improve consistency in our modules, indeed
15:24:53 <spredzy> then it will automatically submit a review for each project within the msync umbrella
15:24:59 <crinkle> i think it should be done manually a couple of times to see if there are any kinks with modulesync and gerrit
15:25:07 <EmilienM> sbadia: os infra does
15:25:16 <EmilienM> crinkle: good poing
15:25:16 <spredzy> gerrit-bot I think'
15:25:18 <sbadia> s/gerrit/jenkins
15:25:21 <sbadia> ok
15:25:21 <spredzy> or something similar
15:25:23 <EmilienM> spredzy, sbadia: let's start manually first
15:25:23 <mfisch> sounds like an interesting idea
15:25:27 <sbadia> crinkle: +1
15:25:27 <EmilienM> see how it behaves
15:25:37 <EmilienM> and like crinkle suggests, wait a bit
15:26:04 <spredzy> ok for men
15:26:07 <spredzy> me*
15:26:11 <sbadia> #link https://review.openstack.org/#/c/177959/
15:26:11 <EmilienM> sbadia, spredzy: I guess you guys already have your plan to make it
15:26:25 <sbadia> 0:-)
15:26:46 <EmilienM> I like it
15:26:56 <spredzy> #action spredzy sbadia work on the mysnc automatization
15:27:02 <EmilienM> sbadia, spredzy: anything else we can help?
15:27:30 <spredzy> all good for me so far if any help i will ask
15:27:44 <EmilienM> spredzy: cool
15:27:55 <EmilienM> let's move on
15:28:05 <EmilienM> #topic puppet-oslo vs puppet-openstacklib
15:28:14 <EmilienM> so I ran this thread on the ML
15:28:27 <EmilienM> #link http://lists.openstack.org/pipermail/openstack-dev/2015-May/063587.html
15:28:49 <EmilienM> some good thoughts came up
15:29:05 <EmilienM> and there is one about creating puppet-openstackclient to move all the provider things inside that one
15:29:19 <EmilienM> and have puppet-oslo for Oslo things (messaging, logging, etc)
15:29:22 <EmilienM> OR
15:29:31 <EmilienM> keep everything in openstacklib
15:29:53 <EmilienM> my personal opinion is I would prefer having puppet-oslo, since it's really tight to OpenStack itself
15:29:58 <EmilienM> ie: releases
15:30:25 <EmilienM> while openstacklib is more a lib to manage common resources (database, queue, etc)
15:31:17 <EmilienM> mfisch, mgagne crinkle: you were in the thread/discussion, feel free to bring up your thoughts
15:31:35 <crinkle> i think my thoughts are well said in the thread
15:31:55 <crinkle> i was against puppet-oslo but mgagne brought up an interesting point
15:32:18 <crinkle> so now i'm +0 either way
15:32:19 <EmilienM> I don't know if puppet-openstacklib version-agnostic is important to have
15:32:22 <mgagne> there is a lot of oslo modules and each have its version. we will have to deal with it
15:32:42 <mgagne> oslo messaging section name is a good example
15:32:50 <EmilienM> mgagne: are they close to OpenStack release ?
15:33:04 <EmilienM> I think yes
15:33:07 <mgagne> EmilienM: yes and no
15:33:36 <mgagne> EmilienM: afaik, releases aren't sync with openstack
15:34:12 <EmilienM> well, I see stable/kilo
15:34:25 <EmilienM> but I also see tags
15:34:29 <mgagne> true, I think they used to not create stable branches
15:34:41 <mgagne> not use about the intention from now on
15:35:45 <EmilienM> mgagne: so you in favor of puppet-oslo ?
15:36:26 <EmilienM> also creating a puppet-openstackclient module
15:36:50 <mgagne> EmilienM: I don't have strong opinion yet because whatever we come up with, we will have to deal with all those oslo versions and their differences
15:37:01 <mgagne> and we don't have a plan yet
15:37:20 <EmilienM> mgagne: if the goal here is to bring consistency across all our modules, we can use openstacklib
15:37:53 <mgagne> I wouldn't mind unless we really wish to make it clear that openstacklib is for our module and oslo is for oslo specific stuff
15:37:56 <EmilienM> I'm just scared openstacklib is the repo where we put all common things, while we still need to make differentiation sometimes
15:38:02 <mgagne> yep
15:38:04 <mgagne> that ^
15:38:23 <mmagr> I like the separate openstackclient module, it's seems more clean to me
15:38:54 <EmilienM> anyone against having openstackclient and oslo modules ?
15:39:11 <mfisch> not me
15:39:31 <EmilienM> mgagne, crinkle: are we fine?
15:39:36 <mgagne> I'm ok with it
15:39:43 <mgagne> I think we have to think about how/why we wish to have those modules
15:39:47 <crinkle> i'm fine with it
15:39:51 <mgagne> and how we plan on facing the challenges I mentionned
15:39:52 <EmilienM> mgagne: big +1
15:40:21 <EmilienM> mgagne: do you want to take a slot for next week meetings?
15:40:29 <mgagne> it's summit
15:40:35 <EmilienM> I'm talking about summit
15:40:44 <EmilienM> mgagne: https://etherpad.openstack.org/p/liberty-summit-design-puppet
15:41:00 <EmilienM> maybe it's something we can investigate further IRL
15:41:04 <mgagne> I haven't figured out my schedule yet, we shall see
15:41:14 <EmilienM> mgagne: kk
15:41:41 <EmilienM> #action EmilienM create puppet-oslo & puppet-openstackclient modules
15:41:58 <EmilienM> agenda is finished
15:41:59 <EmilienM> #topic open discussion
15:42:14 <EmilienM> if anyone here wants to bring up a blueprint, a patch, a bug, a topic
15:42:17 <EmilienM> go ahead now!
15:44:08 <EmilienM> richm: is everything moving on for Keystone v3 ?
15:44:23 <EmilienM> do we have any blocker this week ?
15:44:32 <richm> EmilienM: not really - gildub decided we needed to redesign provider authentication first
15:44:56 <richm> so now all of the v3 work is on hold until gildub finishes that
15:45:33 <EmilienM> richm: ok
15:46:49 <EmilienM> seems like we are done
15:47:06 <Hunner> See you all irl next week :)
15:47:18 <EmilienM> I'm looking forward to see you guys!
15:47:32 <spredzy> cya next week
15:47:41 <EmilienM> I'm closing the meeting
15:47:52 <EmilienM> #endmeeting