15:00:08 <EmilienM> #startmeeting puppet-openstack
15:00:08 <openstack> Meeting started Tue Jul 14 15:00:08 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:14 <EmilienM> #link agenda: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20150714
15:00:16 <EmilienM> hello folks !
15:00:23 <iurygregory> hello :D
15:00:34 <crinkle> o/
15:00:39 <mfisch> yo
15:00:40 <spredzy> morning
15:00:48 <clayton> hi
15:01:01 <mdorman> o/
15:01:51 <EmilienM> #topic Review past action items
15:02:00 <_ody> o/
15:02:02 <EmilienM> crinkle on pushing zuul-cloner changes to all modules -> DONE
15:02:07 * _ody making coffee
15:02:13 <EmilienM> mdorman to update all oslo/messaging/heartbeat patches to disable it by default and provide good doc about it -> DONE
15:02:29 <EmilienM> #topic Announcements
15:02:36 <EmilienM> I have some very exiting announcements
15:02:49 <EmilienM> #info stable/kilo 6.0.0 released
15:02:56 <EmilienM> #info zuul-cloner works for all of our modules now, we can use Depends-On feature
15:03:00 <EmilienM> thanks crinkle for that work ^
15:03:16 <EmilienM> #info oslo/messaging/heartbeat is now disabled by default
15:03:48 <EmilienM> #link wiki page to create new modules: https://wiki.openstack.org/wiki/Puppet/New_module
15:03:54 <EmilienM> thx spredzy, sbadia ^
15:04:16 <EmilienM> #link master branch policy is documented: http://specs.openstack.org/openstack/puppet-openstack-specs/specs/kilo/master-policy.html
15:04:34 <EmilienM> I would like to congratulate everyone for the Kilo release, we made it !
15:04:42 <mfisch> yay
15:04:53 <EmilienM> I can now leave in holidays
15:04:53 <pabelanger> o/
15:04:58 <iurygregory> congratulations people
15:05:11 <EmilienM> #topic Montreal Sprint - September 2 to 4
15:05:14 <_ody> gratz
15:05:38 <EmilienM> #link Liberty Puppet sprint: https://etherpad.openstack.org/p/puppet-liberty-mid-cycle
15:05:50 <mfisch> who is planning on coming?
15:05:54 <EmilienM> o/
15:06:10 <spredzy> will try
15:06:11 <clayton> I have other obligations that week unfortunately.
15:06:14 <xarses> I likely won't make it =(
15:06:18 <pabelanger> working on approval myself
15:06:23 <mfisch> I'm going to try to come too
15:06:28 <pabelanger> I've just around the corner
15:06:36 <mdorman> i probably will not.
15:06:53 <iurygregory> =/ i can't i live in Brazil
15:07:01 <crinkle> o/
15:07:09 <EmilienM> sbadia: ?
15:07:13 <_ody> Just got done fighting through the process to get us all you Tokyo so another trip is probably not happening...
15:07:27 <mfisch> Tokyo planning is blocking me saying yes actually
15:07:33 <dfisher> i would really like to so that maybe I can get Solaris support in with everybody's help but with Tokyo right around the corner, I don't know if mgmt will let me.  (where mgmt is my wife)
15:07:37 <mfisch> mdorman: can you come?
15:07:54 <EmilienM> richm is coming also (FYI)
15:08:18 <mdorman> mfisch:   i will ask, but i’m not sure i can make the ‘business case’ for it.  and since i’m traveling for ops meetup the week before.  we’ll see.
15:08:28 <EmilienM> oh it's national day in France
15:08:31 <mfisch> its either or for me
15:08:39 <mfisch> mdorman: Ops or puppet
15:08:52 <_ody> Possibility of virtual attendance?
15:08:55 <crinkle> EmilienM: is there any topic so big that we really need to meet in person? maybe we could organize a virtual sprint
15:08:55 <mdorman> yeah.
15:09:11 <clayton> crinkle: I could probably do that
15:09:19 <EmilienM> crinkle: it might be an alternative
15:09:43 <EmilienM> crinkle: infra team did run a virtual sprint, was it good enough?
15:09:53 <mfisch> it can be difficult to block off time
15:10:00 <xarses> I would probably be able to attend virtually
15:10:13 <EmilienM> crinkle: I'm just afraid people would be working on their regular work
15:10:27 <mfisch> I'd probably stay home during it
15:10:40 <mfisch> we could also do it say a half day for 2/3 days
15:10:48 <Vinsh> +1
15:11:01 <EmilienM> I'm confused now
15:11:16 <mfisch> personally I'd rather go visit Montreal but if we dont have critical mass...
15:11:42 <crinkle> EmilienM: yeah i think infra's sprint went well
15:11:54 <dfisher> is it done via google hangout?
15:11:59 <dfisher> was* it done
15:12:02 <crinkle> it is done in the #openstack-sprint channel
15:12:04 <EmilienM> IRC I think
15:12:05 <pabelanger> virtual sprint went well
15:12:18 <pabelanger> but I see the benefit of in person too.
15:12:26 <EmilienM> no matter if we do a sprint or not, we need an agenda my friends
15:12:28 <mfisch> with a smaller team I'd want to do google hangouts if we cant meet in person
15:12:29 <mdorman> seems like virtual could work well if people can commit to focusing on that vs. multitasking with normal work
15:12:41 <spredzy> I tend to think that live meeting add a plus for collaboration meeting people IRL actually means something IMO. Yet if possible we gould go hybrid, people that can go will work on site but everything will be also possible to do on hg
15:12:52 <EmilienM> and until now, there is only 3 points in the agenda: https://etherpad.openstack.org/p/puppet-liberty-mid-cycle
15:12:53 <crinkle> EmilienM: if there's not even an agenda yet then sending everyone to montreal doesn't seem worth it
15:13:00 <EmilienM> crinkle: +10000
15:13:25 <mfisch> so my idea for this was a sprint
15:13:30 <EmilienM> mfisch: what would you work on? have you a specific topic?
15:13:31 <mfisch> not a conversation about stuff but working on code
15:13:45 <mfisch> I'd spend 4 hours on bug triage and fixes for example
15:13:53 <mdorman> i would be interested in maybe owrking on venv support in the modules.  if that’s something we decided we might want to do.
15:13:58 <mfisch> I'd put everyone working on CI beaker stuff along with you showing us more about it
15:14:03 <mfisch> stuff like that
15:14:05 <mdorman> and +1 on just trying ot knock out bugs
15:14:09 <EmilienM> mdorman: topic #2 I think
15:14:16 <mdorman> ah yup yup
15:14:21 <EmilienM> mfisch: can you add a topic for bug triage maybe?
15:14:24 <pabelanger> I'm interested in the AIO work, which would be something to discuss at the mid-cycle.  Hammering out spec, design
15:14:41 <EmilienM> pabelanger: nice, CI thing is topic #1 - good to have you onboard by the way
15:15:03 <_ody> I likely try to host a place at PL HQ for people to hang out to do the mid-cycle virtually.
15:15:03 <pabelanger> additionally, learning more about beaker so I can help openstack-infra move their puppet modules into move functional testing is high on my list
15:15:15 <pabelanger> for downstream infra CI
15:15:26 <pabelanger> might you, I think crinkle is also working on that?
15:15:44 <crinkle> yep a bit
15:16:08 <EmilienM> pabelanger: this is out of our work I would say
15:16:17 <EmilienM> pabelanger: and then, out of our puppet sprint
15:16:38 <EmilienM> pabelanger: our focus is 100% puppet openstack modules
15:16:55 <pabelanger> EmilienM, right, I'm going to offer up support for puppet openstack modules, with beaker and such. SO I can learn more about it
15:17:02 <EmilienM> nice
15:17:05 <EmilienM> anything else?
15:17:08 <pabelanger> easy way for me to learn it
15:17:25 <crinkle> EmilienM: did we decide anything?
15:17:29 <EmilienM> richm is going to help us to coordinate the next steps for keystone v3
15:17:38 <EmilienM> crinkle: no
15:17:51 <EmilienM> crinkle: I think virtual sprint is enough until now
15:18:03 <crinkle> +1
15:18:25 <clayton> +1
15:19:19 <EmilienM> mfisch, spredzy, mdorman, richm ?
15:19:27 <mdorman> sounds good to me.
15:19:30 <mfisch> I will just drink wine at my house then
15:19:33 <mdorman> haha
15:19:43 <richm> yes
15:19:54 <richm> either way is fine with me
15:20:09 <EmilienM> richm: you can come in MTL if you want :-P
15:20:10 <spredzy> EmilienM, ok for me
15:20:17 <richm> I will miss poutine . . .
15:20:20 <EmilienM> ahah
15:20:23 <pabelanger> EmilienM, I might drop in for a day then, since I'm just a train ride away.  Can you get some desk space locally?
15:20:58 <EmilienM> pabelanger: yeah and I can relocate
15:21:02 <mfisch> EmilienM: I will volunteer to run the bug scrub, I have some ideas in my head
15:21:15 <EmilienM> pabelanger: you and me are going to do CI, we might need to see each others a couple of days
15:21:25 <EmilienM> mfisch: ok
15:21:49 <pabelanger> EmilienM, okay, if manager approves I could make a few days of it
15:21:51 <EmilienM> #action EmilienM to inform the ML Puppet sprint will be virtual
15:21:57 <pabelanger> EmilienM, I should loop you into email
15:22:42 <EmilienM> let's move on
15:22:51 <EmilienM> #topic Default parameter policy
15:22:52 <EmilienM> spredzy: o/
15:23:24 <spredzy> I had found a possible way to go with sane default, but DavidS add another suggestion https://github.com/puppetlabs/puppetlabs-inifile/pull/176
15:23:51 <spredzy> My question here is, would we like to go with it (the terner) or is it to heavy in the manifests
15:23:53 <EmilienM> it sounds like he *closed* the discussion :(
15:24:01 <clayton> I understand why he doesn't want to take the patch, but the puppet 4.x suggestion is kind of gross, and I think the 3.x one is not really any better than the if/else
15:24:12 <mdorman> (reading the PR)
15:24:21 <spredzy> If we apply this patch, basically if they are undef, they will be ensure absent
15:24:56 <spredzy> clayton, mainly one-line, but it would still be IMO really heavy to read
15:25:01 <richm> What happens with values that are not strings?  e.g. boolean values that only have a value of true or false?
15:25:52 <clayton> my vote would be to create an intermediary inifile parent class in openstacklib and put the behavior that spredzy implemented there.
15:26:03 <spredzy> richm, nice catch :)
15:26:06 <mdorman> so there is no way in the provider to recognize when a parameter is undef ?
15:26:08 <crinkle> Hunner: you were at the triage when this was discussed ^
15:26:18 <spredzy> in our case it would be a define check
15:26:22 <richm> well, I ran into the same problem with keystone::resource::authtoken - insecure parameter
15:26:23 <clayton> mdorman: not in puppet 3.x, I think that changes in 4.x
15:26:39 <mdorman> clayton:  ok, right.  yeah that sounds right.
15:27:49 <spredzy> I have no objection against clayton's idea
15:28:27 <EmilienM> I think it's just moving the problem
15:29:16 <clayton> how so?
15:29:48 <mdorman> it is moving the problem, but i think we’re saying there’s really no solution to the problem until puppet 4.x right?
15:29:57 <mdorman> so we have no other option really
15:29:58 <_ody> Doesn't sit with me right.  Passing undef to a parameter effectively "unsets" it, resulting is the parameter passing its default value to the provider.  If the default value for ensure was "absent" then this would make more sense and inline with the other type interfaces.
15:30:28 <xarses> I thought inifile didn't write out undef values
15:30:48 <clayton> _ody: I don't think any of us are happy with the solutions available, but we're lacking attractive alternatives :)
15:30:51 <mdorman> is an unquoted absent value translate into something special, or does it just get changed to the string ‘absent’ ?
15:31:06 <clayton> it gets changed into a string
15:31:14 <spredzy> yeah values are stringfied
15:31:16 <mdorman> k
15:31:20 <spredzy> nil is actually understood as 'nil'
15:31:47 <clayton> there are special cases, like undef, true, false, but that's generally how it works
15:32:05 <_ody> The latter usually endup as symbols.
15:32:23 <_ody> (until Puppet 4.x then its all typed properly)
15:32:26 <mdorman> right.
15:32:53 <_ody> Thing being "fixed" it puppet 4.x isn't terribly useful though.
15:32:56 <mdorman> well i agree with clayton’s plan as well.  implement it in openstacklib… then at least the complexity is abstracted away from the other modules
15:33:27 <EmilienM> well, we can try and see how it works
15:33:27 <clayton> xarses: it won't write out the undef values, but it also won't remove them.  it makes it hard to remove values after they've been set.
15:33:36 <xarses> clayton: ahh
15:33:43 <xarses> so, lets get on the same page
15:34:09 <xarses> and present a joined oponion to puppetlabs-inifile
15:34:26 <EmilienM> clayton, spredzy: openstacklib patch needs to work on 3.x & 4.x version and be backward compatible I think
15:34:40 <xarses> that we need a better solution / here is ours
15:34:50 <clayton> xarses: I tend to think we'd get better traction if we implemented it internally first, and figured out what works and doesn't before pushing it upstream
15:35:03 <Hunner> mdorman: No, no way for a provider to recognize undef. Only false or something
15:35:13 <EmilienM> clayton: it sounds fair
15:35:14 <spredzy> EmilienM, ack
15:35:22 <xarses> likely, but we should get an useful opinion from upstream too
15:35:29 <xarses> we shouldn't have to fork to fix this
15:35:48 <clayton> xarses: I'd propose we wrap the existing methods, not fork it
15:36:12 <clayton> that we'd continue to have a dependency on the inifile provider
15:36:20 <xarses> seems ugly but ok
15:36:27 <clayton> less ugly than forking :)
15:37:32 <EmilienM> clayton, spredzy: all right, so next step is a patch in oslib, right?
15:38:11 <EmilienM> clayton, spredzy: you can come-up with an example in puppet-nova by using Depends-On, would be useful to see/test behaviors
15:38:22 <spredzy> EmilienM, ack will do that
15:38:27 <clayton> good idea
15:38:27 <EmilienM> spredzy: thx
15:38:43 <EmilienM> #topic CI status
15:39:05 <EmilienM> puppet-keystone is now gating WSGI setup
15:39:20 <EmilienM> I'm working with Tempest team to have tempest running in our jobs
15:39:46 <EmilienM> and I'm working on getting log files in our jenkins workspace, I might need your inputs of log files we would need
15:39:57 <EmilienM> example https://review.openstack.org/199712
15:40:20 <EmilienM> and http://logs.openstack.org/12/199712/13/check/gate-puppet-keystone-puppet-beaker-rspec-dsvm-centos7/bff0421/
15:41:04 <EmilienM> I would love some feedback on the patch itself. I'm using acceptance to get the logs, not sure it's the right way but it works
15:41:58 <EmilienM> pabelanger: you might have a look too
15:42:09 <mfisch> Will these be voting jobs eventually?
15:42:28 <EmilienM> mfisch: what, tempest?
15:42:31 <pabelanger> EmilienM, ack
15:42:43 <mfisch> y
15:42:45 <EmilienM> mfisch: yes, this is part of beaker jobs.
15:43:29 <EmilienM> mfisch: I'm also wondering if we should run a scenario or test a whole set of tests like 'identity'
15:43:43 <mfisch> what would that include?
15:43:59 <EmilienM> mfisch: I should write a blueprint for that
15:44:10 <crinkle> wouldn't the tempest tests belong as part of the integration suite?
15:44:20 <EmilienM> mfisch: identity is testing all keystone
15:44:21 <pabelanger> crinkle, I agree
15:44:26 <crinkle> since the acceptance tests don't test a whole openstack
15:44:48 <EmilienM> crinkle: right, this is a good idea
15:45:36 <EmilienM> crinkle: so we keep serverspec tests for puppet-* modules jobs
15:45:40 <pabelanger> One way to do it, if puppet-keystone has a patch set, the puppet-openstack-integration test would be a gate, then using zuul-cloner, you'd pull in that ref to run against
15:45:45 <EmilienM> crinkle: and think about tempest for the whole AIO jobs ?
15:46:02 <EmilienM> pabelanger: this was exactly our intention ;)
15:46:08 <crinkle> EmilienM: yep
15:46:14 <EmilienM> crinkle: ok fair enough
15:46:26 <EmilienM> we need a blueprint about openstack integration
15:46:33 <EmilienM> to define how we do that
15:46:43 <pabelanger> EmilienM, ya, it is scary! I'm on the same page as other people
15:46:55 <mfisch> devils advocate but at what point are we testing openstack and not puppet?
15:46:59 <EmilienM> #action pabelanger & EmilienM to work on openstack integration CI
15:47:05 <EmilienM> anything else about CI?
15:47:29 <EmilienM> ok let's move on
15:47:30 <crinkle> mfisch: that's sort of what a black box test is supposed to do, isn't it?
15:47:53 <crinkle> make sure the thing we intended to do got done, no matter if we did it with puppet or something else
15:48:17 <crinkle> i don't expect we would run every tempest test, just the general ones
15:48:24 <EmilienM> yes typically a scenario
15:48:29 <EmilienM> basic ops scenario maybe
15:48:47 <EmilienM> we will figure that out with tempest team and discuss about that in the blueprint
15:49:03 <pabelanger> Ya, have some grand ideas using multi node testing with zuul :)
15:49:08 <pabelanger> but single node stuff for now I see
15:49:17 <EmilienM> yes let's iterate :)
15:49:26 <EmilienM> non voting + single node is our first target
15:49:30 <pabelanger> !
15:49:34 <EmilienM> #topic Open Discussion, Bug and Review triage
15:49:42 <EmilienM> we have 10 minutes for triage
15:49:58 <mfisch> I have one bug to bring up
15:50:19 <mfisch> let me find it
15:50:25 <mfisch> https://bugs.launchpad.net/puppet-glance/+bug/1471364
15:50:25 <openstack> Launchpad bug 1471364 in puppet-glance "glance_image keeps trying to update an image from location causing an error" [Undecided,New]
15:50:26 <mdorman> i have one to raise as well.
15:50:35 <mfisch> I was curious if people had success making glance images with puppet from a URL
15:50:50 <EmilienM> please +A the WSGI bug backports: https://review.openstack.org/#/c/201597/ - https://review.openstack.org/#/c/201605/
15:51:07 <EmilienM> mfisch: this one is nice indeed
15:51:28 <mfisch> I'm not convinced anyone ever uses that feature
15:51:37 <mdorman> i have not used it
15:51:39 <EmilienM> mfisch: our CI does
15:52:13 <EmilienM> https://github.com/openstack/puppet-glance/blob/master/spec/acceptance/basic_glance_spec.rb#L77-L83
15:52:32 <EmilienM> and it works well today AFIK
15:53:00 <crinkle> that's using source, not location
15:53:08 <crinkle> isn't location supposed to be a local file?
15:53:13 <EmilienM> oh
15:54:21 <EmilienM> https://github.com/openstack/glance/blob/master/glance/api/v1/images.py#L433-L447
15:54:28 <EmilienM> it sounds like a bad config of Glance maybe
15:55:00 <santosh> Hi All
15:55:16 <mfisch> location should be a URL iirc
15:55:16 <EmilienM> mfisch: have you enabled http in glance config?
15:55:24 <mfisch> the image works and is uploaded
15:55:29 <EmilienM> https://github.com/openstack/glance/blob/master/etc/glance-api.conf#L522-L523
15:55:30 <clayton> EmilienM: yeah
15:55:31 <mfisch> the issue is that puppet keeps trying to update it
15:55:40 <mfisch> puppet cant figure out that its already been uploaded
15:56:11 <EmilienM> mfisch: why don't we have the issue when using source then?
15:56:27 <mfisch> thats from a file right?
15:56:27 <EmilienM> our puppet run is idempotent: https://github.com/openstack/puppet-glance/blob/master/spec/acceptance/basic_glance_spec.rb#L88
15:56:41 <EmilienM> probably
15:56:59 <mfisch> okay let me try that
15:57:11 <mfisch> I must misunderstand what location meant
15:57:18 <EmilienM> mfisch: please look https://review.openstack.org/#/c/201597/
15:57:33 <mfisch> merged
15:57:41 <mfisch> was waiting for that
15:57:46 <EmilienM> thanks
15:58:05 <EmilienM> spredzy: we have 3 min, I had a question - what's the status of backport things in OpenStack Infra ?
15:58:16 <EmilienM> do you have any blocker?
15:58:32 <crinkle> mfisch: commit 1d0a8ba83dfa0b4970b1b40259f45e3dd77ea543 changed the behavior of that param, if you try the commit before that does anything change?
15:58:33 <spredzy> Had some feedback from -infra late last week need to checkout what it was
15:58:50 <spredzy> Well - no - sorry I am confused it was about usiing a commong setup_git
15:58:51 <mfisch> crinkle: I have not, I will note that and look today
15:58:57 <crinkle> cool
15:58:59 <spredzy> and the review has been amended
15:59:02 <spredzy> waiting for review
15:59:10 <mdorman> i’ll slip in at the very end here:  https://review.openstack.org/#/c/193328/   crinkle and EmilienM both commented on this, just wanted to get some consensus on how to go forward.  if folks could look at the review, i’d appreciate it.  doesn’t have to be figured out right this second.
15:59:13 <EmilienM> spredzy: ok. nice
15:59:30 <EmilienM> mdorman: will look today
15:59:31 <crinkle> i keep running into https://bugs.launchpad.net/puppet-horizon/+bug/1470993 and I don't think the proposed fix works, has anyone else run into this on ubuntu?
15:59:31 <openstack> Launchpad bug 1470993 in puppet-horizon "if compress_static=true failed to apply horizon puppets" [Undecided,In progress] - Assigned to Vasyl Saienko (vsaienko)
15:59:45 <EmilienM> It's the end
15:59:51 <mdorman> EmilienM:  ty
16:00:04 <Vinsh> An fyi on puppet-swift work.  I am back from deploying https://review.openstack.org/#/c/177037/ to staging and production in our shop.  It works very well.  I'll be completing this review to gain acceptance now.
16:00:05 <EmilienM> crinkle: will look today too
16:00:09 <EmilienM> have a great day!
16:00:17 <EmilienM> #endmeeting