15:00:01 <EmilienM> #startmeeting puppet-openstack
15:00:03 <openstack> Meeting started Tue Aug  4 15:00:01 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:09 <EmilienM> #link agenda: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20150804
15:00:12 <EmilienM> hello
15:00:13 <crinkle> o/
15:00:17 <mwhahaha> hi
15:00:17 <bogdando> o/
15:00:20 <spredzy> o/
15:00:41 <sbadia> o/
15:00:42 <iurygregory> o/
15:00:55 <RedShift_> \o/
15:01:26 <EmilienM> #topic Review past action items
15:01:56 <EmilienM> EmilienM to iterate on Puppet/logs  -> DONE: https://review.openstack.org/#/c/206693
15:02:10 <EmilienM> sbadia & pabelanger: figure out Gemfile split in our modules
15:02:24 <EmilienM> sbadia: what's up? ^
15:02:31 <sbadia> patchs are ready (on my laptop)
15:02:34 <sbadia> ready to push
15:02:43 <sbadia> but I wait an answer from cody
15:02:46 <EmilienM> cool
15:02:53 <EmilienM> sbadia & pabelanger: figure out Gemfile split in our modules -> POSTPONED
15:03:00 <EmilienM> sbadia launch a initial msync on all our modules -> ?
15:03:02 <sbadia> (I used cody's patchs)
15:03:07 <EmilienM> I guess it's related ^
15:03:12 <sbadia> yep it's related
15:03:19 <pabelanger> o/
15:03:42 <EmilienM> sbadia launch a initial msync on all our modules -> POSTPONED
15:03:58 <mattymo_> sorry I'm a couple mins late
15:04:01 <EmilienM> #topic announcements
15:04:03 <sbadia> #action sbadia launch a initial msync on all our modules
15:04:21 <EmilienM> #info spredzy (yanis) is now part of core team - congrats Yanis!
15:04:28 <sbadia> yes congrats!
15:04:29 <spredzy> Thanks :)
15:04:32 <iurygregory> congrats :D
15:04:49 <EmilienM> #topic CI status
15:05:13 <EmilienM> so I have some updates to share
15:05:44 <EmilienM> * thanks to pabelanger, syntax & unit jobs are now running on centos7 - which should accelerate our CI, since centos7 nodes are faster to get in zuul
15:06:08 <EmilienM> * integration: got tempest running successfully on centos7 and ubuntu
15:06:23 <EmilienM> #action EmilienM & pabelanger continue to iterate on puppet integrations
15:06:27 <EmilienM> reviews are welcome !
15:06:46 <EmilienM> it's happening on https://review.openstack.org/#/q/status:open+project:openstack/puppet-openstack-integration,n,z
15:06:55 <EmilienM> #link Puppet OpenStack Integration work: https://review.openstack.org/#/q/status:open+project:openstack/puppet-openstack-integration,n,z
15:07:32 <EmilienM> * we almost have logs in our Puppet beaker jobs: https://review.openstack.org/#/c/206693/
15:08:07 <EmilienM> * and this week we are pushing some patches to test CI against Liberty (got successful results locally)
15:08:17 <EmilienM> anything else about CI we need to discuss? any blocker?
15:08:47 <EmilienM> #action EmilienM give an update about Liberty status after testing
15:08:47 <pabelanger> nothing on myside. Going to look into more optimizations for puppet jobs
15:08:53 <guimaluf> EmilienM, in my review, some CI tests are failed with no relation to the implementation itself
15:08:59 <EmilienM> pabelanger: cool, thanks for your help!
15:09:02 <sbadia> thanks!
15:09:03 <EmilienM> guimaluf: link?
15:09:05 <guimaluf> EmilienM, something like bundle errors, etc.
15:09:24 <EmilienM> guimaluf: might be related to what pabelanger did lately, we had some fixes. Maybe 'recheck' will fix it
15:09:36 <guimaluf> EmilienM, https://review.openstack.org/#/c/207161/
15:09:36 <guimaluf> ok
15:09:37 <pabelanger> guimaluf: that was likely my fault.  There was a path issue on friday
15:09:47 <guimaluf> np! :)
15:09:55 <pabelanger> but, recheck failures. Everything _should_ be working today
15:09:59 <EmilienM> pabelanger: the error is from this morning though
15:10:04 <pabelanger> if not, let me know and I can look at them
15:10:08 <EmilienM> from 6.25am for us
15:10:16 <pabelanger> Ya, checking now
15:10:23 <EmilienM> pabelanger: http://logs.openstack.org/61/207161/6/check/gate-puppet-swift-puppet-beaker-rspec-dsvm-trusty/b644bf3/console.html
15:10:55 <_ody_> o/
15:10:58 <EmilienM> there is no other item in our agenda, so I'll open a topic for triage
15:11:18 <pabelanger> EmilienM: will dig deeper, but I didn't make changes to beaker jobs.
15:11:18 <EmilienM> #topic bug/patches triage
15:11:23 <pabelanger> this could be something else
15:11:24 <EmilienM> pabelanger: ack
15:12:05 <angdraug> mattymo_: around?
15:12:41 <angdraug> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/071089.html
15:13:25 <angdraug> looks like puppet-keystone part of this needs more work
15:13:32 <sbadia> _ody_: \o/ hi!
15:14:00 <sbadia> _ody_: according openstack-dev ML message, I just updated our patch serie (https://review.openstack.org/#/q/status:open+branch:master+topic:msync_rspec_version,n,z)
15:14:01 <mattymo_> angdraug, yes I'm here
15:14:01 <_ody_> Did I see you say that msync has stablized enough to do a complete sync?
15:14:09 <EmilienM> mattymo_: have you read my comments?
15:14:10 <Hunner> pabelanger: Maybe an update in net-ssh that doesn't use ruby 1.9.3 socket correctly?
15:14:11 <mattymo_> it seems that if there is no openrc yet, it misbehaves
15:14:15 <sbadia> but not pushed yet, it's ok for you if I push this?
15:14:21 <mattymo_> EmilienM, of course. You say in one that it's broken and in the other that it needs a dependency change
15:14:26 <sbadia> _ody_: yes
15:14:26 <mattymo_> I'm still working to get it to pass Fuel CI
15:14:45 <EmilienM> mattymo_: anyway, it's not tested as it is, so we can't validate it actually works
15:15:00 <_ody_> sbadia: Cool.  I'll do a review of all of them immediately after breakfast.
15:15:02 <mattymo_> EmilienM, well it's tested that it fails :)
15:15:11 <sbadia> _ody_: thx!
15:15:13 <angdraug> mattymo_: Workflow-1?
15:15:15 <EmilienM> mattymo_: where?
15:15:43 <Hunner> pabelanger: Yeah! net-ssh 2.10.0 came out 2 days ago
15:16:04 <mwhahaha> yes 2.10.0 dropped 1.9 support
15:16:31 <mwhahaha> https://github.com/net-ssh/net-ssh#ruby-1x-support
15:16:33 <Hunner> Heh. "Lets just drop support in a feature bump"
15:16:40 <mattymo_> fails CI in here: https://review.openstack.org/#/c/207873/ and https://review.openstack.org/#/c/207890/
15:16:48 <crinkle> 2.10.0 was yanked
15:16:51 <crinkle> https://rubygems.org/gems/net-ssh/versions
15:17:00 <crinkle> if you re-run tests they should get 2.9.2 and be unbroken
15:17:08 <Hunner> Oh that's why the betas are newer than the .0
15:17:13 <mattymo_> regardless of my patch, looking up @credentials.auth_url should pass
15:17:13 <pabelanger> Hunner: Ya, was going to say something must have changed upstream
15:17:20 <bogdando> folks, lets please don't merge topics?
15:17:31 <EmilienM> mattymo_: ok thanks for the links
15:17:32 <bogdando> hard to parse
15:17:43 <EmilienM> mattymo_: it would be useful to use Depends-On
15:17:50 <EmilienM> so we can actually test the openstacklib
15:17:51 <mattymo_> I did depend one on the other already
15:17:53 <sbadia> EmilienM: task in progress (msync)
15:17:57 <sbadia> #link https://review.openstack.org/#/q/status:open+branch:master+topic:msync_rspec_version,n,z
15:18:03 <mattymo_> EmilienM, is the order of depends-on wrong?
15:18:04 <EmilienM> mattymo_: just saw that indeed
15:18:07 <EmilienM> no it's good
15:18:17 <EmilienM> mattymo_: and it's still failing :(
15:18:57 <mattymo_> I'm still trying to break it on my side. I have nothing else to report
15:19:11 <EmilienM> mattymo_: any blocker we can help?
15:19:58 <mattymo_> EmilienM, not yet. I may ask a couple questions later once I figure out why Fuel side fails
15:20:18 <EmilienM> is there anything else for today?
15:20:46 <iurygregory> hey EmilienM , can we discuss the spec?
15:20:51 <EmilienM> iurygregory: sure
15:20:53 <iurygregory> I've made the fixes proposed by marek and richard on the spec https://review.openstack.org/#/c/190361/
15:21:16 <iurygregory> you can take a look at the comments?
15:21:17 <EmilienM> #link keystone federation spec https://review.openstack.org/#/c/190361/
15:21:57 <EmilienM> #action People to review https://review.openstack.org/#/c/190361/ and eventually give feedback -1/+1
15:22:07 <EmilienM> iurygregory: I'll read it today
15:22:33 <iurygregory> before i was considering just one class to Service Provider, now i'm suggesting one class for each type
15:22:52 <EmilienM> iurygregory: let me see
15:23:34 <EmilienM> iurygregory: what is Mellon?
15:23:53 <EmilienM> it's a service provider
15:24:01 <EmilienM> so we should implement something like in puppet-cinder
15:24:05 <EmilienM> with backends
15:24:15 <iurygregory> It's a choise to configure federation
15:24:26 <iurygregory> we can have protocol SAML using shibboleth or Mellon
15:24:32 <EmilienM> and have a ::keystone::federation::service_provider Define
15:24:39 <EmilienM> and this Define would configure the Service Provider
15:24:46 <EmilienM> can we have multiple service providers in the same time?
15:25:19 <iurygregory> A service provider can have multiple IdP
15:25:27 <EmilienM> ok so not a Define
15:25:29 <EmilienM> but a Class
15:25:34 <EmilienM> that would support Shibboleth and Mellon
15:25:48 <EmilienM> oh and eventually OpenID
15:26:05 <iurygregory> I was thinking in one class for each
15:26:16 <EmilienM> iurygregory: why? Are parameters different ?
15:26:20 <iurygregory> Yes
15:26:26 <EmilienM> mhhh
15:26:40 <iurygregory> well Mellon and Shibboleth have some common attributes
15:26:41 <EmilienM> iurygregory: keystone parameters ?
15:27:30 <iurygregory> not keystone parameters
15:27:50 <EmilienM> yeah, some Apache2 bits I guess
15:28:13 <iurygregory> for example whe using openid connector you don't need entityID
15:28:18 <iurygregory> yes ^^
15:28:55 <EmilienM> I need to read the spec in details because the design of this is really important
15:29:15 <iurygregory> sure EmilienM
15:29:31 <EmilienM> iurygregory: I'm using http://docs.openstack.org/developer/keystone/configure_federation.html as a reference
15:29:36 <EmilienM> I need to learn first :)
15:30:01 <EmilienM> do we have anything else for today?
15:30:01 <iurygregory> any questions can ask me :D (about shibboleth )
15:30:10 <EmilienM> iurygregory: will do
15:30:20 <EmilienM> I close the meeting in 2 minutes of nothing comes up
15:31:15 <EmilienM> I guess I can close it
15:31:24 <EmilienM> have a great day - thanks for attending
15:31:27 <iurygregory> thanks people :D
15:31:35 <EmilienM> #endmeeting