#openstack-meeting-4: puppet-openstack

Meeting started by crinkle at 15:00:20 UTC (full logs).

Meeting summary

  1. Review past action items (crinkle, 15:01:07)
  2. CI status (crinkle, 15:02:12)
  3. Kilo release (should happen next week): please backport bugs or small features (crinkle, 15:04:17)
    1. ping Emilien to get involved with the kilo release (crinkle, 15:06:17)
    2. ACTION: sbadia and jasondotstar signed up to help with kilo release (crinkle, 15:06:28)

  4. ability to override variables of 'params' class (e.g. service/package names) (crinkle, 15:07:13)
    1. https://review.openstack.org/#/c/229918/ (crinkle, 15:07:15)
    2. https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg64891.html (iberezovskiy, 15:08:36)
    3. https://github.com/stackforge/fuel-library/blob/deb63f09df23170207310f06ca4e12785d018dc2/deployment/puppet/openstack/manifests/nova/controller.pp#L399 (mwhahaha, 15:09:27)
    4. ACTION: continue globals topic on mailing list (crinkle, 15:25:15)

  5. Use OpenstackClient for nova providers auth (crinkle, 15:25:33)
    1. https://review.openstack.org/226862 (crinkle, 15:25:37)
    2. https://review.openstack.org/229548 (crinkle, 15:25:42)
    3. ACTION: reviewers review 226862 and 229548 (crinkle, 15:27:10)

  6. blueprints: use-openstackclient-in-module-resources vs use-aviator-in-module-resources (crinkle, 15:27:48)
    1. http://specs.openstack.org/openstack/puppet-openstack-specs/specs/juno/use-openstackclient-in-aviator-resources.html (EmilienM, 15:29:29)
    2. https://groups.google.com/a/puppetlabs.com/forum/#!searchin/puppet-openstack/aviator$20openstackclient/puppet-openstack/GJwDHNAFVYw/ayN4cdg3EW0J (crinkle, 15:31:36)
    3. http://www.slideshare.net/Colleen_Murphy/vancouver-presentation-48498077 (EmilienM, 15:31:53)
    4. ACTION: aglarendil to bring up openstackclient vs aviator on mailing list (crinkle, 15:36:19)

  7. service default provider issues (crinkle, 15:37:14)
    1. https://review.openstack.org/#/c/229095/ (crinkle, 15:37:17)

  8. openstack client timeouts and handling (crinkle, 15:45:23)
  9. Open Discussion, Bug and Review triage (crinkle, 15:56:10)


Meeting ended at 15:59:54 UTC (full logs).

Action items

  1. sbadia and jasondotstar signed up to help with kilo release
  2. continue globals topic on mailing list
  3. reviewers review 226862 and 229548
  4. aglarendil to bring up openstackclient vs aviator on mailing list


Action items, by person

  1. aglarendil
    1. aglarendil to bring up openstackclient vs aviator on mailing list
  2. jasondotstar
    1. sbadia and jasondotstar signed up to help with kilo release
  3. sbadia
    1. sbadia and jasondotstar signed up to help with kilo release
  4. UNASSIGNED
    1. continue globals topic on mailing list
    2. reviewers review 226862 and 229548


People present (lines said)

  1. crinkle (65)
  2. EmilienM (61)
  3. aglarendil (38)
  4. clayton (22)
  5. mwhahaha (21)
  6. iberezovskiy (18)
  7. degorenko (9)
  8. sbadia (7)
  9. Hunner (7)
  10. iurygregory (6)
  11. mattymo1 (6)
  12. xarses (4)
  13. jasondotstar (4)
  14. angdraug (3)
  15. dilyin (3)
  16. openstack (3)
  17. skolekonov (1)
  18. aderyugin (1)


Generated by MeetBot 0.1.4.