15:00:04 <EmilienM> #startmeeting puppet-openstack
15:00:08 <openstack> Meeting started Tue Oct 20 15:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:22 <EmilienM> #link agenda: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151020
15:00:30 <EmilienM> o/
15:00:34 <angdraug> hi
15:00:37 <mkarpin> hi
15:00:38 <spredzy> hi
15:00:48 <degorenko> hey o/
15:00:50 <sbog_> hi
15:01:03 <richm> here
15:01:11 <skolekonov> hi
15:01:21 <iberezovskiy> hi
15:01:31 <EmilienM> #topic review past action items
15:01:39 <EmilienM> 1) continue "global topic" on ML
15:01:42 <iurygregory> o/
15:01:44 <EmilienM> mwhahaha: ^
15:01:49 <aderyugin> o/
15:01:55 <EmilienM> 2/ reviewers review 226862 and 229548
15:02:12 <EmilienM> for the summit actions, we have a topic today;
15:02:20 <mwhahaha> hi
15:02:30 <EmilienM> 3) EmilienM & aderyugin patch infra to enable beaker jobs on murano module (done https://review.openstack.org/#/c/234322/1 )
15:02:40 <EmilienM> 4) aderyugin to make sure puppet-murano has compliant parameter
15:02:55 <EmilienM> 5) skolekonov to continue nova_admin_* options deprecation topic on ML (done, see https://www.mail-archive.com/openstack-dev%40lists.openstack.org/msg65834.html)
15:03:00 <crinkle> o/
15:03:05 <EmilienM> 6) chem to run ML thread about oslo.config vs inifile -> done
15:03:07 <mfisch> yo
15:03:20 <EmilienM> and 7) the group to take care of openstacklib exception handling http://permalink.gmane.org/gmane.comp.cloud.openstack.devel/65977
15:03:31 <EmilienM> we have a really short agenda today
15:03:42 <mfisch> 8) cancel next week's meeting
15:03:51 <EmilienM> mfisch: nice reminder
15:04:02 <EmilienM> #action EmilienM to cancel next week's meeting
15:04:14 <EmilienM> #topic OpenStack Summit
15:04:24 <EmilienM> #link Summit etherpad: https://etherpad.openstack.org/p/HND-puppet
15:04:42 <EmilienM> so I worked a bit on the schedule: http://mitakadesignsummit.sched.org/type/Puppet%20OpenStack#.ViZYAZdm-Zf
15:04:52 <EmilienM> is there any conflicts that would prevent people here to  join?
15:05:22 <mfisch> I dont know of any right now for myself but in all likelihood I will miss a session probably just due to other commitments
15:05:30 <EmilienM> I also created some etherpads for our sessions
15:05:36 <mdorman> +1 same here, I’m sure I can make it to some of them.
15:05:36 <EmilienM> mfisch: with session?
15:05:38 <xarses> hi
15:05:54 <EmilienM> #link community session https://etherpad.openstack.org/p/HND-puppet-community
15:06:11 <EmilienM> #link ci/testing session https://etherpad.openstack.org/p/HND-puppet-ci
15:06:14 <mfisch> EmilienM: nothing stands out right now but I also need to attend most of the operators stuff and a few normal sessions too because puppet is not 100% of my job if that makes sense
15:06:20 <EmilienM> #link doc session https://etherpad.openstack.org/p/HND-puppet-doc
15:06:37 <EmilienM> #link coding session https://etherpad.openstack.org/p/HND-puppet-code
15:06:40 <EmilienM> mfisch: ok, no problem at all
15:06:53 <EmilienM> just make sure to be here for the session you're leading
15:07:23 <EmilienM> I would ask anyone who has a topic, to come "prepared"... ie: a PoC of code, or some thoughts
15:08:05 <EmilienM> any thoughts about summit?
15:08:56 <EmilienM> well, I guess that's all
15:09:03 <xarses> looking forward
15:09:06 <EmilienM> #topic Open Discussion, Bug and Review triage
15:09:24 <mkarpin> Hello all
15:09:30 <EmilienM> spredzy: you wanted to say something ?
15:09:58 <spredzy> Mainly I wanted to know if some people would be available to hack on some modules (ie, the service default feature) during the summit
15:10:29 <EmilienM> spredzy: I've heard the lunch room will be big enough
15:10:40 <degorenko> spredzy, i can help with it :)
15:10:51 <EmilienM> spredzy: if that happens, I'll let you coordinate this session, with an etherpad, + ML communication
15:10:53 <spredzy> degorenko, \o/
15:10:59 <spredzy> EmilienM, ack
15:11:04 <iurygregory> me too, just need to ask my boss =)
15:11:27 <spredzy> :)
15:11:32 <EmilienM> mkarpin: hey
15:11:40 <mkarpin> ah yes sorry
15:11:47 <mkarpin> i am a bit new)
15:11:57 <skolekonov> I'll try to attend also
15:12:10 <mkarpin> can i discuss glance stuff now?
15:12:16 <EmilienM> mkarpin: go ahead
15:12:18 <angdraug> mkarpin: go for it, we're in open discussion )
15:12:52 <mkarpin> we need to have ability to set more parameters for glance-api and glance-registry i propose some of them in https://review.openstack.org/#/c/237035/
15:12:52 <mkarpin> but there are some parameters which i believe need new classes, the first ones are for database section
15:13:30 <mkarpin> 'database/max_pool_size':              value => $max_pool_size;
15:13:30 <mkarpin> 'database/max_retries':                value => $max_retries;
15:13:30 <mkarpin> 'database/max_overflow':               value => $max_overflow;
15:13:38 <EmilienM> I think you should use db.pp then
15:13:51 <mkarpin> so is it ok to add 2 db classes by analogy with glance::api::logging and glance::registry::logging ?
15:13:56 <EmilienM> there is no db.pp ? spredzy ^
15:14:16 <degorenko> no, glance doesn't have this class
15:14:21 <degorenko> #link https://github.com/openstack/puppet-glance/tree/master/manifests
15:14:24 <EmilienM> why?
15:14:46 <degorenko> good question, we missed this :(
15:14:48 <iurygregory> maybe we missed =/
15:14:49 <angdraug> historic reasons, by the looks of it )
15:15:01 <EmilienM> spredzy was working on these bits
15:15:09 <degorenko> spredzy, do you need any help?
15:15:33 <EmilienM> he was here 4 min ago
15:15:57 <spredzy> EmilienM, I am around, was looking how come there is no review for that
15:16:00 <spredzy> I think I missed it
15:16:08 <iurygregory> https://review.openstack.org/#/q/status:open+branch:master+topic:class_db,n,z
15:16:16 <EmilienM> #action spredzy to patch puppet-glance to create db.pp
15:16:21 <iurygregory> considering the topic class_db
15:16:39 <spredzy> ack
15:16:43 <mkarpin> and also
15:16:44 <iurygregory> and the merged ones https://review.openstack.org/#/q/status:merged+branch:master+topic:class_db,n,z
15:16:47 <EmilienM> mkarpin: for the other options, it depends which services use it
15:17:42 <mkarpin> aha understood, i also wanted to ask about glance cache logging
15:17:49 <EmilienM> anything else for today?
15:17:58 <mkarpin> there is no class for it
15:18:14 <mkarpin> but cache can have its own setting for logging
15:18:16 <EmilienM> mkarpin: I think you can go for it
15:18:35 <EmilienM> mkarpin: I'll suggest to create separated patches, it's easier for review & testing.
15:18:43 <mkarpin> ok
15:18:43 <EmilienM> you can use gerrit dependencies
15:18:47 <EmilienM> thanks
15:18:51 <degorenko> mkarpin, i'll help you with it
15:18:55 <EmilienM> anything else for today?
15:19:02 <iurygregory> yeah o/
15:19:08 <mkarpin> degorenko: thanks
15:19:22 <iurygregory> How to modify keystone conf in apache ?(apache::vhost - custom_fragment,  concat::fragment, template?)
15:19:58 <iurygregory> the agenda have some useful links to understand the problem https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151020
15:20:11 <EmilienM> iurygregory: we alreadu have a wsgi parameter for vhost_custom_fragment
15:20:22 <EmilienM> why not using this approach?
15:20:25 <degorenko> so, this case is supposed, that should be changed virtualhost section and added some another section to the same file.
15:20:44 <degorenko> we can't add those sections with standard way
15:20:47 <iurygregory> yeah, custom_fragment should work for one part i think
15:20:56 <degorenko> take a look
15:20:59 <degorenko> #link https://github.com/puppetlabs/puppetlabs-apache/blob/master/manifests/vhost.pp#L973-L977
15:21:24 <degorenko> so, i suggest use concat fragment for adding new sections
15:21:38 <degorenko> as i mentioned in https://review.openstack.org/#/c/216821/
15:21:59 <EmilienM> iurygregory: which vhost do you need to change?
15:21:59 <iurygregory> thanks for your review degorenko
15:22:41 <iurygregory> Keystone with port 5000 or 35357 (according to the specified port)
15:22:47 <EmilienM> iurygregory: you should use ::keystone::wsgi::apache for the vhost config
15:22:50 <EmilienM> and do not dupplicate it
15:22:54 <EmilienM> like degorenko says in the review
15:23:31 <iurygregory> yeah i agree, to add the location part its worth to create a template?
15:23:33 <angdraug> degorenko: please be aware that concat can only generate the target file once per puppet run
15:23:46 <degorenko> angdraug, no :)
15:23:50 <angdraug> using it limits your ability to update it more than once per different events
15:24:11 <degorenko> angdraug, we can keep old config and then concat them with a new one
15:24:40 <degorenko> we already did it with aderyugin here: https://review.openstack.org/#/c/218333/22/manifests/dashboard.pp
15:24:40 <EmilienM> mhh, can't we use custom_fragment?
15:24:54 <degorenko> EmilienM, we can. But only for virtualhost section
15:24:58 <EmilienM> we're repeating the mistake of puppet-swift...
15:25:00 <iurygregory> to add the location? i don't think
15:25:13 <EmilienM> I'm not in favor of using concat
15:25:51 <degorenko> any other ideas?
15:26:04 <angdraug> degorenko: concat {} is the resource that triggers generation of the target file
15:26:05 <EmilienM> I thought we could use custom_fragment parameter from puppetlabs-apache
15:26:23 <iurygregory> i've seen this discussion in puppetlabs https://ask.puppetlabs.com/question/14089/how-to-create-location-using-apache-module/
15:26:23 <EmilienM> but it does not seem enough
15:26:31 <degorenko> angdraug, we can load old file in concat, then we can concat old file with new
15:26:42 <iurygregory> but i need the location after </VirtualHost>
15:27:10 <EmilienM> we should rather patch puppetlabs-apache to support the use case
15:27:22 <degorenko> make sense
15:27:40 <EmilienM> instead of torturing the way we use the module
15:27:52 <EmilienM> using concat would work, but would be an hack.
15:28:16 <EmilienM> I'm sure patching puppetlabs-apache to support that use case (like I already asked to iurygregory when he started to work on it) would make sense for long term.
15:29:06 <degorenko> but in fact - it will be concat again
15:30:18 <EmilienM> degorenko, iurygregory: let's continue on gerrit
15:30:22 <EmilienM> anything else for today?
15:30:30 <skolekonov> Please look at my patch also https://review.openstack.org/#/c/235356/. It's about nova_admin_ options.
15:30:30 <iurygregory> ok EmilienM ^^
15:30:38 <skolekonov> I've started from moving to password auth plugin
15:30:47 <EmilienM> skolekonov: good move, thanks!
15:31:09 <iberezovskiy> very small patch to review
15:31:11 <iberezovskiy> #link https://review.openstack.org/#/c/237505/
15:31:39 <EmilienM> iberezovskiy: no tests?
15:31:49 <EmilienM> iberezovskiy: puppet-murano won't be released until we have serious testing
15:32:03 <degorenko> EmilienM, change in params file :)
15:32:12 <iberezovskiy> EmilienM, tests for one param?
15:32:23 <iberezovskiy> in params.pp
15:32:25 <EmilienM> degorenko: if the module was correctly tested, you would also have had to change unit tests.
15:32:42 <EmilienM> for platform paramters when testing if the package is installed.
15:32:56 <iurygregory> tests for each parameter is necessary i think
15:33:03 <EmilienM> I close the meeting
15:33:10 <EmilienM> have a safe trip everyone, see you in Tokyo
15:33:18 <iurygregory> thanks o/
15:33:20 <iberezovskiy> thx
15:33:23 <skolekonov> thanks
15:33:24 <degorenko> o/
15:33:28 <sbadia> thanks everyone
15:33:29 <EmilienM> #endmeeting