15:00:59 <clayton> #startmeeting puppet-openstack
15:01:01 <openstack> Meeting started Tue Nov 10 15:00:59 2015 UTC and is due to finish in 60 minutes.  The chair is clayton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <openstack> The meeting name has been set to 'puppet_openstack'
15:01:12 <clayton> he's running late, he asked me to help things get started
15:01:25 <iurygregory> oh ;) np
15:01:43 <clayton> We have a very light agenda this week, I suspect we may be done before he gets here :)
15:01:58 <clayton> Agenda is here - https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151110
15:02:08 <skolekonov> Hi
15:02:14 <IvanBerezovskiy> hi
15:02:16 <degorenko> hey o/
15:02:17 <richm> hello
15:02:23 <mwhahaha> hi
15:02:24 <aderyugin> 0/
15:02:26 <iurygregory> hello
15:02:43 <clayton> #topic review past items - spredzy to patch puppet-glance to create db.pp
15:02:50 <clayton> is spredzy here?
15:03:19 <sbadia> hi!
15:03:24 <spredzy> clayton, hello
15:03:32 <spredzy> clayton, back from PTO haven't looked at it yet
15:03:34 <degorenko> clayton, actually patch already on review :) https://review.openstack.org/237970
15:03:43 <degorenko> i've uploaded it before summit
15:03:46 <clayton> ah, ok
15:03:53 <clayton> so status is in progress, needs reviews?
15:03:57 <degorenko> yes
15:04:01 <degorenko> need +2 :)
15:04:50 <clayton> #info Denis put up review for glance::db, needs reviews
15:05:06 <clayton> do you want to discuss anything about it here?
15:05:18 <degorenko> nope :)
15:05:25 <angdraug> looks in good shape, 4 +1's so far
15:06:12 <spredzy> will review it
15:07:00 <clayton> ok, next topic is this murango-initial-implementation gerrit topic
15:07:29 <clayton> not sure how to summarize that one for the bot.  Is this just a request for reviews, or request for discussion?
15:07:55 <IvanBerezovskiy> I think it's last patch from big set, let's merge it :)
15:08:12 <angdraug> aderyugin: is it the last one?
15:08:14 <degorenko> yeah :) there is a last patch
15:08:21 <iurygregory> acceptance is merged?
15:08:24 <degorenko> yep
15:08:25 <clayton> #topic Finishing puppet-murano initial patches
15:08:37 <iurygregory> nice :D
15:08:54 <clayton> #link https://review.openstack.org/#/q/status:open+project:openstack/puppet-murano+branch:master+topic:murano-initial-implementation,n,z  Last review remaining
15:09:57 <clayton> any further discussion on that?  Seems straightforward
15:11:18 <clayton> #info request core reviews to review final puppet-murano initial implementation patch
15:11:40 <clayton> Guessing this is the same story
15:11:44 <clayton> #topic Final reviews and merge on puppet-swift feature: https://review.openstack.org/#/c/203220/
15:11:50 <clayton> vinsh, this is yours?
15:12:55 <angdraug> already has one +2...
15:13:13 <iurygregory> he is not here clayton
15:13:31 <vinsh> o/
15:15:03 <clayton> vinsh: anything you want to say about the patch?  I assume you're looking for a second +2?
15:15:27 <vinsh> Yes, just looking for a second +2.  Its been through testing by others as well as my self.
15:15:40 <vinsh> I think its just been around so long its lost interest of others
15:16:03 <vinsh> So, i'm asking for renewed interest to move it forward.
15:16:53 <clayton> I'll take a look this week.  hopefully we can get it merged.  I think we tend to lack people with expertise/experience on puppet-swift, plus it's a big patch
15:17:24 <clayton> ok, moving on unless there is any other comments?
15:17:34 <vinsh> Sounds good.  Its step one in a series of other changes on the way.  Broken out as small as possible for the feature it adds at this time.
15:18:01 <clayton> #topic Help with concat::fragment https://review.openstack.org/#/c/216821/
15:18:09 <iurygregory> me
15:18:11 <clayton> This is yours Iury?
15:18:16 <iurygregory> yep ;)
15:18:31 <iurygregory> ok i'm trying to do this to the keystone virtual host http://paste.openstack.org/compare/473858/473857/
15:18:39 <iurygregory> add the green things
15:19:14 <iurygregory> for the location part i'm using concat::fragment, but i'm facing some issues degorenko help me many times
15:19:47 <iurygregory> yesterday Hunner give some tips and the CI pass, but the tempate is not apply to the file =/
15:20:20 <iurygregory> i've tried different ways (thats way have many patches)
15:20:52 <mfisch> sorry I'm late, had night maintenance work
15:21:02 <sbadia> mfisch: np
15:21:38 <iurygregory> so if anyone can give help me in this patch i'll be glad =)
15:21:39 <clayton> iurygregory: sounds like you've gotten some help, but it's still not clear why it's not working then?
15:21:50 <iurygregory> yeah =/
15:22:21 <iurygregory> for some reason my workspace is a little crazy, and to test i need to send a patch
15:22:42 <iurygregory> and then i use vagrant to verify if the manifest is ok
15:22:57 <clayton> ah, so that's also why so many patches?
15:23:02 <iurygregory> yeah
15:23:19 <iurygregory> i can just run lint and syntax o.o
15:24:11 <clayton> any particular action item you'd like?  Sounds like you've been able to get help when asking in channel?
15:24:27 <iurygregory> nope =)
15:24:32 <clayton> or any volunteers to take another look?
15:25:40 <iurygregory> with hunner approach the CI pass but the file doesn't change (patch  45)
15:25:45 <clayton> ok, I'd say just ask in channel, or might actually want to try #puppet also, since it seems likely the issue is somewhere in the interaction between puppet-concat and puppet-apache
15:26:05 <iurygregory> thanks for the tip clayton =)
15:26:35 <clayton> #topic Trove seems broken in RDO packages ( https://review.openstack.org/#/c/214798/ )
15:26:38 <clayton> sbadia ?
15:26:57 <sbadia> yep, just an info, I take a look with rdo people on this
15:27:18 <clayton> ok, so you'll take the action to look into it further?
15:27:25 <sbadia> (openstack-trove-taskmanager, isn't present anymore in repo :/)
15:27:29 <sbadia> yep!
15:27:50 <clayton> #action sbadia to investigate Trove bring broken in RDO (openstack-trove-taskmanager appears to be missing)
15:27:52 <degorenko> rdo guys said that repo not full ready now :) it will be ready in ~2 days
15:27:57 <sbadia> #action sbadia take a look with rdo people for openstack-trove-taskmanager missing package
15:27:59 <sbadia> oups…
15:28:04 <clayton> either way :)
15:28:07 <sbadia> eck…
15:28:12 <IvanBerezovskiy> the same problem was with missed pymysql package. RDO guys sad that they should fix mirorr after 1-2 days
15:28:22 <clayton> That's everything we had on the agenda
15:28:26 <IvanBerezovskiy> s/sad/said
15:28:26 <sbadia> haha #rdo…
15:28:38 <clayton> #topic Open discussion
15:28:44 <clayton> Any other topics to cover?
15:29:04 <degorenko> yeah, probably
15:29:18 <degorenko> what about review for https://review.openstack.org/229548 and  https://review.openstack.org/229895 ?
15:29:19 <degorenko> :)
15:29:29 <degorenko> it is on review so long
15:29:34 <xenolog13> guys, what about review https://review.openstack.org/#/c/238156/
15:30:04 <clayton> xenolog13: let's do one at a time
15:31:29 <clayton> degorenko do you guys have many people using nova-network still?
15:31:35 <clayton> I was surprised to see the patch
15:32:28 <degorenko> clayton, actually, nova-network is still using, not too common
15:33:34 <degorenko> there are no actual changes in provider work, some refactoring
15:33:40 <clayton> #info degorenko requesting reviews of  https://review.openstack.org/229548 and  https://review.openstack.org/229895
15:34:19 <clayton> xenolog13: what about your review?  Any comments or just needing reviews?
15:34:44 <degorenko> clayton, some strange situation - no actual errors, but jobs are failed
15:35:21 <mfisch> degorenko: which one was the fails?
15:35:28 <xenolog13> patch on review too long time.
15:35:30 <degorenko> mfisch, all scenario jobs
15:35:32 <clayton> scenario tests
15:35:40 <mattymo> this change is really important to get around potential SSL warnings
15:36:25 <clayton> do we have a volunteer to help xenolog13 troubleshoot the scenario job failures on that patch?  I agree it would be good to get this one merged
15:36:30 <xenolog13> logs of scenario tests does not carry information what was failed.
15:36:48 <degorenko> only non-fatal errors
15:36:56 <degorenko> like image list request
15:37:03 <degorenko> http://logs.openstack.org/56/238156/11/check/gate-puppet-openstack-integration-scenario001-dsvm-trusty/5b5c581/console.html#_2015-11-10_12_53_59_197
15:37:10 <degorenko> no any other error
15:38:45 <clayton> Does this need Emilien to take a look?  We can assign action items to him since he's not here :)
15:38:58 <degorenko> nice :)
15:39:03 <degorenko> but i don't think so
15:39:21 <xenolog13> I found just one reason:
15:39:21 <xenolog13> http://paste.openstack.org/show/478447/
15:39:24 <xenolog13> for error
15:39:29 <clayton> so are you guys going to continue investigating on your own then?
15:40:04 <degorenko> i meant, that i don't know how Emilien can help us on PTO :)
15:40:30 <xenolog13> but puppet return non-zero return code not means 'error while deployment'
15:40:45 <clayton> it's failing because the second run wasn't idempotent
15:40:56 <degorenko> clayton, no
15:41:03 <degorenko> the first run also returns 2
15:41:14 <clayton> first run is allowed to return 2 ;)
15:42:00 <clayton> I think this is probably the last topic, let's continue this in #puppet-openstack and see if there are any other topics for today
15:42:30 <clayton> Anyone else have a topic before we end the meeting?
15:43:16 <clayton> ok then
15:43:19 <clayton> #endmeeting