#openstack-meeting-4: puppet-openstack

Meeting started by EmilienM at 15:00:05 UTC (full logs).

Meeting summary

    1. agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151117 (EmilienM, 15:00:23)

  1. review past items (EmilienM, 15:00:55)
  2. keystone federation status (EmilienM, 15:03:30)
    1. https://github.com/puppetlabs/puppetlabs-apache/blob/master/manifests/params.pp#L88 (iurygregory, 15:04:57)
    2. ACTION: review federation patche https://review.openstack.org/#/c/216821 (EmilienM, 15:21:17)

  3. os_service_defaults (EmilienM, 15:21:45)
    1. os_service_defaults feature can be implemented in all modules from today (EmilienM, 15:26:33)
    2. ACTION: clayton to update https://wiki.openstack.org/wiki/Puppet/Coding_style about os_service_defaults (EmilienM, 15:32:03)

  4. incorrect defaults for *::db classes (EmilienM, 15:32:29)
    1. https://bugs.launchpad.net/puppet-tuskar/+bug/1515273) (EmilienM, 15:32:43)
    2. https://trello.com/c/XLJJJBF0/71-move-modules-to-the-os-service-default-pattern (degorenko, 15:45:18)

  5. Open Discussion, Bug and Review triage (EmilienM, 15:46:33)
    1. https://review.openstack.org/#/c/244900/ (mwhahaha, 15:47:04)
    2. https://review.openstack.org/#/c/220238/ (aderyugin, 15:48:08)
    3. ACTION: emilien to check https://github.com/openstack/puppet-cinder/commit/70daad9ea4a25471f4d40b78ad70ae0aa2f99a1e is consistent across all modules (EmilienM, 15:57:04)
    4. ACTION: everyone to use #action when posting reviews they want reviewed (mfisch, 15:58:41)
    5. ACTION: review https://review.openstack.org/245876 (degorenko, 15:58:54)
    6. ACTION: review https://review.openstack.org/#/c/216654/ (degorenko, 15:59:13)
    7. ACTION: review https://review.openstack.org/#/c/233011/ (myatsenko1, 15:59:17)
    8. ACTION: review https://review.openstack.org/#/c/241614/ (mkarpin, 15:59:41)
    9. ACTION: review https://review.openstack.org/#/c/220238/ (aderyugin, 15:59:42)
    10. ACTION: review https://review.openstack.org/#/c/216821/ (iurygregory, 15:59:52)


Meeting ended at 16:00:06 UTC (full logs).

Action items

  1. review federation patche https://review.openstack.org/#/c/216821
  2. clayton to update https://wiki.openstack.org/wiki/Puppet/Coding_style about os_service_defaults
  3. emilien to check https://github.com/openstack/puppet-cinder/commit/70daad9ea4a25471f4d40b78ad70ae0aa2f99a1e is consistent across all modules
  4. everyone to use #action when posting reviews they want reviewed
  5. review https://review.openstack.org/245876
  6. review https://review.openstack.org/#/c/216654/
  7. review https://review.openstack.org/#/c/233011/
  8. review https://review.openstack.org/#/c/241614/
  9. review https://review.openstack.org/#/c/220238/
  10. review https://review.openstack.org/#/c/216821/


Action items, by person

  1. clayton
    1. clayton to update https://wiki.openstack.org/wiki/Puppet/Coding_style about os_service_defaults
  2. openstack
    1. review federation patche https://review.openstack.org/#/c/216821
    2. clayton to update https://wiki.openstack.org/wiki/Puppet/Coding_style about os_service_defaults
    3. emilien to check https://github.com/openstack/puppet-cinder/commit/70daad9ea4a25471f4d40b78ad70ae0aa2f99a1e is consistent across all modules
    4. review https://review.openstack.org/245876
    5. review https://review.openstack.org/#/c/216654/
    6. review https://review.openstack.org/#/c/233011/
    7. review https://review.openstack.org/#/c/241614/
    8. review https://review.openstack.org/#/c/220238/
    9. review https://review.openstack.org/#/c/216821/


People present (lines said)

  1. EmilienM (110)
  2. clayton (52)
  3. iurygregory (36)
  4. chem (20)
  5. degorenko (18)
  6. mwhahaha (15)
  7. xarses (10)
  8. mfisch (9)
  9. sbadia (7)
  10. richm (6)
  11. aderyugin (5)
  12. openstack (4)
  13. myatsenko1 (3)
  14. delatte (2)
  15. Guest20594 (2)
  16. mkarpin (2)
  17. angdraug (1)
  18. crinkle (1)
  19. mentat (1)
  20. holser (1)
  21. mdorman (1)


Generated by MeetBot 0.1.4.