15:00:00 <EmilienM> #startmeeting puppet-openstack
15:00:06 <openstack> Meeting started Tue Nov 24 15:00:00 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:12 <EmilienM> #link agenda: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151124
15:00:14 <EmilienM> o/
15:00:16 <iurygregory> o/
15:00:23 <degorenko> hey o/
15:00:23 <mkarpin> o/
15:00:36 <clayton> o/
15:00:44 <skolekonov> o/
15:00:44 <xarses> o/
15:00:45 <richm> hello
15:00:45 <aderyugin> 0/
15:00:47 <crinkle> o/
15:01:19 <EmilienM> #topic CI status
15:01:36 <EmilienM> some modules are failing with Puppet 4.3.0
15:01:40 <EmilienM> gchamoul is working on it
15:01:52 <EmilienM> #link Unit tests failures bug https://trello.com/c/IXdfcqXd/74-bug-1517805-unit-tests-broken
15:02:02 <EmilienM> gchamoul: do you need some help or can you handle the bugs?
15:02:50 <degorenko> as i know, neutron has same bug - skolekonov faced with it
15:02:52 <EmilienM> not sure gael is around
15:03:00 <EmilienM> degorenko: great.
15:03:11 <sbadia> o/
15:03:14 <EmilienM> it's not a blocker at this time but it would be great if we could fix it this week, while I'm doing the release
15:03:22 <degorenko> +1
15:03:27 <skolekonov> Yep, it starts to fail on my patch with switching to os_service_default
15:03:27 <EmilienM> on the packaging side, only manila is broken at this time
15:03:58 <EmilienM> skolekonov: look at gchamoul's patches to see what he did, maybe you're having the same bug
15:04:15 <EmilienM> cody is not online but thanks to him we have our beaker jobs back alive on ubuntu trusty
15:04:25 <degorenko> \o/
15:04:37 <EmilienM> #topic release status
15:04:48 <iurygregory> tks cody
15:04:49 <EmilienM> #link release status https://goo.gl/XIBRz6
15:04:57 <EmilienM> I'm working on it
15:05:07 <EmilienM> this morning I created stable/liberty for puppet-openstack-integration
15:05:12 <EmilienM> I released puppet-openstacklib
15:05:16 <EmilienM> and now I'm working on puppet-keystone
15:05:30 <EmilienM> tomorrow, I'll do the other modules
15:05:48 <EmilienM> CI should not be affected but let me know if you see something strange
15:05:50 <degorenko> so, the green filed means that brunch is ready and merged? May be also put links here on merged patches?
15:05:55 <degorenko> field*
15:06:28 <EmilienM> degorenko: the green means: ok or passing
15:06:38 <EmilienM> _ody: hey, thanks for the beaker patch & release - it helped a lot
15:06:53 <_ody> np.
15:07:19 <_ody> oh man does this meeting feel early
15:07:29 <IvanBerezovskiy> EmilienM: can pymysql patches be merged before release? :)
15:07:36 <EmilienM> IvanBerezovskiy: i'm not sure
15:07:41 <EmilienM> but we can backport them later
15:07:59 <EmilienM> right now, we are pushing only critical & non backward compatible patches
15:08:18 <EmilienM> but afik there is one patch left, in puppet-keystone
15:08:28 <EmilienM> richm: can you look at it? I sent you the link on IRC a few time ago
15:08:39 <IvanBerezovskiy> ok. if they won't be merged, I'll take care about backporting them :)
15:08:49 <EmilienM> richm: https://review.openstack.org/#/c/239434
15:08:53 <EmilienM> IvanBerezovskiy: thx
15:09:16 <EmilienM> any question about release?
15:09:21 <richm> EmilienM: done
15:09:24 <EmilienM> richm: thx
15:09:59 <EmilienM> #topic os_service_default status
15:10:20 <EmilienM> I would like to know the progress on this work
15:10:35 <EmilienM> the work is well distributed, does anyone has blockers?
15:10:48 <degorenko> i have strange error on murano patch: https://review.openstack.org/247482
15:11:29 <iurygregory> TypeError: no implicit conversion from nil to integer
15:11:51 <skolekonov> I'm currently preparing the fix for Puppet 4-related error in puppet-neutron, and the first part (switching undef -> os_service_default) will be ready for review
15:11:52 <EmilienM> degorenko: that's lint
15:12:50 <iurygregory> keystone and nova - logging and db moved to os_service_default https://review.openstack.org/#/c/247743/  https://review.openstack.org/#/c/248901/
15:12:50 <degorenko> yeah
15:12:56 <degorenko> but i dont understand where is problem
15:13:15 <EmilienM> degorenko: could you create an etherpad with the status of this feature?
15:13:22 <mkarpin> i am working on part 2 for Heat - it will include params for apis, engine
15:13:26 <EmilienM> for each module we know 1/ patches in progress 2/ who plan to work on it
15:13:34 <degorenko> EmilienM, for os_service_default?
15:13:38 <EmilienM> degorenko: y
15:13:41 <degorenko> we have trello board fot this
15:13:45 <degorenko> why we need ehterpad?
15:13:48 <EmilienM> oh, even better
15:13:56 <EmilienM> I forgot Trello board
15:13:59 <degorenko> #link https://trello.com/c/XLJJJBF0/71-move-modules-to-the-os-service-default-pattern
15:14:07 <degorenko> we have all info here :)
15:14:11 <degorenko> what is in progress
15:14:18 <EmilienM> nice
15:14:21 <degorenko> who is working on some module and links to review
15:14:41 <EmilienM> degorenko: we need to take care about the logging stuff
15:14:48 <EmilienM> https://github.com/openstack/puppet-cinder/commit/70daad9ea4a25471f4d40b78ad70ae0aa2f99a1e
15:15:01 <degorenko> EmilienM, yep, i know about this
15:15:24 <EmilienM> nice
15:15:36 <EmilienM> do we have any further action about this feature? any blocker?
15:15:40 <degorenko> I will pin this patch to descritpion
15:16:21 <EmilienM> ok
15:16:25 <EmilienM> #link midcycle
15:16:28 <EmilienM> oops
15:16:32 <EmilienM> #undo
15:16:32 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x95f0c10>
15:16:46 <EmilienM> #item midcycle
15:16:52 <EmilienM> #topic midcycle
15:16:58 <EmilienM> I should sleep sometimes... sorry
15:17:14 <EmilienM> Just to give a quick poll url -> http://goo.gl/forms/lsBf55Ru8L
15:17:19 <EmilienM> if people could take 1 minute to feed it
15:17:34 <EmilienM> that would help our group to decide if we do a meetup or not, and where
15:17:41 <degorenko> do we really need mid-cycle? :)
15:17:49 <EmilienM> degorenko: use the poll :)
15:17:57 <degorenko> :D okay
15:18:17 <EmilienM> I think it's a good opportunity for our group to work together
15:18:58 <EmilienM> if anyone has questions or thoughts about midcycle, go ahead, we have time I guess
15:19:02 <xarses> If we do, I think it would be helpful to be near the operators mid-cycle
15:19:16 <EmilienM> xarses: that's why the poll contains this question ;-)
15:19:20 <xarses> yep
15:19:27 <xarses> just re-iterating
15:19:59 <EmilienM> #topic review past actions
15:20:03 <EmilienM> a bit late but nevermind...
15:20:08 <EmilienM> clayton updated https://wiki.openstack.org/wiki/Puppet/Coding_style
15:20:19 <EmilienM> so people can understand what is os_service_defaults
15:20:37 <degorenko> cool :)
15:20:47 <EmilienM> all other actions are done
15:20:51 <EmilienM> we have a last item
15:21:01 <EmilienM> #topic mitaka follow-up on aviator package maintaining
15:21:09 <EmilienM> who is veremin ?
15:21:53 <EmilienM> I'm not sure what we need to follow-up since we decided to not using aviator or whatever
15:22:14 <yottatsa> sorry I was on call
15:22:47 <xarses> I thought we agreed that we'd only look at another solution once it was ready to start switching
15:22:47 <EmilienM> if nobody comes up about the aviator topic item, i'll go ahead
15:23:06 <yottatsa> I'm veremon
15:23:09 <yottatsa> veremin
15:23:10 <EmilienM> ah
15:23:15 <yottatsa> so, about aviator
15:24:00 <yottatsa> dborodaenko asked me to assess current state of aviator, it supportts Leystone v3 auth, but didn't support any of required functions for fuel
15:24:46 <EmilienM> yottatsa: I think we already know the status of aviator. We discussed about that in Tokyo.
15:25:12 <yottatsa> on the other hand, aviator comes with good test coverage and it's pretty easy to add new functions
15:25:28 <EmilienM> we are not going to spend time discussing on it I think
15:25:35 <EmilienM> we covered that in Tokyo
15:25:36 <yottatsa> someone on that meeting in Tokyo offered their help to maintain aviator
15:25:41 <degorenko> as mentioned xarses: we can look at another solution - when it will be ready to start switching
15:25:41 <yottatsa> ol
15:25:42 <EmilienM> we had an open discussion on the mailing list
15:25:43 <yottatsa> ok
15:26:24 <EmilienM> yottatsa: what's the point of discussing about that now?
15:26:32 <EmilienM> do you have a blueprint? an idea?
15:26:45 <yottatsa> as I missed the start, let's discuss it in ml
15:26:49 <EmilienM> great
15:27:00 <yottatsa> sorry for bothering (
15:27:00 <EmilienM> #action yottatsa follows-up aviator discussion on ML
15:27:06 <EmilienM> #topic open discussions / bugs / reviews
15:27:23 <EmilienM> if you have bugs / patches that needs attention go ahead - or any topic not in the agenda
15:27:25 <Vinsh> oh me oh me
15:27:27 <Vinsh> https://review.openstack.org/#/c/203220/
15:27:32 <EmilienM> Vinsh: always you !
15:27:36 <Vinsh> Yep :)
15:27:36 <degorenko> https://review.openstack.org/245178 https://review.openstack.org/245253 :)
15:27:48 <Vinsh> are the gates just busted all over or just for swift?
15:27:51 <degorenko> https://review.openstack.org/246988 and https://review.openstack.org/245876 :D
15:28:02 <iurygregory> in the last meeting someone give the idea to add "#action" for each review =)
15:28:08 <EmilienM> Vinsh: it happens what are the logs saying?
15:29:06 <Vinsh> http://logs.openstack.org/20/203220/55/check/gate-puppet-swift-puppet-beaker-rspec-dsvm-centos7/827612b/console.html.gz
15:29:12 <Vinsh> some keystone failures that I don't understand
15:29:39 <EmilienM> maybe chem or richm can help
15:29:53 <chem> I'm looking
15:29:53 <Vinsh> I guess the others are just ruby gems time outs.. which means keep rechecking
15:30:21 <EmilienM> degorenko: done for both
15:31:00 <mkarpin> guys can you please review https://review.openstack.org/#/c/237035/ thanks!
15:31:08 <_ody> Can someone add me to the trello board so I can get the stuff I am working on up there?
15:31:08 <degorenko> EmilienM, thanks!
15:31:18 <EmilienM> iurygregory: yes, but it does not have much success :(
15:31:20 <chem> Vinsh: Something went wrong when restarting the server I'm checking what it is
15:31:41 <Vinsh> Thanks, its a new one I havn't seen before.
15:31:44 <EmilienM> _ody: sure
15:31:53 <iurygregory> me? O.o
15:32:02 <iurygregory> oh sorry =P
15:32:04 <EmilienM> _ody: your nickname?
15:32:11 <EmilienM> iurygregory: no the #action thing for reviews
15:32:28 <iurygregory> yeah got lost talking to my boss
15:32:38 <_ody> EmilienM: Trello says "codyherriges"
15:32:53 <EmilienM> _ody: done
15:32:57 <EmilienM> anything else for today?
15:33:08 <_ody> EmilienM: Thanks!
15:33:26 <degorenko> _ody, you now in trello board :)
15:34:07 <EmilienM> I'll close the meeting in 30s
15:34:35 <EmilienM> thanks everyone, have a nice day!
15:34:40 <EmilienM> #endmeeting