15:00:17 <EmilienM> #startmeeting puppet-openstack
15:00:19 <openstack> Meeting started Tue Dec 15 15:00:17 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:24 <EmilienM> #link Agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151215
15:00:26 <EmilienM> o/
15:00:26 <xarses> hi
15:00:27 <mwhahaha> hi
15:00:29 <skolekonov> hi
15:00:31 <IvanBerezovskiy> hi
15:00:32 <degorenko> hello :)
15:00:37 <chem> yo
15:00:41 <ntpttr> hello
15:01:01 <iurygregory> o/
15:01:26 <EmilienM> #topic review past action items
15:01:32 <EmilienM> EmilienM to follow-up on mailing-list about reno: done
15:01:50 <EmilienM> I think we got nice feedback on that
15:02:00 <EmilienM> I added the topic to the sprint agenda
15:02:13 <EmilienM> talking about sprint...
15:02:21 <EmilienM> #topic midcycle sprint
15:02:33 <EmilienM> #link micycle sprint agenda https://etherpad.openstack.org/p/puppet-happy-new-year-2016
15:02:37 <EmilienM> this is a draft ^
15:02:49 <EmilienM> please write your name if you're interested to join the party
15:03:12 <EmilienM> for now, we are 5 and we have 4 topics
15:03:34 <EmilienM> feel free to propose topics
15:03:59 <EmilienM> by the end of this year (soon) I'll send a date proposal, regarding schedule constraints
15:04:22 <ntpttr> Is this an in person sprint then, or virtual? Haven't been to one bfore
15:04:24 <rosmaita> flaper87: i just put a -1 on the "in" spec, https://review.openstack.org/#/c/246971/ , just asking for a revsion
15:04:34 <EmilienM> ntpttr: it will be virtual
15:04:41 <EmilienM> rosmaita: wrong channel?
15:04:49 <ntpttr> EmilienM: Okay, thanks :)
15:05:05 <EmilienM> ntpttr: so anyone can join, without financial constraint
15:05:34 <EmilienM> any question / suggestion about the sprint?
15:06:31 <richm> hola
15:06:35 <sbadia> hi
15:06:46 <EmilienM> #action send an email by December 31th to propose Sprint final schedule
15:06:53 <EmilienM> #undo
15:06:54 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa633bd0>
15:07:02 <EmilienM> #action EmilienM to send an email by December 31th to propose Sprint final schedule
15:07:31 <EmilienM> #topic meeting next week
15:07:43 <EmilienM> should we do a meeting next week?
15:08:06 <xarses> I'll be around
15:08:18 <degorenko> ne to
15:08:19 <degorenko> me*
15:08:28 <chem> me no
15:08:29 <iurygregory> me too =)
15:08:34 <ntpttr> I won't be
15:08:51 <EmilienM> I can propose an agenda and if we don't have much, maybe we can cancel it and talk on IRC as usual?
15:09:01 <degorenko> agree
15:09:05 <chem> good idea
15:09:05 <EmilienM> or do you really me to dress in santa claus?
15:09:11 <iurygregory> yeah
15:09:15 <EmilienM> ... no way
15:09:20 <degorenko> actually, if you can...
15:09:20 <chem> I really you
15:09:21 <degorenko> :D
15:09:22 <iurygregory> lol
15:09:37 <iurygregory> you just need to send chocolate XD
15:09:37 <EmilienM> we have a last topic before open discussion
15:10:01 <EmilienM> #action EmilienM to propose an agenda during Christmas week but eventually cancel the meeting if nothing
15:10:15 <EmilienM> #topic Bump CI to Mitaka
15:10:50 <EmilienM> is someone against bumping our CI to Mitaka packages as soon Ubuntu release packaging?
15:11:08 <EmilienM> RDO packaging is already in a good shape, only sahara & aodh are not working but it's all WIP now.
15:11:21 <EmilienM> #link Mitaka/RDO testing https://review.openstack.org/255635
15:11:32 <degorenko> yeah, we already talked with rdo guys, it should be fixed soon
15:11:44 <EmilienM> nice
15:11:56 <EmilienM> and I talked with ubuntu team and they plan to release mitaka-1 next week
15:11:56 * _ody yawns
15:12:15 <EmilienM> it will be in -proposed as usual
15:12:30 <EmilienM> in the last cycle, we had issues because RDO had no CI
15:12:42 <degorenko> fully +1 for bumping our ci
15:12:48 <EmilienM> but now it's fixed, they have tested repos and they actually use our puppet modules to test it.
15:12:50 <EmilienM> cool
15:13:01 <iurygregory> +1 for bump
15:13:27 <EmilienM> #action Wait for RDO fix (sahara + aodh) and Ubuntu release to bump our CI to Mitaka
15:13:39 <EmilienM> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
15:14:11 <degorenko> need last +2 here: https://review.openstack.org/255393 :)
15:14:36 <degorenko> and also we have tested switch to os_service_default https://review.openstack.org/253416 https://review.openstack.org/249711
15:14:45 <EmilienM> degorenko: what is the status of service default?
15:14:47 <degorenko> for neutron and heat on tempest test patches
15:14:57 <EmilienM> https://trello.com/c/XLJJJBF0/71-move-modules-to-the-os-service-default-pattern
15:15:00 <EmilienM> is it updated?
15:15:09 <degorenko> i'm not sure
15:15:18 <iurygregory> i'm on ironic
15:15:32 <iurygregory> we still have some modules to update
15:15:32 <degorenko> i guess we have only glance now
15:15:43 <iurygregory> according to the list in trello
15:15:48 <degorenko> all another modules already have some patches
15:15:48 <delattec> need +2 reviewers on https://review.openstack.org/#/c/197572/
15:15:57 <EmilienM> mfisch: I'm still wondering when monasca will be compliant
15:16:34 <mfisch> EmilienM: me too
15:16:49 <mfisch> EmilienM: I'll mention it to the guys here again
15:16:59 <degorenko> iurygregory, are you going to make some changes in nova?
15:17:09 <iurygregory> i can
15:17:11 <degorenko> or we keep it as is for now? :)
15:17:19 <mfisch> I think anyone could make the monasca changes though
15:17:35 <EmilienM> mfisch: well, not sure anyone is using it
15:17:39 <EmilienM> except you
15:17:41 <mfisch> true
15:17:50 <EmilienM> it's a lot of refact
15:17:53 <EmilienM> refacto*
15:18:07 <iurygregory> degorenko, i'll update  after ironic
15:18:19 <IvanBerezovskiy> small fix for murano https://review.openstack.org/#/c/255869/
15:18:23 <degorenko> iurygregory, be careful with nova :)
15:18:30 <iurygregory> yeah =X
15:18:32 <EmilienM> yes...
15:18:35 <iurygregory> i know XD
15:18:58 <iurygregory> Keystone didn't broken
15:19:03 <iurygregory> \o/
15:19:13 <degorenko> we saw it on tempest patch :)
15:19:37 <degorenko> so, when you will upload nova switch - you can upload tempest test patch :)
15:19:42 <degorenko> no
15:19:43 <EmilienM> IvanBerezovskiy: -1
15:19:45 <degorenko> you MUST
15:20:23 <iurygregory> ok
15:20:31 <degorenko> EmilienM, https://review.openstack.org/#/c/255869/6/manifests/dashboard.pp i think we should also fix it in liberty
15:20:32 <IvanBerezovskiy> EmilienM: it's incorrect path in package
15:20:35 <degorenko> because it is incorrect path
15:20:41 <EmilienM> cool
15:20:44 <EmilienM> but update the doc also
15:20:49 <degorenko> aderyugin, ^^^
15:20:50 <IvanBerezovskiy> EmilienM: it should be fixed in liberty as well
15:20:55 <IvanBerezovskiy> in stable/liberty
15:20:55 <EmilienM> ok
15:21:12 <IvanBerezovskiy> will be updated, thanks
15:21:24 <EmilienM> do we have anything else for today?
15:21:42 <degorenko> this one i guess https://review.openstack.org/#/c/197572/
15:22:22 <EmilienM> _ody has a valid comment on it
15:23:42 <EmilienM> but well, he +1-ed
15:23:46 <angdraug> EmilienM: I'm trying to put together Fuel 9.0 schedule, wondering what kind of schedule do you plan for Mitaka
15:23:58 <degorenko> also eveerywhere we have RegioneOne as default
15:24:18 <EmilienM> angdraug: regarding our progress to bump our CI, I think we can do releases very shortly after official schedule
15:24:22 <crinkle> i would like feedback on https://review.openstack.org/#/c/256031/
15:24:54 <mgrosz> Hey, need +2 and workflow here: https://review.openstack.org/#/c/255431/
15:24:54 <angdraug> cool, that's what I was hoping for. shortly as in a week or two after?
15:24:57 <IvanBerezovskiy> oh, I forgot one patch. It was already approved but merge has failed https://review.openstack.org/#/c/226011/
15:25:08 <EmilienM> angdraug: yes, eventually
15:25:15 <EmilienM> angdraug: again, depending on packaging
15:25:18 <_ody> EmilienM: I did.  My comment is out of scope of the change.
15:25:22 <EmilienM> but I hope one day we will stop using ubuntu packaging
15:25:29 <EmilienM> and use what is doing zigo
15:25:54 <EmilienM> I think chem and richm might want to look crinkle's patch
15:26:12 <chem> EmilienM: will do
15:26:24 <chem> EmilienM: which one it is ?
15:26:34 <EmilienM> chem: she posted ^
15:26:34 <chem> oki
15:26:34 <crinkle> chem: https://review.openstack.org/#/c/256031/
15:26:37 <EmilienM> https://review.openstack.org/#/c/256031/
15:26:42 <chem> oki :)
15:27:02 <EmilienM> I'll let 1 more minute to let anyone bring something else otherwise I'll close the meeting
15:27:58 <EmilienM> crinkle: would it require backporting to stable/liberty I presume?
15:28:22 <crinkle> EmilienM: yes i think so
15:28:43 <EmilienM> crinkle: makes sense
15:29:16 <EmilienM> thanks everyone
15:29:23 <degorenko> o/
15:29:25 <EmilienM> enjoy Christmas time if no meeting next week
15:29:26 <IvanBerezovskiy> thx
15:29:31 <ntpttr> thanks
15:29:36 <crinkle> o/
15:29:38 <EmilienM> #endmeeting