14:59:26 <EmilienM> #startmeeting puppet-openstack
14:59:27 <openstack> Meeting started Tue Dec 29 14:59:26 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:30 <openstack> The meeting name has been set to 'puppet_openstack'
14:59:39 <EmilienM> #link agenda: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20151229
14:59:41 <EmilienM> hello !
14:59:44 <mwhahaha> hi
14:59:49 <degorenko> o/
14:59:50 <chem> yo
14:59:51 <IvanBerezovskiy> hi
14:59:57 <skolekonov> hi
15:00:01 <xarses> hi
15:00:18 * EmilienM is running IRC from a public place with 3g
15:00:27 <EmilienM> I hope you had fun during xmas time
15:00:50 <EmilienM> and you had lot of presents :-P
15:01:03 <IvanBerezovskiy> we've just begun :D
15:01:06 <EmilienM> #topic Review past action items
15:01:11 <EmilienM> EmilienM to send an email by December 31th to propose Sprint final schedule: done
15:01:15 <EmilienM> EmilienM to propose an agenda during Christmas week but eventually cancel the meeting if nothing: done
15:01:23 <EmilienM> Wait for RDO fix (sahara + aodh) and Ubuntu release to bump our CI to Mitaka: done
15:01:34 <EmilienM> #topic Clean-up our modules from previous deprecations & warnings
15:01:44 <EmilienM> so I ran a thread last week about that
15:02:07 <EmilienM> so basically, with the current master we got some warnings
15:02:19 <EmilienM> we have different bugs related to them
15:02:24 <EmilienM> let's do a bit of triage / review
15:02:34 <EmilienM> https://bugs.launchpad.net/puppet-swift/+bug/1433390
15:02:35 <openstack> Launchpad bug 1433390 in puppet-swift mitaka "rsync with default chmod to 644" [High,In progress] - Assigned to Emilien Macchi (emilienm)
15:02:56 <EmilienM> gerrit is in bad shape lately
15:03:06 <EmilienM> but for this bug, we have one patch: https://review.openstack.org/#/c/261327/
15:04:06 <EmilienM> #action people to review the patch about warnings in puppet-swift  https://review.openstack.org/#/c/261327/
15:04:21 <EmilienM> we have https://bugs.launchpad.net/puppet-nova/+bug/1506066
15:04:22 <openstack> Launchpad bug 1506066 in puppet-nova "Scope-related warnings from nova::vncproxy::common" [Medium,In progress] - Assigned to Nate Potter (ntpttr)
15:04:25 <EmilienM> very interesting one ^
15:05:10 <EmilienM> mwhahaha: I see your comment
15:05:26 <mwhahaha> that one seems like it's because of the structure of the module
15:05:43 <EmilienM> yeah, so you suggest we keep the warning for now?
15:05:49 <mwhahaha> without a larger rewrite, i don't think we can get away from that awful if/else block
15:06:15 <mwhahaha> or just dupe the code
15:06:28 <EmilienM> mwhahaha: wdyt about https://review.openstack.org/#/c/255529/3/manifests/vncproxy/common.pp ?
15:06:31 <EmilienM> is it acceptable?
15:06:46 <EmilienM> last time I checked, we still had the warning
15:06:48 * EmilienM checking again
15:07:13 <mwhahaha> personally, no but if we really care about that warning then it's something we might have to live with
15:07:50 <EmilienM> http://logs.openstack.org/29/255529/3/check/gate-puppet-openstack-integration-scenario001-tempest-dsvm-trusty/72247e6/console.html.gz#_2015-12-17_23_34_54_866
15:07:50 <EmilienM> mwhahaha: his patch does not drop the warning anway ^
15:08:07 <EmilienM> to me, a warning is a bad user experience, we should do our best to drop it asap
15:08:24 <mwhahaha> yea i can see that, the problem is that setting is shared :/
15:09:00 <mwhahaha> so other than leveraging some sort of ensure resource for duplication, we're having to work around a whole bunch of puppetness because we are sharing it between two ways of deploying nova
15:09:08 <mwhahaha> maybe if i get some time today i'll pull it down and give it a run
15:09:33 <EmilienM> mwhahaha: cool, that's not urgent I guess. I think it's Medium now
15:09:34 <EmilienM> thanks!
15:09:38 <mwhahaha> the defines probably are wrong
15:10:11 <EmilienM> #action continue the investigation on https://review.openstack.org/#/c/255529/
15:10:51 <EmilienM> mwhahaha: ok, let us know if you have some thoughts later, thanks again
15:10:57 <mwhahaha> will do
15:11:01 <EmilienM> I've seen some progress on https://bugs.launchpad.net/bugs/1528963
15:11:02 <openstack> Launchpad bug 1528963 in puppet-neutron "warnings about auth_ parameters present by default" [High,In progress] - Assigned to Sergey Kolekonov (skolekonov)
15:11:13 <EmilienM> which is affecting lot of modules
15:11:30 <EmilienM> this one is High, I think we can safely drop the old parameters
15:11:46 <EmilienM> and keep auth_uri & identity_uri, right? they seem enough and the way to go for Mitaka, right?
15:11:58 <EmilienM> degorenko: ^
15:12:13 <degorenko> yep :)
15:12:32 <degorenko> is anyone against this way?
15:12:54 <EmilienM> degorenko: I need to update https://review.openstack.org/#/c/261120/
15:13:01 <degorenko> for example my heat patch
15:13:04 <degorenko> #link https://review.openstack.org/261326
15:13:05 <EmilienM> #action EmilienM update https://review.openstack.org/#/c/261120/ like it's done for other modules
15:13:31 <degorenko> EmilienM, let's wait more feedbacks on my heat patch
15:13:37 <degorenko> if everyone will ok with it
15:13:39 <skolekonov> do we keep version-less URIs?
15:13:43 <degorenko> then i guess we can use it as pattern
15:13:52 <EmilienM> degorenko: ok, I would like to see other thoughts
15:13:54 <degorenko> skolekonov, for heat it was important
15:14:05 <EmilienM> skolekonov: for now, we keep as it was before by default
15:14:08 <degorenko> EmilienM, sure
15:14:12 <EmilienM> the bug is about parameters only
15:14:15 <EmilienM> not the value (yet)
15:14:25 <skolekonov> But they were set to false
15:14:32 <EmilienM> I have a bug about version-less
15:14:35 <skolekonov> So we need a new default :)
15:14:46 <EmilienM> skolekonov: follow the default of old parameters for now
15:15:00 <skolekonov> Ok, thanks
15:15:04 <EmilienM> the heat patch is a good example i think
15:15:13 <degorenko> or use construction from port, protocol and host :)
15:15:45 <EmilienM> skolekonov: https://review.openstack.org/#/c/261291/ looks good no?
15:15:58 <EmilienM> degorenko: we want to drop these params no?
15:16:09 <skolekonov> Yep, it works
15:16:19 <degorenko> EmilienM, yeah, i meant, i saw in some module construction like
15:16:29 <degorenko> protocol//host:port/v2.0
15:16:41 <degorenko> i don't remember where
15:16:44 <degorenko> but i saw :D
15:16:51 <EmilienM> look https://review.openstack.org/#/c/261291/2/manifests/server.pp
15:17:16 <EmilienM> $auth_uri_real = "${auth_protocol}://${auth_host}:5000/"
15:17:21 <degorenko> yeah
15:17:30 <degorenko> that's what i talking about
15:17:49 <degorenko> so, we don't have api version here
15:18:02 <degorenko> and i guess we can drop it for default in auth_uri
15:18:10 <degorenko> module specific case i guess
15:18:14 <EmilienM> it looks fine I guess, CI is passing
15:18:16 <EmilienM> our CI use:
15:18:18 <EmilienM> identity_uri        => 'http://127.0.0.1:35357/'
15:18:29 <EmilienM> and default of auth_uri which is ${auth_protocol}://${auth_host}:5000/
15:18:33 <EmilienM> so I guess endpoint less is fine
15:18:47 <degorenko> anyway, if something will wrong - we will see -1 from scenario jobs
15:18:57 <EmilienM> when all these patches are merged, we will update scenarios manifests
15:19:14 <EmilienM> my refacto patch will help a bit to avoid dupplicated code
15:19:35 <EmilienM> and the last one was in puppet-ceilometer https://review.openstack.org/#/c/262143/
15:20:06 <degorenko> it has -1 :)
15:22:16 <EmilienM> I've lost 3g
15:22:18 <EmilienM> I'm back :)
15:22:20 <EmilienM> sorry for that
15:22:24 <degorenko> no problem
15:22:30 <EmilienM> ok, let's continue the puppet-ceilometer discussion on gerrit
15:22:36 <EmilienM> another bug in this topic: https://bugs.launchpad.net/bugs/1528964
15:22:37 <openstack> Launchpad bug 1528964 in puppet-sahara "Warning is showed by default when deploying notify.pp" [High,In progress] - Assigned to Denis Egorenko (degorenko)
15:22:45 <degorenko> it is already on review :)
15:22:56 <degorenko> #link https://review.openstack.org/261481
15:22:58 <EmilienM> #action people to review the warning/puppet-sahara patch: https://review.openstack.org/261481
15:23:04 <EmilienM> thx degorenko for this work
15:23:20 <EmilienM> nex:
15:23:22 <EmilienM> next: https://bugs.launchpad.net/puppet-vswitch/+bug/1524559
15:23:23 <openstack> Launchpad bug 1524559 in puppet-vswitch "warnings in ovs_redhat.rb code" [High,Confirmed]
15:24:00 <EmilienM> _ody (not here) mentionned he would work on it but I haven't heard about it yet
15:24:18 <EmilienM> #action catchup with Cody about https://bugs.launchpad.net/puppet-vswitch/+bug/1524559 and see any progress
15:24:34 <EmilienM> degorenko: have you seen it in Fuel too ^ ?
15:24:49 <xarses> we don't use vswitch
15:24:54 <degorenko> yeah
15:25:13 <degorenko> we have our fuel specific module for network management
15:25:28 <EmilienM> oh ok no problem
15:25:39 <EmilienM> well, this warning is ugly, we want to fix it.
15:25:45 <EmilienM> we'll catch up in next meeting
15:25:53 <EmilienM> anything else about warning cleanup?
15:26:17 <EmilienM> let's go ahead then
15:26:27 <EmilienM> #topic Blockers to bump our CI to Mitaka
15:26:37 <EmilienM> so I have a status to give
15:27:01 <EmilienM> on ubuntu, we're still waiting for mitaka packaging in trusty-proposed... I've ping ubuntu folks but I guess holidays slow down the work
15:27:10 <EmilienM> on rdo, we have some blockers, all WIP
15:27:22 <degorenko> sahara and aodh?
15:27:27 <EmilienM> we also found a bug in Mitaka: https://review.openstack.org/#/c/260945/
15:27:40 <EmilienM> degorenko: yeah, they need to promote the current-passed-ci repo for Mitaka
15:27:49 <degorenko> really slow process :D
15:27:54 <EmilienM> AFIK sahara & aodh are the only one blockers...
15:28:11 <EmilienM> degorenko: yeah but that's for the best. They built a CI from scratch and it really helps to stabilize
15:28:35 <degorenko> ok, we will wait :)
15:29:02 <EmilienM> also, mitaka dropped EC2 in Nova
15:29:04 <degorenko> if it's needed - we can disable sahara & aodh in master for now
15:29:04 <EmilienM> so we need to land https://review.openstack.org/#/c/261091/
15:29:18 <EmilienM> #action people to review puppet-nova/drop-ec2 https://review.openstack.org/#/c/261091/
15:29:30 <EmilienM> degorenko: that would be a regression and we don't want it I guess
15:29:41 <EmilienM> we're not in a hurry I think to have mitaka
15:29:43 <degorenko> i case of emergency :)
15:29:49 <EmilienM> I'm sure we'll bump our CI during January
15:29:56 <degorenko> ok, that's good
15:30:19 <EmilienM> #topic Puppet-OpenStack Sprint
15:30:35 <EmilienM> #link https://etherpad.openstack.org/p/puppet-happy-new-year-2016
15:30:52 <EmilienM> so if we look at schedule constraints, 25-26-27 of January seems the best for everyone
15:31:07 <EmilienM> but since few people is present today, we need to postpone this decision
15:31:36 <EmilienM> #action postpone sprint schedule to next meeting and define a meeting date by then
15:31:50 <EmilienM> last topic
15:32:00 <EmilienM> #topic keystone::endpoint::version set to empty has no effect
15:32:02 <EmilienM> chem: o/
15:32:06 <EmilienM> #link https://bugs.launchpad.net/puppet-keystone/+bug/1529374
15:32:08 <openstack> Launchpad bug 1529374 in puppet-keystone "keystone::endpoint::version set to empty has no effect" [High,New] - Assigned to Sofer Athlan-Guyot (sofer-athlan-guyot)
15:32:22 <chem> EmilienM: no able to reproduce it yet
15:32:23 <EmilienM> chem: did you reproduce it?
15:32:24 <EmilienM> arghhhh
15:32:34 <EmilienM> our CI did, 2 times at least
15:32:38 <chem> EmilienM: it seems to work as described
15:32:42 * EmilienM looks for links again
15:33:00 <EmilienM> https://review.openstack.org/262008
15:33:21 <EmilienM> this patch is a proof something is wrong ^
15:34:29 <chem> EmilienM: yes but I don't think that the version parameter is the culprint but rather a check somewhere that the valid path is 'v3/v3X/v2. ...''
15:34:32 <chem> not the module
15:35:04 <chem> EmilienM: but I'm stuck with strange problem on scenario003
15:35:15 <chem> EmilienM: I'll keep looking
15:35:36 <EmilienM> chem: I went on #openstack-keystone and talked with notmorgan
15:35:44 <EmilienM> he told me he has an idea
15:35:51 <EmilienM> we need to catch-up with him
15:36:11 <chem> EmilienM: ack
15:36:18 <EmilienM> #action catch-up with notmorgan about bug 1529374
15:36:20 <openstack> bug 1529374 in puppet-keystone "keystone::endpoint::version set to empty has no effect" [High,New] https://launchpad.net/bugs/1529374 - Assigned to Sofer Athlan-Guyot (sofer-athlan-guyot)
15:36:35 <EmilienM> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
15:36:57 <EmilienM> so there are a bunch of patches in the etherpad
15:37:09 <EmilienM> people who wants some patches to review can have a look at the etherpad
15:37:20 <EmilienM> do we have any questions / outstading bug/patch we need to discuss?
15:37:47 <degorenko> but gerrit doesn't want
15:37:51 <EmilienM> (gerrit is down for me too)
15:38:13 <chem> gerrit is not working well today, for sure
15:38:20 <EmilienM> I'll do some reviews tonight & tomorrow in the plane :)
15:38:26 <degorenko> if anyone from core team is around: https://review.openstack.org/260468 please +A this :)
15:40:04 <EmilienM> anything else for today?
15:40:09 <EmilienM> I'll close the meeting in 30s otherwise
15:40:53 <mwhahaha> unless your 3g drops :D
15:41:00 <degorenko> :D lol
15:41:02 <EmilienM> lol
15:41:08 <EmilienM> enjoy new year
15:41:11 <EmilienM> drink a lot and have fun
15:41:16 <xarses> thanks
15:41:19 <xarses> you too
15:41:20 <IvanBerezovskiy> thanks
15:41:20 <EmilienM> see you next time
15:41:23 <EmilienM> #endmeeting