15:00:27 <EmilienM> #startmeeting puppet-openstack
15:00:28 <openstack> Meeting started Tue Jan  5 15:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:36 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160105
15:00:46 <EmilienM> hello folks, and happy new year!
15:00:50 <mwhahaha> hi
15:01:01 <richm> hello
15:02:06 <EmilienM> #topic Review past action items
15:02:08 <ntpttr> hello
15:02:28 <EmilienM> people to review the patch about warnings in puppet-swift  https://review.openstack.org/#/c/261327/ : done
15:02:39 <EmilienM> continue the investigation on https://review.openstack.org/#/c/255529/ : mwhahaha ?
15:02:47 <mwhahaha> i put comments on the review
15:02:55 <EmilienM> ok cool
15:03:03 <mwhahaha> unfortunately i don't think it can be solved without some sort of rewrite
15:03:16 <EmilienM> mwhahaha: let's rewrite it!
15:03:25 <EmilienM> I don't see a trouble in that
15:03:26 <mwhahaha> unless there's a puppet way to surpress the warnings because it's loading the class prior to evaulating the other stuff
15:04:02 <mwhahaha> but basically we're defining the same config in two ways so it give a warning unless you specify the common class yourself
15:04:22 <mwhahaha> (that's all i've got on that)
15:04:36 <EmilienM> mwhahaha: I guess a rewrite would make sense
15:04:57 <ntpttr> yes that's all I could think of at this point as well
15:04:59 <EmilienM> #link https://bugs.launchpad.net/puppet-nova/+bug/1506066
15:05:01 <openstack> Launchpad bug 1506066 in puppet-nova "Scope-related warnings from nova::vncproxy::common" [Medium,In progress] - Assigned to Nate Potter (ntpttr)
15:05:21 <ntpttr> thanks for the feedback on that one mwhahaha
15:05:36 <EmilienM> mwhahaha: how would you see a rewrite?
15:06:03 <EmilienM> maybe we can discuss that in the launchpad or in gerrit review
15:06:09 <mwhahaha> yea i'm not sure at the moment
15:06:20 <EmilienM> ok
15:06:42 <EmilienM> #action consider a rewrite design for https://bugs.launchpad.net/puppet-nova/+bug/1506066
15:06:44 <openstack> Launchpad bug 1506066 in puppet-nova "Scope-related warnings from nova::vncproxy::common" [Medium,In progress] - Assigned to Nate Potter (ntpttr)
15:07:02 <EmilienM> EmilienM update https://review.openstack.org/#/c/261120/ like it's done for other modules -> DONE + ironic done too
15:07:13 <EmilienM> people to review the warning/puppet-sahara patch: https://review.openstack.org/261481 : DONE
15:07:35 <EmilienM> catchup with cody on https://bugs.launchpad.net/puppet-vswitch/+bug/1524559 -> not done (and he's offline now)
15:07:35 <openstack> Launchpad bug 1524559 in puppet-vswitch "warnings in ovs_redhat.rb code" [High,Confirmed]
15:07:50 <EmilienM> #action catchup with Cody about https://bugs.launchpad.net/puppet-vswitch/+bug/1524559
15:08:13 <EmilienM> postpone sprint schedule to next meeting and define a meeting date by then -> done (we have a topic about that today)
15:08:21 <EmilienM> and catch-up with notmorgan about bug 1529374 (need to be postponed)
15:08:22 <openstack> bug 1529374 in puppet-keystone "keystone::endpoint::version set to empty has no effect" [High,Confirmed] https://launchpad.net/bugs/1529374 - Assigned to Sofer Athlan-Guyot (sofer-athlan-guyot)
15:08:30 <EmilienM> #topic sprint
15:08:59 <EmilienM> it seems that 25-26-27 of January would work for everyone
15:09:30 <EmilienM> crinkle, mfisch, chem ^ is it ok for you?
15:09:41 <EmilienM> nibalizer and denis are not online
15:09:54 <chem> EmilienM: sorry I missed it
15:10:10 <EmilienM> chem: 25-26-27 of January for the puppet sprint
15:10:15 <chem> EmilienM: yep
15:10:16 <EmilienM> is it ok for everyone?
15:10:23 <EmilienM> (everyone who participate)
15:10:33 <EmilienM> #link sprint etherpad https://etherpad.openstack.org/p/puppet-happy-new-year-2016
15:10:36 <ntpttr> yes
15:10:52 <EmilienM> ntpttr: I don't see your name
15:11:14 <ntpttr> headed to the etherpad now :)
15:11:33 <ntpttr> have to recheck dates of cinder midcycle quick
15:12:18 <EmilienM> we'll have to wait for crinkle, nibalizer and mfisch confirmations too
15:12:35 <EmilienM> but I guess that's fine regarding constraints
15:12:45 <EmilienM> it's very hard to satisfy everyone :)
15:13:09 <EmilienM> we don't have much items today, so I suggest we do a bug/review triage
15:14:01 <EmilienM> ntpttr, chem, mwhahaha, richm: do you have patches / bugs that need attention?
15:14:15 <mwhahaha> nope
15:14:15 <EmilienM> oh _ody is here :-)
15:14:26 <EmilienM> _ody: I wanted to catchup about https://bugs.launchpad.net/puppet-vswitch/+bug/1524559
15:14:28 <openstack> Launchpad bug 1524559 in puppet-vswitch "warnings in ovs_redhat.rb code" [High,Confirmed]
15:14:32 <_ody> just stumbled in for the tail.
15:14:34 <EmilienM> do you have something in progress for that bug?
15:14:36 <chem> EmilienM: my same old https://review.openstack.org/202689
15:14:39 <EmilienM> _ody: good morning sir :)
15:14:48 <ntpttr> EmilienM: still some commits for puppet-magnum https://review.openstack.org/#/c/253216/ https://review.openstack.org/#/c/254392/
15:15:33 <ntpttr> and for some reason the tripleo jobs having trouble in the multiple store implementation in glance https://review.openstack.org/#/c/242718/
15:15:51 <_ody> EmilienM: I didn't.  You simply asked me about the error one day.  I feel like I know what is going on though so you can assign it to me.
15:16:03 <EmilienM> _ody: thanks
15:16:04 <ntpttr> not a lot new since just got back from holiday yesterday
15:16:12 <EmilienM> we're going to get rid of all warnings, I like it!
15:16:46 <EmilienM> _ody: can you assign it to you?
15:17:15 <EmilienM> ntpttr: doing recheck again
15:17:24 <EmilienM> ntpttr: last recheck did not recheck :)
15:17:24 <richm> I don't think so
15:17:42 <EmilienM> I have a question for richm and chem
15:17:44 <ntpttr> EmilienM: Ah that would make sense! thanks
15:17:46 <richm> #topic bug triage/review
15:17:52 <EmilienM> yeah
15:17:55 <EmilienM> #topic bug triage/review
15:17:57 <EmilienM> thanks richm
15:18:05 <EmilienM> richm, chem, what do you think about https://review.openstack.org/#/c/261317/
15:18:22 <_ody> done
15:19:36 <richm> Does it cause problems to have a space in the service name?
15:19:55 <EmilienM> richm: I also wondered but I haven't noticed any issue until now
15:20:46 <EmilienM> I also wanted to read from mdorman mfisch and clayton eventually
15:20:58 <EmilienM> but seems like they're busy
15:21:14 <Vinsh> I think timezone is an issue for some now
15:21:15 <chem> EmilienM: the update path is not clear for me, what was the previous name of this service before (or I will check later)
15:21:24 <clayton> I got here late
15:21:31 <EmilienM> #link etherpad agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160105
15:22:09 <richm> EmilienM: I don't really understand what the problem is - my only concern is that existing deployments may have some implicit or explicit assumptions (e.g. some sort of external monitoring script) that expects service name == openstack project name
15:22:17 <EmilienM> Vinsh: why? it's the same schedule as usual
15:22:44 <clayton> EmilienM: as long as their is some way to override it to the old name I'm fine with "fixing" them.
15:22:44 <EmilienM> clayton: context: https://review.openstack.org/#/c/261317/
15:22:57 <EmilienM> there is a way to override it
15:22:58 <richm> but it looks as though this is something that mmagr has planned to deprecate for a while now
15:22:59 <Vinsh> Not sure, is 8am for MST guys.. could be busy with family before work.
15:23:08 <clayton> nod, I saw the previous discussion about it on the mailing list or some such
15:23:09 <richm> I'm MST
15:23:20 <EmilienM> Vinsh: the time changed for you?
15:23:28 <ntpttr> EmilienM: I just moved back to PST, 7am here now
15:23:29 <Vinsh> Just talking about mfisch ;)
15:23:29 <EmilienM> is it the same time for US folks?
15:23:48 <Vinsh> it moved up an hour with the day light time change right?
15:23:54 <EmilienM> Vinsh: but he usually comes up in our meetings so I'm wondering if US changed time?
15:24:07 <EmilienM> Vinsh: very long time ago
15:24:12 <EmilienM> "last year" ;-)
15:24:18 <richm> US DST -> ST was in November
15:24:22 <EmilienM> no, seriously, schedule did not change since Nov
15:24:39 <EmilienM> richm: yeah we change the default
15:24:46 <Vinsh> Stuff comes up, folks can be busy I suppose. :)
15:24:51 <EmilienM> but I wanted to hear from actual operators and see if that's acceptable
15:25:08 <EmilienM> but clayton seems ok if they can override it (which is the case already)
15:25:26 <EmilienM> clayton: I'll you review this patch please
15:25:30 <EmilienM> so we can make progress on other modules
15:25:40 <EmilienM> we have 4 other modules to update iirc
15:25:55 <EmilienM> #action operators to review https://review.openstack.org/#/c/261317/
15:26:09 <mfisch> here now
15:26:21 <EmilienM> MFISH !
15:26:48 <EmilienM> mfisch: sprint: we need to define the final schedule
15:27:01 <EmilienM> 25-26-27 of January is ok for you?
15:27:21 <mfisch> 1 sec
15:27:27 <mfisch> yes thats fine
15:27:31 <mfisch> I'm out the 28th, was double checking
15:27:42 <EmilienM> cool
15:27:53 <EmilienM> so we need nib & crinkle confirmations I guess
15:28:28 <mfisch> per usual I wont be here 100% but will do what I can
15:28:47 <EmilienM> mfisch: awesome
15:28:55 <EmilienM> I have a backport: https://review.openstack.org/263745 for puppet-neutron
15:29:03 <EmilienM> this one too: https://review.openstack.org/263503
15:29:18 <EmilienM> I also need review on ironic/wsgi https://review.openstack.org/263450
15:29:52 <EmilienM> I also initiated puppet-rally https://review.openstack.org/262970 and I talked with Andy on IRC and we're going to work together on the follow-up
15:30:03 <iurygregory> nice =D
15:30:08 <EmilienM> need review on ironic/workers https://review.openstack.org/262966
15:30:21 <EmilienM> ironic/warnings: https://review.openstack.org/262799
15:30:32 <EmilienM> glance/warnings: https://review.openstack.org/261120
15:30:50 <EmilienM> chem: I'll see how https://review.openstack.org/261105 works now
15:30:56 <EmilienM> but it's weird it does not pass CI
15:31:00 <EmilienM> and it worked for you
15:31:33 <EmilienM> one of you could merge the refactor of integ manifests ? https://review.openstack.org/261115
15:31:38 <EmilienM> it would help
15:31:48 <EmilienM> another backport for swift: https://review.openstack.org/259885
15:32:03 <EmilienM> a deprecation for ceilometer: https://review.openstack.org/260604
15:32:09 <EmilienM> and I'll stop here :)
15:32:09 <mfisch> that refactor is huge!
15:32:14 <EmilienM> mfisch: yeah
15:32:19 <EmilienM> but very helpful I think
15:32:29 <chem> EmilienM: so the bug is indeed invalid, no ?
15:32:43 <EmilienM> chem: for now, until the CI is red, there is something we need to look at
15:32:50 <EmilienM> chem: tempest was failing last time
15:32:58 <EmilienM> let check now how it works :)
15:34:07 <EmilienM> if you have anythin else for today go ahead
15:34:12 <EmilienM> or I'll close the meeting in 30s
15:34:13 <chem> EmilienM: I can further inverstigate the tempest failure, just to see.  I still have my idea why it fails ... :)
15:34:26 <EmilienM> chem: ahah nice :) thx for your help
15:34:54 <EmilienM> thank you all for your time
15:34:59 <EmilienM> see you online
15:35:05 <EmilienM> #endmeeting