15:00:29 <EmilienM> #startmeeting puppet-openstack
15:00:29 <openstack> Meeting started Tue Feb  9 15:00:29 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:36 <mfisch> morning
15:00:41 <richm> hello
15:00:42 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160209
15:00:45 <mwhahaha> hi
15:00:53 <EmilienM> hey oh!
15:01:02 <clayton> hey
15:01:04 <degorenko> hey o/
15:01:35 <EmilienM> we don't have actions from last meeting
15:01:47 <EmilienM> #topic managing cinder types via ruby provider with auth based on openstack client
15:01:50 <EmilienM> degorenko: what's up?
15:01:56 <degorenko> hey
15:02:04 <degorenko> i have a couple of patches
15:02:10 <degorenko> and i need your attention :)
15:02:23 <degorenko> primary patch is https://review.openstack.org/273513
15:02:41 <degorenko> it's about switching current defines for managing cinder types to providers
15:02:50 <degorenko> and two other - for openstack-integration
15:02:51 <EmilienM> degorenko: could you recheck the ones that fail on scenario001/ubuntu?
15:03:00 <EmilienM> we fixed the ceph pin last night, it caused an issue
15:03:14 <degorenko> EmilienM, ok, i will recheck it
15:03:25 <degorenko> but i don't think, that here is some problem
15:03:27 <EmilienM> very nice work! we're dropping more Exec resources, cool
15:03:31 <EmilienM> degorenko: just to make sure
15:03:36 <degorenko> sure :)
15:03:55 <degorenko> and btw, how long we will have scenario as non-voting?
15:04:27 <EmilienM> well, I wanted to re-enable it tonight or so
15:04:37 <EmilienM> we had some issues yesterday, all fixed but just wanted to wait a little
15:04:47 <degorenko> ok :) just for information
15:05:22 <degorenko> and, i want to get more feedbacks for my patch, from crinkle _ody chem :) anyone is welcome
15:05:24 <EmilienM> degorenko: can we move forward?
15:05:27 <degorenko> sure
15:05:33 <EmilienM> zigo: ping
15:05:40 <EmilienM> #topic beta release
15:05:51 <zigo> o/
15:05:56 <EmilienM> zigo came on IRC and asked if we could follow other openstack projects
15:06:03 <EmilienM> that do release:cycle-with-milestones
15:06:11 <EmilienM> instead of what we're doing right now: release:independent
15:06:26 <EmilienM> release:cycle-with-milestones would make us create tags during dev cycles, something we never did
15:06:47 <zigo> Yeah, so that I can use the beta 1, 2, 3 tags and package that in Debian.
15:06:52 <clayton> would it also mean we'd have to release when everyone else does?
15:07:13 <EmilienM> we always have some lag, because of packaging (specially in UCA)
15:07:25 <clayton> nod, that's why I ask.  would that still be allowed?
15:07:30 <EmilienM> I think the target goal is to use zigo packaging at some point
15:07:36 <zigo> clayton: I don't have this as a hard requirement to be in sync, but let's say "not too long" after...
15:07:49 <zigo> A week or 2 tops.
15:07:51 <EmilienM> we can ask dhellmann
15:08:22 <mwhahaha> rather than switch can we just release tags more often? we never really publish changes to the stable branches either which makes the forge modules useless
15:08:26 <EmilienM> dhellmann: if you around, does release:cycle-with-milestones means we have to strictly follow openstack project releases dates?
15:08:34 <zigo> I can do Debian + Trusty packages + working Tempest CI tests in about a week after each beta.
15:09:24 <EmilienM> mwhahaha: right, I'm thinking about stopping to publish on puppetlabs forge, and let Hunner or _ody (offline) doing it
15:09:29 <zigo> What I care is having tags to package, so I have a reference point which I know works. Currently, I only have 7.0.0 to eat, which is too far in the past.
15:09:42 <clayton> I think l last time we asked almost no one used the forge releases
15:09:47 <EmilienM> mwhahaha: well, it does not take much time, but some help from puppetlabs would be appreciated on this side
15:09:58 <clayton> granted, that might be because they're not updated, but I suspect it's more than that.
15:10:05 <EmilienM> zigo: right, your point is valid
15:10:20 <mwhahaha> i'd assume it's because we don't publish on a frequent basis
15:10:36 <EmilienM> so yeah, we can start producing tags during the dev cycle
15:10:43 <clayton> I assumed it was because most advanced puppet users dont' use forge, but maybe I'm wrong
15:10:45 <EmilienM> and eventually change our release cycle model
15:11:06 <EmilienM> clayton: I think you're right, that's the feedback we have during each summit fwiw
15:11:38 <zigo> Fuel will be a user starting at Newton.
15:12:16 <EmilienM> #action EmilienM investigate release:cycle-with-milestones and if we need to follow other projects schedule
15:12:24 <sbadia> zigo: of debian puppet-modules packages?
15:12:27 <zigo> 1 week to do packages, 1 week for puppet, 1 week for Fuel, that's already 3 weeks delay...
15:12:32 <sbadia> (hey here :-))
15:12:52 <EmilienM> so is it fine if we push a tag on our compliant modules for end of february?
15:13:02 <zigo> sbadia: Yes, and therefore tags of beta releases.
15:13:34 <sbadia> EmilienM, you always do this hard work (release all module) you estimate it take how long (to do the release)?
15:14:00 <sbadia> zigo: ack, cool!
15:14:11 <EmilienM> sbadia: do we need release notes for this tag?
15:14:23 <EmilienM> zigo: does projects provide release note for each tag?
15:14:29 <EmilienM> or just for major releases?
15:14:39 <EmilienM> doing a tag takes me 5 minutes
15:14:40 <zigo> I don't think its needed.
15:14:43 <sbadia> yes, I think (we can maybe automate more, with your initial work on reno)
15:14:46 <EmilienM> doing releass notes take me 3 days
15:15:06 <zigo> Then skip it! :)
15:15:12 <EmilienM> so if we don't need release note for a first mitaka beta tag, let's do it end of Feb
15:15:25 <zigo> I just need git tags, nothing else.
15:15:32 <EmilienM> our CI is in pretty good shape and run Mitaka from trunk on RDO
15:15:45 <zigo> Otherwise, I'm packaging any random commit, which I don't know if it works or not.
15:16:05 <EmilienM> zigo: right, we need to help you on that
15:16:20 <zigo> Even worse, I could be packaging a version of puppet-openstacklib which would break something else (ie: I didin't take them in sync)...
15:16:23 <EmilienM> #action EmilienM sends a proposal to ML about pushing first mitaka beta tag
15:16:24 <zigo> That's what I want to avoid.
15:16:41 <EmilienM> any question about releases? Anything else?
15:17:07 <EmilienM> #topic open discussion (bugs / reviews)
15:17:17 <EmilienM> if you have outstanding reviews or bugs, please go ahead
15:17:38 <mfisch> I was going to give an update on the thing clayton talked about last week which was admin token on localhost
15:18:03 <chem> I have a cookicutter CI that I would like to see working :)
15:18:05 <EmilienM> mfisch: go ahead
15:18:19 <mfisch> so I found out that I didnt need to make any puppet changes at all
15:18:30 <mfisch> I just ended up needing a new keystone filter
15:18:38 <chem> here https://review.openstack.org/#/c/272156/ and there https://review.openstack.org/#/c/272146/
15:18:59 <EmilienM> chem: you have some comment on the second one
15:19:11 <chem> EmilienM: oups, sorry
15:19:36 <EmilienM> mfisch: would love to know details :-)
15:20:24 <mfisch> EmilienM: sure I can post the code
15:20:49 <EmilienM> mfisch: can you patch examples/ in puppet-keystone maybe ? I'll send you cookies
15:20:58 <mfisch> EmilienM: sure
15:21:05 <EmilienM> let me know the flavor
15:21:16 <EmilienM> do we have anything else for today?
15:21:30 <degorenko> we also have one issue in horizon :) i will be after chem in queue :)
15:22:03 <degorenko> chem, are you done with ci for cookiecutter?
15:22:44 <chem> degorenko: yes, but I have to address the comment in the puppet-openstack-cookiecutter script
15:22:58 <chem> degorenko: ci part is ok, but puppet-openstack-cookiecutter may be not
15:23:05 <chem> degorenko:have to check
15:23:24 <degorenko> ok, good to know, can i proceed with my question? :)
15:23:58 <EmilienM> degorenko: shoot
15:23:59 <degorenko> we have this one: https://review.openstack.org/#/c/276961/
15:24:14 <degorenko> EmilienM,  it can be problem for your bump of apache
15:24:29 <degorenko> because 1.7.x apache has concat < 2.0.0
15:24:34 <degorenko> and 1.8.x < 3.0.0
15:24:40 <EmilienM> oh I see
15:24:47 <degorenko> https://github.com/puppetlabs/puppetlabs-apache/blob/1.8.x/metadata.json#L11-L12
15:25:13 <degorenko> i've left some comments on horizon change
15:25:39 <EmilienM> degorenko: I'm trying to have 1.8.x in our Puppetfile for apache module, you saw?
15:25:44 <degorenko> yeah
15:25:45 <degorenko> i saw
15:25:56 <degorenko> and that's why i raise this
15:26:12 <degorenko> man from patch says that he has master of apache
15:26:21 <degorenko> and file resource for horizon conf is not found
15:26:54 <degorenko> but from current implementation of concat (for 1.x version) - we have defined this file resource in concat manifests
15:27:04 <degorenko> from 2.x version of concat - it is from types
15:27:08 <degorenko> and it is not found
15:27:21 <degorenko> i don't know why actually
15:27:49 <EmilienM> me neither
15:27:54 <EmilienM> I'll investigate with you, later
15:28:01 <degorenko> ok :)
15:28:06 <EmilienM> #action investigate concat issue on https://review.openstack.org/#/c/276961/
15:28:12 <EmilienM> anything else for today?
15:29:19 <EmilienM> ok I guess we're done
15:29:21 <EmilienM> have a good dayy
15:29:24 <EmilienM> #endmeeting