15:00:03 <EmilienM> #startmeeting puppet-openstack
15:00:04 <openstack> Meeting started Tue Feb 23 15:00:03 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:13 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160223
15:00:15 <EmilienM> o/
15:00:29 <mwhahaha> hi
15:00:36 <clayton> o/
15:00:49 <mfisch> good morning
15:00:54 <EmilienM> #topic Review past action items
15:00:57 <bkero> o/
15:01:03 <EmilienM> EmilienM to push a mitaka beta tag: need to be postponed due to CI issues
15:01:22 <EmilienM> #action EmilienM to push a mitaka beta tag once our CI is stable
15:01:29 <EmilienM> mfisch and chem to initiate a blueprint about admin_token_auth deprecation
15:01:34 <EmilienM> mfisch, chhavi: postponed?
15:01:37 <mfisch> yeah
15:01:42 <mfisch> no action, probably none this week
15:01:44 <_ody> o/
15:01:51 <EmilienM> ok
15:01:56 <_ody> lurking for a bit.  Need to get kid ready for school.
15:02:08 <EmilienM> #action mfisch & chem postpone blueprint about admin_token_auth deprecation
15:02:30 <EmilienM> #topic mailing list
15:02:32 <EmilienM> mfisch: o/
15:02:44 <mfisch> yo
15:02:56 <mfisch> ok im up
15:03:08 <richm> hello
15:03:13 <mfisch> first is mailing list... its possible to subscribe to openstack-dev and just to the [puppet] tag
15:03:22 <mfisch> and I'd like everyone to do so, especially if you are core
15:03:29 <EmilienM> or if you want to become
15:03:44 <mfisch> when you subscribe you can choose the topics you want
15:03:50 <EmilienM> but yeah, it's a basic thing to subscribe & read e-mails if you want to get involved
15:04:07 <clayton> did the old mailing list get removed entirely?  If not might be worth posting that there also
15:04:26 <EmilienM> clayton: nobody is using it for long time, I guess we can close it
15:04:34 <mfisch> yes lets close iut
15:04:38 <EmilienM> I'm not admin though, we might need to ask Hunner or _ody
15:04:44 <mfisch> action?
15:04:50 <clayton> should probably post an update about how to subscribe to openstack-dev tags there before closing it though
15:04:58 <EmilienM> #action _ody / Hunner to close puppetlabs-openstack mailing list
15:04:58 <clayton> so people wondering why it's so quiet know what they should do
15:05:06 <mfisch> its been almost a year since we used it
15:05:10 * _ody will make it happen
15:05:29 <EmilienM> right, _ody can send a last email about that on this ML
15:05:31 <mfisch> #action _ody to close old ML and tell people to subscribe to the new one
15:05:59 <EmilienM> mfisch: thx for pointing that out
15:06:17 <EmilienM> the excuse "oh e-mails... so much traffic" does not work anymore ;-)
15:06:41 <EmilienM> #topic keystone::python deprecation
15:06:43 <EmilienM> mfisch: again !
15:06:47 <mfisch> yay me
15:06:47 <mfisch> ok
15:06:50 <EmilienM> we have some reviews
15:06:52 <clayton> I think it's important to give people good instructions on how to subscribe to the tag vs just tell people to do it
15:06:59 <clayton> it's not obvious
15:07:16 <bkero> thank you
15:07:19 <EmilienM> clayton: right, does OpenStack provide an official guide?
15:07:33 <EmilienM> there is https://wiki.openstack.org/wiki/Mailing_Lists
15:07:37 <clayton> not sure, when I looked a year ago I couldn't find one, but that doesn't mean it didn't exist
15:07:47 <clayton> I found an explanation from fungi I think that said how to do it
15:07:55 <mfisch> crinkle explained it to me once
15:08:03 <mfisch> but once I found it it, its easy
15:08:24 <xingchao> I think https://wiki.openstack.org/wiki/Puppet/Mailing_lists is clear
15:08:25 <EmilienM> #undo
15:08:27 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0xa11e7d0>
15:08:47 <EmilienM> specially https://wiki.openstack.org/wiki/Mailing_Lists#Future_Development
15:09:01 <mfisch> that explains it
15:09:06 <EmilienM> it's well explained here, I don't where is trouble.
15:09:13 <EmilienM> bkero: did you read it?
15:09:20 <bkero> I did
15:09:23 <EmilienM> cool
15:09:30 <EmilienM> do we have more questions about ML?
15:09:36 <mfisch> thanks for finding that link
15:10:04 <EmilienM> cool
15:10:10 <EmilienM> so keystone::python deprecation
15:10:14 <mfisch> ok
15:10:37 <mfisch> so I found an ancient class called keystone::python and all it does is install keystoneclient
15:10:42 <mfisch> just like keystone::client
15:10:44 <EmilienM> we have 4 commits: https://review.openstack.org/#/c/282065 - https://review.openstack.org/283376 - https://review.openstack.org/283377 and https://review.openstack.org/283378
15:10:56 <mfisch> for some reason things like glance and neutron are pulling it in
15:11:00 <mfisch> references from like 2013
15:11:10 <EmilienM> it's part of legacy code iirc
15:11:13 <mfisch> so I'd like to make this class do nothing except warn and remove all the warnings
15:11:18 <mfisch> then remove it completely in N
15:11:31 <mfisch> I dont see any reason why glance::api needs to install the keystoneclient
15:11:34 <mfisch> (for example)
15:11:38 <clayton> agreed
15:11:54 <EmilienM> right
15:12:05 <EmilienM> it's up to packaging dependencies to solve this problem, I think
15:12:09 <mfisch> so we can discuss more in the reviews
15:12:28 <mfisch> thats it for that topic
15:12:33 <EmilienM> they are all lgtm, except the puppet-keystone
15:12:38 <mfisch> you +2d it?
15:12:44 <EmilienM> no, I -1'ed
15:12:45 <mfisch> ah denis did
15:12:53 <mfisch> yep I see I will fix
15:12:56 <mfisch> you're right
15:13:11 <EmilienM> we have a last topic in the agenda
15:13:15 <mfisch> me agin!
15:13:18 <EmilienM> #topic r10k path and testing
15:13:21 <EmilienM> mfisch: hello !
15:13:28 <EmilienM> he's hot
15:13:41 <mfisch> I brought this up on the ML but it's been frustrating that I can't run unit tests easily since r10k is not installed properly
15:14:00 <mfisch> I'd been just pushing rveiews and letting jenkins find issues which is a waste of time
15:14:00 <EmilienM> that's something we need to adress, indeed
15:14:20 <mfisch> I dont honestly know much about how those deps are installed
15:14:25 <mfisch> isnt r10k listed as a requirement?
15:14:26 <EmilienM> it's weird you're the only one to complain until now
15:14:30 <clayton> well, it's not in your path, it is installed properly
15:14:36 <clayton> I've had the same issue.
15:14:46 <mfisch> its not that it its not in my path
15:14:47 <clayton> it happens if you set GEM_HOME before running bundler
15:14:52 <mfisch> its not in the path the code wants it to be in
15:15:01 <mfisch> usually /foo/1.9.1/bin
15:15:18 <EmilienM> I run a script to execute testing: https://gist.github.com/EmilienM/61d590a89c44364d0436
15:15:20 <clayton> I don't think it happens if you use gemsets or some such
15:15:21 <mfisch> all I run is bundle install && bundle exec rake spec
15:15:43 <clayton> EmilienM: do you have r10k installed on the test system?
15:15:52 <mfisch> bottom line it should be easy and work out of the box, I dont know enough about gems to discuss more intelligently than that
15:16:08 <EmilienM> clayton: no, it installs it everytime in my temp dir
15:16:19 <EmilienM> mfisch: you're right, it should work out of the box
15:16:28 <clayton> I'm not sure how it's finding the r10k binary then, since I think all the tooling assumes its in your path
15:16:42 <bkero> Is there a more sane way?
15:16:45 <mfisch> the tooling wants it to be somewhere pretty specific
15:16:56 <mfisch> it's not just running "r10k" its specifying a full path from what I saw
15:17:44 <clayton> maybe I'm misremembering then.  I did have the same issue a while back
15:17:57 <clayton> I thought I added it to my path temporarily as a work around
15:18:18 <mfisch> clayton: I ended up symlinking the installed copy from /usr/local/bin into where it was looking
15:18:22 <mfisch> should we just file a bug for this and move on?
15:18:31 <mwhahaha> can we create a bug with all of the details like steps to reproduce? some of the problem is that it doesn't happen to everyone
15:18:32 <EmilienM> yes, please file a bug
15:18:43 <mwhahaha> seems like an environment thing
15:18:48 <mfisch> which project?
15:19:23 <EmilienM> the one you like
15:19:26 <EmilienM> it affects all modules
15:19:35 <EmilienM> let's start with keystone module
15:19:38 <mfisch> ok
15:19:52 <EmilienM> thanks
15:20:06 <mfisch> #action mfisch to file bug on r10k issue during spec tests
15:20:06 <EmilienM> #action mfisch to create a bug about r10k path & testing
15:20:09 <EmilienM> #undo
15:20:09 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x8a152d0>
15:20:14 <EmilienM> anything else?
15:20:23 <mfisch> no, thanks
15:20:27 <EmilienM> #topic open discussion
15:21:28 <EmilienM> if you have outstanding bugs / patches, go ahead
15:21:34 <EmilienM> mwhahaha: where are we with puppet-glance CI?
15:21:58 <mwhahaha> not sure i haven't had a chance to dig into https://bugs.launchpad.net/puppet-glance/+bug/1548515 much
15:21:58 <openstack> Launchpad bug 1548515 in puppet-glance "glance acceptance failing after removal of keystone auth token" [Critical,Confirmed]
15:22:33 <mwhahaha> i'm going to try and take a look later today if i get time but for now glance is broke
15:23:09 <EmilienM> mwhahaha: I'll look too
15:23:39 <EmilienM> I just got some inputs from jamespage on #openstack-dev about updates in Ubuntu that will likely break puppet-neutron
15:23:51 <EmilienM> specially in config file management & also packaging renames...
15:24:20 <EmilienM> anything else for today?
15:24:39 <EmilienM> short & effective. Have a nice week all
15:24:45 <bkero> Thanks guys
15:24:46 <EmilienM> #endmeeting