15:00:16 <EmilienM> #startmeeting puppet-openstack
15:00:17 <openstack> Meeting started Tue Mar 29 15:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:25 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160329
15:00:27 <EmilienM> o/
15:00:28 <iurygregory> o/
15:00:31 <mfisch> heyo
15:00:33 <degorenko> hey :)
15:00:41 * beagles lurks
15:00:56 <bkero> o/
15:01:00 <mwhahaha> hi2u
15:01:04 <EmilienM> #topic Review past actions items
15:01:12 <_ody> o/
15:01:16 <xarses> o/
15:01:41 <EmilienM> initiate email on operators mailing list about Austin summit -> it's done, I sent an email to operators ML and also proposed a session about deployment tools at OPS sessions.
15:01:50 <EmilienM> EmilienM & chem work on normalize_ip_for_uri function
15:01:58 <EmilienM> I think we can postpone it, we did not work on it
15:02:10 <EmilienM> #action EmilienM & chem work on normalize_ip_for_uri function (postponed)
15:02:17 <EmilienM> degorenko / chem to follow-up domain-specific testing with multi backends
15:02:29 <EmilienM> chem: is it the thing you were doing today?
15:03:05 <EmilienM> EmilienM to send email about release notes (postponed action from last week) -> done
15:03:15 <degorenko> EmilienM, i think yes, here is chem patch https://review.openstack.org/#/c/296370/
15:03:16 <chem> EmilienM: yep it is
15:03:17 <EmilienM> EmilienM to create Wiki page for Puppet backports -> done: https://wiki.openstack.org/wiki/Puppet/Backport_policy
15:03:21 <EmilienM> great
15:03:39 <EmilienM> #topic announcements
15:03:46 <chem> EmilienM: I'm about to push the first version without prefetch for keystone_user now that I have some to test
15:03:53 <saneax> o/
15:03:55 <EmilienM> #info stable/mitaka branches are created
15:03:57 <EmilienM> chem: excellent
15:04:06 <EmilienM> #info 8.0.0 is out !
15:04:16 <EmilienM> #info developpment is open to newton now
15:04:19 <degorenko> chem, i saw a few patches from mjblack (probably) about domains and prefetching
15:04:40 <EmilienM> once RDO is ready, we'll start using the rights repos to download OpenStack Newton
15:05:00 <degorenko> oh, it is already abandoned https://review.openstack.org/289995 ok
15:05:01 <EmilienM> #info governance: applying for release:cycle-with-intermediary tag https://review.openstack.org/297382
15:05:21 <EmilienM> flaper87: feel free to review it again, I addressed your comment ^
15:05:40 <EmilienM> do we have any other announcement for this week?
15:06:20 <EmilienM> ok, let's move forward
15:06:22 <chem> ^^ degorenko: yep, I have asked him to abandonned one of them and the other is legit (I was fixed in my test https://review.openstack.org/#/c/296370/ but I rebase on top of his https://review.openstack.org/#/c/298672/)
15:06:24 <xarses> I'd like to announce that EmilienM and the Puppet-openstack team is awesome
15:06:39 * EmilienM hides
15:06:48 <EmilienM> xarses: we do our best :)
15:06:55 <EmilienM> #topic kilo backports
15:06:57 <bkero> Such fame
15:07:04 <EmilienM> who proposed this topic?
15:07:15 <saneax> xarses, +1
15:07:38 <xarses> mfisch: ?
15:07:41 <mwhahaha> the color seems to indicate mfisch?
15:07:44 <degorenko> chem, ack, thanks for info
15:07:50 <mfisch> yo
15:07:50 <xarses> We still see third-party tools such as contrail that only support Kilo, I'd like for the ability to propose backports to remain an option
15:07:52 <mfisch> me
15:08:09 <EmilienM> what is the big deal with kilo?
15:08:19 <mfisch> should we still be supporting backports?
15:08:32 <mfisch> there's been a few idling because they might break stuff, concerns about stuff moving etc
15:08:42 <mfisch> config options moving
15:08:54 <mfisch> It doesnt really hurt me to leave it open but I'd like to know our policy
15:08:55 <EmilienM> we should "maintain" it until the release is not supported anymore
15:09:09 <EmilienM> backporting features is a no-go
15:09:11 <mwhahaha> i think we should have the option, but be more restrictive as to what we would back port
15:09:12 <mfisch> its only in security mode until May 26
15:09:24 <EmilienM> backporting critical bugs, if there are, why not
15:09:25 <mwhahaha> some people still rock Kilo
15:09:35 <xarses> mwhahaha: +1
15:09:37 <mfisch> like some of our services
15:09:52 <EmilienM> I initiated https://wiki.openstack.org/wiki/Puppet/Backport_policy last week
15:09:54 <mfisch> backports are going to get harder and harder as stuff moves
15:10:25 <EmilienM> we also have this: https://wiki.openstack.org/wiki/Puppet/releases that documents what we support (we should update it btw)
15:10:33 <EmilienM> mfisch: right
15:10:36 <xarses> but doesn't that make it then the interest of the person on kilo to back port stuff they are interested in
15:10:40 <richm> hello
15:10:41 <mfisch> so what are we going to do after May 26?
15:10:50 <EmilienM> mfisch: what do other projects?
15:11:07 <mfisch> well I know Horizon took a bug fix 2 weeks ago that technically they didnt have to
15:11:15 <mfisch> so honestly I dont know.
15:11:38 <EmilienM> soon, Puppet OpenStack will apply for http://governance.openstack.org/reference/tags/stable_follows-policy.html
15:12:13 <EmilienM> so we might need to investigate the requirements
15:12:20 <mfisch> yes
15:12:37 <EmilienM> at least we need to support what core projects still support
15:12:54 <mfisch> so as I said right now Kilo is in security fixes only
15:13:05 <EmilienM> do we have security patches?
15:13:14 <EmilienM> not much afik
15:13:20 <mfisch> no
15:13:32 <mfisch> but I understand the desire for backports, does stable policy prevent us from doing backports?
15:13:33 <david-lyle> mfisch: that was mistake on kilo
15:13:35 <bkero> I think if one came up it would be evident though
15:13:37 <david-lyle> for Horizon
15:13:48 <mfisch> david-lyle: well there you go... thanks
15:13:55 <EmilienM> david-lyle: o/
15:14:02 <david-lyle> EmilienM: o/
15:14:15 <EmilienM> mfisch: I think it requires some investigation, before taking any decision
15:14:19 <EmilienM> but it's a very good point
15:14:43 <mfisch> thats why I wanted to bring it up
15:14:44 <mfisch> thanks
15:15:16 <EmilienM> #action EmilienM to investigate stable_follows-policy tag requirements and investigate about Kilo support
15:15:23 <EmilienM> I'll look at it this week
15:15:55 <EmilienM> I think until now we never had a strong policy on that
15:16:15 <EmilienM> but since we try to follow other projects in term of governance, we need to investigate that for sure. Thanks mfisch !
15:16:27 <EmilienM> anything else about backports for now?
15:16:46 <EmilienM> #topic Austin Summit
15:16:51 <EmilienM> #link https://etherpad.openstack.org/p/newton-design-puppet
15:17:19 <EmilienM> so the summit is starting soon, and we don't have much topics yet
15:17:34 <EmilienM> we have 5 slots and also a community session
15:17:52 <degorenko> i will add some topics :)
15:17:54 <EmilienM> if you are a developper or an operator, feel free to add topics
15:18:22 <EmilienM> it can be new ideas, new features, discussions, etc... anyway: feel free to propose topics
15:18:24 <bkero> Should one topic be about policies for support for previous versions and backports?
15:18:36 <bkero> Or should that just be a listed policy and we can spend our time doing other things?
15:18:39 <EmilienM> bkero: it can be
15:18:42 <mwhahaha> i need to come up with some topics for fuel/puppet-openstack so if anyone has anything they'd like to talk about let me know as well
15:19:30 <iberezovskiy> I think we need to discuss switch to puppet-oslo in each module and not only for messaging
15:19:38 <EmilienM> right
15:19:49 <EmilienM> this is the kind of topic where it's "just do it" thing
15:19:54 <iberezovskiy> yep
15:19:55 <EmilienM> we agreed puppet-oslo would help
15:20:01 <degorenko> +
15:20:06 <EmilienM> now, we need to write the code :-) you already did awesome job on that, thanks
15:20:06 <degorenko> i've added this topic to agenda
15:20:38 <EmilienM> there are 2 things I would like to initiate: docker and multi node deployments
15:20:59 <chem> \o/
15:21:02 <EmilienM> I would like to initiate a project under Puppet OpenStack tent, to deploy modules in containers
15:21:10 <bkero> Cool!
15:21:15 <degorenko> wow :)
15:21:15 <iberezovskiy> what configuration do you wanna suggest for multi node?
15:21:20 <EmilienM> twc is already doing it and I plan to talk about moving their stuff
15:21:32 <EmilienM> iberezovskiy: I'm more interested in the orchestration
15:21:52 <EmilienM> iberezovskiy: today, fuel is using mcollective (iiuc) and tripleo is using heat
15:22:03 <EmilienM> some folks use ansible, etc
15:22:05 <mfisch> we use heat for our multinode test
15:22:08 <xarses> there is also solar
15:22:19 <EmilienM> maybe our community has a great experience so we could share our knowledges
15:23:05 <xarses> EmilienM: Fuel uses nailgun, astute, and mcollective together to orchestrate
15:23:14 <EmilienM> ok, interesting
15:23:17 <mfisch> ansible+heat for us
15:23:25 <bkero> That seems like a big stack. Is mcollective maintained anymore?
15:23:37 <EmilienM> anyway. Let's talk about it during the Summit, and maybe find common ideas
15:23:50 <xarses> but we might switch some of that to solar
15:24:22 <EmilienM> do we have questions / feedback for the Summit?
15:24:26 <mfisch> mcollective ugh
15:24:30 <mfisch> will be a good convo
15:24:57 <xarses> "mcollective ugh" is a good convo =)
15:25:02 <mwhahaha> well we basically only use mcollective to run puppet apply and upload a file
15:25:03 * bkero threw this on the sessions section on the summit etherpad
15:25:10 <mwhahaha> it could be switched out for something else
15:25:39 <mfisch> there's a reason we switched, will be glad to show/explain
15:26:02 <EmilienM> feel free to use etherpad to prepare the agenda
15:26:19 <EmilienM> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
15:27:22 <degorenko> one request from my side :) https://review.openstack.org/298586 simple cherry-pick
15:27:24 <EmilienM> if you have any question / bug / review, please drop it here
15:28:09 <EmilienM> a release not would have been great
15:28:15 <EmilienM> but maybe it can be submitted in master
15:28:27 <degorenko> release notes?
15:28:50 <EmilienM> degorenko: yes, it sounds like you add a new feature
15:29:02 <degorenko> not exactly
15:29:06 <degorenko> but i will fix it
15:29:16 <degorenko> i will add release notes in separate patches then
15:29:21 <degorenko> for master and stable, sure
15:29:32 <degorenko> i forgot about notes
15:29:40 <degorenko> it's first time of using that :) sorry :)
15:29:42 <EmilienM> cool
15:29:44 <EmilienM> no worries!
15:30:05 <mwhahaha> i'm going to be looking at extending the glance_image provider to support extra params for properies
15:30:16 <degorenko> +1 for this
15:30:23 <mwhahaha> trying to rewrite some awful ruby we've got to leverage the glance_image provider
15:30:26 <degorenko> we don't have ability to set properties now
15:31:13 <EmilienM> _ody: do you have a status on puppet4?
15:32:22 <EmilienM> looking at https://review.openstack.org/#/c/296557/ we have a good progress here
15:32:45 <EmilienM> I'll let the meeting open 30 seconds, feel free to ask anything otherwise i'll close it
15:33:34 <EmilienM> thanks guys, keep rocking OpenStack !
15:33:38 <EmilienM> #endmeeting