15:00:18 <degorenko> #startmeeting puppet-openstack
15:00:19 <openstack> Meeting started Tue Apr  5 15:00:18 2016 UTC and is due to finish in 60 minutes.  The chair is degorenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:23 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:27 <degorenko> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160405
15:00:31 <degorenko> hey o/
15:00:33 <mwhahaha> hi2u
15:00:34 <iberezovskiy> hi
15:00:37 <skolekonov> hi
15:00:39 * twm2016 is lurking
15:00:49 <degorenko> #topic Review past actions items
15:00:56 <degorenko> EmilienM & chem work on normalize_ip_for_uri function
15:01:07 <degorenko> as i know - there is no progress
15:01:21 <degorenko> chem ping :)
15:01:38 <degorenko> ok, then postpone it
15:01:43 <degorenko> #action EmilienM & chem work on normalize_ip_for_uri function (postponed)
15:01:51 <degorenko> EmilienM to investigate stable_follows-policy tag requirements and investigate about Kilo support
15:01:56 <degorenko> first part to investigate stable_follows-policy tag requirements - in progress
15:02:01 <degorenko> patch is on review https://review.openstack.org/#/c/297382/
15:02:08 <degorenko> and waiting for Newton cycle
15:02:21 <degorenko> second part - AFAIK is not started so should be postponed
15:02:26 <degorenko> #action EmilienM need investigation about kilo support in our modules (postponed)
15:02:40 <degorenko> #topic Fuel/Puppet-openstack integration summit topics
15:02:44 <degorenko> #link https://etherpad.openstack.org/p/fuel-puppet-openstack-summit-topics
15:02:48 <degorenko> mwhahaha, hey o/
15:02:59 <holser_> hey o/
15:03:00 <mwhahaha> Hey everyone, so we've got a summit slot scheduled for fuel/puppet-openstack integration topics.
15:03:00 <mwhahaha> I've put together a starting list of ideas for things that includes expanding Fuel CI and possibly sharing some of the modules that currently live in fuel-library.
15:03:00 <mwhahaha> Please review feel free to add some additional topics of feedback.
15:03:24 <richm> hello
15:03:24 <mwhahaha> also i think we have some open slots for puppet-openstack that if anyone wants to talk about stuff we can use as well
15:03:44 <degorenko> that's good idea
15:03:59 <mwhahaha> #link https://etherpad.openstack.org/p/newton-design-puppet
15:04:24 <mwhahaha> that's all i've got
15:04:39 <degorenko> some of modules that can be shared can be placed under existing modules, for example sahara_templates
15:04:46 <degorenko> ok, thank you
15:04:47 <mwhahaha> yea i think that's a prime one to upstream
15:05:16 <degorenko> ok, moving on
15:05:21 <degorenko> #topic moving to puppet-oslo
15:05:28 <degorenko> we are planning to switch some parameters from native modules classes to puppet-oslo
15:05:36 <degorenko> so, should we keep all converting/checks and etc in old place?
15:05:45 <degorenko> or it should be moved to puppet-oslo too?
15:05:50 <degorenko> for example https://review.openstack.org/#/c/298702/
15:06:07 <degorenko> any ideas folks?
15:06:33 <degorenko> as i see now, some modules have different format of these parameters
15:06:34 <mwhahaha> probably should move them
15:06:50 <iberezovskiy> oslo defines should take care of converting, other modules should just pass parameters
15:07:15 <xarses> o/
15:07:29 <degorenko> yeah, that's ok to me, we don't break anything, just pass parameters to puppet-oslo
15:08:05 <degorenko> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
15:08:20 <degorenko> if you have any questions, review requests, raise your hand :)
15:09:22 <mwhahaha> a quiet meeting today
15:09:49 <xarses> yes
15:10:03 <degorenko> ok, i will close meeting in 30 seconds if nothing came up
15:10:42 <degorenko> thanks everyone, have a good day
15:10:45 <degorenko> #endmeeting