15:01:26 <EmilienM> #startmeeting puppet-openstack
15:01:27 <openstack> Meeting started Tue May 10 15:01:26 2016 UTC and is due to finish in 60 minutes. The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:32 <openstack> The meeting name has been set to 'puppet_openstack'
15:01:35 <EmilienM> hello
15:01:40 <degorenko> hey :)
15:01:40 <iurygregory> o/
15:01:45 <bkero> o/
15:01:52 <EmilienM> [] tripleo meeting -> [] puppet meeting
15:01:53 <mwhahaha> hi
15:01:53 <mattymo> hi
15:02:08 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160510
15:02:11 <clayton> o/
15:02:42 <EmilienM> #topic Review past actions items
15:02:58 <EmilienM> EmilienM & chem work on normalize_ip_for_uri function (still postponed)
15:03:09 <EmilienM> #action EmilienM create launchpad for normalize_ip_for_uri function
15:03:24 <EmilienM> chem to investigate how to show puppet manifests for each beaker test
15:03:32 <EmilienM> ah chem is not around
15:03:49 <EmilienM> #topic announcements
15:04:13 <EmilienM> #info centos7 jobs are bumped on Newton (thanks to RDO)
15:04:25 <EmilienM> #info summit summary: https://openstack.nimeyo.com/82967/openstack-dev-puppet-austin-summit-sessions-recap
15:04:51 <EmilienM> anything else for announcements?
15:05:21 <EmilienM> #topic xenial testing status
15:05:33 <EmilienM> #link xenial work https://etherpad.openstack.org/p/puppet-openstack-xenial
15:05:57 <EmilienM> so Vinsh is not online, but he volunteered to help with puppet-swift
15:06:14 <EmilienM> who can help?
15:06:45 <degorenko> i'll take a look
15:07:01 <EmilienM> degorenko: I used https://review.openstack.org/#/c/308530/ to test
15:07:13 <EmilienM> degorenko: you'll need experimental jobs, triggered by "check experimental" comment
15:07:20 <degorenko> yeah, i know :) kk
15:07:21 <EmilienM> feel fee to take over my patches
15:07:24 <iurygregory> this week and next i'm full sorry =(
15:07:31 <clayton> I pinged vinsh
15:08:15 <EmilienM> #action degorenko to start looking at Xenial support
15:08:31 <EmilienM> #action vinsh to work on puppet-swift for xenial support
15:08:37 <EmilienM> it's recorded now :)
15:08:42 <vinsh> :)
15:09:17 <EmilienM> we have ~2 or 3 weeks before Caninocal provides UCA for Newton
15:09:27 <EmilienM> so until then, we might want to make our jobs working on Mitaka
15:09:41 <EmilienM> (which does not require UCA, just pure Xenial repos)
15:10:07 <EmilienM> if any volunteer, please ping degorenko for work sync
15:10:35 <EmilienM> just a reminder: it's critical priority to have xenial jobs, we'll drop testing on Trusty starting from newton cycle
15:10:53 <degorenko> EmilienM: do we know when a new mysql module will be released?
15:11:13 <EmilienM> degorenko: I asked Hunner but not sure it was scheduled
15:11:34 <degorenko> ack
15:11:35 <EmilienM> Hunner: if you need help on that please let us know
15:11:43 <EmilienM> #topic release management status
15:12:09 <EmilienM> so our project moved to cycle-trailing model
15:12:12 <EmilienM> #link http://governance.openstack.org/reference/projects/puppet-openstack.html
15:12:20 <EmilienM> #link http://governance.openstack.org/reference/tags/release_cycle-trailing.html#tag-release-cycle-trailing
15:12:43 <EmilienM> we'll provide a first newton milestone by the end of the month probably
15:12:58 <iurygregory> nice =)
15:13:07 <degorenko> cool, nice work EmilienM! :)
15:13:21 <iberezovskiy> awesome :)
15:13:52 <EmilienM> I'll also propose a 8.0.1 release by this time
15:13:58 <bkero> woot
15:14:08 <iurygregory> ++
15:14:09 <EmilienM> we did some backports, it might be useful
15:14:39 <EmilienM> any question / feedback about releases?
15:15:04 <EmilienM> #topic blueprint status
15:15:23 <EmilienM> we have one spec that is currently not implemented, from clayton
15:15:26 <EmilienM> #link http://specs.openstack.org/openstack/puppet-openstack-specs/specs/mitaka/config-deprecation-for-inifile-provider.html
15:16:02 <EmilienM> clayton: should we postpone it to Newton?
15:16:22 <clayton> I won't have time to work on it, so probably so
15:16:49 <EmilienM> who is interested by contributing on this blueprint?
15:17:06 <EmilienM> #action postpone config-deprecation-for-inifile-provider to newton
15:17:58 <EmilienM> mhh ok I'll defer it to Newton and we'll see.
15:18:12 <EmilienM> but well, if nothing happens afterwards we'll revisit its existence.
15:18:27 <EmilienM> #topic bug triage status
15:18:35 <EmilienM> ah _ody is not here
15:18:44 <EmilienM> #link https://etherpad.openstack.org/p/newton-puppet-bug-triage
15:18:58 <EmilienM> during summit Cody and I did some bug triage, we've not finished yet.
15:19:16 <EmilienM> do we have critical bugs we want to raise now?
15:20:32 <EmilienM> sounds like no
15:20:38 <EmilienM> #topic doc status
15:20:51 <EmilienM> (well if someone wants to help for bug triage feel free to ping me)
15:21:06 <EmilienM> iurygregory, bkero: hey, can we have a status on doc?
15:21:22 <iurygregory> Almost everything done i think
15:21:36 <EmilienM> should we remove old Wiki pages afterwards or keep them?
15:21:39 <bkero> The etherpad from the summit has porting status
15:21:49 <EmilienM> how did infra?
15:21:51 <bkero> reviews should at least be filed for all docs
15:21:53 <EmilienM> nibalizer is not around
15:22:04 <bkero> infra is not shutting down wiki for a while
15:22:16 <EmilienM> bkero: yeah, but I want to make sure we don't edit wiki anymore
15:22:26 <iurygregory> i raised just two new wiki pages that i think we need to migrate to docs.. ( i can take care to migrate)
15:22:32 <bkero> I'd suggest wr modify thr wiki pages to point to the new docs
15:22:38 <bkero> at thr least
15:22:45 <iurygregory> ++ bkero
15:23:00 <EmilienM> we're going to loose google index :P
15:23:10 <EmilienM> oh well, wfm
15:23:12 <bkero> strike through the contentd
15:23:13 <iurygregory> <o>
15:23:19 <bkero> contents, but keep them up
15:23:28 <EmilienM> ok
15:23:35 <EmilienM> thanks a lot for your help on that guys
15:23:42 <EmilienM> I had one question though
15:23:47 <iurygregory> you are welcome =)
15:23:50 <EmilienM> about README in all openstack/puppet-* modules
15:23:58 <EmilienM> what should we do? keep them? reduce them?
15:24:11 <EmilienM> if reduce, then where/what to document?
15:24:43 <bkero> I'd say put them in docs.o.o if we want them out of the modules, but I don't want to make that decision
15:24:50 <mwhahaha> probably should pull them all into the docs
15:24:57 <mwhahaha> it's kinda part of a user/usage guide anyway
15:25:10 <EmilienM> should we have a single README for all modules?
15:25:19 <bkero> There should at least be some document in the module to point to the docs
15:25:29 <chem> readme are bigs because module are challenging
15:25:30 <EmilienM> iurygregory started to copy puppet-keystone/README to doc.o.o but it's going to be a lot of copy paste for... why?
15:25:43 <crinkle> don't take the readmes out of the modules, it's part of the puppetlabs approved modules criteria
15:25:54 <EmilienM> bkero: exactly what I proposed in https://review.openstack.org/312779
15:25:57 <iurygregory> wow ^
15:26:04 <EmilienM> good point crinkle
15:26:07 <bkero> crinkle has a good point
15:26:11 <iurygregory> yeah
15:26:20 <EmilienM> well, end of the story for readmes then
15:26:22 <crinkle> it's also just nice to have since a lot of puppet users will expect it to be there
15:26:22 <EmilienM> :)
15:26:40 <iurygregory> i'll abandon the patch =)
15:26:52 <chem> I'm not sure what is the problem with big readme ?
15:27:04 <EmilienM> ok let's give up that
15:27:08 <iurygregory> ok
15:27:22 <EmilienM> though we should drop the release codenames / versions
15:27:32 <EmilienM> crinkle: +1 on that? ^?
15:27:46 <iurygregory> the wiki?
15:27:46 <crinkle> EmilienM: sure
15:27:48 <EmilienM> ok
15:27:54 <EmilienM> anything else about doc?
15:28:05 <chem> more working quick working examples would certainly help a lot for people to bootstrap their own
15:28:25 <chem> as a side note to this the "tests" directory is deprecated
15:28:34 <chem> by puppet it's now the example directory
15:28:47 <EmilienM> chem: cool, so maybe we need more example/*.pp ?
15:29:17 <chem> I would be willing to make the change from test -> example first and then add more very simple working test to ... all modules :)
15:29:35 <chem> s/test/example/ manifest
15:29:35 <EmilienM> cool
15:30:05 <EmilienM> yeah, contributions are welcome in this area, specially for people doing actual deployments
15:30:14 * EmilienM looks at mfisch and clayton :-)
15:30:33 <mfisch> sorry EmilienM im in the lab racking hw today
15:30:36 <mfisch> looking
15:30:39 <bkero> is this in each module?
15:30:44 <EmilienM> bkero: yeah
15:30:47 <bkero> ok
15:30:57 <EmilienM> mfisch: enjoy :)
15:31:06 <EmilienM> #topic open discussion
15:31:15 <chem> so first moving test -> example, then find the simplest working manifest for everything called "basic"
15:31:18 <mfisch> EmilienM: working examples will be opinionated
15:31:19 <EmilienM> feel free to raise outstanding bugs / reviews
15:31:30 <EmilienM> mfisch: right, but good examples for newcommers
15:31:34 <mfisch> the integration module is the best working example
15:31:43 <EmilienM> mfisch: look how many people come on irc and ask for examples of deployments
15:32:07 <EmilienM> chem: before you /join the channel, I asked the status on "investigate how to show puppet manifests for each beaker test"
15:32:15 <EmilienM> should we postpone/cancel it?
15:32:31 <chem> EmilienM: postpone one more week, I have faith!
15:32:42 <EmilienM> ahah ok
15:32:49 <EmilienM> no pressure, just asking
15:33:31 <EmilienM> I'll let the meeting open 30 more seconds
15:34:29 <EmilienM> have a great day folks! and don't forget to brushing teeth
15:34:31 <EmilienM> #endmeeting