15:01:08 <EmilienM> #startmeeting puppet-openstack
15:01:09 <openstack> Meeting started Tue Jul 26 15:01:08 2016 UTC and is due to finish in 60 minutes. The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:12 <openstack> The meeting name has been set to 'puppet_openstack'
15:01:19 <EmilienM> hello
15:01:22 <iurygregory> o/
15:01:23 <mwhahaha> hi
15:01:34 <degorenko> hi
15:01:48 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160726
15:01:53 <bklei> o/
15:01:56 <EmilienM> degorenko: can you clean-up what we don't need to discuss?
15:02:07 <xarses> o/
15:02:10 <degorenko> EmilienM, so, first point is about new keystone_authtoken params
15:02:22 <degorenko> do we need put all these to init/api classes?
15:02:26 <EmilienM> #topic authtoken
15:02:36 <degorenko> may be we can go with way that already done for logging and db parameters?
15:02:47 <EmilienM> mhh, good question
15:02:54 <iurygregory> i like the idea haha
15:03:13 <degorenko> because some time ago - we want to clean up our init/api classes from some basic and common parameters
15:03:18 <degorenko> and now - we want overload them again
15:03:20 <EmilienM> right
15:03:27 <EmilienM> I'm fine with having another file
15:03:33 <EmilienM> it's just a bit more work :)
15:03:37 <degorenko> yeah, it's backward compatible with pick
15:03:41 <mwhahaha> so like a aodh::keystone::authtoken or something?
15:03:48 <EmilienM> probably
15:03:50 <degorenko> like that yes
15:04:04 <mwhahaha> and just include ::aodh::keystone::authtoken in api/init?
15:04:08 <degorenko> right
15:04:09 <richm> hello
15:04:15 <mwhahaha> seems ok
15:04:17 <iurygregory> +1
15:04:23 <EmilienM> and people not using hiera will be backed by pick function, right?
15:04:31 <degorenko> yeah
15:04:34 <EmilienM> cool
15:04:36 <EmilienM> go ahead !
15:04:53 <EmilienM> do we have blockers otherwise about $topic?
15:04:54 <degorenko> then, i guess we need to get back all merged changes to confirmed
15:05:06 <degorenko> no, i dont think so
15:05:16 <EmilienM> I see mwhahaha and iurygregory making progress
15:05:36 <degorenko> this idea come to me when i tried to make patch for glance :D
15:05:38 <iurygregory> i'll update my patches to work with this
15:05:50 <mwhahaha> i think we merged one, so i'll have to go back and fix it
15:05:55 <iurygregory> ec2api
15:05:59 <degorenko> 2 :)
15:05:59 <iurygregory> is merged
15:06:02 <iurygregory> and watcher
15:06:06 <mwhahaha> lets get a proposed patch with the <whatever>::keystone::authtoken and we can follow it
15:06:12 <EmilienM> ++
15:06:21 <EmilienM> degorenko: you want to do it? :)
15:06:22 <degorenko> yeah, and guys, lets use one common topic :)
15:06:38 <iurygregory> we are using the bug for topic i think
15:06:46 <iurygregory> well i'm using =)
15:06:50 <degorenko> EmilienM, well, i have not time for all modules, but i'll do some of them :)
15:06:50 <EmilienM> iurygregory: right
15:06:55 <EmilienM> degorenko: not all dude
15:07:02 <EmilienM> but one example we all follow after merging it
15:07:07 <iurygregory> degorenko, if you want i can provide the example
15:07:09 <degorenko> EmilienM, ah, sure
15:07:12 <EmilienM> ok
15:07:13 <degorenko> or iurygregory
15:07:15 <degorenko> :)
15:07:23 <EmilienM> #action degorenko to provide an example of <modulename>::keystone::authtoken
15:07:34 <EmilienM> or Iury
15:07:39 <iurygregory> EmilienM, ack
15:07:48 <mwhahaha> also update the bug
15:07:52 <mwhahaha> with a reference
15:08:10 <iurygregory> ok
15:08:37 <EmilienM> anything else about this topic?
15:08:59 <EmilienM> #topic https://etherpad.openstack.org/p/puppet-openstack-mascot-logo
15:09:14 <EmilienM> ok so I sent an email last night about $topic
15:09:20 <EmilienM> please vote the one you like
15:09:24 <EmilienM> deadline: tomorrow
15:09:33 <iurygregory> wow
15:09:45 <EmilienM> yeah, I sent the link 2 weeks ago
15:10:15 <EmilienM> I think that's all for this week
15:10:24 <EmilienM> #topic open discussion
15:11:26 <EmilienM> ok
15:11:29 <EmilienM> have a good week folks
15:11:31 <EmilienM> #endmeeting