15:01:24 <mwhahaha> #startmeeting puppet-openstack
15:01:24 <openstack> Meeting started Tue Jul 11 15:01:24 2017 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:28 <openstack> The meeting name has been set to 'puppet_openstack'
15:01:41 <mwhahaha> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20170711
15:01:41 <EmilienM> o/
15:01:43 <iurygregory> o/
15:01:58 <mwhahaha> hi2u
15:03:14 <mwhahaha> don't think there's anyone else going to join us so lets just go
15:03:21 <iurygregory> yep
15:03:24 <mwhahaha> #topic cycle work review
15:03:43 <mwhahaha> #link https://docs.google.com/spreadsheets/d/1GV4v-T8E7Sq6GDE12pcTk_i0hFaVrDGnIDDVikXrQ34/edit?usp=sharing
15:04:03 <mwhahaha> so i think we're good in terms of openstack global work
15:04:22 <mwhahaha> we have the docs migration done and we've added wsgi support for the services we agreed to
15:04:30 <EmilienM> wouuuuh
15:04:44 <iurygregory> sorry for not helped too much =( (master degree at the end hehe)
15:05:02 <EmilienM> iurygregory: no worries, we know what it is :)
15:05:15 <iurygregory> trying to help at least in reviews =)
15:05:42 <mwhahaha> yea reviews are helpful
15:06:05 <mwhahaha> We're coming up on m3 for pike but i think we're in a decent spot
15:06:06 <xarses> o/
15:06:33 <EmilienM> yeah I don't see any blocker
15:06:38 <EmilienM> we've met community goals
15:06:42 <mwhahaha> any other comments on cycle stuff?
15:06:49 <EmilienM> the next goals will probably be tempest plugins & policies in code
15:06:56 <EmilienM> which would not give us much work
15:07:12 <EmilienM> probably some changes in config & adding some packages in puppet-tempest but nothing terrible
15:07:24 <iurygregory> nice =D
15:07:28 <EmilienM> to me, we're good to release
15:07:30 <mwhahaha> probably be a good time to revisit puppet-tempest
15:07:40 <mwhahaha> since it's a trainwreck of parameters :D
15:07:44 * EmilienM hides
15:07:51 <mwhahaha> or not
15:07:56 <mwhahaha> anyway
15:07:57 <mwhahaha> #topic latest puppet test issues
15:08:07 <mwhahaha> #link https://bugs.launchpad.net/puppet-openstacklib/+bug/1702964
15:08:08 <openstack> Launchpad bug 1702964 in puppet-openstacklib "latest puppet expects catalog to contain resources to for requires and subscribes" [Medium,In progress] - Assigned to zhongshengping (chdzsp)
15:08:28 <mwhahaha> i think we've got most of the module covered but i noticed with puppet5 unit test failures due to catalog validation changes
15:08:28 <EmilienM> should we start to have a puppet5 unit test job voting?
15:08:41 <EmilienM> and keep unit-latest non voting
15:08:48 <mwhahaha> possibly
15:08:52 <EmilienM> I'm afraid we'll break it again if we don't do that
15:09:13 <mwhahaha> most of the issues point to some test coverage gaps or bad require references
15:09:15 <EmilienM> I can investigate
15:09:26 <EmilienM> and create a job
15:09:29 <mwhahaha> so once we get those fixes we'll be good until they decide to break something :D
15:09:56 <EmilienM> let me know if you think we should have one puppet5 job voting (for unit tests to start)
15:10:19 <mwhahaha> yea once we get this bug fixed we can probably add a puppet5 unit job
15:10:33 <iurygregory> +1 to the puppet5 job XD
15:10:52 <EmilienM> #action EmilienM to create a puppet5-unit voting job when LP#1702964 is closed
15:11:08 <EmilienM> we'll probably wait a little bit more for p-o-i job with puppet5
15:11:11 <EmilienM> maybe queens
15:11:14 <mwhahaha> yea
15:11:20 <EmilienM> the whole thing doesn't seem production ready yet
15:11:31 <mwhahaha> #topic Open Discussion, Bug and Review triage
15:11:41 <EmilienM> quick update: we finally got mitaka EOL
15:11:47 <EmilienM> also hammer EOL
15:12:12 <mwhahaha> so i sent a note about removing the fuel jobs, they did merge my change but there still wasn't any feedback if we should leave it
15:12:15 <EmilienM> project-config / p-o-i are updated - we shouldn't have workaround for these branches - let me know if you found something weird, I'll fix it
15:12:31 <mwhahaha> i noticed there's some deprecation removals in puppet-cinder (or maybe nova i think) that's goign to break noop
15:12:55 <EmilienM> mwhahaha: who is our contact at Mirantis for Fuel CI?
15:13:17 * mwhahaha shrugs
15:13:21 <EmilienM> ok
15:13:29 <EmilienM> remove them all then
15:13:30 <mwhahaha> i don't think anyone is watching it
15:13:36 <xarses> do we need to find some one?
15:13:44 <iurygregory> maybe ^
15:13:50 <mwhahaha> it didn't sound like anyone was objecting to the removal
15:13:53 <EmilienM> xarses: I don't think so
15:14:04 <mwhahaha> i'll reply again on the ML to raise attention again
15:14:05 <xarses> no, I don't think any one was objecting to the removal
15:14:15 <iurygregory> mkyta (not sure its correct) still work at Fuel?
15:14:19 <EmilienM> ping people directly maybe
15:14:26 <EmilienM> email / irc
15:14:30 <mwhahaha> yea i'll poke some folks as well
15:14:43 <xarses> I can ping some people if you need, is all I was noting
15:16:05 <EmilienM> do we have anything else for this week?
15:16:10 <mwhahaha> that's all i've got
15:16:17 * EmilienM goes back to work
15:16:28 * iurygregory goes to lunch =P
15:17:16 <mwhahaha> thanks everyone
15:17:18 <mwhahaha> #endmeeting