#openstack-meeting-3: Python-Openstacksdk

Meeting started by jnoller at 19:01:40 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/PythonOpenStackSDK (dhellmann, 19:02:13)

  1. Feedback on the wiki / current state (open discussion) (jnoller, 19:07:15)
    1. IDEA: I'm trying to suggest that we talk about the actions the cloud can take and the objects, rather than any implementation details of those services dhellmann (jnoller, 19:11:04)
    2. http://martinfowler.com/articles/mocksArentStubs.html (Alex_Gaynor, 19:22:49)
    3. ACTION: it's clear we need to flesh out a wiki page about vendor extension requirements / standards and how they would live / register into the namespace of say, openstack.extensions.* (jnoller, 19:35:07)
    4. ACTION: briancurtin wiki page outlining vendor extension plugins/namespacing/loading and abstractions (jnoller, 19:35:49)
    5. ACTION: briancurtin fix wiki namespaces / cleaning things up (jnoller, 19:37:34)

  2. State of blueprints / API strawman (jnoller, 19:38:07)
    1. ACTION: jollier rename launchpad project (jnoller, 19:40:22)
    2. https://github.com/stackforge/python-openstacksdk/tree/master/api_strawman (jnoller, 19:44:58)
    3. https://github.com/stackforge/python-openstacksdk/tree/master/api_strawman (jnoller, 19:45:02)
    4. ACTION: jollier "note make the object on demand, and let the api call fail if the service isn't there" (jnoller, 20:00:41)
    5. https://github.com/stackforge/python-openstacksdk/tree/master/api_strawman (jnoller, 20:04:07)
    6. https://github.com/stackforge/python-openstacksdk (briancurtin, 20:04:08)
    7. ACTION: Alex_Gaynor Flesh out your underlying http transport separation example documented on the wiki / blueprints (jnoller, 20:05:59)


Meeting ended at 20:07:31 UTC (full logs).

Action items

  1. it's clear we need to flesh out a wiki page about vendor extension requirements / standards and how they would live / register into the namespace of say, openstack.extensions.*
  2. briancurtin wiki page outlining vendor extension plugins/namespacing/loading and abstractions
  3. briancurtin fix wiki namespaces / cleaning things up
  4. jollier rename launchpad project
  5. jollier "note make the object on demand, and let the api call fail if the service isn't there"
  6. Alex_Gaynor Flesh out your underlying http transport separation example documented on the wiki / blueprints


Action items, by person

  1. Alex_Gaynor
    1. Alex_Gaynor Flesh out your underlying http transport separation example documented on the wiki / blueprints
  2. briancurtin
    1. briancurtin wiki page outlining vendor extension plugins/namespacing/loading and abstractions
    2. briancurtin fix wiki namespaces / cleaning things up
  3. openstack
    1. it's clear we need to flesh out a wiki page about vendor extension requirements / standards and how they would live / register into the namespace of say, openstack.extensions.*
  4. UNASSIGNED
    1. jollier rename launchpad project
    2. jollier "note make the object on demand, and let the api call fail if the service isn't there"


People present (lines said)

  1. dhellmann (121)
  2. jnoller (94)
  3. edleafe (40)
  4. jamielennox (32)
  5. dolphm (31)
  6. Alex_Gaynor (27)
  7. rgbkrk (17)
  8. bknudson (17)
  9. mfer (15)
  10. briancurtin (13)
  11. dtroyer (7)
  12. glyph (6)
  13. chris_johnson (4)
  14. openstack (3)
  15. wchrisj (1)
  16. redrobot (1)
  17. rdodev (1)
  18. markmcclain (1)
  19. lbragstad (1)
  20. smashwilson (1)


Generated by MeetBot 0.1.4.