#openstack-meeting-3: python-openstacksdk

Meeting started by briancurtin at 19:00:22 UTC (full logs).

Meeting summary

  1. Progress - can we move forward toward a MVP? (briancurtin, 19:04:41)
  2. https://wiki.openstack.org/wiki/PythonOpenStackSDK/ClassDesignDiscussion (briancurtin, 19:08:34)
  3. https://review.openstack.org/#/c/81882/ (Add requests.Session wrapper class) (briancurtin, 19:32:10)
  4. https://review.openstack.org/#/c/81988/ (Add redirection handling to openstack.session.Session) (briancurtin, 19:44:27)
  5. https://review.openstack.org/#/c/82646/ (Add API discovery support) (briancurtin, 19:47:21)
    1. ACTION: edleafe: prepare minimal example of manager-client-resource (briancurtin, 19:49:48)
    2. ACTION: revive Alex_Gaynor client (briancurtin, 19:50:15)
    3. ACTION: possible ORM-style client (briancurtin, 19:50:36)


Meeting ended at 20:00:07 UTC (full logs).

Action items

  1. edleafe: prepare minimal example of manager-client-resource
  2. revive Alex_Gaynor client
  3. possible ORM-style client


Action items, by person

  1. Alex_Gaynor
    1. revive Alex_Gaynor client
  2. edleafe
    1. edleafe: prepare minimal example of manager-client-resource


People present (lines said)

  1. briancurtin (51)
  2. edleafe (27)
  3. dtroyer (20)
  4. bknudson (14)
  5. jamielennox (14)
  6. Alex_Gaynor (11)
  7. terrylhowe (9)
  8. openstack (3)


Generated by MeetBot 0.1.4.