17:01:42 <sdague> #startmeeting qa
17:01:43 <openstack> Meeting started Thu May 23 17:01:42 2013 UTC. The chair is sdague. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:44 <mlavalle> cool
17:01:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:47 <openstack> The meeting name has been set to 'qa'
17:01:56 <sdague> #topic Blueprints
17:02:10 <sdague> ok, lets specifically start with the quantum blueprints
17:02:17 <sdague> mlavalle the floor is yours
17:02:32 <mlavalle> sdague: Last week I volunteered to consolidate the Quantum BP's
17:02:50 <mlavalle> The vast majority are from Bagshree
17:03:11 <mlavalle> so I sent gel an email proposing group her BP's in 3 groups
17:03:24 <mlavalle> sent her an email
17:03:43 <ravikumar_hp> mlavalle: we are prioritizing . Looks like we will deliver some in havava-2
17:03:49 <ravikumar_hp> and some in Havav-3
17:04:02 <ravikumar_hp> I will update milestone...
17:04:07 <sdague> ravikumar_hp: so I'd still like to see them consolidated a bit
17:04:19 <ravikumar_hp> sure
17:04:22 <sdague> right now they are at the single test level, and I think mlavalle has some good thinking on consolidation
17:04:41 <mlavalle> ravilumar-hp: I know, I will forward you the email I sent her. I prose to align 3 groups by the milestones
17:04:59 <mlavalle> the same milestones she proposed
17:05:03 <ravikumar_hp> mlavalle: Thanks . will discuss with Shree
17:05:26 <mlavalle> sdague: I forwarded you and Jay the email this morning
17:05:58 <sdague> mlavalle: yes, I saw, I think it was in a very good direction
17:06:16 <mlavalle> that's the progress in this front so far. I will follow up with ravikumar_hp
17:06:22 <psedlak> hi ... sorry for being late
17:06:23 <sdague> great
17:06:52 <sdague> #action mlavalle to follow up with ravikumar_hp on quantum blueprint consolidation - due by next tempest meeting
17:07:16 <sdague> ravikumar_hp: also, I really want the owner of the blueprint to be the implementer
17:07:33 <sdague> so please correct those as well, so we can ask folks directly who are doing them
17:07:35 <ravikumar_hp> sdague: okay
17:08:04 <sdague> ok, so I think we are good on those
17:08:19 <sdague> other blueprint status? please use #info so it shows up in minutes
17:08:28 <sdague> #link https://blueprints.launchpad.net/tempest
17:09:15 <sdague> #info tempest-repo-restructure completed
17:09:24 <ravikumar_hp> #info - Keystone tests - good progress. Pending BPs will be completed by Havava-2
17:09:44 <sdague> #info cleanup-launchpad completed (all untouched blueprints purged on monday)
17:10:41 <sdague> #info flake8-extensions - in review, good chance for H1 (lauria has code for review)
17:11:17 <sdague> #info nightly-upgrade-testing - making progress, but will probably slip past H1 (will determine tomorrow)
17:11:24 <sdague> any other blueprint updates?
17:11:28 <afazekas> I will create a wiki about heat and I will try to put together the info I know about the speed-up-tempest project, I will be on trip so +2 week
17:11:54 <giulivo> afazekas, what is the wiki about heat needed for>
17:11:56 <giulivo> ?
17:12:15 <afazekas> giulivo: test plans
17:12:17 <sdague> afazekas: ok, cool, by then mtreinish should be back and digging into it as well
17:12:25 <afazekas> infra requirements
17:12:34 <giulivo> do we have wikis for the other components ?
17:12:42 <sdague> #action afazekas to create a wiki about heat requirements in testing
17:13:05 <afazekas> giulivo: no, but we should have for bigger projects
17:13:14 <giulivo> cause I'm following the heat updates too but maybe can also do something good for cinder
17:13:27 <giulivo> so heat is the first we'll have a wiki about?
17:13:27 <sdague> heat is kind of special too
17:13:45 <sdague> because it's going to push a lot of stuff, and we might need to handle it a little different than the other projects
17:14:00 <sdague> so ++ to afazekas pulling together info there
17:14:06 <sdague> i think it will help a lot
17:14:15 <giulivo> sure, i'm trying to figure out what
17:14:20 <giulivo> and with which purpose
17:15:07 <sdague> ok, so next week we'll bump things to H2 that don't make it, but a push for getting things in for H1 would be good
17:15:09 <giulivo> I think it'd be nice to share some documentation aroun the tests
17:15:31 <sdague> yep, lets get to docs in a minute
17:15:43 <sdague> people ok to move on from blueprints to reviews?
17:15:47 * kashyap in
17:15:48 <sdague> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting - agenda
17:16:11 <psedlak> sdague: wrong date there ;)
17:16:20 <sdague> yeh, I know, want to fix it? :)
17:16:29 <sdague> sorry it was early this morning when I updated
17:16:30 <psedlak> next time ;)
17:16:40 <sdague> #topic Critical reviews tied to blueprints
17:17:00 <sdague> ok, anyone want to pimp reviews they need eyes on?
17:17:33 <giulivo> I have the snapshot thing which was approved but needs +2 again
17:17:43 <giulivo> cause the automerge failed after restructuring the directory
17:17:44 <sdague> giulivo: can you provide #link?
17:17:53 <giulivo> https://review.openstack.org/#/c/28480/
17:18:08 <sdague> #link https://review.openstack.org/#/c/28480/ - needs additional +2 after rebase
17:18:15 <sdague> ok, I'll take a look after the meeting
17:18:28 <sdague> any other reviews people are blocked on?
17:18:51 <sdague> going once...
17:18:58 <sdague> going twice...
17:19:15 <sdague> ok, I'll try to go through everything this afternoon, but then it's a long holiday weekend in the us
17:19:25 <sdague> so I expect things to be slow until mid next week
17:19:52 <sdague> #topic QA Docs
17:20:14 <sdague> ok, so as part of the tempest-repo-restructure blueprint I created all these readmes
17:20:37 <kashyap> sdague, Can you post the URL here please
17:20:51 <sdague> kashyap: url of?
17:20:57 <psedlak> kashyap: check the rsts in the tempest repo
17:21:00 <kashyap> review request
17:21:01 <kashyap> Checking..
17:21:24 <sdague> kashyap: yeh, there is no outstanding review here
17:21:34 <kashyap> Ah, ok.
17:21:42 <sdague> however, we do have a new docs-job in our check (and soon to be gate)
17:21:56 <sdague> that will create the tempest doc website from the docs in the tree
17:21:59 <kashyap> Question: Will it be rST continuing or asciidoc is being considered ?
17:22:22 <sdague> kashyap: rst is currently what we have, and unless there is a compelling reason to change, I'd rather keep it
17:22:28 <sdague> we have tooling that works well with it
17:22:41 <sdague> is there a reason you think we should switch?
17:22:48 <kashyap> Sure. I mentioned asciidoc, as Anne Gentle brought it up on the list
17:22:50 <afazekas> kashyap: is the git hub parses the asciidoc ?
17:23:09 <kashyap> afazekas, Yes, I confirmed github supports asciidoc markup
17:23:27 <sdague> I did rst because that's what we already had in tree.
17:23:31 <kashyap> " and asciidoc is a clear winner from the OpenStack docs perspective due to our existing build tools being able to handle it. It converts to docbook easily."
17:23:46 <sdague> ok, well CI uses rst :)
17:23:55 <kashyap> ACK.
17:24:08 <sdague> As I don't think we're building a manual, I think for web workflow rst is fine
17:24:17 <kashyap> True.
17:24:34 <kashyap> andreaf, asciidoc requires some extra 'packages' to be in.
17:24:36 <psedlak> sdague: how does the doc building and that venv in tox ini? and is there described step/cmd how to build them manualy? (don't know much about sphinx)
17:24:41 <kashyap> rST has less dependencies.
17:24:53 <sdague> psedlak: right, yes, let me explain
17:25:03 <kashyap> (Pops, didn't mean to prompt him.)
17:25:05 <sdague> so there is now a doc/source directory
17:25:16 <sdague> you can either
17:25:32 <sdague> tox -evenv -- python setup.py build_sphinx
17:25:36 <sdague> which is what the gate does
17:25:38 <sdague> or just
17:25:41 <sdague> python setup.py build_sphinx
17:25:48 <sdague> if you have it installed locally
17:26:01 <sdague> and it will create a doc/build directory
17:26:08 <sdague> with html, man format, maybe something else
17:26:31 <sdague> that html will be pushed live on build as soon as this lands - https://review.openstack.org/#/c/30199/
17:26:42 <sdague> #link https://review.openstack.org/#/c/30199/ - review to publish tempest docs on merge
17:27:34 <sdague> to handle the README.rst files in the tree, I've done it with symlinks, because of sphinx security things
17:27:58 <sdague> all these docs could be made much better, contributions welcomed and encouraged!
17:28:11 <sdague> but at least we've got a workflow now that will get them out to the web
17:28:52 <sdague> ok, I'm done talking on that. Other questions or comments or offers to help?
17:29:19 <psedlak> would it be ok to put there also distro specific steps to get tempest runnable?
17:29:28 <sdague> psedlak: yes, absolutely
17:29:35 <psedlak> cool
17:29:45 <giulivo> one more thing, do we plan to use those to document the actual tests?
17:29:58 <sdague> I think anything that makes it easier to use or develop for tempest is fair game
17:30:12 <sdague> giulivo: I think that's totatlly possible
17:30:27 <sdague> we probably want to structure it in such a way that it's kind of it's own base page
17:30:45 <sdague> but I like the idea of having that in there, especially if we can pull it from the tests themselves in some way
17:31:00 <giulivo> yeah I was thinking about docstrings too
17:31:05 <sdague> it just needs a volunteer
17:31:32 <sdague> giulivo: ok, you up for building some kind of proof of concept with a few tests to come up with a model that might work for all of it?
17:31:49 <giulivo> can't in short timew
17:31:57 <sdague> no worries
17:32:14 <giulivo> but I was going to propose that for heat, to afazekas
17:32:17 <sdague> well, if anyone wants to prototype something, it's encouraged
17:32:25 <sdague> ah, yeh, that might be a good idea
17:32:41 <kashyap> As an example, I did something for nested vmx testing -- https://github.com/kashyapc/nvmx-haswell/blob/master/SETUP-nVMX.rst
17:33:05 <psedlak> well for this we will first have to solve the 'docstrings' issue with nose/testr
17:33:08 <kashyap> #link https://raw.github.com/kashyapc/nvmx-haswell/master/SETUP-nVMX.rst
17:33:15 <sdague> I don't know about other people, but I kind of like using gerrit for doc review, as it gives you commenting and voting
17:33:28 <giulivo> +1 from me
17:33:36 <sdague> psedlak: true, that would be part of the prototype for anyone proposing to sort out
17:34:19 <sdague> ok, other thoughts on docs?
17:34:25 <kashyap> sdague, Was that info pointed at me ? If so - that's not entirely related OpenStack yet. It's mostly lower layers.
17:34:27 <psedlak> and what that 'prototype' should look like? as it would require changes to gate scripts etc ... so probably not a posted review ...
17:34:50 <sdague> psedlak: why would it require a change to gate scripts?
17:35:20 <sdague> kashyap: not really, just gerrit vs. wiki
17:35:22 <psedlak> to let nosetest/testr skip using docstrings as 'test names'
17:35:33 <kashyap> sdague, Ok, just clarifying. Thanks.
17:35:37 <sdague> psedlak: so actual nose invocation in the gate now is controlled in our tox.ini
17:35:53 <sdague> so we'd be able to control it without a gate repo change
17:36:04 <psedlak> for nose there is plugin which does it ... so yeah in test-requires + tox ... ok
17:36:26 <sdague> yeh, so it could all be self contained in a review, and we'd know it passes the gate
17:36:29 <sdague> which is goodness
17:36:51 <psedlak> ok
17:37:37 <sdague> ok, so the next thing I had on the agenda was to discuss tags, but I feel like we're missing most of the core folks becauses me and afazekas, so maybe we postpone. Especially given holiday weekend here.
17:38:09 <sdague> or we just take that to the list, which has been working well recently
17:38:21 <sdague> +1 to everyone participating there so actively :)
17:38:41 <sdague> #topic Bug Day?
17:39:03 <afazekas> #link https://wiki.openstack.org/wiki/BugTriage
17:39:05 <sdague> so afazekas, where do we stand on organizing a bug day?
17:39:24 <afazekas> We have an open supervisor group
17:39:44 <sdague> #info tempest now has open supervisor group for bugs, anyone can triage
17:39:45 <sdague> nice
17:39:56 <afazekas> #link https://launchpad.net/~tempest-bug-team
17:40:23 <sdague> great
17:40:44 <kashyap> #info - #openstack-bugday is the IRC channel
17:40:45 <afazekas> The main issue we need to made progress in Task 1, ie. confirming the bugs before we can triage them
17:41:21 <kashyap> # info - https://wiki.openstack.org/wiki/BugFilingRecommendations
17:41:21 <sdague> afazekas: ok, so were you going to organize a bug day, and drum up interest on the mailing list?
17:42:05 <afazekas> I will
17:42:17 <sdague> ok, great. Have you picked a day for it?
17:42:21 <kashyap> TBH, Yesterday was nova bug-day, I saw absolutely no word there. MStill is the only person appears to be interested
17:42:42 <sdague> well, I think instead of using #openstack-bugday, we should use #openstack-qa
17:42:43 <afazekas> Not yet
17:42:46 <sdague> when we do ours
17:42:58 <sdague> just to drive traffic to a place we normally are
17:43:22 <sdague> they are sometimes tough to get folks into, but at least for the first one if we can get all the normally active people into them, it will help
17:43:31 <kashyap> +1
17:43:38 <sdague> it's a lot nicer to work on bug triage with others around doing it at the same time
17:43:47 <sdague> otherwise you go crazy
17:43:51 <afazekas> :)
17:43:53 <kashyap> Indeed. I'm around during CET zone
17:44:11 <sdague> so we'll at least have 1/2 day overlap :) (/me in US EST)
17:44:38 <sdague> afazekas: ok, will you have picked a day by next week's meeting, or are you off for a bit now?
17:44:39 <mlavalle> I'll be covering US Central ;-)
17:44:40 <kashyap> Well, I'm in IST, but mostly work w/ folks in CET, so just noting it here :)
17:45:19 <sdague> would be nice to get it sooner rather than later, but still give folks a few days warning so they can try to clear up time for it
17:45:30 <afazekas> I will not be here on the next meeting :(
17:45:48 <kashyap> No worries, not everyone can make all IRC meetings.
17:45:54 <afazekas> I will be on vacation
17:46:01 <afazekas> far far :)
17:46:03 <kashyap> If you have specific things to cover, just maybe post on the list.
17:46:24 <sdague> afazekas: vacation is good :)
17:46:36 <sdague> ok, is there another volunteer that wants to take up organizing the first bug day?
17:46:43 <jhenner> not in the time of meetings, right afazekas?
17:46:52 <sdague> would be nice to have a couple between now and H3
17:47:25 <kashyap> I could let a more tempest familiar person take charge the first one, then I could lend a hand for the next one
17:47:27 <sdague> #help need volunteer to organize first tempest bug day
17:47:51 <sdague> kashyap: well really the organize is just picking a day, and sending some emails :)
17:48:04 <kashyap> I don't actively work on tempest (I work on lower layers), so I'm not technically right to take charge right away
17:48:11 <kashyap> sdague, Sure. I could do that
17:48:25 <sdague> kashyap: cool thanks
17:48:38 <kashyap> Unless someone wants to beat me to it.
17:48:45 <afazekas> kashyap: thank you
17:48:55 <sdague> yeh, it's not so much a tempest specific thing, as an organizing thing. I'm just trying to spread the work around otherwise I forget to do things :)
17:49:00 <sdague> afazekas: +1
17:49:28 <sdague> #action kashyap to organize first tempest bug day, all tempest members greatly thank him for it
17:50:06 <sdague> ok, let's go to open discussion
17:50:11 <kashyap> :) You're exaggerating the effect. Maybe I could send an email right away, asking for convenient time zone?
17:50:11 <sdague> #topic Open Discussion
17:50:22 <kashyap> s/time zone/day
17:50:23 <sdague> kashyap: typically we just declare a "day"
17:50:32 <sdague> kashyap: yeh, sure
17:50:36 <kashyap> Yep, typo :)
17:50:52 <sdague> thanks again
17:51:00 <sdague> ok, other topics that people want to bring up?
17:51:19 <psedlak> copyright lines?
17:51:33 <psedlak> how did it ended ... is there final decision/guideline?
17:51:55 <psedlak> i saw a lot of email but at the end i was even more confused :]
17:52:02 <afazekas> psedlak: do not read them :)
17:52:05 <sdague> heh
17:52:19 <sdague> yeh, the TC discussion really didn't seem to have a resolution
17:52:34 <sdague> maybe I'll go ask ttx on what he finally thought
17:53:15 <afazekas> psedlak: I mean do not read the licenses :)
17:53:34 <sdague> we might have a small enough number of contributors we could do it anyway, I know in nova it's a lot
17:53:54 <giulivo> a couple more things from me: 1. I think is is all sorted now and can be closed? https://blueprints.launchpad.net/tempest/+spec/set-gate-attribute 2. maybe we should get the infra setup changed to test at least the cinder multibackend feature in gate? probably using either lvm/nfs?
17:55:08 <psedlak> sdague: if you will learn/get final desicions please update https://wiki.openstack.org/wiki/LegalIssuesFAQ or maybe hacking or something like that and anounce it please :)
17:55:09 <sdague> giulivo: on point 1, are all the reviews through?
17:55:17 <sdague> psedlak: will do
17:55:41 <sdague> giulivo: on point 2, we definitely need to bring back periodic jobs
17:56:11 <giulivo> the last one I was looking for is related to "compute" and has been approved; is there anything out of /api/ which need the tag to be set?
17:56:11 <sdague> giulivo: so you think we need a blueprint for multi cinder backend?
17:56:33 <kashyap> sdague, Also, good to CC Richard Fontana (legal) on that discussion of copyright lines. (/me hasn't read the threads, so not sure, if he's on it.)
17:56:34 <giulivo> not necessarily a blueprint, but maybe it's worth gating it, probably with two different backend types
17:56:35 <sdague> giulivo: probably not
17:56:58 <sdague> giulivo: ok, at least a blueprint would keep track of the fact that it might be an infrastructure change
17:57:05 <giulivo> so regarding the gate attribute I'll double check that and eventually close the blueprint
17:57:09 <psedlak> hm probably cli should get attrs too
17:57:20 <psedlak> ?
17:57:27 <giulivo> psedlak, good hint, will look into that and submit changes where needed
17:57:47 <psedlak> or do we want to keep it running completely?
17:57:54 <sdague> psedlak: we trigger the cli tests directly
17:58:03 <sdague> so maybe we don't need it outside of api
17:58:28 <psedlak> yeah i know, but not sure if it would not be easier to move everything to gate/smoke tags now
17:58:32 <sdague> I'm sure we'll figure out a few other fixes down the road, but lets just make sure all the reviews landed first
17:58:57 <psedlak> so we would not have to touch the gates later again ...
17:59:16 <sdague> yeh, though again, because we control things now in tox.ini... it's *so* much easier
17:59:39 <psedlak> heh, i'm still not used to it sorry :)
17:59:46 <sdague> yep, no worries :)
17:59:59 <sdague> ok, I've got to run here in a minute. Any last things from folks?
18:00:35 <sdague> ok, we're at top of the hour
18:00:39 <sdague> #endmeeting