17:00:59 <sdague> #startmeeting qa
17:00:59 <openstack> Meeting started Thu Jun  6 17:00:59 2013 UTC.  The chair is sdague. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:02 <openstack> The meeting name has been set to 'qa'
17:01:03 <mlavalle> I am
17:01:08 <afazekas> hi
17:01:25 <mtreinish> hi
17:01:43 <sdague> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting
17:01:51 <sdague> ok, lets get running on agenda
17:02:00 <sdague> #topic Bug Day Roundup
17:02:11 <sdague> #link http://status.openstack.org/bugday/
17:02:19 <sdague> so I think that went very well yesterday
17:02:28 <afazekas> nice :)
17:02:32 <sdague> really nice to get the bug tracker into some kind of shape
17:02:47 <sdague> and I want to thank everyone for participating, and kashyap for organizing
17:03:08 <sdague> we basically got everything out of new state
17:03:13 <sdague> and got some bugs fixed
17:03:22 <sdague> and got more eyes on the tracker, so success over all :)
17:03:34 <sdague> anyone else with comments from the day?
17:04:22 <sdague> ok, we'll take that as a no :)
17:04:27 <sdague> #topic Blueprints
17:04:40 <sdague> #link https://launchpad.net/tempest/+milestone/havana-2
17:05:12 <sdague> as per past weeks, if you have blueprints that you have status updates for, could you please put an #info out about it?
17:05:29 <sdague> mtreinish I assigned you the testr one which was hanging out under me :)
17:05:30 <afazekas> #link https://blueprints.launchpad.net/tempest/+spec/stop-leaking
17:05:31 <afazekas> new
17:05:53 <sdague> #info https://blueprints.launchpad.net/tempest/+spec/speed-up-tempest now being driven by mtreinish
17:06:03 <mtreinish> sdague: yeah I just noticed that, not a problem
17:06:23 <sdague> afazekas: that sounds like a good blueprint
17:06:31 <sdague> are you going to be tackling it?
17:06:48 <afazekas> mtreinish: can you update the wiki https://wiki.openstack.org/wiki/Blueprint-speed-up-tempest ,  it just half complete
17:07:12 <afazekas> sdague: yes
17:07:27 <mtreinish> afazekas: sure, I can do that
17:07:28 <sdague> afazekas: when you do resource tracking like that, it would be nice if it wasn't just at the start and end of tempest, but also after each test
17:07:48 <sdague> so we can guage the resource consumptions, leaks of the tests individually as well
17:08:01 <afazekas> it has high cost
17:08:01 <sdague> afazekas: do you have a milestone target for it?
17:08:18 <sdague> afazekas: does it? to just list the resources and quotas?
17:08:22 <afazekas> I want to create script which runs the test cases individually with the tracker
17:08:44 <sdague> afazekas: ok, cool.
17:09:11 <afazekas> If it will be gating, change cannot pass with a leak introduction
17:09:13 <sdague> afazekas: milestone target I should set for it?
17:09:40 <sdague> afazekas: so if you just want to solve the gate issue, it's actually much easier
17:09:48 <afazekas> when will be the H2 release ?
17:09:51 <sdague> because we know there shouldn't be any resources on that machine
17:09:58 <sdague> H2 is middle of July
17:10:11 <sdague> the 17th I think
17:10:24 <afazekas> ok
17:10:49 <sdague> so should I mark this for h2?
17:10:54 <afazekas> yes
17:11:21 <sdague> #info https://blueprints.launchpad.net/tempest/+spec/stop-leaking added as h2 blueprint
17:11:28 <sdague> great, other blueprint updates?
17:11:32 <tkammer> I would like to propose: https://blueprints.launchpad.net/tempest/+spec/tempest-encapsulation-of-data
17:11:44 * afazekas I will think about adding similar things to the setUP and tearDown as well.
17:12:02 <kashyap> Also thanks to all the guys who did more triaging
17:12:07 <sdague> tkammer: ok, before more new blueprints, it would be nice to see about existing ones
17:12:23 <tkammer> sdague, sorry, still new here, learning the procedures as I go :)
17:12:41 <sdague> davidkranz: update here https://blueprints.launchpad.net/tempest/+spec/stress-tests?
17:13:13 <sdague> ravikumar_hp: how about your BPs?
17:13:19 <davidkranz> sdague: There is not that much more to do but I am not sure when I will be able to get to it.
17:13:49 <sdague> davidkranz: ok
17:14:11 <sdague> Shree-HP: how about your BPs?
17:14:33 <afazekas> grep ERROR /opt/stack/screen-logs/screen-n-cpu.log | wc -l
17:14:33 <afazekas> 165
17:14:56 <afazekas> I still see errors in the nova log without an ERROR
17:15:18 <sdague> afazekas: well ERRORs in nova are probably ok in some conditions
17:15:31 <davidkranz> afazekas: Yes, running the stress tests will not be so useful until the logs are clean.
17:15:40 <Shree-HP> <sdague> We will be submitting our test in next few days, I have moved all my BP to H2 and H3 for now
17:16:03 <sdague> Shree-HP: could you please assign the bps to whoever is actually doing them?
17:16:28 <sdague> and people working on blueprints should be in the #openstack-qa channel to discuss things :)
17:16:35 <Shree-HP> I am doing it actually . But as u might know we were waiting for HP internal approval for openstack submission
17:16:40 <sdague> ok
17:17:00 <sdague> ok, I think that's all the folks I know in this channel with active blueprints
17:17:07 <Shree-HP> will follow-up in openstack-qa channel
17:17:16 <sdague> next up, tkammer your turn
17:17:29 <tkammer> sdague, thanks
17:17:32 <sdague> #link https://blueprints.launchpad.net/tempest/+spec/tempest-encapsulation-of-data
17:17:55 <sdague> so I think that blueprint needs more details to be something that is doable
17:18:14 <tkammer> https://wiki.openstack.org/wiki/Blueprint-EncapsulatingData
17:18:16 <tkammer> :)
17:18:18 <sdague> we like to have blueprints that are something that you can declare as "done"
17:18:20 <sdague> ok :)
17:18:36 <dwalleck> sdague: ++. Interesting concept, but not sure what the outputs would be
17:19:06 <tkammer> I gave an example of what I mean with the encapsulation in the wiki page
17:19:27 <tkammer> I think it shouldn't be too much trouble to implement
17:19:31 <sdague> tkammer: so I'm concerned for tempest/api that it actually goes against what we are trying to do
17:19:41 <tkammer> sdague, what do you mean?
17:19:48 <sdague> because we don't want people to be changing the underlying apis willy nilly
17:20:28 <RAX-Sam> It sounds like you guys are talking about what we have done with Models in Open/CloudCafe
17:20:47 <sdague> it could be, maybe we should take it to the mailing list for discussion?
17:21:39 <tkammer> that's a good idea, I think encapsulation of things can be a good first step to reuse of code
17:22:25 <sdague> sure, I think we just want to be cautious about hiding away what the tests are doing too much from a reviewability perspective, but I think a good ML discussion will get us to the right place
17:22:26 <afazekas> I think it just helps in the user management, but it can help a lot there
17:22:44 <sdague> sounds good
17:22:53 <sdague> #action tkammer to kick of ML thread on BP proposal
17:23:05 <tkammer> will do :)
17:23:11 <sdague> cool, we'll discuss there with examples and such
17:23:24 <sdague> ok, any other blueprint things?
17:23:47 <sdague> #topic Critical reviews
17:24:08 <sdague> ok, now is the time to pimp reviews that you think haven't gotten enough attention
17:24:19 <sdague> anyone have reviews they want people to look at?
17:24:54 <sdague> going once...
17:24:58 <kashyap> fyi: "git-review -l" gives all the reviews on CLI
17:25:19 <sdague> going twice...
17:25:29 <sdague> ok, we'll assume we are keeping up well at the moment
17:25:52 <sdague> #topic QA Docs
17:26:03 <sdague> #link http://docs.openstack.org/developer/tempest/
17:26:23 <sdague> so we now have a docs job as part of the tempest gate, and docs get published there on every commit
17:26:34 <sdague> so increasing help there would be appreciated :)
17:27:00 <sdague> I tried to correct some of the biggest accuracies with the READMEs but I'm sure some are still there
17:27:43 <sdague> ok, moving forward
17:27:46 <sdague> #topic Tempest/Flake8/testr issues
17:27:51 <afazekas> sdague: where is the hacking rules on that site?
17:28:00 <sdague> afazekas: they aren't
17:28:07 <sdague> we should probably do something on that
17:28:31 <afazekas> I would like to add some exception handling guideline
17:28:38 <sdague> afazekas: ok, great!
17:29:02 <sdague> you can add files to tempest/doc/source
17:29:14 <sdague> and they will publish there
17:29:32 <afazekas> thx, I'll check it next week.
17:29:41 <sdague> #action afazekas to add exception handling guidelines to docs
17:29:55 <sdague> ok, so onto the Tempest / Flake8 / testr issues
17:30:16 <sdague> I didn't add that to the agenda, so whoever did, you want to lead the discussion?
17:31:50 <sdague> anyone?
17:32:10 <sdague> ok, I gues we're moving on to open discussion :)
17:32:22 <sdague> #topic Open Discussion
17:32:33 <sdague> ok, any other topics from folks?
17:32:36 <afazekas> may be the esiest way to workaround to issue to add --safe option to the flake8
17:32:41 <jhenner> I have some topic
17:32:55 <sdague> jhenner: go for it
17:32:57 <afazekas> Or it should not check for those rules whan it is not en the explicitly enforced rule set
17:33:29 <afazekas> The other way is solving it similar as I wanted long time ago
17:33:43 <sdague> afazekas: the other way broke on mac though, right?
17:34:00 <afazekas> But instead of ising the imp module, we need to implement a module finder which works as the python's on every supported os
17:34:24 <afazekas> that thing "working" in vary strange way on mac
17:34:38 <afazekas> s/vary/very/
17:34:46 <sdague> yeh, so if someone signs up for that solution and gets it in hacking, that would be cool. Honestly I expect that testr and fixtures are going to cause other changes that affect it anyway
17:34:52 <sdague> jhenner: what's your topic?
17:35:00 <afazekas> I would say it is bug on the mac python, but ..
17:35:13 * psedlak_ is sorry that he almost missed the meeting
17:35:14 <jhenner> We (RedHat) may want to add some script which would take as an input an answer file from our installation tool and prepared the stack and Tempest for run
17:35:24 <jhenner> psedlak_: you came just in time
17:35:46 <jhenner> would someone had something against?
17:35:58 <sdague> jhenner: ok, is that something you think goes in tempest, or like devstack, where the config tool is in the installer?
17:36:09 <afazekas> jhenner: https://github.com/stackforge/packstack  ?
17:36:48 <jhenner> packstack is the deploying tool. It can take answer file as it's input
17:37:08 <jhenner> we could use the same answer file to fill the stack with some images and generate tempest.conf
17:37:11 <jhenner> and users
17:37:15 <jhenner> that would be it
17:37:36 <sdague> jhenner: ok, is there a reason not to put the tool in packstack?
17:37:42 <sdague> I'm just wondering
17:37:55 <sdague> and what does this answer file look like?
17:38:18 <sdague> maybe this would be a good ML topic as well, so examples could be given
17:38:18 <jhenner> sdague: Well, it feels like probably it should be separate thing to be honest.
17:38:20 <psedlak_> imho steps which are in devstack could be shared also with our tools, and probably used by others who will want to do the same
17:38:28 <psedlak_> *tool
17:38:41 <psedlak_> like the image creation and so on, those things will be the same
17:38:57 <jhenner> psedlak_: yep, we would need the iniset
17:39:16 <afazekas> jhenner: IMHO: if you have the admin credentials in your environment,  you can get all info for tempest prepare in any env
17:39:35 <psedlak_> https://github.com/stackforge/packstack/blob/master/docs/packstack.rst
17:40:09 <jhenner> afazekas: db passwords?
17:40:11 <psedlak_> answer file contains OPT = value, as they can be seen on that page
17:40:33 <afazekas> jhenner: .my.cnf or read it from the service conf
17:40:42 <sdague> ok, so let's take this into the mailing list?
17:40:50 <psedlak> ok
17:40:53 <jhenner> sdague: ok
17:41:28 <sdague> #action jhenner to start discussion on ML on tempest config tool for packstack
17:41:37 <psedlak> btw - who replaced the agenda?
17:42:08 <psedlak> ah i see sdague :)
17:42:25 <sdague> psedlak: did I break something? :)
17:42:37 <psedlak> ou, sorry my mistake, it's not replaced ... too much work today probably :)
17:42:37 <sdague> ok, other open discussion items?
17:42:55 <psedlak> did I missed that flake8/testr topic?
17:43:03 <jhenner> psedlak: yep
17:43:20 <sdague> psedlak: we can do it now
17:43:27 <sdague> go for it
17:43:52 <psedlak> well i would like to now what possibilies to fix it we have
17:43:58 <psedlak> and if anyone is pursuing them
17:44:04 <psedlak> */any of them
17:44:20 <psedlak> as in that mail
17:44:26 <psedlak> #link http://lists.openstack.org/pipermail/openstack-qa/2013-May/000429.html
17:44:48 <afazekas> psedlak: http://paste.openstack.org/show/38193/
17:44:48 <psedlak> and following messages
17:45:24 <psedlak> yeah, i missed it i see, but if we can do it now ... (do we have time?)
17:45:49 <psedlak> those emails ... it was mentioned that it should be moved to meeting
17:45:53 <psedlak> but it never was
17:46:50 <psedlak> so does anyone know what is the state of this issue?
17:46:55 <sdague> psedlak: so I think with mtreinish looking into what will change with fixtures, we might move the problem around again
17:47:04 <sdague> maybe it just is worth seeing what falls out of that first
17:47:12 <mpavlase> I have just tiny note, on the main wiki page with QATeamMeeting there is a typo... today isn't 8th but 6th June :-) If it would be noticed at some log etc. it should be fixed, otherwise let as it.
17:47:49 * psedlak facepalms
17:48:39 <sdague> heh
17:48:41 <psedlak> sdague: fixtures? they will solve config loading issue?
17:48:53 <ravikumar_hp> sdague: sorry . I got struck up in some urgent work . Will check BPs that are pending
17:49:01 <sdague> psedlak: they will move the problem of loading the config
17:49:11 <sdague> whether they fix it is a whole other thing :)
17:49:25 <afazekas> psedlak: they are just a nice abstractions over the setUp and tearDown
17:49:39 <psedlak> hm, ok
17:50:40 <sdague> ok, so anything else?
17:51:03 <psedlak> well, maybe ...
17:51:25 <psedlak> would it be acceptable, to create new tempest/xy
17:51:45 <sdague> psedlak: for what kind of things?
17:52:07 <psedlak> for specific/additional test for non devstack versions of openstack
17:52:08 <afazekas> psedlak: with little tweak they can be similar to the cafe 'bahavior'
17:52:39 <psedlak> like as RH has RDO http://openstack.redhat.com/ (that packstack installer)
17:52:55 <psedlak> we will need to create additional, packstack/RDO specific tests
17:53:13 <sdague> psedlak: so tempest tests shouldn't be specific to an implementation
17:53:18 <psedlak> and as there is 'thirdparty' ... for thirdparty (api) extensions ...
17:53:42 <psedlak> sdague: so suggestion would be to keep them in separated repository ...
17:53:48 <psedlak> right?
17:53:57 <sdague> I think an example would be helpful
17:54:41 <psedlak> for example check that log from installation done using packstack contains valid url to dashboard and that user can log-in using that url
17:55:11 <sdague> yeh, I think that gets too implementation specific
17:55:29 <sdague> we really want tempest to be able testing any cloud
17:55:52 <psedlak> ok
17:55:57 <sdague> anyway, we're about at the end of the hour, so my suggestion is further topics should go back on #openstack-qa
17:56:04 <sdague> any last things from folks?
17:57:10 <sdague> ok, thanks all
17:57:13 <sdague> #endmeeting