17:01:08 <dkranz> #startmeeting qa
17:01:09 <openstack> Meeting started Thu Jun 27 17:01:08 2013 UTC.  The chair is dkranz. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:12 <openstack> The meeting name has been set to 'qa'
17:01:35 <dkranz> So there is nothing on the agenda in the wiki at the moment.
17:01:48 <dkranz> Who else is here?
17:02:07 <mlavalle> Hi
17:02:15 <giulivo> dkranz, honestly I was looking forward for some updates on testr
17:02:21 <giulivo> and the migration from nose to testr
17:02:46 <dkranz> giulivo: Me too, but the reporters are in NY.
17:03:15 <dkranz> giulivo: Since next Thursday is a major US holiday, we should ask them for status on the mailing list.
17:03:22 <giulivo> plus I wanted to introduce a couple of topics
17:03:30 <giulivo> 1. enable Heat in gating jobs
17:04:05 <dkranz> There was some discussion about whether heat should have its own job.
17:05:14 <dkranz> That made sense to me.
17:05:30 <giulivo> that means a new VM as per quantum?
17:05:39 <dkranz> Yes.
17:06:20 <dkranz> But it really depends on what the heat tests are ultimately doing.
17:06:47 <dkranz> We should ping Steve Baker about that.
17:07:11 <dkranz> giulivo: Do you have anything to add about this?
17:07:30 <giulivo> no I'd start work on those
17:07:48 <giulivo> as soon as the things reach some level of stabilization
17:08:03 <giulivo> so currently I'm keeping an eye on the reviews
17:08:10 <dkranz> giulivo: what kind of work do you mean you would start?
17:08:18 <giulivo> maintain the existing heat tests
17:08:23 <giulivo> and improve where necessary
17:08:37 <giulivo> with tests for the additional functionalities
17:08:44 <giulivo> it is mostly what I've done with cinder
17:08:48 <psedlak> hi, sorry for being late
17:08:55 <dkranz> psedlak: np
17:09:15 <dkranz> giulivo: Perhaps you should check with Steve Baker about his plans going forward.
17:09:36 <psedlak> after quick look, they already have the gate/smoke attrs, so they were already run when proposed right?
17:09:57 <giulivo> ideally, but AFAIK heat is just disabled
17:09:58 <dkranz> psedlak: I believe the issue is that devstack by default is not setting up heat.
17:10:27 <dkranz> So we either need to turn it on for all tempest jobs, or run them in a separate job.
17:10:39 <psedlak> oh i see
17:10:51 <afazekas> hi
17:11:08 <dkranz> #topic QA as an OpenStackk Program
17:11:15 <dkranz> afazekas: hi there
17:11:57 <dkranz> As Sean said, it makes sense to choose a "leader"  and then let that person drive producing the mission.
17:12:00 <dkranz> http://lists.openstack.org/pipermail/openstack-dev/2013-June/010950.html
17:12:11 <psedlak> well imho it depends, if there will be some non-gating tests, they should be later part of full/periodical test right?
17:12:37 <dkranz> psedlak: RIght, that full/periodic would be configured with heat.
17:12:40 <psedlak> and also if heat is not set-up by devstack now, that should be fixed first ... or why not?
17:13:10 <dkranz> psedlak: We could just do that for all jobs.
17:13:12 <psedlak> dkranz: ok, but what's the reason to not have heat also in the gate job?
17:13:54 <dkranz> psedlak: I am not sure but there was a discussion about it.
17:14:15 <dkranz> I don't really care either way but we should check with the infra folks.
17:14:28 <giulivo> psedlak, it is roughly perceived as a slowdown
17:14:36 <psedlak> :/
17:14:37 <giulivo> and just an additional layer on top of the APIs we test already
17:14:43 <psedlak> dkranz: makes sense
17:15:00 <giulivo> so it'd be worth write some specifics for Heat, but going trough the whole process would just produce
17:15:06 <giulivo> more testing for the underlying API
17:15:16 <giulivo> we should try to test the logic in Heat, not the actual functionalities
17:15:35 <dkranz> giulivo: I presume that is the focus of the tests now being added.
17:15:38 <psedlak> giulivo: not only that, also coop between heat and those underlying APIs ... the heat itself ... or?
17:15:46 <giulivo> dkranz, to be honest
17:15:50 <giulivo> partially it is
17:15:57 <giulivo> but I see added unneeded stuff
17:16:17 <giulivo> like this https://review.openstack.org/#/c/33899/
17:16:22 <dkranz> giulivo: This is really a question of what the heat test plan is.
17:16:26 <giulivo> yeah
17:16:31 <dkranz> giulivo: Can you make sure there is one :)
17:16:38 <psedlak> ok, then those unneeded could be 'just' not marked as gate/smoke ... ?
17:16:53 <dkranz> psedlak: If they are unneeded they should be removed.
17:16:57 <giulivo> yeah actually there is a blueprint
17:17:12 <giulivo> https://blueprints.launchpad.net/tempest/+spec/add-basic-heat-tests
17:17:13 <dkranz> giulivo: Can you see if it is a real test plan?
17:17:39 <dkranz> It doesn't seem to be.
17:17:40 <psedlak> dkranz: really unneeded should be removed, i meant unneeded for gate/time-concerned testing ...
17:17:48 <giulivo> yeah I think we're already going further the few tests described anyway
17:18:28 <dkranz> giulivo: So what is the action to be taken here?
17:18:52 <giulivo> I'll try to get in touch with the author of the tests and see if we can draft more infos in the blueprint
17:18:55 <dkranz> I have to step out for two minutes but please continue.
17:18:55 <giulivo> stick with those tests
17:19:00 <giulivo> and later work on the Heat VM
17:19:09 <giulivo> ...
17:19:55 <giulivo> so is there people focusing on blueprints which should get some attention?
17:20:03 <giulivo> like, not yet prioritized?
17:20:50 <giulivo> ok I'd consider the silence as a no
17:21:22 <giulivo> ...
17:21:33 <giulivo> given that nobody jumped into the testr discussion either
17:21:45 <giulivo> I assume there aren't updates on that
17:22:03 <giulivo> ...
17:22:15 <giulivo> and with that the last topic which I can think about
17:22:20 <giulivo> is reviews in need of love
17:22:26 <psedlak> giulivo: i think dkranz mentioned that testr state should be asked on ML
17:23:20 <giulivo> so before we get into the reviews needing help
17:23:30 <giulivo> are there other topics proposed?
17:23:57 <dkranz> The current topic was qa as a program.
17:24:18 <giulivo> dkranz, please go on
17:24:30 <dkranz> The easiest thing would be for any one who wants to be the qa "leader" to send something to the mailing list.
17:24:46 <dkranz> If there is more than one we would have a vote, same as other projects.
17:25:33 <dkranz> But I think being a Core reviewer would be necessary for the leader.
17:26:47 <afazekas> dkranz: I think we do not have everybody here to discuss the leader
17:26:48 <giulivo> dkranz, doesn't the core team actually act as a group of people leading the program?
17:27:26 <psedlak> giulivo: no, core is about activity
17:27:33 <giulivo> what would be the value added from having a "leader" ?
17:27:38 <psedlak> giulivo: there is also drivers group
17:27:46 <dkranz> giulivo: There are two answers.
17:28:07 <dkranz> One is that it is a technical requirement for being a program.
17:28:45 <dkranz> The other is that the group will work better if some one knows it is there job to prepare an agenda for the meeting, organize blueprints, etc.
17:29:03 <giulivo> dkranz, indeed but I mean
17:29:06 <dkranz> And attend cross-project/program meetings.
17:29:21 <giulivo> isn't the current core group the tempest PTL? isn't the core group already in charge of those duties?
17:29:27 <dkranz> I mean is required to attend. Any one can attend any meeting.
17:29:55 <dkranz> giulivo: Yes, in our own little world.
17:30:26 <dkranz> From the OpenStack perspective though, each group needs a representative and/or single point of contact.
17:30:45 <giulivo> oh the PTL isn't a group
17:31:09 <afazekas> dkranz: How can we decide who will be the single point of contact ?
17:31:11 <dkranz> giulivo: No, it is the Project Technical Lead who is an elected person by the members of their group.
17:31:39 <dkranz> afazekas: The same way as all the other projects: if there is more than one candidate, we vote.
17:32:35 <dkranz> We would have to determine who can vote but first let's see if there is more than one candidate.
17:32:36 <afazekas> Who has a suggestion for PTL ?
17:33:05 <dkranz> sdague was suggested a while ago and he said he would be willing.
17:33:12 <jking_swift> identify 6dca42to04
17:33:17 <jking_swift> or not
17:33:22 <jking_swift> sorry, stupid client
17:33:26 <dkranz> jking_swift: Huh?
17:33:34 <giulivo> we won't steal your nick
17:35:01 <dkranz> Remember that "PTL" is not a position of any particular authority, more about dedicating time to the project in a reliable way with the backing of your employer.
17:35:41 <dkranz> Any other comments about "PTL"?
17:36:26 <dkranz> afazekas: BTW, me saying single point of contact was a little misleading.
17:36:36 <giulivo> my comment is that I don't see the vertical structuring a good idea
17:36:44 <dkranz> There is hardly anything that would be sent only to that person.
17:36:55 <giulivo> so I'd prefer to keep that a group, as it has been with the "core" team of people
17:37:00 <giulivo> but clearly it is just my 2c
17:37:09 <dkranz> It is more that the leader is *required* to do certain things and takes on that responsibility.
17:37:23 <giulivo> dkehn, indeed, required by?
17:37:28 <afazekas> giulivo: It is the normal Openstack way, projects has a PTL
17:37:34 <giulivo> yeah
17:37:44 <dkranz> giulivo: We don't really have a choice.
17:38:38 <dkranz> giulivo: required to show up at the weekly project meeting, for example.
17:39:05 <dkranz> So if there are no more comments I will send something to this list requesting people to express their interest.
17:40:01 <afazekas> dkranz: sounds good to me
17:40:35 <dkranz> Any other items to discuss?
17:40:55 <dkranz> I am still trying to find time to do some more work on the stress tests.
17:41:56 <afazekas> Back to the heat test, one of the most interesting heat feature is the auto-scaling
17:42:42 <afazekas> At gate time until we do not get normal parallel test execution, it would be difficult to do
17:43:18 <afazekas> Probably some heat tests needs to be switched periodic, but we will see
17:44:11 <dkranz> afazekas: Yes, longer running scenario tests should be on our radar screen.
17:45:12 <afazekas> dkranz: Yes, so probably we will need find some good balance , how and when to run the heat tests
17:46:07 <dkranz> afazekas: We just need the test plan. Once we know what is to be run we can decide how and when.
17:46:08 <afazekas> Log time ago I got little more input from heat guys, I'll try to add some summary to the blueprint
17:46:23 <afazekas> long
17:46:45 <dkranz> afazekas: That would be great. In my view of the world, every blueprint would contain a complete test plan ideally.
17:46:51 <giulivo> afazekas, yeah I think we should try to find the scope of the tests firstly
17:46:58 <afazekas> dkranz: ok, I try to collect the infos
17:47:01 <dkranz> I understand that is not realistic in many cases.
17:48:15 <afazekas> dkranz: The heat  team has high level, concept . But it enough to see, what is coming, and what kind of changes might be necessary
17:48:34 <dkranz> afazekas: OK, good.
17:50:59 <dkranz> ANything else
17:51:04 <dkranz> ?
17:51:29 <dkranz> #action David will send email to the list about choosing leader
17:51:53 <dkranz> Going once...
17:52:03 <psedlak> and maybe about testr status? or giulivo wants to send it ...
17:52:24 <dkranz> psedlak: I can send that too.
17:52:41 <dkranz> #action David will request status of testr on the list
17:52:48 <dkranz> Going twice...
17:52:59 <psedlak> bye :)
17:53:21 <dkranz> Bye all. I think there may be no meeting next week, at least from US participants.
17:53:35 <dkranz> July 4 holiday.
17:53:40 <dkranz> #endmeeting