17:00:09 <mtreinish> #startmeeting qa
17:00:10 <openstack> Meeting started Thu Apr 10 17:00:09 2014 UTC and is due to finish in 60 minutes.  The chair is mtreinish. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'qa'
17:00:22 <mtreinish> Hi who do we have here today?
17:00:30 <dwalleck> o/
17:00:47 <mtreinish> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_April_10_2014_.281700_UTC.29
17:00:51 <mtreinish> ^^^ Today's agenda
17:00:52 <afazekas> o/
17:01:14 <dkranz> o/
17:01:42 <mtreinish> well I guess it'll be a quicker meeting today
17:01:47 <mtreinish> but let's get started
17:01:58 <mtreinish> #topic Summit sessions (mtreinish)
17:02:10 <mtreinish> #link https://etherpad.openstack.org/p/Juno-QA-design-summit-topics
17:02:18 <mtreinish> so I just wanted to bring up the summit sessions again
17:02:26 <mtreinish> the deadline for submissions in the tool is the 20th
17:03:03 <mtreinish> I was planning to discuss the sessions people put on the etherpad the meeting after the deadline
17:03:17 <mtreinish> so I just wanted to remind people to put things in the tool too
17:03:56 <mtreinish> if no one has any questions about that we can move on to the next topic
17:04:03 <dkranz> mtreinish: ok
17:04:23 <mtreinish> #topic Blueprints
17:05:13 <mtreinish> So I think we'll hold off on discussing the specs review until sdague is around (he said he'd miss the first part of the meeting)
17:05:23 <sdague> mtreinish: actually, I'm free at the moment
17:05:27 <mtreinish> oh ok
17:05:33 <mtreinish> then go ahead
17:05:49 <sdague> here is the branchless-tempest qa-spec draft - https://review.openstack.org/#/c/86577/
17:06:21 <mtreinish> #link https://review.openstack.org/#/c/86577/
17:06:31 <sdague> it's a summary of what's been discussed, as well as a bunch of specific scenarios. I was hoping to get rounds of feedback today on it.
17:07:14 <mtreinish> yep I'm working on some comments on it
17:07:31 <mtreinish> that'll be a good one of the first 4 to get merged
17:07:50 <dkranz> sdague: Do you think a "plan for havana" should be part of that or separate?
17:08:12 <dkranz> sdague: I made a few comments about it in review.
17:08:13 <sdague> dkranz: I feel like havana is still up for debate relative to the amount of work it would be
17:08:24 <sdague> so I think that would be a second qa-spec
17:08:57 <sdague> this is the basic path for icehouse, then we have the decision on whether we believe backport to havana is useful to do before havana expires
17:09:02 <dkranz> sdague: That depends. It could be that just skipping what does not work would be enough to start.
17:09:31 <sdague> dkranz: definitely
17:09:46 <sdague> dkranz: actually, you want to take the pen on the havana spec, as you've got most of the data
17:09:57 <dkranz> sdague: And upstream is willing to discard releases much more rapidly than many users are so we have to be careful
17:10:02 <dkranz> sdague: Yes, I can do that.
17:10:55 <sdague> great
17:11:14 <dkranz> sdague: I will do both that and no-admin spec before EOD tomorrow.
17:11:19 <sdague> #action dkranz to write up qa-spec on havana/stable testing with tempest master
17:11:24 <sdague> sounds good to me
17:11:53 <sdague> that's all I had unless there are questions
17:11:59 <mtreinish> ok, I wanted to point out that sdague moved all the open non-high prio bps on lp back to new from whatever status they were at
17:12:25 <mtreinish> in preperation for using the specs repo for Juno
17:12:35 <mtreinish> but that still leaves 4 open high prio bps
17:12:38 <mtreinish> for Icehouse
17:13:26 <mtreinish> I think we can close 2 of them soon after Juno opens
17:13:36 <mtreinish> the unit test one I plan to close at release
17:13:53 <mtreinish> and the neutron full gating one should be turned on soon after Juno opens
17:14:06 <sdague> sounds good
17:14:17 <mtreinish> and andrea has a spec for the multiauth already
17:14:27 <mtreinish> so that just leaves: https://blueprints.launchpad.net/tempest/+spec/tempest-heat-integration
17:15:06 <mtreinish> sdague: do you know what the status of that is?
17:15:09 <sdague> yeh, I think once we open the qa-specs repo for more general consumption, we should ask the heat folks to redo that as a spec
17:15:20 <sdague> it's not really specific enough to track at this point honestly
17:15:39 <mtreinish> ok
17:15:42 <mtreinish> makes sense
17:16:07 <mtreinish> does anyone else have any blueprints they wanted to bring up or discuss?
17:17:09 <mtreinish> ok then let's move on to the next topic
17:17:17 <mtreinish> #topic Neutron testing
17:17:23 <mtreinish> mlavalle: are you around?
17:17:26 <mlavalle> hi
17:17:34 <mtreinish> are there any updates on neutron testing?
17:18:03 <mlavalle> we have continued making progress with api testing. ASt this point we have merged 20 pathcsets out of 28 we are tracking
17:18:23 <mlavalle> e also recovered the 5 patchsets that were abandoned and they are being actively worked on
17:18:51 <mlavalle> so we are in good shape to complete the coverage we defined at the beginning of Icehouse
17:19:14 <mlavalle> this week I have also been working with yfried on a plan for scenario tests for Juno
17:19:32 <mlavalle> we want to create a blueprint with the scanerios we want to implement in Juno
17:19:50 <sdague> mlavalle: great, please submit that to the qa-specs repo, that's how we're doing review on these
17:19:52 <mtreinish> mlavalle: yeah you can go ahead and push a spec to the qa-specs repo for that when you're ready
17:19:55 <dkranz> mlavalle: Great!
17:20:08 <mlavalle> and would like to have a session in Atlanta to review them with the team and get a buy in from both the Neutron and Tempest teams
17:20:32 <mlavalle> once we achieve that, we will send an email to the ML inviting people to implemet the specified tests
17:20:35 <dkranz> mlavalle: Please add it to the etherpad
17:20:44 <mlavalle> and track them throuout Juno
17:20:56 <mlavalle> Yes, I will add the session to the summit etherpad
17:21:00 <mtreinish> mlavalle: ok well propose the session in the tool but also add it to the etherpad: https://etherpad.openstack.org/p/Juno-QA-design-summit-topics
17:21:00 <dkranz> mlavalle: https://etherpad.openstack.org/p/Juno-QA-design-summit-topics
17:21:11 <mlavalle> and will bring the proposal to the Neutron IRC meeting next Monday
17:21:33 <mlavalle> that's all I have
17:21:47 <mtreinish> mlavalle: ok cool, thanks
17:21:57 <mtreinish> does anyone have anything else to discuss about neutron testing?
17:22:37 <mtreinish> ok, then lets move on
17:22:42 <mtreinish> #topic Heat testing
17:23:03 <mtreinish> so I've seen a few heat patches in progress recently
17:23:24 <mtreinish> sdague: you were the one who asked for this to be a regular topic
17:23:33 <mtreinish> so do you have any updates?
17:24:34 <mtreinish> stevebaker: is there anything worth mentioning on the heat tempest front?
17:25:31 <sdague> mtreinish: there are a few in flight
17:25:31 <mtreinish> ok well I guess we can move on then :)
17:25:37 <sdague> but nothing major right now
17:25:41 <mtreinish> sdague: ok
17:25:55 <mtreinish> #topic Bugs
17:26:20 <mtreinish> So I haven't looked at the numbers lately but I was doing a little triage earlier this week
17:26:28 <mtreinish> it seems pretty tame
17:26:40 <mtreinish> does anyone have any bugs that they'd like to bring up?
17:27:34 <mtreinish> ok then let's move on
17:27:39 <mtreinish> #topic
17:27:40 <mtreinish> Critical Reviews
17:27:48 <mtreinish> well I failed there...
17:27:54 <afazekas> #link https://review.openstack.org/#/c/86265/
17:27:54 <mtreinish> #topic Critical Reviews
17:28:19 <mtreinish> I have one today too:
17:28:21 <mtreinish> #link https://review.openstack.org/#/c/86174/
17:28:38 <mlavalle> I have a couple that only need one more +2 to merge
17:28:49 <mtreinish> afazekas: I think there is an oslo thing to do that
17:28:53 <mlavalle> https://review.openstack.org/#/c/66259
17:28:55 <mtreinish> save and reraise or something like that
17:29:08 <mlavalle> https://review.openstack.org/#/c/66541
17:29:10 <afazekas> mtreinish: It does the opsite as I remember
17:29:33 <mtreinish> #link https://review.openstack.org/#/c/66259
17:29:39 <mtreinish> #link https://review.openstack.org/#/c/66541
17:29:43 <afazekas> s/opsite/opposite/
17:29:49 <mtreinish> afazekas: ok I'll take a closer look
17:30:47 <mtreinish> mlavalle: I'll put those on my list for today
17:31:00 <mlavalle> thanks! :-)
17:31:06 <mtreinish> Does anyone else have any reviews?
17:32:04 <mtreinish> ok then let's open up the floor
17:32:09 <mtreinish> #topic open discussion
17:32:09 <afazekas> #link old https://review.openstack.org/#/c/84533/
17:32:42 <afazekas> #link old https://review.openstack.org/#/c/78345/
17:33:21 <mtreinish> ok does anyone have any topics they would like to discuss?
17:34:33 <mtreinish> ok well then I guess we'll call it a meeting early today
17:34:35 <mtreinish> thanks everyone
17:34:53 <mlavalle> this was a quicj one
17:34:56 <mtreinish> #endmeeting