17:00:08 <mtreinish> #startmeeting qa
17:00:12 <openstack> Meeting started Thu Aug 14 17:00:08 2014 UTC and is due to finish in 60 minutes.  The chair is mtreinish. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:15 <openstack> The meeting name has been set to 'qa'
17:00:24 <mtreinish> hi who do we have here today?
17:00:27 <afazekas> o/
17:00:29 <mtreinish> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_August_14_2014_.281700_UTC.29
17:00:29 <mlavalle> hi
17:00:31 <maurosr> hey
17:00:41 <mtreinish> ^^^ today's agenda
17:00:48 <psedlak> hi
17:01:09 <andreaf> o/
17:01:19 <asselin> o/
17:01:39 <mtreinish> ok let's get started
17:01:51 <mtreinish> #topic Name for tempest library (mtreinish)
17:01:56 <dpaterson> o/
17:02:25 <mtreinish> so as part of splitting off parts of tempest into a library
17:02:31 <mtreinish> we need to make a new repo
17:02:47 <mkoderer> o/
17:02:51 <mtreinish> I wanted to call it mesocyclone
17:02:53 <jlanoux> hi
17:03:09 <mtreinish> but some people have expressed issue with that name
17:03:17 <andreaf> mtreinish: seriously? :D
17:03:41 <mtreinish> I've heard from some people that since it's a library a more functional name is more appropriate
17:03:42 <mlavalle> mtreinish: what's the rationale behind that name?
17:03:54 <mtreinish> mlavalle: mesocyclone is a precursor to a tornado
17:03:57 <dkranz> o/
17:04:21 <mlavalle> mtreinish: I like it. + 1 fro  me
17:04:31 <dpaterson> twister
17:04:48 <mtreinish> I'm planning to take it to the ml before I do the split
17:04:54 <mtreinish> but I wanted to bring up here first
17:05:06 <mtreinish> to get people thinking about it :)
17:05:07 <dkranz> mtreinish: I like it but maybe it is too long
17:05:11 <jlanoux> blackstorm?
17:05:16 <mkoderer> ahm sry.. maybe I missed that... why are we doing that?
17:05:43 <mtreinish> mkoderer: http://specs.openstack.org/openstack/qa-specs/specs/tempest-library.html
17:06:06 <psedlak> tempestish? :)
17:06:11 <afazekas> tsepmet - tempest in reverse order
17:06:14 <mkoderer> lol
17:06:19 <maurosr> lol
17:06:20 <dkranz> mtreinish: Is there a proposed list of what will be moved? The spec doesn't really say.
17:06:28 <mtreinish> dkranz: not yet
17:06:38 <mtreinish> I was going to start with the cli
17:06:44 <mtreinish> and the rest client
17:06:48 <mtreinish> and go from there
17:06:54 <mtreinish> cli tests that is
17:07:24 <mtreinish> I have to do a list of everything that makes sense to split off still
17:07:30 <dkranz> mtreinish: rest client drags auth and conf and ...
17:07:38 <mtreinish> auth yes
17:07:49 <mtreinish> but I'm going to refactor it to take in args instead of a conf
17:07:56 <mtreinish> to make it portable
17:08:01 <mtreinish> I think I put that part in the spec
17:08:03 <dkranz> mtreinish: great. we needed to do that anyway
17:08:26 <mtreinish> ok is there anything else on this topic?
17:08:50 <psedlak> mtreinish: are there already proposed names? something to pick from? or is this first round?
17:09:03 <mtreinish> psedlak: this is the first round
17:09:05 <afazekas> tempest-lib / lib-tempest
17:09:15 <mkoderer> libtemp ;)
17:09:17 <andreaf> what about calm? the calm before the storm
17:09:24 <psedlak> andreaf: ++
17:09:27 <mtreinish> afazekas: yeah that would be a more functional name
17:09:49 <mtreinish> anyway I'll put it on the ML
17:10:08 <andreaf> mtreinish: a really functional name would be something like integration-test-lib which is ugly :D
17:10:24 <mtreinish> andreaf: yeah that was my concern :)
17:10:33 <mkoderer> libit then
17:10:33 <afazekas> oepnstack-pythonclient
17:10:37 <jlanoux> mesocyclone is fine for me ;)
17:10:45 <mtreinish> jlanoux: heh, yeah I like it too
17:11:02 <mtreinish> plus google a picture of it, it's cool looking
17:11:14 <mtreinish> anyway lets move on
17:11:30 <mtreinish> #topic Specs Review
17:11:51 <mtreinish> so I haven't had a chance to review any specs lately
17:12:02 <mtreinish> are there any that people would like to get eyes on
17:12:05 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:12:09 <andreaf> I have one
17:12:13 <andreaf> #link https://review.openstack.org/#/c/94741/
17:12:25 <andreaf> I refreshed the ssh auth strategy one
17:12:28 <dkranz> mtreinish: https://review.openstack.org/#/c/104098/ is waiting for +A from you
17:12:59 <dkranz> https://review.openstack.org/#/c/86967/ is looking for another +2
17:13:08 <mtreinish> dkranz: hmm, ok I'll take a look
17:13:41 <mtreinish> but for the provider networking one I'm wondering if it belongs under the existing neutron testing bp
17:14:22 <mtreinish> dkranz: the seond one should be fine, but I'll take a closer look after the meeting
17:14:28 <dkranz> mtreinish: It might but I'm not sure we need more spec churn
17:14:48 <mtreinish> andreaf: oh, yeah that one, I need to take a close look
17:14:56 <mtreinish> dkranz: fair enough
17:15:15 <mtreinish> andreaf: cleaning up the ssh code is definitely something we need to do
17:15:20 <andreaf> mtreinish: yes I updated it - included the idea of wait_for_sshable that sdague mentioned in some meeting
17:15:40 <andreaf> mtreinish: and it's something that should probably go in the library as well
17:15:41 <mtreinish> cool
17:15:47 <mtreinish> yeah definitely
17:16:01 <mtreinish> but we don't necessarily have to hold up work on it until the library is a thing
17:16:15 <mtreinish> it'll all depend on the timing I guess
17:16:24 <andreaf> mtreinish: right it can be done in tempest and moved across
17:16:36 <andreaf> to mesocyclone - if I can spell it :P
17:16:48 <mtreinish> ok, are there any other specs?
17:17:34 <mtreinish> then let's move on
17:17:42 <mtreinish> #topic Blueprints
17:17:52 <mtreinish> #link https://blueprints.launchpad.net/tempest
17:18:06 <mtreinish> so we've still got a large number of open blueprints
17:18:20 <mtreinish> does anyone have a status update on an open bp?
17:18:29 <mkoderer> I nearly finished with the api schema unification
17:18:40 <mkoderer> but I need reviews... https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/api-schema-unification,n,z
17:18:47 <mtreinish> mkoderer: awesome
17:19:01 <andreaf> mkoderer: I'll check those
17:19:22 <dpaterson> I sumbitted pull req for review.
17:19:23 <mkoderer> and I started to work on a porting guide for negative tests
17:19:27 <dpaterson> #link https://review.openstack.org/#/c/112581/
17:19:57 <mtreinish> dpaterson: ok, cool
17:20:10 <mkoderer> dpaterson: nice
17:20:11 <mtreinish> it's good to see progress being made on things
17:20:43 <andreaf> mtreinish: regarding scenario migration to tempest client
17:21:28 <andreaf> mtreinish: we have *a lot* of changes up, but they all depend on the initial one still not merged - so I need reviews on these three
17:22:20 <andreaf> https://review.openstack.org/#/c/107428 https://review.openstack.org/#/c/107552 https://review.openstack.org/#/c/107562
17:22:42 <mtreinish> andreaf: ok, yeah I'll take a look at those soon
17:22:51 <andreaf> mtreinish: thanks
17:23:09 <mtreinish> also, for the test-accounts bp we're making progress
17:23:16 <mtreinish> the alternate credential provider has landed
17:23:22 <andreaf> regarding test accounts, your change is merged, and I just changed mine to use deprecated option for tenant isolation
17:23:25 <mtreinish> so now it's a matter of aactually using it
17:23:33 <mtreinish> andreaf: heh
17:24:05 <mtreinish> ok are there any other bps to discuss?
17:24:16 <andreaf> and there are two other changes in progress by psedlak for a tool to generate credentials and its use in devstack
17:24:49 <mkoderer> andreaf: did you checked the -1 from yair on https://review.openstack.org/#/c/107562
17:25:09 <asselin> i haven't had a chance to rework the stree test BP. It's next after I get 3rd party ci working for my team.
17:25:23 <mtreinish> asselin: ok nice
17:25:59 <andreaf> mkoderer: oh yes thanks I almost forgot I'll make a new patch later today for that
17:26:02 <mtreinish> I was curious what the status was on that one
17:26:33 <mtreinish> ok are there any other bps to discuss? Otherwise we can move on
17:27:30 <mtreinish> #topic Grenade
17:27:51 <mtreinish> so we merged the patch to start using javelin2
17:28:06 <mtreinish> which is awesome
17:28:29 <mtreinish> so now we can start at iterate on feature improvements there
17:28:54 <mkoderer> btw I realized that we have too few grenade cores IMHO
17:29:04 <mtreinish> aside from that I'm not aware of any big updates on grenade
17:29:13 <mtreinish> mkoderer: yeah, I agree
17:29:28 <mtreinish> jogo was just added
17:29:37 <mtreinish> but 3 is still kind of few
17:29:40 <mkoderer> I think we have three
17:29:52 <mtreinish> mkoderer: yeah
17:30:11 <mtreinish> the issue is not too many people have been actively reviewing things there
17:30:50 <mtreinish> I would like to grow that
17:31:02 <mkoderer> yep.. I think there aren't many ppl aware of this project
17:31:45 <mtreinish> heh, that might be, but I'm not sure
17:32:12 <psedlak> also imho it's not directly usefull/usable to/by anyone directly
17:32:40 <mtreinish> psedlak: well it's mostly for gating and testing an upgrade locally for dev
17:32:47 <mtreinish> not for doing it in production
17:33:01 <psedlak> mtreinish: right, though i'm not sure if devs are going to use it much localy act.
17:33:09 <dkranz> mtreinish: I am not that familiar with grenade but should that be revisited?
17:33:32 <mtreinish> dkranz: probably not, because it's based on devstack
17:33:38 <dkranz> mtreinish: I think the moves to make tempest not have any devstack dependency helped its adoption a lot
17:33:54 <psedlak> mtreinish: so at the end i think it's "just" kind of thing like "gating glue"
17:34:11 <mtreinish> dkranz: it's not meant to be general purpose tool
17:34:29 <dkranz> mtreinish: I get that
17:34:35 <andreaf> there were some discussions at the infra mid-cycle about making grenade general purpose, but it would be very little left
17:34:49 <andreaf> most of grenade content is devstack specific probably
17:34:55 <dkranz> mtreinish: I was just wondering how much abstraction/pluggability it would need to serve more general purpose
17:35:04 <mtreinish> dkranz: almost everything
17:35:13 <dkranz> mtreinish: ok :)
17:35:19 <mtreinish> it's basically devstack++
17:35:20 <mkoderer> so I think what be a good idea if some of us have a closer look to grenade? ;)
17:35:36 <mtreinish> mkoderer: heh, yes I agree :)
17:35:42 <andreaf> dkranz mtreinish so it would be good to have a grenade kind of tool for tripleo environment, but how much could we reuse really?
17:36:11 <mtreinish> andreaf: it's more the methodology you can use
17:36:19 <andreaf> yep
17:36:19 <mtreinish> and javelin2 would also be useful
17:36:36 <mtreinish> to test things stay up through an upgrade
17:37:07 <mtreinish> ok is there anything else on grenade?
17:37:54 <mtreinish> ok then lets move on
17:38:04 <mtreinish> #topic Neutron testing
17:38:20 <mtreinish> so salv-orlando is really close to merging parallel full neutron everwhere
17:38:28 <mtreinish> which is exciting
17:38:33 <mkoderer> cool
17:39:18 <mtreinish> mlavalle, salv-orlando: are there any other updates on neutron testing?
17:39:48 <mlavalle> mtreinish: I've been investing time developing the client and api test for the new LBaaS api
17:39:50 <andreaf> mtreinish: so just a note to keep an eye on the full job even if not voting
17:40:05 <mlavalle> mtreinish: I've been sending updates to the ML
17:40:09 <mtreinish> andreaf: oh yes, good point
17:40:14 <mtreinish> mlavalle: yes I've been seeing those
17:40:38 <mlavalle> mtreinish: I have also been helping the group based policy to develop their tests
17:40:55 <mlavalle> they are developing them themelves but I've been training and guiding them
17:41:15 <mtreinish> ok, cool
17:41:57 <mlavalle> and I intend to start developing an scenario test for the new LBaaS api. I will follow the work that andreaf has been doing with test_minmum_basic to convert it to the tempest client
17:42:15 <mlavalle> that's all I have this week
17:42:32 <mtreinish> mlavalle: how does that differ from the existing LBaaS scenario test?
17:42:45 <mtreinish> just covers more of the api?
17:43:03 <mlavalle> mtreinish: the absatractions offered by the new api are different
17:43:08 <mtreinish> ahh, ok
17:43:23 <mlavalle> I really intend to reuse the current scenario test and convert it to the new abstractions
17:43:31 <mtreinish> ok that makes sense
17:43:37 <mlavalle> and make the move to tempest client
17:44:11 <mtreinish> good, that'll make everyone happy :)
17:44:13 <mlavalle> my belief is that by statying close to the new Neutron subprojects we will keep the api and scenario tests fresh
17:44:26 <mlavalle> instead of always catching up
17:44:52 <mtreinish> yeah that'll probably help
17:45:01 <mtreinish> ok is there anything else to discuss on neutron testing?
17:45:01 <mlavalle> ok, that's all I have
17:45:08 <mlavalle> :-)
17:45:40 <mtreinish> ok then let's move on
17:45:47 <mtreinish> #topic bugs
17:46:13 <mtreinish> so I haven't been watching the bug list too closely the past few weeks
17:46:23 <mtreinish> #link https://bugs.launchpad.net/tempest
17:46:41 <mtreinish> but we've got 259 open bugs right now
17:46:42 <andreaf> mtreinish: I didn't really look at bugs either - how do we keep them under control usually?
17:46:57 <mtreinish> andreaf: not very well honestly :)
17:47:16 <mtreinish> I'm thinking we might need to do a bug day soon
17:47:33 <mtreinish> it'll also be helpful if someone volunteered to keep on top of them after the bug day
17:47:50 <mkoderer> yep a bug day is a good idea
17:47:57 <mtreinish> so we don't grow to this level again
17:48:17 <mtreinish> are there any volunteers to organize a bug day?
17:48:36 <mtreinish> maurosr: I believe you did the last one :)
17:49:11 <dkranz> mtreinish: Does that involve more than picking a day and sending out emails?
17:49:27 <mtreinish> dkranz: not much, just tracking the results
17:49:34 <mtreinish> and pestering people to look at bugs
17:49:44 <andreaf> :D
17:49:51 <mtreinish> oh and changing the topic in the -qa channel :)
17:50:26 <mtreinish> well don't everyone volunteer at once
17:50:27 <dkranz> mtreinish: ok, I will find some one or do it
17:50:33 <mtreinish> dkranz: ok awesome
17:50:42 <mtreinish> #action dkranz to find a volunteer to organize a bug day
17:50:49 <mtreinish> ok then lets move on
17:50:49 <dkranz> mtreinish: I is during August too early?
17:50:57 <mtreinish> no I think that'll be fine
17:51:03 <andreaf> mtreinish: does one need special status to triage bugs in lp or how does that work?
17:51:04 <mtreinish> as long as there's a weeks notice
17:51:14 <mtreinish> andreaf: I think there is a tempest bug team
17:51:18 <mtreinish> in lp
17:51:22 <mtreinish> but membership is open
17:51:32 <andreaf> mtreinish, oh ok
17:51:34 <dkranz> For folks here is there any day of week that is bad. Just asking...
17:52:08 <mtreinish> dkranz: well I like to have it before thurs so we can do a summary during the meeting
17:52:15 <mtreinish> but that's not the biggest deal
17:52:33 <dkranz> mtreinish: ok, then it shall be Mon,Tue,or Wed
17:52:42 <dkranz> mtreinish: we can move on
17:52:45 <mtreinish> ok
17:52:53 <mtreinish> #topic Critical Review
17:53:01 <mkoderer> I am worried about https://review.openstack.org/#/c/113900/
17:53:05 <mtreinish> ok in the time remaining does anyone have any reviews that need more eyes
17:53:15 <mkoderer> I thought flake8 checks the indentation
17:53:26 <mtreinish> mkoderer: it does, that's from pylint
17:53:36 <mtreinish> I'm actually -1 there, because if we don't automate it
17:53:44 <mtreinish> I don't see a point in correcting it periodically
17:53:50 <mtreinish> it'll just cause rebase churn
17:54:00 <dkranz> mtreinish: I agree
17:54:19 <mkoderer> mtreinish: but having over indented lines are ugly
17:54:24 <mkoderer> but anyway :)
17:54:40 <mtreinish> mkoderer: yeah, so we need to check that in the pep8 jobs then :)
17:54:48 <andreaf> mkoderer I think what mtreinish is saying is that we need an hacking rule for that?
17:54:52 <mtreinish> I don't want to fix a style issue unless it's enforcing
17:54:52 <mkoderer> danny is working on that currently
17:55:08 <mkoderer> the pylint jobs in cinder didn't cover it too
17:55:23 <mtreinish> mkoderer: ok, well I'm going to -2 it with that comment until we run the check in the gate we can't merge it
17:55:58 <mkoderer> mtreinish: ok I will talk to danny that he is not sad :)
17:56:09 <mtreinish> I'll try to be more verbose to make it clear to try and not upset him :)
17:56:14 <mtreinish> but on this note:
17:56:22 <mtreinish> #link https://review.openstack.org/98909
17:56:31 <mtreinish> #link https://review.openstack.org/98918
17:56:52 <mtreinish> if we can get those merged it'll turn back on all the rules we had to disable with the last hacking update
17:56:58 <mtreinish> they just need +As
17:57:12 <mtreinish> asssuming they don't need another rebase...
17:57:18 <mkoderer> mtreinish: ok I will have a look
17:57:57 <mtreinish> ok are there any other reviews that people would like to bring up?
17:59:08 <mtreinish> ok then I guess we can end ~1min early
17:59:12 <mtreinish> thanks everyone
17:59:29 <dpaterson> cheers
17:59:31 <mtreinish> #endmeeting