22:00:12 <gmann> #startmeeting qa
22:00:14 <openstack> Meeting started Thu Jan 22 22:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:18 <openstack> The meeting name has been set to 'qa'
22:00:28 <gmann> Hi, who all here today?
22:00:43 <riwinters> hello
22:00:58 <gmann> riwinters: hello
22:01:36 <gmann> may be ppl ll join later . Let�s start meeting
22:01:47 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_January_22nd_2015_.282200_UTC.29
22:01:52 <gmann> ^^^ Today's agenda
22:02:18 <gmann> #topic Specs Reviews
22:02:39 <gmann> Does anyone have any open spec review to discuss?
22:03:26 <gmann> Ok, if nothing then, let's move onto the next topic
22:03:28 <riwinters> no :)
22:03:39 <gmann> #topic Blueprints
22:03:58 <gmann> Any open blueprints that we need to discuss or any status updates?
22:04:53 <gmann> I want to bring some updates on rest_client movement to tempest-lib on which oomichi is working
22:05:03 <gmann> rest_client has been moved to tempest-lib (version 0.1.0).
22:05:27 <gmann> global requirement updates is required because of  tempest-lib version up
22:05:39 <gmann> patch is up for that
22:05:40 <gmann> #link https://review.openstack.org/#/c/148789/
22:06:48 <gmann> you may get import error with tempest-lib version up
22:07:25 <gmann> so once global requirement is updated, its all good
22:07:47 <gmann> oomichi is working on service clients movement.
22:07:55 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:service-client,n,z
22:08:17 <gmann> Anything else on BP updates
22:08:41 <gmann> riwinters: looks like we 2 of us here :)
22:08:53 <riwinters> yes - :)
22:09:00 <gmann> ok, let�s move onto next topic.
22:09:02 <afazekas> o/
22:09:09 <gmann> #topic Devstack
22:09:14 <gmann> afazekas: hi
22:09:50 <gmann> sdague, dtroyer: u guys around
22:10:57 <dkranz> o/
22:11:01 <dpaterson> o/
22:11:07 <gmann> anything on devstack from anyone
22:11:46 <curtis_penner> o/
22:12:13 <gmann> let's move onto the next topic then
22:12:19 <gmann> #topic Grenade
22:12:52 <gmann> Anyone has anything to discuss on Grenade
22:13:53 <gmann> #topic Bugs
22:13:56 <gmann> #link https://etherpad.openstack.org/p/Tempest-bug-report
22:14:04 <gmann> ^^This week bug report
22:14:31 <gmann> I had the triage rotation this week. maurosr will have for next week.
22:14:43 <gmann> #link  https://etherpad.openstack.org/p/qa-bug-triage-rotation
22:15:06 <gmann> Need more volunteer for triage rotation.
22:15:08 <dkranz> gmann: I put myself in for three weeks from now
22:15:26 <gmann> dkranz: great. Thanks..
22:15:35 <dkranz> gmann: maybe send an email to ask for volunteers
22:15:54 <dkranz> NOt such a big job now that we have caught up
22:16:07 <gmann> dkranz: yes, that will be good i will do that.
22:16:45 <gmann> #action: gmann to send mail for bug triage volunteers
22:17:15 <gmann> i have put myself for feb-2 week
22:17:49 <gmann> anything else on this topic.
22:18:29 <gmann> ok, so move to next topic
22:18:35 <gmann> #topic Critical Reviews
22:18:48 <gmann> Does anyone have any critical reviews they'd like to bring up?
22:19:59 <gmann> dkranz: regarding service client (neutron one) movement to lib
22:20:22 <gmann> oomichi has started the work
22:20:24 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:service-client,n,z
22:20:28 <dkranz> gmann: I discusssed this with marun
22:20:49 <gmann> dkranz: ok
22:21:26 <dkranz> gmann: The important thing is to have a version of the client in tempest that can be used outside. After https://review.openstack.org/148773 merges we will have that
22:21:42 <dkranz> gmann: the neutron team can experiment a little with a copy
22:22:03 <dkranz> gmann: of course we need to fix the auth/credentials thing but it is not strictly necessary for them to proceed
22:22:25 <dkranz> gmann: They are going to be using the client in a no-auth way in any event
22:22:46 <gmann> dkranz: ok, then its fine.
22:23:01 <gmann> i will do review for client movement
22:23:11 <gmann> and auth work can be done in parallel
22:23:27 <dkranz> gmann: Since it will be much harder to make changes to clients after they move, it would be good to have a little settling time before actually moving
22:23:47 <dkranz> gmann: But we should not allow any changes to the neutron client unless approved by the neutron team
22:24:07 <dkranz> gmann: they do have a goal of moving the neutron api tests into the neutron tree
22:24:14 <dkranz> gmann: but there are still some issues to work out
22:24:27 <dkranz> gmann: like how we will continue to have a coherent test suite after that happens
22:24:56 <gmann> dkranz: yes, that true. I discussed about neutron advance service tests in tempest with Matt
22:25:05 <gmann> dkranz: he has also same thought.
22:25:16 <dkranz> gmann: and of course we will still need integration tests in tempest that exercise the neutron apis as called from other services
22:25:46 <dkranz> gmann: so I think marun will propose something
22:26:00 <gmann> dkranz: thats make sense.
22:26:15 <dkranz> ok, that's about all I have on that subject
22:26:34 <dkranz> I will be on vacation next but will get back to more client-returns-one-value changes after that.
22:26:35 <gmann> dkranz: more nd more scenario tests should be welcome
22:26:49 <gmann> dkranz: Thanks a lot.
22:27:02 <dkranz> gmann: yes, but we should make sure they are really integration tests
22:27:33 <gmann> dkranz: yes.
22:28:48 <gmann> anything else on review side
22:29:47 <gmann> #topic open discussion
22:30:06 <gmann> as we have much time, anything anyone want to discuss
22:31:53 <gmann> ok, if there is nothing else, we'll end here
22:32:24 <gmann> Thanks everyone for joining the meeting.
22:32:32 <gmann> Have a great day/night
22:32:41 <gmann> #endmeeting