22:00:59 <mtreinish> #startmeeting qa
22:01:00 <openstack> Meeting started Thu Jun 25 22:00:59 2015 UTC and is due to finish in 60 minutes.  The chair is mtreinish. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:03 <openstack> The meeting name has been set to 'qa'
22:01:13 <mtreinish> hi, who's here today?
22:01:22 <gmann> hi
22:01:38 <mtreinish> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_June_25th_2015_.282200_UTC.29
22:01:43 <mtreinish> ^^^ today's agenda
22:02:35 <mtreinish> jogo, dtroyer, oomichi, masayukig: around?
22:03:04 <mtreinish> gmann: heh, it might be just us today
22:03:20 <gmann> masayukig: he was working late night in office so he would not be able to join
22:03:24 <gmann> heh
22:03:50 <mtreinish> well, I guess that's a good segway into the first topic
22:04:01 <gmann> dkranz:  on vacation ?
22:04:04 <mtreinish> #topic Moving 2200 UTC meeting time a little later (mtreinish)
22:04:05 <mtreinish> gmann: yep
22:04:38 <mtreinish> so this is something we've discussed informally before, but I wanted to get it on the agenda before I took it to the ML
22:04:50 <mtreinish> which is attendance for the 2200 UTC meeting is light
22:05:08 <mtreinish> it's too early for a lot of APAC
22:05:16 <mtreinish> so I'll start a ML poll and find a better time
22:05:18 <gmann> yea
22:05:30 <jogo> mtreinish: sort of
22:05:33 <Rockyg> ++
22:05:58 <gmann> mtreinish: +++ :)
22:06:37 <mtreinish> #action mtreinish to start a ML poll to find a better time for the 2200UTC meeting
22:06:50 <mtreinish> ok, well that settles this topic
22:07:06 <dtroyer> o/
22:07:15 <mtreinish> let's move on
22:07:25 <mtreinish> #topic Specs Reviews
22:08:04 <mtreinish> does anyone have an open spec review they'd like to bring up?
22:08:27 <mtreinish> #link https://review.openstack.org/184992
22:08:35 <mtreinish> I wanted to bring that one up again
22:08:57 <mtreinish> someone else needs to +A that, so we can get started on it
22:09:09 <mtreinish> it depends on some of the CLI stuff being implemented
22:09:16 <gmann> mtreinish: i have just one concern about admin writable resources tests in more than one places
22:09:25 <mtreinish> I'll bug dpaterson about that tomorrow
22:09:34 <gmann> after that m +A
22:10:06 <mtreinish> gmann: so honestly I'm not sure how much of a concern that really is because we can't control what plugins are doing
22:10:09 <gmann> because tempest tests + plugin tests will be running on same env and can bring conflict issue
22:10:44 <mtreinish> that's kinda of the point. If the plugins are doing something wrong (like not protecting against global scope resources) that's a bug in the plugin
22:11:28 <gmann> mtreinish: yea, that will kinda bug but i agree we can control that manually if anyone does
22:11:47 <mtreinish> we're just using oslo.concurrency for locking so they can leverage that too. (although we probably can move the tempest specific fixture which just sets a name to the lib or something)
22:13:32 <mtreinish> ok, is there anything else on specs?
22:13:38 <gmann> can we document that somewhere? for plugin writer benefit
22:14:13 <mtreinish> gmann: yeah, I plan to have a detailed doc in tempest on the plugin interface and writing plugins once the interface works
22:14:14 <Rockyg> gmann:  ++ a guidelines section or devref for that?
22:14:20 <gmann> that make sense to me for using locking there if they want
22:14:43 <mtreinish> I didn't think that made sense to do before we've even started working on the interface
22:15:01 <Rockyg> mtreinish: ++ ;-)
22:15:10 <gmann> mtreinish: Thanks. m will review that spec. mostly lGTM
22:15:20 <mtreinish> gmann: ok, cool thanks
22:15:28 * afazekas checking the plugin loading costs..
22:15:33 <gmann> mtreinish: +1 after working condition we can write doc
22:15:51 <mtreinish> afazekas: man you're online late :)
22:16:00 <gmann> :)
22:16:20 <mtreinish> afazekas: yeah I'm not sure what the overhead is for stevedore loading, but I think it'll be pretty minimal compared to everything else
22:16:20 <afazekas> mtreinish: It's meeting time :)
22:17:01 <afazekas> mtreinish: If it means all python package scan..
22:18:54 <mtreinish> afazekas: I'm pretty sure it uses pkg_resources to do an entry point list
22:20:13 <mtreinish> which anyway let's move on, since I don't think there are any other specs to discuss
22:20:19 <mtreinish> #topic Blueprints
22:20:28 <mtreinish> does anyone have an open bp to discuss?
22:20:33 <mtreinish> or give a status update on
22:22:34 <mtreinish> ok I guess not :)
22:22:37 <mtreinish> let's move on then
22:22:41 <mtreinish> #topic Devstack
22:22:51 <mtreinish> dtroyer: anything exciting in devstack land?
22:23:14 <mtreinish> although, like me, you're just coming back
22:23:17 <mtreinish> so maybe not
22:23:28 <dtroyer> I've been out for a while, but most exciting I've seen is sc68cal getting more neutron bits working
22:23:59 <dtroyer> also, I may have some folk to pick up the neutron re-write… film at eleven
22:24:42 <mtreinish> heh, ok
22:25:04 <mtreinish> yeah getting the linux bridge stuff will be cool
22:25:19 <dtroyer> lastly, there is cleaning up some of the WSGI service implementation going on, keystone merged, I'm working on some Nova bits now
22:25:20 <mtreinish> dtroyer: and I think everyone is looking forward to you rewriting neutron
22:26:20 <mtreinish> dtroyer: is this to have a common way of registering wsgi services?
22:26:47 <dtroyer> it changes where the files are loaded from (removed a copy) and makes the apache template files more common
22:26:57 <mtreinish> ah, ok
22:27:50 <mtreinish> ok, is there anything else on devstack?
22:27:59 <dtroyer> not from me
22:29:31 <mtreinish> ok, then let's move on
22:29:35 <mtreinish> #topic Grenade
22:29:44 <mtreinish> jogo, dtroyer: anything new for grenade this week?
22:29:58 <mtreinish> jogo: I know you've been looking at the work required for multi-node grenade right?
22:30:17 <jogo> mtreinish: mordred broke it
22:30:33 <mtreinish> jogo: heh, good to know
22:30:41 <jogo> new jobs are set up  to run tempest-smoke for nova-net and neutron
22:30:55 <jogo> to see how viable multinode grenade will be
22:31:01 <mtreinish> I think keeping mordred away from grenades is probably good for everyone
22:31:04 <jogo> and sdague said he will own those jobs
22:31:27 <jogo> mordred broke setting of the  hostname so both nodes have the same name and nova had a seizure
22:31:40 <mtreinish> oh, that explains the really bizarre errors
22:31:46 <jogo> yeah
22:32:25 <jogo> and I will not be here for next weeks meeting ... or any more
22:32:44 <mtreinish> jogo: tsk tsk
22:32:53 <dtroyer> -1
22:33:20 <mtreinish> jogo: what will you do if https://review.openstack.org/194774 actually lands?
22:33:35 <jogo> mtreinish: we will see ;)
22:33:50 <mtreinish> oh wait today was the spec freeze right?
22:33:57 <mtreinish> I guess dansmith will have to put in an exception
22:34:16 <mtreinish> ok, is there anything else on grenade?
22:35:05 <jogo> it can use a new core
22:35:32 <mtreinish> yes, I've been thinking about that ever since you told me you're leaving
22:36:07 <mtreinish> we'll come up with something
22:36:32 <mtreinish> which might be to just set up robo calls to spam your phone to do reviews
22:36:46 * jogo will be on IRC still
22:37:18 <gmann> jogo:  +1. just wanted to ask about your presence on IRC
22:38:21 <mtreinish> ok, let's move on
22:38:34 <mtreinish> #topic Bugs
22:38:41 <mtreinish> #link https://etherpad.openstack.org/p/Tempest-bug-report
22:38:41 <greghaynes> jogo: fix is up for that btw
22:38:55 <jogo> greghaynes: thanks!
22:39:04 <mtreinish> gmann: anything to report on bugs for this week?
22:39:23 <gmann> nothing special, did triaged this week.
22:39:51 <mtreinish> anything stand out during that?
22:40:07 <gmann> cleaned up bugs got to new state due to abandon patches but most of them were fixed by other patches
22:40:37 <gmann> mtreinish: regarding https://bugs.launchpad.net/tempest/+bug/1370086
22:40:38 <openstack> Launchpad bug 1370086 in tempest "Tempest ignores its custom virtualenv location" [Low,Confirmed] - Assigned to Ghanshyam Mann (ghanshyammann)
22:41:11 <gmann> mtreinish: it just need sync from oslo.incubator right or we keep tempest version of those scripts?
22:41:47 <mtreinish> gmann: those are oslo synced iirc
22:43:17 <gmann> mtreinish: i saw Temp st has old version than oslo
22:45:13 <mtreinish> ok, then we probably just need to sync
22:45:13 <gmann> mtreinish: ok thanks. I will put that today
22:45:13 <dims_> mtreinish: probablye this first (https://review.openstack.org/#/c/189127/) before you sync
22:45:13 <mtreinish> dims_: heh, good call :)
22:45:13 <mtreinish> dims_: well except that removes the install venv bit we were talking about
22:45:13 <dims_> mtreinish: ok, then i'll abandon this one
22:45:13 <mtreinish> from because the tempest version doesn't quite work
22:45:14 <dims_> gotcha
22:45:34 <mtreinish> ok is there anything else on bugs?
22:45:50 <gmann> nothing else from me
22:46:14 <mtreinish> ok, then let's move on
22:46:18 <mtreinish> #topic Critical Reviews
22:46:28 <mtreinish> Does anyone have any reviews they'd like to get extra eyes on?
22:47:24 <gmann> mtreinish: neutron client refactor are up
22:47:32 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:refactor_neutron_client,n,z
22:47:50 <mtreinish> gmann: oh, cool I'll take a look
22:47:58 <mtreinish> that should be easy to review
22:48:01 <gmann> mtreinish: Thanks
22:48:37 <mtreinish> gmann: oh, you know the next step after that is to split each resource type up into it's own module
22:48:57 <gmann> mtreinish: yes
22:49:20 <gmann> mtreinish: actually current refactor patches will conflict with https://review.openstack.org/#/c/186559/
22:49:49 <gmann> mtreinish: m ok to land that first if you want and then ll do rebase the refactor patches
22:49:51 <mtreinish> gmann: well dougwig wants to wait a bit longer on that, so he'll have to rebase
22:49:57 <mtreinish> it's just a delete so it'll rebase cleanly
22:49:59 <gmann> mtreinish: ok
22:50:21 <gmann> mtreinish: Thanks
22:50:34 <mtreinish> ok, are there any other reviews?
22:52:32 <mtreinish> ok, then let's open the floor
22:52:36 <mtreinish> #topic Open Discussion
22:52:50 <mtreinish> does anyone have a topic they'd like to discuss that wasn't on the agenda?
22:53:45 <mtreinish> ok, then I guess let's end here today
22:53:48 <mtreinish> thanks everyone
22:53:54 <gmann> Thansk all
22:53:56 <mtreinish> #endmeeting