17:01:37 <mtreinish> #startmeeting qa
17:01:37 <openstack> Meeting started Thu Jul 16 17:01:37 2015 UTC and is due to finish in 60 minutes.  The chair is mtreinish. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:40 <openstack> The meeting name has been set to 'qa'
17:01:45 <mtreinish> hi, who's here today?
17:01:53 <andreaf> o/
17:02:19 <mtreinish> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_July_16th_2015_.281700_UTC.29
17:02:23 <mtreinish> ^^^ today's agenda
17:02:44 <mtreinish> dkranz, mkoderer, sdague, dtroyer_zz, afazekas: around?
17:02:53 <dkranz> o/
17:03:28 <sdague> mtreinish: o/ amazingly enough
17:03:29 <dtroyer_zz> o/
17:03:42 <mtreinish> dtroyer_zz: you're not asleep? :)
17:03:55 <sdague> but I'm at the tire place so might have to leave mid way through meeting
17:03:59 <dtroyer_zz> I wish I was…  znc is confused
17:04:00 <mtreinish> ok, let's get started
17:04:07 <mtreinish> sdague: heh, sure np
17:04:16 <mtreinish> #topic New meeting time poll (mtreinish)
17:04:36 <mtreinish> so I just wanted to throw a reminder on here that the poll to reschedule the alternate timeslot for this meeting is still open
17:04:41 <mtreinish> #link http://doodle.com/eykyptgi3ca3r9mk
17:05:01 <mtreinish> if you have an opinion on when that should be scheduled feel free to vote
17:05:29 <mtreinish> I'm probably going to close the poll early next week, because next week's meeting will be at the new time
17:05:55 <dpaterson> o/
17:06:14 <mtreinish> ok is there anything else on this? Otherwsie we can move on
17:06:52 <mtreinish> #topic Specs Review
17:07:02 <mtreinish> ok does anyone have any open specs reviews to discuss?
17:07:12 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:07:53 <mtreinish> dkranz: oh, that non-admin tempest spec is still open. Do we still need a spec/bp for that?
17:08:12 <dkranz> mtreinish: I don't think so. It was basically done, perhaps not exactly in the same way.
17:08:40 <mtreinish> dkranz: ok, cool I'll abandon it then and close the bp
17:08:47 <mtreinish> dkranz: unless you wanted to take care of that?
17:09:04 <dkranz> mtreinish: I don't care, but we could mark it as Done rather than abandoned
17:09:18 <dkranz> mtreinish: not that it matters much
17:09:32 <dkranz> mtreinish: I'll abandon it
17:09:37 <mtreinish> ok, I'll leave it up to you :)
17:09:54 <mtreinish> are there any other specs to discuss? Otherwise let's move on
17:11:05 <mtreinish> #topic Blueprints
17:11:25 <mtreinish> does anyone have any in progress BPs they'd like to discuss?
17:12:39 <mtreinish> well I wanted to bring up the tempest cli improvements one and the tempest external plugin bp
17:13:07 <mtreinish> for the cli improvements work dpaterson and I have been testing the patches up: https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/tempest-cli-improvements,n,z
17:13:23 <mtreinish> it looks like tempest init works fine, but tempest run still needs a lot of work
17:13:50 <dpaterson> mtreinish: still a WIP in progress for me.  The init had one defect which we discussed but still working with run
17:14:13 <mtreinish> fwiw, you can still use init with just testr or ostestr and it works fine
17:14:25 <mtreinish> since run clearly doesn't work yet :)
17:14:36 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/tempest-cli-improvements,n,z
17:15:18 <mtreinish> dpaterson: oh, right I still need to push a fix for that path bug in tempest init
17:15:27 <mtreinish> dpaterson: can you leave a -1 vote on the review to remind me
17:15:43 <dpaterson> mtreinish: okay
17:15:46 <mtreinish> thanks
17:16:09 <mtreinish> the other BP I wanted to bring up was the tempest external plugin interface
17:16:24 <mtreinish> the base patches for that have landed already and mkoderer has been testing it on the manila side
17:16:48 <mtreinish> he found a couple of bugs which the fixes have already landed for
17:17:01 <mtreinish> so at this point the external test loading is working with the plugin interface
17:17:15 <andreaf> cool! :)
17:17:21 <dkranz> mtreinish: huge!
17:17:26 <mtreinish> the next step is to work on the config registration piece:
17:17:28 <mtreinish> #link https://review.openstack.org/197749
17:17:33 <mtreinish> yeah it's exciting
17:17:43 <mtreinish> mkoderer is working on getting the manila tests to use it all
17:18:00 <mtreinish> #link https://review.openstack.org/201955
17:18:47 <andreaf> mtreinish: is there anything to be done about extra requirements? Are they installed as part of the plugin installation?
17:18:59 <mtreinish> andreaf: they'll be handled as part of the plugin installation
17:19:10 <mtreinish> since for tempest to know about the plugin you need to install it
17:19:20 <mtreinish> otherwise the entry point won't be registered
17:19:39 <mtreinish> using entry points and stevedore for this actually end up simplifying a lot of problems like that
17:20:01 <andreaf> mtreinish nice :)
17:20:53 <mtreinish> are there any other BPs to discuss? otherwise let's move on
17:21:24 <andreaf> yes I wanted to mention the ssh-bp
17:21:40 <andreaf> #link http://specs.openstack.org/openstack/qa-specs/specs/tempest/ssh-auth-strategy.html
17:22:20 <andreaf> so the implementation of the common bits has made really good progress I think - the last patch just failed the gate :( but hopefully a recheck it's all is needed
17:23:06 <andreaf> next steps are either try and enable validation in the gate, or make a non-voting job with validation on
17:23:22 <mtreinish> andreaf: cool, it'll be nice to see this finishing up soon
17:23:23 <andreaf> and then start migrating all tests to use the common bits
17:23:24 <mtreinish> andreaf: has the deprecation of the old options started?
17:23:32 <andreaf> mtreinish: yes it has
17:23:43 <andreaf> mtreinish: where possible
17:23:59 <mtreinish> ok, because those are still causing confusion for some people
17:24:21 <mtreinish> it'll be nice to have that all simplified and common
17:24:25 <andreaf> any preference about the way to go? I tend towards a non-voting job so we can check stability for a while
17:24:42 <andreaf> before turning validation on in the gate
17:24:56 <mtreinish> andreaf: I'm fine with making it non-voting to start I guess
17:25:11 <mtreinish> we dropped the icehouse jobs recently so we're running a few less jobs then before
17:25:15 <mtreinish> so adding one doesn't hurt
17:25:17 <mtreinish> as much...
17:25:28 <andreaf> ok cool
17:26:36 <mtreinish> ok, let's move on
17:26:39 <mtreinish> #topic Devstack
17:26:55 <mtreinish> dtroyer_zz: so anything exciting for devstack this week?
17:27:17 <dtroyer_zz> not much from me…
17:27:34 <dtroyer_zz> we have been working through jamielennox's series of patches to switch everything to Identity v3
17:27:34 <mtreinish> ok
17:27:47 <dtroyer_zz> taking it slowly to adjust as we go
17:28:13 <dtroyer_zz> also, cdent has the removel of ceilometer to a plugin WIP
17:28:51 <mtreinish> dtroyer_zz: that's still partially blocked on getting the grenade side working iirc right?
17:29:02 <dtroyer_zz> I think that is where he is, yes
17:29:24 <mtreinish> ok cool
17:29:30 <dtroyer_zz> that's it from me… sdague, anything to add?
17:29:50 <mtreinish> dtroyer_zz: sdague had to drop
17:30:00 <dtroyer_zz> ok, I missed him leaving
17:30:14 <mtreinish> he sent me a hangout msg about it :)
17:30:32 <mtreinish> ok does anyone else have something to discuss on devstack?
17:31:48 <mtreinish> #topic Grenade
17:32:00 <mtreinish> ok does anyone have any updates on grenade?
17:32:35 <mtreinish> sdague wanted me to mention that we got a successful run of grenade multinode in the gate this morning
17:32:46 <mtreinish> which is a big step
17:32:51 <dtroyer_zz> woot!
17:33:00 <mtreinish> there are still some bugs, but it's moving along
17:33:09 <mtreinish> the patch is here:
17:33:11 <mtreinish> #link https://review.openstack.org/#/c/199091/
17:33:53 <mtreinish> that's all I had :)
17:34:00 <mtreinish> is there anything else on grenade?
17:34:53 <mtreinish> ok, lets move on
17:35:01 <mtreinish> #topic Bugs
17:35:11 <mtreinish> does anyone have anything to discuss on bugs this week?
17:35:17 <mtreinish> #link https://etherpad.openstack.org/p/Tempest-bug-report
17:35:34 <mtreinish> err I guess that link is still from last week
17:35:41 <dkranz> andreaf: did you see my email about the failing periodic non-admin jobs? (no bug ticket)
17:36:13 <dkranz> andreaf: about how admin_domain_name is needed even for non-admin keystone tests?
17:36:24 <mtreinish> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/069506.html
17:36:28 <mtreinish> dkranz, andreaf: ^^^
17:36:43 <dkranz> andreaf: v3 that is. I;d like your input before I push a fix
17:36:48 <andreaf> dkranz: ok that sounds like a bug
17:37:04 <dkranz> andreaf: yes, it is described in the email
17:37:19 <dkranz> andreaf: you even anticipated it :)
17:37:39 <dkranz> andreaf: you can answer offline in the email
17:38:15 <andreaf> dkranz: will do, thanks for bringing it up
17:38:22 <mtreinish> dkranz: you also had the triage rotation this week, was there anything that stood out?
17:39:18 <dkranz> mtreinish: oops
17:39:31 <mtreinish> hehe, no worries :)
17:39:38 <dkranz> mtreinish: I was so buried coming back I forgot. Will take care of it tomorrow
17:39:44 <dkranz> mtreinish: there are a bunch of new ones
17:39:57 <mtreinish> ok
17:40:50 <mtreinish> ok, let's move on
17:40:55 <mtreinish> #topic Critical Reviews
17:41:14 <mtreinish> does anyone have a review they'd like to get extra eyes on?
17:41:15 <dpaterson> #link https://review.openstack.org/#/c/191978/
17:41:29 <dpaterson> please :)
17:41:40 <mtreinish> dpaterson: man, I'm terrible I forget about that every week
17:41:46 <dkranz> mtreinish: I gave it a +2 before but was rebased
17:42:23 <dkranz> mtreinish: The potential controversial thing is that it now only allows cleanup with test accounts
17:42:40 <dkranz> mtreinish: but it never really worked with tenant isolation and I'm not sure it really can
17:42:55 <mtreinish> dkranz: well now that we prefix all created resources names it can
17:42:58 <mtreinish> but that's a separate patch
17:43:20 <mtreinish> I definitely think having support for test-accounts is a good thing
17:43:36 <dkranz> mtreinish: but what it a tenant goes away but leaves stuff behind?
17:44:09 <dpaterson> dkranz. mtreinsh: if prefix implementation fixes original isolation issues I can revisit
17:44:21 <mtreinish> dkranz: well the resources will still be prefixed so if we can find and delete them as admin (which we can't with everything just some) we can
17:44:31 <mtreinish> dkranz: it should still be an opt in flag, like --prefix-cleanup
17:44:35 <dkranz> mtreinish: right, but there are some we can't
17:44:36 <mtreinish> and then load the prefix value from config
17:44:46 <dkranz> mtreinish: yes, it can partially work
17:44:53 <mtreinish> dkranz: there's nothing we can do about that, short of filing a bug with the project and fixing it there
17:45:01 <dpaterson> some objects not globally scoped right?  So admin cannot see them, only deleted tenents
17:45:09 <dkranz> dpaterson: right
17:45:19 <dpaterson> that will still be an issue.
17:45:30 <dkranz> But once test accounts become the norm perhaps isolation will only be used for throw-away cloueds
17:45:52 <mtreinish> dpaterson: right, but that's also a problem for every user not just tempest
17:46:07 <mtreinish> there were some ml threads about the issue a while ago, I'm not sure what happened to them though
17:46:48 <dkranz> mtreinish: yeah,
17:47:17 <dkranz> mtreinish: we can re-enable isolatoin with prefixes later I think
17:47:58 <mtreinish> dkranz: right adding support to the cleanup tool todo prefixed resource deletion is a separate thing
17:48:07 <mtreinish> ok, are there any other patches to bring up?
17:49:15 <mtreinish> heh, I guess not
17:49:25 <mtreinish> let's open the floor then
17:49:28 <mtreinish> #topic Open Discussion
17:49:43 <dpaterson> mid-cycle meetup: any plans for where and when yet?
17:50:11 <dpaterson> I'm getting dings from bossmen about projected travel expenses for the year.
17:50:27 <mtreinish> dpaterson: so I'm looking at 2 options right now either the week of aug 10th or Sept. 10th
17:50:42 <mtreinish> most likely at hp in ft collins
17:51:03 <mtreinish> I'm leaning towards the sept. one because it gives us a bit more time for planning and travel approval
17:51:31 <dpaterson> mtreinish: +1 for sept, tix will be expensive for aug 10th
17:51:41 <dkranz> mtreinish: Tokyo is only six weeks after that :)
17:52:08 <dkranz> so 3/4 cycle
17:52:09 <mtreinish> dkranz: heh, yeah it's more another end of cycle like what we did in ny :)
17:52:14 <andreaf> we could meet a few days ealier in Tokyo and do the mid cycle there :D
17:52:40 <dpaterson> :)
17:52:41 <andreaf> go to Nikko and code around the temples
17:53:19 <dtroyer_zz> mtreinish: I don't recall If I mentioned here yet or not, but I'll be out most of August after back surgery on the 28th of this month…
17:53:31 <mtreinish> andreaf: hah, I'm not opposed to doing that, except I'm probably going to be vacationing in Japan after summit
17:53:46 <mtreinish> dtroyer_zz: oh, well more reason to do sept :)
17:54:19 <mtreinish> ok, I'll try to plan something for sept and I'll take it to the ML after I have a room reserved and stuff in motion
17:54:49 <dtroyer_zz> don't do Sept just because of me…I may not be travle ready by then anyway
17:55:09 <mtreinish> dtroyer_zz: it's not just you, other people have expressed a preference for sept over aug too
17:55:20 <dtroyer_zz> ok, good
17:55:55 <mtreinish> #action mtreinish to try and organize a midcycle/end-of-cycle for week of sept 10
17:56:09 <mtreinish> ok with ~5min left is there anything to discuss?
17:57:05 <mtreinish> ok, then let's end here
17:57:09 <mtreinish> thanks everyone
17:57:13 <mtreinish> #endmeeting