09:03:09 <oomichi> #startmeeting qa
09:03:10 <openstack> Meeting started Thu Sep  3 09:03:09 2015 UTC and is due to finish in 60 minutes.  The chair is oomichi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:03:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:03:13 <openstack> The meeting name has been set to 'qa'
09:03:20 <oomichi> Hi, who all here today?
09:03:24 <mkoderer> hi
09:03:28 <gmann> o/
09:03:46 <dmellado> \o
09:03:53 <oomichi> hi mkoderer, gmann, dmellado
09:03:58 <dmellado> hi oomichi
09:04:23 <oomichi> ok, lets start meeting
09:04:48 <oomichi> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_September_3rd_2015_.280900_UTC.29
09:04:54 <oomichi> ^^^ Today's agenda
09:05:02 <oomichi> #topic Specs Reviews
09:05:21 <oomichi> so there are some qa-specs
09:05:52 <oomichi> and most specs get -1s and I guess there are not so many topic now
09:06:10 <oomichi> someone want to talk about that?
09:06:26 <oomichi> #link      https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:07:05 <dmellado> oomichi: I wanted also to know the state of the external plugins, but IIRC this is going to be covered later, isn't it?
09:07:29 <oomichi> dmellado: yeah, I also want to know :)
09:07:44 <oomichi> dmellado: and that will be the next topic ;)
09:07:52 <oomichi> Ok, let's move onto the next topic
09:08:08 <oomichi> #topic Tempest
09:08:41 <oomichi> according to the agenda, the first topic is from me ;)
09:09:11 <oomichi> I'd like to mention about current status of service client for tempest-lib
09:09:25 <mkoderer> +1 for moving the clients to the lib
09:09:40 <oomichi> mkoderer: yeah, thanks
09:09:54 <mkoderer> do you need some help? pls let me know if I can help with something
09:09:54 <oomichi> we are working for that on 3 topics
09:10:08 <oomichi> #link  https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/consistent-service-method-names,n,z
09:10:18 <oomichi> #  https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/method-return-value-and-move-service-clients-to-lib,n,z
09:10:24 <oomichi> #link  https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/method-return-value-and-move-service-clients-to-lib,n,z
09:10:34 <oomichi> #link  https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:service-client-unit-tests,n,z
09:10:57 <oomichi> mkoderer: much thanks, you can help the above link patches :)
09:11:18 <gmann> mkoderer: yea, it will be helpful. Thanks
09:11:23 <mkoderer> yeah I areadly reviewed a ton of them :)
09:11:30 <oomichi> and most part of nova service clients are done.
09:11:53 <oomichi> as the next step, I will migrate the compute service clients to tempet-lib
09:12:01 <gmann> oomichi: almost all compute service client unit test patches are up
09:12:11 <gmann> oomichi: only server client left-  https://etherpad.openstack.org/p/tempest-service-client-unit-tests
09:12:17 <oomichi> gmann: yeah, nice progress
09:12:30 <oomichi> #link https://etherpad.openstack.org/p/tempest-service-client-unit-tests
09:12:38 <gmann> oomichi: you are planning to working on that if not someone else can pick that up
09:12:55 <oomichi> gmann: yeah, thanks for pointing it out. that is difficult, and we need to implement it
09:13:48 <oomichi> gmann: I will try it later after https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/consistent-service-method-names,n,z
09:13:58 <gmann> oomichi: +1 Thanks
09:14:19 <mkoderer> ok, I will start reviewing the unit test and then have a look the the etherpad
09:14:20 <oomichi> #action: oomichi implements servers_client unit test
09:14:37 <oomichi> mkoderer: that will be very helpful
09:14:48 <gmann> mkoderer: Thanks.
09:15:04 <oomichi> #action mkoderer starts reviewing the unit test
09:15:11 <oomichi> mkoderer: ^^^ ;)
09:15:27 <mkoderer> :)
09:15:37 <oomichi> so I'd like to ask mkoderer for the next topic
09:15:48 <mkoderer> ok
09:15:50 <oomichi> I'd like to know current status of external plugins
09:15:56 <dmellado> +1 ;)
09:16:10 <mkoderer> the manila plugin is ready for merge
09:16:12 <mkoderer> https://review.openstack.org/#/c/201955/
09:16:24 <oomichi> #link https://review.openstack.org/#/c/201955/
09:16:26 <mkoderer> but we have a blocking novaclient bug currently in Manila :(
09:16:52 <mkoderer> anyway.. I hope that this will be merged within this week
09:16:56 <oomichi> oops, you are asking novaclient release
09:17:10 <oomichi> can you catch someone ?
09:17:22 <oomichi> to release a new novaclient?
09:17:26 <mkoderer> oomichi: not yet..
09:17:49 <oomichi> ok, will check someone later
09:17:58 <mkoderer> so in general the external plugin works fine
09:18:10 <gmann> mkoderer: wow :)
09:18:10 <oomichi> mkoderer: that is great :)
09:18:13 <mkoderer> open issue is currently the dependency with tempest
09:18:46 <gmann> mkoderer: dependency ?
09:18:46 <oomichi> mkoderer: what kind of dependency?
09:18:46 <dmellado> mkoderer: what kind of dependency issues are you dealing with?
09:18:54 <mkoderer> e.g. the work on the service clients broke the manila scenario tests
09:19:22 <mkoderer> since the scenario test are using other clients and if the client is changed we have to adapt
09:19:42 <oomichi> oops, so we need to implement service client in tempest-lib asap, that will be helpful?
09:19:47 <gmann> mkoderer: ahh, yea
09:20:02 <gmann> mainly return value changes causing a  lot
09:20:07 <mkoderer> I talked to mtreinish and he doesn't like the idea to have a check job for Manila in tempest queue
09:20:19 <dmellado> mkoderer: so then the manila scenario test will have to be rewritten? (or at least adapted?)
09:20:33 <mkoderer> dmellado: there are already adapted
09:20:49 <dmellado> mkoderer: great, thnx ;)
09:20:55 <oomichi> mkoderer: one question
09:21:06 <mkoderer> but in the current state I need to checkout a commit-id from tempest to ensure that a change in tempest doesn't break the manila gate
09:21:19 <oomichi> mkoderer: on manila gate, do tempest tests also run?
09:21:31 <gmann> mkoderer:  anything from pending return value changes can affect
09:21:34 <gmann> # link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/method-return-value-and-move-service-clients-to-lib,n,z
09:21:41 <oomichi> mkoderer: or do manila original tests only run?
09:21:44 <gmann> so that we can try to merge that fast
09:21:58 <mkoderer> oomichi: no currently we only run manila api and manila scenario tests
09:22:45 <oomichi> mkoderer: that seems nice. and just using some service clients on manila tests, right?
09:22:48 <mkoderer> so with the commit-id we are save and can wait until everything needed is merged to tempest-lib
09:23:36 <mkoderer> oomichi: yeah I try to reduce the coupling as much as possible.. and scenario tests are one thing were we can't avoid it
09:23:46 <mkoderer> but anyway I think we are on a good track
09:23:56 <oomichi> mkoderer: we are working for implementing nova service clients as the first step. and they will be stable for manila gate in near future
09:24:43 <mkoderer> oomichi: yeah that's cool
09:24:55 <mkoderer> dmellado: any other question to that topic?
09:25:02 <oomichi> mkoderer: so I don't have plan for the next step after nova service client. do you have any idea for the next service client?
09:25:17 <gmann> mkoderer: oomichi : may be server_client will affect - https://review.openstack.org/#/c/216559/
09:25:43 <dmellado> mkoderer: I was thinking about if it would affect the whole scenario test set in the future, besides from manila
09:25:46 <oomichi> mkoderer: ok, I will concentrate on server_client
09:26:23 <dmellado> mkoderer: oomichi gmann Do you know what's in the plan for it, to get them back into each project or tempest will be still having a set of its own scenario tests
09:26:25 <dmellado> ?
09:26:28 <dmellado> I'm kinda lost on that
09:27:09 <mkoderer> oomichi: I need also network_client for the manila scneario tests
09:27:23 <oomichi> dmellado: After implementing external plugins in manila, basically we can use it on any projects ideally
09:27:49 <oomichi> dmellado: but as mkoderer said, we will face problems if using tempest code
09:28:00 <mkoderer> we could move the scenario test also to a seperate repo
09:28:08 <gmann> mkoderer: i think network client is in good shape. for return value no changes required
09:28:15 <oomichi> dmellado: and we are working for making these tempest code as library
09:28:18 <mkoderer> gmann: ok fine :)
09:28:22 <dmellado> oomichi: that means that at some point, every new scenario test would have to go into its own 'based project' repo, isn't it?
09:28:36 <oomichi> mkoderer: thanks. ok, next target is neutron service client.
09:28:51 <dmellado> mkoderer: that'd be great, because what would happen if a scenario test makes use of more than 1 project
09:29:07 <oomichi> dmellado: yeah, right.
09:29:11 <mkoderer> oomichi: thanks
09:30:15 <oomichi> does someone have more topic on this?
09:30:21 <mkoderer> nope
09:30:26 <oomichi> it was very interesting for me :)
09:30:43 <oomichi> dmellado: ok for you ?
09:31:20 <dmellado> oomichi: yep, was just thinking about those multi-project scenario tests, but we'll see eventually, thanks! ;)
09:31:33 <oomichi> #action oomichi start implementing neutron service client after migrating nova service client to tempset-lib.
09:31:51 <oomichi> ok, lets move to the next topic
09:32:10 <oomichi> #topic devstack
09:32:23 <oomichi> jamielennox: hi
09:32:44 <oomichi> maybe not
09:33:13 <oomichi> he wrote a topic on the agenda, but no attendence.
09:33:29 <oomichi> do someone have any topics on devstack?
09:33:55 <oomichi> ok, lets move to the next topic
09:33:57 <dmellado> I was having again some issues with F22, will write it to the MK
09:33:59 <dmellado> ML
09:34:19 <oomichi> dmellado: that is devstack?
09:34:32 <dmellado> oomichi: yep
09:34:46 <dmellado> I was just writing when you switched topic ;)
09:34:54 <oomichi> dmellado: can you provide the link?
09:35:10 <oomichi> to share the issue
09:35:15 <dmellado> oomichi: not now but I'll open a bug us and send the link to the ML
09:35:44 <oomichi> dmellado: ah, OK. that will be nice :)
09:35:47 <dmellado> so we can go to the next topic ;)
09:35:56 <oomichi> dmellado: ok :)
09:36:14 <oomichi> #topic critical reviews
09:36:46 <jlanoux> I have a couple
09:36:46 <oomichi> are there any patches which need reviews asap?
09:37:03 <jlanoux> #link https://review.openstack.org/#/c/209144/
09:37:40 <jlanoux> and #link https://review.openstack.org/#/c/180968/. This one is infra but if you can have a look that would be great. Thanks!
09:37:43 <gmann> jlanoux: yea, i forgot to review that had open only. I will look into tomorrow
09:37:50 <dmellado> oomichi, not really critical but I'd be great if you could review https://review.openstack.org/#/c/218367/
09:37:55 <jlanoux> gmann: thanks!
09:38:00 <dmellado> thanks! ;)
09:38:17 <oomichi> #link https://review.openstack.org/#/c/218367/
09:38:50 <oomichi> dmellado: that is good for me, will review later
09:39:21 <oomichi> I also have some reviews
09:39:27 <oomichi> #link https://review.openstack.org/#/c/217459/
09:39:52 <oomichi> #link https://review.openstack.org/#/c/218705/
09:40:05 <oomichi> are there more?
09:40:50 <oomichi> dkranz: hi
09:41:18 <dkranz> oomichi: hi :)
09:41:21 <oomichi> dkranz: we are talking critical reviews now
09:41:44 <oomichi> do you have any patches about that?
09:41:57 <dkranz> oomichi: just a sec
09:42:23 <oomichi> dkranz: ok :)
09:42:55 <dmellado> hi dkranz ;)
09:43:17 <mkoderer> dkranz: seems you are a real early bird :)
09:43:35 <dkranz> oomichi: oh, the one I wsa thinking of already merged
09:43:42 <dkranz> mkoderer: I am not really here
09:43:57 <gmann> :)
09:44:01 <oomichi> dkranz: good news :)
09:44:12 <dkranz> Need to go back to bed
09:44:25 <mkoderer> dkranz: +1
09:44:26 <oomichi> ok, lets move to the next topic
09:44:42 <oomichi> dkranz: yeah ;)
09:44:58 <oomichi> dkranz: sorry for catching you now
09:45:14 <oomichi> #topic Code Sprint Reminder
09:45:17 <dkranz> oomichi: no worries. You did not wake me up :)
09:45:31 <oomichi> #https://wiki.openstack.org/wiki/QA/CodeSprintLibertyFortCollins
09:45:39 <oomichi> dkranz: :)
09:45:51 <mkoderer> so many people can't join the code sprint in person
09:46:06 <oomichi> we will have meetup on FortCollins
09:46:10 <dmellado> if considering the time zone, besides dkranz I guess so ;)
09:46:12 <gmann> oomichi: do you know how that works remotely ? through etherpad only
09:46:25 <oomichi> mkoderer: yeah, it is
09:46:43 <oomichi> mkoderer: but mtreinish wanted that you join to it
09:46:55 <oomichi> mkoderer: I also
09:47:09 <oomichi> gmann: ah, nice question
09:47:21 <mkoderer> oomichi: I know... he wrote me an email.. but traval approval process is hell :(
09:47:45 <oomichi> mkoderer: I can know the situation, I also faced such thing..
09:48:02 <mkoderer> I think remotley is quite probelmatic..
09:48:10 <gmann> yea thats most common issue for meetup :)
09:48:12 <oomichi> gmann: there is not any hint for remotely
09:48:19 <gmann> humm
09:48:31 <dmellado> oomichi: gmann I was checking that as well, but I guess it's meant to be real-time, isn't it?
09:48:49 <oomichi> dmellado: yeah, that should be real-time
09:48:52 <gmann> dmellado: yea
09:48:58 <oomichi> dmellado: with skype or something
09:49:21 <mkoderer> I guess it would make sense to split into groups and do a google hangout for each of them
09:49:37 <gmann> mkoderer: +1, that will be good
09:49:52 <dmellado> mkoderer: +1 on that, or either try to duplicate it in EMEA region...
09:50:18 <oomichi> mkoderer: nice idea
09:50:54 <oomichi> OK, I will ask mtreinish how to make remote acess and write it on the wiki
09:51:10 <mkoderer> dmellado: I am not a big fan of duplication.. since how will we sync then.
09:51:16 <gmann> oomichi: Thanks
09:51:20 <mkoderer> oomichi: +1
09:51:28 <oomichi> #action oomichi ask mtreinish how to make remote conference and write it on the wiki
09:51:30 <dmellado> mkoderer: splitting the topics?
09:52:12 <mkoderer> dmellado: ah you mean to do another meetup in EMEA?
09:52:39 <dmellado> mkoderer: something like that, another meetup in EMEA with maybe some of the topics to be covered in the original one
09:53:06 <dmellado> mkoderer: but maybe it's just too close to think about it, given that I can get enough coffee it'd be good to access it remote ;)
09:53:23 <mkoderer> yeah we are a bit on time pressure I think
09:54:39 <oomichi> if there are topics you need to join, it is nice to write available time on https://etherpad.openstack.org/p/liberty-qa-code-sprint with UTC
09:54:45 <oomichi> for each topic
09:55:23 <oomichi> maybe we will write code or review except the time ;)
09:55:41 <oomichi> as code sprint
09:55:41 <dmellado> oomichi: ;)
09:56:15 <oomichi> ok, lets move to the next
09:56:26 <oomichi> #topic open discussion
09:56:53 <oomichi> does someone want to talk about something?
09:57:05 <gmann> nothing from my side
09:57:19 <oomichi> me too
09:57:23 <dmellado> +1 here
09:57:39 <oomichi> mkoderer: do you ?
09:57:47 <mkoderer> no we can close the meeting
09:57:59 <oomichi> nice
09:58:05 <mkoderer> thx folks
09:58:10 <oomichi> thanks all
09:58:14 <oomichi> #endmeeting