17:00:07 <oomichi> #startmeeting qa
17:00:09 <openstack> Meeting started Thu Jun 9 17:00:07 2016 UTC and is due to finish in 60 minutes. The chair is oomichi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:12 <openstack> The meeting name has been set to 'qa'
17:00:22 <oomichi> whois here today?
17:00:32 <fnaval> o/
17:00:35 <slowrie> o/
17:00:50 <dpaterson> o/
17:00:56 <mtreinish> hi
17:01:12 <oomichi> ok, lets start the meeting
17:01:23 <oomichi> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_June_9th_2016_.281700_UTC.29
17:01:40 <oomichi> ^^^ today agenda(almost same every meeting ;)
17:01:49 <oomichi> #topic Spec Review
17:02:05 <oomichi> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:02:27 <oomichi> very old specs are abondaned and now we have 5 specs
17:02:39 <oomichi> and all are red on reviews
17:02:40 <mtreinish> all with -1s
17:02:45 <oomichi> mtreinish: yea
17:02:53 <oomichi> the fist one is I need to update
17:03:05 <oomichi> that is tempest-resources spec
17:03:07 <mtreinish> oomichi: why didn't you abandon: https://review.openstack.org/#/c/101232/
17:03:21 <mtreinish> the last update was from 2014
17:03:46 <oomichi> mtreinish: ah, I missed that
17:03:57 <oomichi> I will do that later
17:03:59 <mtreinish> ok
17:04:15 <oomichi> #action oomichi abandons https://review.openstack.org/#/c/101232/
17:04:45 <oomichi> mtreinish: the second one is you prefer one, I guess
17:04:53 <oomichi> Policy testing apis
17:05:04 <mtreinish> oomichi: well I still haven't heard any response from rlrossit
17:05:25 <mtreinish> on the implementation side it's just adding it to gerrit and governance under qa
17:05:33 <oomichi> mtreinish: is it difficult to get rlrossit on IRC?
17:05:56 <mtreinish> but I don't think we should merge it until the tempest interfaces it uses are in lib
17:06:07 <mtreinish> oomichi: nah, he's in the nova channel normally
17:06:28 <oomichi> mtreinish: ok, please get the response :)
17:06:49 <oomichi> mtreinish: what interfaces of tempest are you want to use on the project?
17:07:04 <oomichi> mtreinish: which is not defined as tempest.lib
17:07:49 <mtreinish> oomichi: things like the cred providers iirc
17:07:55 <oomichi> #action mtreinish gets response of https://review.openstack.org/#/c/314704/ from rlrossit
17:08:01 <mtreinish> oomichi: https://github.com/rlrossiter/cinnamon-role
17:08:44 <oomichi> mtreinish: ok thanks. That will be next one for defining tempest.lib
17:09:09 <mtreinish> oomichi: yeah a quick grep it looks like it's the credentials providers and some exceptions
17:09:17 <mtreinish> (which are probably tied to the cred providers)
17:09:45 <oomichi> yeah, andreaf is working for making the cred thing as tempest.lib
17:09:58 <oomichi> that seems a nice time to do that
17:10:28 <oomichi> do we have another discussion about qa-spec?
17:10:51 <oomichi> ok, let's move on
17:10:59 <oomichi> #topic Tempest
17:11:33 <oomichi> Tempest CLI is high priority one on this cycle, and that seems good progress
17:11:49 <oomichi> most patches of CLI are approved now, I guess
17:11:55 <oomichi> mtreinish: is it right?
17:11:59 <mtreinish> oomichi: no, they're still in progress
17:12:01 <mtreinish> #link https://review.openstack.org/284411
17:12:05 <mtreinish> adds teh run command
17:12:27 <mtreinish> and starts a branch we'll build off over time
17:12:31 <oomichi> mtreinish: ah, that is most important one
17:12:43 <dpaterson> mtreinish: I started looking at patch, want to take it for spin today.
17:13:03 <mtreinish> oomichi: andreaf and I are disagreeing about 1 detail inline, but other than that discussion it should be ready
17:13:08 <mtreinish> dpaterson: ok cool, thanks
17:13:40 <oomichi> mtreinish: what is the 1 detail inline?
17:13:58 <oomichi> ah, the last comment on the gerrit
17:14:45 <oomichi> #action dpaterson takes it for spin on https://review.openstack.org/284411
17:15:09 <mtreinish> oomichi: we're debating calling testr init as part of the run workflow, which I feel is necessary
17:15:13 <oomichi> https://review.openstack.org/284411 is the last one on CLI?
17:16:13 <mtreinish> oomichi: no that's the first patch, there are 2 up on that branch now
17:16:26 <mtreinish> and I have at least another 2 or 3 planned in my head
17:16:37 <mtreinish> but I didn't want to get ahead of myself and push out all of that at once
17:16:55 <oomichi> #link https://review.openstack.org/#/q/topic:bp/tempest-run-cmd+status:open
17:17:14 <dpaterson> mtreinish: the impact of calling testr init is run will function in an uninitialized directory correct?
17:17:29 <oomichi> mtreinish: yeah, it is nice to merge the first one before pushing a lot of patches
17:17:54 <slowrie> dpaterson: yes, andreaf is commenting about the fact that it will be different from current functionality which breaks if there's no .testr.conf files in your cwd
17:18:36 <mtreinish> I guess I can respin it to check for the presence of a .testr.conf before running testr init
17:18:46 <dpaterson> mtreinish: I would tend to agree. I would think the flow is create a directory, tempest init that directory and tempest run from that directory
17:18:47 <mtreinish> that should prevent leaving .testrepository dirs everywhere
17:19:15 <slowrie> mtreinish: at least for this merge maybe it makes sense to just check for the existence and if it doesn't throw up an error message that's sane before exiting?
17:19:36 <oomichi> slowrie: then "tempest run" needs to check the path is initialized before the operation, right?
17:19:52 <mtreinish> slowrie: for the existence of .testrepository?
17:20:05 <slowrie> oomichi: tempest run is a passthrough layer to testr, testr will not function if your cwd doesn't have the correct files
17:20:54 <mtreinish> slowrie: I added this after I went to use tempest run and was hit with: "No repository found in /home/computertreker/git/tempest-lib. Create one by running "testr init"."
17:21:05 <mtreinish> well s/tempest-lib/tempest
17:21:21 <slowrie> mtreinish: Gotcha
17:21:29 <mtreinish> which is a bad UI, even changing the error message doesn't really help here
17:21:39 <mtreinish> because we still depend on testr init being run
17:21:58 <mtreinish> tempest init will do it, but there is no requirement to use a workspace with tempest run
17:22:26 <mtreinish> especially since tempest run isn't workspace aware yet
17:23:43 <oomichi> is it fine to merge it as experimental now?
17:23:50 <dpaterson> mtreinish: so as it stands if you were to execute tempest run in non-inited directory where is tempest.conf picked up from? /etc/tempest/tempest.conf
17:24:16 <mtreinish> dpaterson: it behaves the same way as tempest run with testr does
17:24:29 <mtreinish> so it relies on the env vars or the default which is etc/tempest.conf iirc
17:24:45 <mtreinish> oomichi: I think it is, but I have vested interest in getting it off the ground :)
17:25:23 <dpaterson> +1 on getting merged as starting point.
17:26:21 <oomichi> mtreinish: how about clarifying it on the reno?
17:26:39 <mtreinish> oomichi: was there a comment on what I put in the release notes for it?
17:26:48 <oomichi> "this is still experimental" or something
17:27:02 <mtreinish> I can add onto it if you think it's necessary
17:27:13 <mtreinish> leave a -1 review comment and I'll respin it
17:27:29 <oomichi> mtreinish: ok, I will do that.
17:27:49 <oomichi> now many people are working on the same patch ;)
17:28:17 <oomichi> #action oomichi put the comment about reno on https://review.openstack.org/#/c/284411
17:28:37 <oomichi> can we move to the next topic in tempest?
17:28:54 <oomichi> about service clients
17:29:14 <mtreinish> oomichi: that's all I had on cli, so sure
17:29:19 <oomichi> the last one of v2 images client is images_client
17:29:44 <oomichi> I will push the patch today, and v2 image service client will be done
17:30:09 <oomichi> the next is v1 image client, but I have a concern about v1 image service clients now
17:30:24 <oomichi> the API is very different from the other services
17:30:43 <oomichi> like most info is contained in header instead of body
17:30:47 <mtreinish> oomichi: more different than swift's API?
17:30:52 <mtreinish> swift does the same thing
17:31:07 <oomichi> mtreinish: oh, nice point. yeah that seems similar with swift
17:31:55 <oomichi> but we are not touching swift clients yet
17:32:26 <oomichi> and maybe glance v1 clients will be defined as temepst.lib with a few odd interfaces
17:33:02 <mtreinish> oomichi: IIRC, the v1 glance stuff looks like the normal clients, we move the headers into the body
17:33:03 <oomichi> current v1 clients returns header info as body
17:33:13 <mtreinish> for better or worse
17:33:18 <oomichi> mtreinish: yeah, right
17:33:28 <mtreinish> we can change that, but we'll have to update all the tests
17:33:34 <oomichi> the clients translate header into the body
17:33:48 <oomichi> mtreinish: yes, that is a big impact
17:34:10 <oomichi> and we will start to swith glance v2 api in nova as http://lists.openstack.org/pipermail/openstack-dev/2016-June/096807.html
17:34:31 <mtreinish> oomichi: sure, but v1 is still the de facto standard being used everywhere
17:34:38 <oomichi> so it seems enough to define v1 image clients as current format
17:34:54 <mtreinish> and that's not gonna change anytime soon, even if we move master to use v2 for nova
17:35:53 <oomichi> or we will create a lot of patches to make v1 clients return headers as headers instead of body
17:35:53 <mtreinish> but, that being said I'm fine with the weird header->body thing with the v1 clients, it's too much of a pain to change them
17:36:22 <mtreinish> and our glance testing is very light in general so I don't think it really matters
17:37:06 <oomichi> mtreinish: ah, ok. I will check how impact if we do that in actual code
17:37:54 <oomichi> #action oomichi checks how many patches are necessary if making v1 image clients to return headers as headers
17:38:14 <oomichi> ok, that is all in service clients
17:38:26 <oomichi> do anyone have topics about tempest?
17:39:20 <oomichi> ok, lets move on
17:39:35 <oomichi> #topic devstack + grenade
17:39:59 <oomichi> I don't have any topics about devstack + grenade today
17:40:11 <oomichi> (sorry, that is every time)
17:40:25 <oomichi> do anyone have any topics
17:40:45 <oomichi> ?
17:40:51 <dpaterson> mid-cycle sprint
17:40:51 <mtreinish> I don't have anything for this topic today
17:41:05 <oomichi> ok, lets move on
17:41:10 <dpaterson> Would great to nail down time and place
17:41:20 <oomichi> dpaterson: that is open one ;)
17:41:36 <oomichi> #topic openstack-health
17:41:56 <oomichi> mtreinish: masayukig: how about o-h today?
17:42:14 <mtreinish> heh it's probably a bit late for masayukig
17:42:29 <oomichi> o-h continues changing every days;)
17:42:43 <mtreinish> the only thing that's significant here from me is the addition of elastic recheck support
17:43:13 <mtreinish> and some performance improvements from internal caching changes
17:43:28 <oomichi> mtreinish: oh, congress. that is important one on https://etherpad.openstack.org/p/newton-qa-newton-priorities
17:43:34 <mtreinish> which gives us a pattern for doing serverside caching request
17:44:21 <oomichi> mtreinish: how much is performance improvement on that?
17:44:47 <mtreinish> caching makes the response near instant
17:45:04 <mtreinish> and we update the cache in the background with a seperate worker thread
17:45:15 <mtreinish> so all the user facing interactions come from the cache only
17:45:28 <mtreinish> right now it's only being used where we use e-r (which is one query)
17:45:39 <mtreinish> but sc68cal and I are gonna work on expanding that to all the requests
17:46:07 <oomichi> mtreinish: cool :)
17:47:24 <oomichi> mtreinish: how about "figure out check data solution" on the above etherpad?
17:47:33 <oomichi> is that next one after caching?
17:48:06 <mtreinish> oomichi: that requires much more work, it'll involve a big schema migration on subunit2sql
17:48:26 <mtreinish> and before we can do that I need to bug mordred some more about moving subunit2sql off of trove
17:48:47 <mtreinish> oomichi: it's still on the radar, just a bit further away
17:49:08 <oomichi> mtreinish: ah, I see. thanks for the status info
17:49:36 <oomichi> ok, do we have another topics about o-h?
17:50:09 <oomichi> ok, lets move on
17:50:13 <oomichi> #topic mid-cycle meetup
17:50:36 <oomichi> we are arranging the meetup 19th-21th Sep in Germany with infra team
17:50:48 <oomichi> but that is not fixed yet with the detail
17:50:55 <mordred> mtreinish: I'll be back for real next week
17:50:59 <mordred> mtreinish: (you know, and not on the road)
17:51:05 <oomichi> we will send a mail to openstack-dev after fixing
17:51:09 <oomichi> dpaterson: ^^^
17:51:10 <mordred> mtreinish: so let's talk about that then (sorry for the interruption
17:51:15 <oomichi> dpaterson: about the meetup
17:51:35 <oomichi> mordred: no worries ;)
17:51:40 <dpaterson> oomichi: cool
17:52:01 <mtreinish> mordred: heh, ok. No worries. Fwiw, it's not been a prio for me either. I had other things to keep me busy
17:52:10 <mordred> so. many. things.
17:52:20 <oomichi> ok, the time is comming, can we move on the next topic if nothing?
17:53:17 <oomichi> #topic Critical Reviews
17:53:39 <oomichi> anyone have patches need to be reviewed?
17:53:50 <mtreinish> #link https://review.openstack.org/326570
17:54:00 <mtreinish> ^^ that should be a quick o-h review
17:54:04 <mtreinish> as is:
17:54:06 <mtreinish> #link https://review.openstack.org/326603
17:54:20 <mtreinish> and:
17:54:22 <mtreinish> #link https://review.openstack.org/324958
17:55:14 <oomichi> the other ones?
17:56:16 <oomichi> ok, lets move on
17:56:24 <oomichi> #topic Open Discussion
17:56:52 <oomichi> I pushed already all thing I wanted to discuss :)
17:57:08 <oomichi> do anyone have any thing for discussion?
17:58:19 <oomichi> (maybe nobody has, that is good)
17:58:35 <slowrie> I'm good
17:58:55 <oomichi> slowrie: :)
17:59:03 <oomichi> ok, lets finish the meeting. thanks all
17:59:06 <slowrie> thanks
17:59:08 <oomichi> #endmeeting