17:00:42 <oomichi> #startmeeting qa
17:00:42 <openstack> Meeting started Thu Jun 23 17:00:42 2016 UTC and is due to finish in 60 minutes.  The chair is oomichi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:46 <openstack> The meeting name has been set to 'qa'
17:00:59 <oomichi> hi who join today ?
17:01:12 <mtreinish> o/
17:01:20 <rfolco> o/
17:01:44 <oomichi> andreaf: ?
17:01:51 <andreaf> o/
17:02:17 <hogepodge> o/
17:02:28 <oomichi> ok, lets get start
17:02:46 <oomichi> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_June_23th_2016_.281700_UTC.29
17:02:51 <oomichi> ^^^ today agenda
17:03:02 <oomichi> #topic Specs Reviews
17:03:15 <oomichi> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:03:35 <oomichi> There are just 4 specs, and I am working for the first one
17:03:51 <oomichi> and will update it soon based on masayukig's comment
17:04:09 <oomichi> what status on the 2nd one, mtreinish?
17:04:19 <oomichi> Policy testing apis
17:04:43 <mtreinish> oomichi: what about it? we're holding off on it until the interfaces it depends on are stable right?
17:04:51 <oomichi> mtreinish: was it difficult to catch ryan?
17:05:15 <oomichi> mtreinish: you said you will catch him to make it forward on the previous meeting
17:06:13 <mtreinish> oomichi: I haven't had a chance to talk to him about any details
17:06:28 <oomichi> mtreinish: oh, I see.
17:06:53 <oomichi> the 3rd one is defcore thing
17:07:10 <oomichi> hogepodge: maybe you have something want to talk here?
17:07:17 <hogepodge> That one is partially replace with one in defcore https://review.openstack.org/#/c/317531/
17:07:24 <hogepodge> On the test spec side of things
17:07:50 <hogepodge> I'm not sure if there's value in tagging tests that defcore has identified. What do you all think?
17:07:59 <oomichi> #link https://review.openstack.org/#/c/317531/
17:08:14 <hogepodge> If it's not something desireable, I can abandon the spec.
17:08:16 <mtreinish> hogepodge: I still think there is value in tagging things like 'single-user', etc
17:08:38 <mtreinish> but just a tag 'in-defcore' I don't think adds much
17:08:51 <mtreinish> especially with ostestr and tempest run (well soon) having support for whitelist files
17:08:55 <oomichi> it will be useful when we take care of renaming or changing tempest tests
17:09:00 <hogepodge> mtreinish: ok, I'll rework the spec
17:09:50 <oomichi> ok, can we move on?
17:09:55 <hogepodge> yes
17:10:05 <oomichi> or anyone have more topics related to specs?
17:10:14 <oomichi> #topic Tempest
17:10:51 <oomichi> many projects still are using tempest code without tmepest.lib. and we are working for implemting tempest.lib more
17:11:21 <oomichi> the image client will be finished soon, and will release a new tag of tempest for new tempest.lib
17:11:40 <oomichi> after implementing image client
17:12:02 <oomichi> the other open patches are https://review.openstack.org/#/q/project:openstack/tempest+status:open
17:12:43 <oomichi> mtreinish: does tempest have still problems on py3
17:12:47 <oomichi> ?
17:13:20 <mtreinish> oomichi: it does, we run unit tests on py3, but most of tempest is self verifying and we have no py3 coverage there
17:13:49 <mtreinish> oomichi: it's been >1 year since I tried to do a full tempest run on py3, but I did a quick scan this morning and there are still a number of issues
17:14:21 <oomichi> mtreinish: oh, OK. there are several patches related to py3 as open reviews
17:14:49 <oomichi> how about running tmepest on py3 after that?
17:15:01 <mtreinish> oomichi: sure, but until we have a tempest job that runs using py3 we have no verification of anything
17:15:27 <mtreinish> oomichi: I'd like it if someone (not me :) ) set up an experimental job that ran tempest on py3
17:16:01 <oomichi> mtreinish: I heard ubuntu16.04 puts py3 as the default
17:16:21 <oomichi> I'd like to try it :)
17:16:37 <oomichi> #action oomichi sets up an experimental job that ran tempest on py3
17:17:03 <mtreinish> oomichi: yeah, 16.04 only install py35 by default
17:17:52 <oomichi> andreaf: you have many patches related to manager thing. is the progress good now?
17:18:29 <andreaf> oomichi: yes I'm working on the interface for plugins to register their own service clients
17:18:30 <oomichi> mtreinish: oh py35, not py34. that is a little big challenge for me
17:19:01 <andreaf> oomichi: there are still a few patches to be done, I'm trying to do it in baby-steps
17:19:11 <andreaf> oomichi: #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/client-manager-refactor
17:19:36 <andreaf> oomichi: one thing I wanted to ask people about that
17:19:39 <mtreinish> oomichi: there's very little difference between 3.4 and 3.5. I've been using 3.5 for py3 testing locally since arch upgraded a while ago
17:20:03 <oomichi> andreaf: what is that?
17:20:37 <oomichi> mtreinish: thanks, that is a good info
17:20:46 <andreaf> well, I feel there is no need to the service_client (the current manager object) to cache service client from plugins
17:21:08 <andreaf> oomichi: it creates more complications because we need to specify the name of the attribute
17:21:55 <andreaf> oomichi: so the way I'm implementing it is that a plugin register its classes under a name and then in tests it can do something like
17:22:30 <oomichi> andreaf: does that mean users of tempest plugin don't need to consider/import service clients at all, right?
17:22:31 <andreaf> self.my_api_client = service_client.my_service_name.MyApiClient1()
17:23:16 <andreaf> oomichi: plugin initialise the service_client and there they get access to core service clients if they need them
17:23:27 <oomichi> andreaf: yeah, the above code is easy to understand for me :)
17:23:40 <andreaf> oomichi: or they get access to their own clients, but not as attribute, instead by class names
17:24:06 <andreaf> oomichi: that also solves the problem of name conflicts between plugins
17:24:28 <oomichi> andreaf: cool, nice steps
17:25:17 <oomichi> do we have more topics about tempest here?
17:25:23 <andreaf> oomichi: thanks - anyone else has an opinion against else I will move forward with that
17:25:38 <mtreinish> oomichi: there are some tempest run things to review
17:25:51 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/tempest-run-cmd
17:26:18 <oomichi> mtreinish: one is already approved
17:26:32 <oomichi> and the second needs just +A
17:26:42 <oomichi> mtreinish: the other are conflict
17:26:46 <mtreinish> ugh, I need to rebase again...
17:27:08 <oomichi> mtreinish: heh, yeah. that also nice progress
17:27:28 <oomichi> mtreinish: will you need more patches after that?
17:28:58 <mtreinish> oomichi: probably, the last one is still a WIP so I need to finish that still. There is also some other stuff from the spec I still have to do IIRC
17:30:10 <oomichi> mtreinish: ok, can we use the command on the gate as the default? or still need these patches for that?
17:30:59 <mtreinish> oomichi: that's part of what still needs to be done, I have a patch that forces it poorly to test: https://review.openstack.org/327291
17:31:43 <oomichi> mtreinish: oh, cool !
17:32:14 <oomichi> #link https://review.openstack.org/#/c/327291
17:32:28 <mtreinish> everything passes with it now
17:33:03 <oomichi> do we have more about tempest?
17:33:23 <mtreinish> oomichi: https://review.openstack.org/333074
17:33:28 <mtreinish> but that's just for you to +A
17:33:59 <oomichi> mtreinish: yeah, I know. I didn't have enough time to review that, will check it later
17:34:02 <hogepodge> oomichi: yes
17:34:13 <oomichi> hogepodge: thanks, go ahead
17:34:26 <hogepodge> oomichi: after the meeting, can you help me get started on the negative testing guidelines?
17:34:58 <oomichi> hogepodge: oh, I am happy to help that
17:35:06 <oomichi> hogepodge: thanks for reminding that
17:35:17 <hogepodge> oomichi: thanks
17:35:22 <oomichi> #action oomichi reviews https://review.openstack.org/#/c/333074/
17:35:41 <oomichi> #action oomichi works together for the negative testing guidelines
17:35:52 <oomichi> #action oomichi works together for the negative testing guidelines with hogepodge
17:36:12 <oomichi> anything else?
17:36:17 <mtreinish> oomichi: there is an #undo
17:36:25 <mtreinish> iirc
17:36:34 <oomichi> #undo #action oomichi works together for the negative testing guidelines
17:36:35 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7fc2af1258d0>
17:36:47 <oomichi> mtreinish: cool, that works
17:37:30 <mtreinish> oomichi: well it might have removed the one without hogepodge since that was the last event
17:37:38 <mtreinish> but, we'll see in the minutes
17:37:52 <oomichi> mtreinish: yeah, I will check the minute
17:38:02 <oomichi> #topic Devstack and Grenade
17:38:24 <oomichi> do we have topics related to devstack&grenade this week?
17:39:08 <oomichi> maybe not, so lets move on
17:39:13 <oomichi> #topic openstack-health
17:39:37 <oomichi> how about openstack-health ?
17:40:02 <oomichi> #link https://review.openstack.org/#/q/project:openstack/openstack-health+status:open
17:40:03 <mtreinish> I don't have any updates this week on either
17:40:47 <oomichi> sc68cal and masayukig are very active now on o-h
17:41:03 <sc68cal> :)
17:41:04 <oomichi> ok, lets move on
17:41:31 <oomichi> #topic critical review
17:41:50 <oomichi> do we have critical reviews now
17:41:54 <oomichi> ?
17:42:15 <andreaf> oomichi: nothing from my side that wasn't mentioned already
17:42:23 <oomichi> I will review a patch mtreinish pointed before
17:42:36 <oomichi> andreaf: yeah, that already is in my list
17:42:47 <mtreinish> oomichi: yeah just:
17:42:48 <mtreinish> #link https://review.openstack.org/333074
17:42:56 <mtreinish> but that's the same one from the tempest topic
17:43:31 <oomichi> mtreinish: yeah, that is my action on the minute
17:43:41 <oomichi> do we have more?
17:44:38 <oomichi> ok, lets move on
17:44:44 <oomichi> #topic open discussion
17:44:54 <oomichi> one topic is just reminder
17:45:37 <oomichi> we have qa/infra code sprint Sep 19th-21th in Germany
17:45:46 <oomichi> #link https://wiki.openstack.org/wiki/Sprints/QAInfraNewtonSprint
17:46:06 <oomichi> please register on the above wiki if you are interested
17:46:33 <oomichi> that is all from my side
17:46:44 <hogepodge> If anyone has interest in attending the DefCore mid cycle, it will be in San Antonio the week of August 1
17:46:46 <andreaf> tempest.tests.cmd.test_run.TestRunReturnCode.test_tempest_run_passes broke again running unit tests on macosx - but I'm not sure why, tempest run returns 1 rc
17:47:12 <oomichi> hogepodge: cool,
17:47:39 <oomichi> hogepodge: is that already public on ml?
17:47:55 <oomichi> hogepodge: or any wiki?
17:48:09 <hogepodge> oomichi: no, markvoelker and VanL are arranging the details and will post once they've firmed them up
17:48:42 <oomichi> hogepodge: I see, thanks for the notification in advance before that
17:48:53 <hogepodge> Also, a version of this (amongst other things) will go go the board next week https://review.openstack.org/#/c/333067/
17:49:12 <hogepodge> Any feedback or changes are welcome
17:49:23 <oomichi> andreaf: are you running tempest on macos?
17:49:23 <hogepodge> #link https://review.openstack.org/#/c/333067/
17:49:35 <andreaf> oomichi: tempest unit tests
17:50:21 <oomichi> hogepodge: ah, that is interesting for me. thanks again :)
17:50:42 <oomichi> andreaf: oh, ok. that's also interesting
17:50:42 <andreaf> a remoteclient test used to fail, I fixed it, it was green, but the new tempest run test is not passing, I guess tempest run may not work on mac
17:51:29 <oomichi> andreaf: I am (not?) sure we can run unit tests on macos on the gate
17:51:45 <andreaf> oomichi: heh no, I don't think so
17:51:57 <oomichi> andreaf: yeah, just kidding
17:52:00 <andreaf> oomichi: I'll just keep going back and fixing them when it makes sense
17:52:11 <andreaf> :D
17:53:01 <oomichi> are there more topics?
17:53:39 <oomichi> or close the meeting early today
17:53:59 <oomichi> 3...
17:54:03 <oomichi> 2..
17:54:11 <oomichi> 1..
17:54:18 <oomichi> ok, thanks all
17:54:22 <oomichi> #endmeeting