09:00:05 <gmann> #startmeeting qa
09:00:06 <openstack> Meeting started Thu Nov 17 09:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:10 <openstack> The meeting name has been set to 'qa'
09:00:33 <gmann> hello, who all here today?
09:00:37 <masayukig> o/
09:00:51 * andreaf o/ I'm only half here - ping me if you need me please :)
09:00:53 <DavidPurcell> o/
09:01:12 <DavidPurcell> Here but barely awake
09:01:21 <gmann> masayukig: DavidPurcell andreaf hi
09:01:36 <gmann> andreaf: sure we need you always :)
09:02:01 <gmann> let's wait for few min in case more people join
09:03:23 <masayukig> ok
09:03:48 <gmann> dmellado: oomichi : ?
09:04:00 <gmann> ok, let's start
09:04:05 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_November_17th_2016_.280900_UTC.29
09:04:10 <gmann> ^^ today agenda
09:04:27 <gmann> #topic Ocata Priorities
09:04:36 <gmann> #link https://etherpad.openstack.org/p/ocata-qa-priorities
09:04:57 <gmann> ^^ this etherpad has all prioirty items we discussed in Barcelona
09:05:20 <gmann> we had most of them from O-2
09:05:51 <gmann> for me this one - Add an option for the number of target VMs to test live-migration
09:06:00 <gmann> i might start this in next week may be
09:06:10 <gmann> not so hard so will be quick
09:06:17 <masayukig> cool :)
09:06:35 <gmann> i also want to do at least 2 VM live migration on gate as default
09:07:02 <gmann> if that is acceptable as live migration job seems not so stable :)
09:07:50 <gmann> next one - Remove deep test class Inheritance for easy debugging
09:08:07 <gmann> we really need some progress in this but not sure whether it is started
09:08:24 <gmann> ekhugen, dmellado, jhakimra  ^^
09:09:06 <gmann> this makes debugging easy and much cleanup
09:09:11 <masayukig> yeah
09:09:45 <gmann> first one  - Add an option for stopping cleanup when test failure happens
09:09:56 <gmann> i did not see its sepc but we can wait on this
09:10:14 <gmann> dpaterson, mkopec ^^
09:10:27 <gmann> those are one for Ocata as this is short cycle
09:10:43 <gmann> anything else on this?
09:11:18 <DavidPurcell> policy spec is waiting on 2nd +2
09:11:27 <DavidPurcell> and a few typo fixes...
09:11:35 <gmann> DavidPurcell: cool, ll cover on spec topic
09:11:38 <gmann> #topic Specs Reviews
09:11:44 <DavidPurcell> okay, sorry I went too early
09:11:58 <masayukig> #link https://review.openstack.org/#/c/382672/
09:11:59 <masayukig> ?
09:12:07 <DavidPurcell> that's the one
09:12:23 <dmellado> gmann:
09:12:23 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:12:24 <dmellado> o/
09:12:26 <dmellado> sorry I was late
09:12:32 <gmann> dmellado: hi, no prob
09:12:48 * masayukig waves to dmellado
09:12:56 <dmellado> \o/
09:13:02 <dmellado> from my side and alongside mkoderer__
09:13:19 <dmellado> we're cleaning up manila tempest plugin, which will need also some work on tempest.lib ;)
09:13:23 <gmann> DavidPurcell: nice, i will check that may be tomorrow morning
09:13:58 <DavidPurcell> gmann: Thanks!  It'd be great if we could get it merged by the end of the week :)
09:14:02 <andreaf> dmellado: let me know if you need anything on that :)
09:14:03 <gmann> DavidPurcell: thanks for that
09:14:18 <dmellado> andreaf: o/ welcome back! sure, will do and I really appreciate it!
09:14:22 <gmann> DavidPurcell: sure
09:14:44 <gmann> dmellado: work on tempest.lib you means credential classes you mentioned in summit?
09:15:04 <dmellado> yep, and also at some point I'd like to move some more stuff to tempest.lib
09:15:12 <dmellado> thinking about how to remove some dependencies first
09:15:14 <oomichi> gmann: hi, sorry for my late joining. The gate of airport took time for passing
09:15:24 <dmellado> such as manager and remote_client
09:15:33 <gmann> dmellado: moving is always great but changing existnig one need backward compatibility manner
09:15:41 <gmann> oomichi: i knew :)
09:15:48 <dmellado> gmann: yep, I'm aware of it, that's why it's being tough!
09:15:50 <andreaf> dmellado: you mean scenario manager?
09:15:56 <gmann> dmellado: yea
09:16:07 <dmellado> andreaf: hold on, I'll post the link to the etherpad where we're tracking this
09:16:35 <gmann> dmellado: yea and paste here too
09:16:54 <dmellado> gmann: andreaf https://etherpad.openstack.org/p/manila_no_tempest_deps
09:17:36 <andreaf> dmellado: cool thanks
09:17:58 <gmann> dmellado: thanks
09:18:02 <dmellado> andreaf: if you're 'back into business' I'll count you into that ;)
09:18:09 <gmann> dmellado: so dynamic_credential is on the way to lib
09:18:27 <dmellado> gmann: cool, that'd deff help too
09:18:51 <gmann> or it is merged, cannot find patch from mtreinish
09:19:14 <andreaf> yes I have some time now for upstream work, so I'll start back on those topics
09:19:35 <gmann> dmellado: anyays, if you need changes in that we can hold that before moving
09:19:43 <oomichi> andreaf: cool, nice back :)
09:19:47 <gmann> andreaf: great news.
09:20:09 <dmellado> gmann: I'll have to sync with mkoderer__ later this morning
09:20:20 <gmann> sure
09:20:22 <gmann> thanks
09:20:22 <dmellado> I'll let you guys know if I need that after it, but thanks!
09:20:27 <gmann> next spec - https://review.openstack.org/#/c/173334/
09:20:30 <gmann> tempest-resource
09:20:41 <gmann> so oomichi andreaf its all good it seems.
09:20:51 <gmann> i will try to review by this week most
09:21:11 <oomichi> gmann: thanks, yeah it is good spec nwo I feel
09:21:22 <oomichi> s/nwo/now
09:21:33 <gmann> oomichi: andreaf Thanks.. ll check for sure
09:21:50 <gmann> other spec seems to be rebase
09:22:01 <gmann> but anything else anyone has on spec?
09:22:48 <gmann> #topic Tempest
09:22:52 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:22:55 <gmann> ^^ open reviews
09:23:21 <gmann> 1 thing i want masayukig to bring about new project he added in qa
09:23:26 <gmann> masayukig: ^^
09:23:38 <dmellado> yeah, I'll try to save some time to review those specs too
09:23:51 <gmann> dmellado: cool. thanks
09:23:54 <masayukig> gmann : coverage2sql?
09:23:58 <oomichi> yeah, for unit tests coverage
09:23:58 <gmann> masayukig: yea
09:24:18 <masayukig> gmann : I'll bring it in the open discussion, though :)
09:24:30 <gmann> masayukig: ok no prob
09:24:51 <dmellado> on tempest also, I'd like to propose a revert, I added you guys to a review to revert one change in ssh
09:25:00 <dmellado> as it's having issues with ssh on the ironic-inspector plugin
09:25:07 <dmellado> did you have the time to have a look?
09:25:07 <gmann> dmellado: link?
09:25:09 <oomichi> dmellado: do you have a patch for that?
09:25:11 <dmellado> on it ;)
09:26:11 <gmann> dmellado: this one? - https://review.openstack.org/#/c/366806/
09:26:24 <dmellado> https://review.openstack.org/#/c/366806/
09:26:27 <dmellado> yep, that one
09:26:34 <dmellado> my network was just being slow, thanks for that gmann
09:27:02 <oomichi> that seems puppet job fails, EmilienM needs to review it
09:27:25 <gmann> dmellado: so what the issue there
09:27:32 <gmann> no more info in commit message
09:27:35 <dmellado> I've found that without that revert and with the ironic-inspector plugin installed, tempest.scenario.test_security_groups_basic_ops.TestSecurityGroupsBasicOps.test_port_security_disable_security_group hangs forever
09:27:45 <dmellado> I'll take it over and add this information
09:28:00 <dmellado> you can have a look at our related issue here, in any case
09:28:04 <dmellado> https://bugzilla.redhat.com/show_bug.cgi?id=1394744
09:28:04 <openstack> bugzilla.redhat.com bug 1394744 in openstack-tempest "TestSecurityGroupsBasicOps.test_port_security_disable_security_group test gets halted by giving request timed out." [Unspecified,New] - Assigned to dmellado
09:28:17 <gmann> dmellado: humm, mainly `recv_exit_status` should be checked after reading
09:29:32 <dmellado> I've checked the bug that led to this issue, and I haven't been able to reproduce it in any case
09:29:41 <gmann> oomichi: file not found on puppet failure
09:29:52 <gmann> anyways ll check that
09:30:02 <oomichi> gmann: yeah, that seems another failure..
09:30:16 <gmann> oomichi: hidden failure :)
09:30:18 <dmellado> in any case please do review it if you have the time, I'll add EmilienM too
09:30:25 <gmann> sure
09:30:41 <oomichi> dmellado: ok, that is stared on my list
09:30:41 <gmann> next thing is baremetal  tests removal - https://review.openstack.org/#/c/355586/
09:30:46 <dmellado> thanks!
09:30:48 <gmann> oomichi: thanks
09:31:23 <gmann> this patch is much close, i have -1 for service availability of Ironic service which i feel should be in plugin side
09:31:32 <gmann> not in tempest.config.py
09:32:08 <gmann> all other looks fine
09:33:07 <gmann> any more poitns on tempest side or we jump to bugs
09:33:45 <oomichi> gmann: yeah, basically these options would be on plugin side
09:33:45 <gmann> Bug Triage:  we discussd in barcelona that we will start triage rotation again same way we used to do before
09:33:55 <gmann> oomichi: ops sorry
09:34:01 <oomichi> gmann: no problem,
09:34:12 <gmann> oomichi: yea same way congress and ceilometer conrdinate
09:34:32 <oomichi> gmann: config is defined as stable interface also, so it is necessary to take deprecation time
09:34:47 <oomichi> if you want to move them into plugin side
09:34:57 <gmann> oomichi: i think no till those are register from plugin side
09:35:21 <gmann> oomichi: becasue if plugin register those and we can access those same way from tempet config
09:35:27 <gmann> no user effect
09:36:00 <oomichi> gmann: true if no projects are using these options from outside
09:36:02 <gmann> i mean user can still override moved config in tempest.conf
09:36:25 <gmann> oomichi: but still other project can get from from tempest inport config right
09:36:50 <gmann> oomichi: ahh you mean if anyone depends on tempest to register those?
09:36:52 <oomichi> gmann: yeah, if they can use other project as plugin correctly
09:37:13 <dmellado> oomichi: by config do you mean that now plugins can import config from tempest.lib too?
09:37:26 <oomichi> gmann: yeah, that is just a small concern. but as you know, some projects are using the options wrongly as you are fixing
09:37:32 <gmann> oomichi: but if we keep in tempest conf then plugin needs to wait till those get removed from tempest
09:37:45 <gmann> oomichi: yea
09:38:12 <oomichi> gmann: I will check the other projects code later
09:38:39 <gmann> oomichi: ok
09:38:41 <oomichi> dmellado: no, we are defining tempest.conf also as stable interface
09:39:04 * oomichi sorry. my pc battery is super low now. will be off soon
09:39:09 <gmann> oomichi: i got your concern as some of the network tests using baremtal driver enalbe or not
09:39:13 <dmellado> oomichi: I see, wouldn't you have any link to that commit? I'll look for it otherwise
09:39:19 <gmann> oomichi: no prob,
09:39:26 <gmann> oomichi: have a safe flight back
09:39:39 <dmellado> ouch! oomichi safe flight, didn't know you were at the airport ;)
09:39:44 <gmann> dmellado: https://review.openstack.org/#/c/355586/
09:39:48 <gmann> #link https://review.openstack.org/#/c/355586/
09:39:48 <dmellado> thanks gmann
09:39:54 <masayukig> safe trip oomichi
09:40:16 <gmann> so on bug side
09:40:24 <gmann> we started triage rotation
09:40:28 <gmann> in thsi etherpad
09:40:34 <masayukig> o/
09:40:40 <gmann> #link https://etherpad.openstack.org/p/ocata-qa-bug-triage
09:40:57 <gmann> this week rtoation was luzC
09:41:01 <gmann> luzC: ^^
09:41:05 <masayukig> ?
09:41:27 <masayukig> gmann : I think it's me
09:41:36 <masayukig> it's my turn
09:41:40 <gmann> masayukig: your is next week right
09:41:54 * dmellado getting confused with the dates
09:41:58 <gmann> masayukig:  got it
09:42:09 <gmann> masayukig: sorry for mis undersatnding the dates
09:42:12 <gmann> masayukig: go ahead
09:42:16 <masayukig> yup
09:42:52 <masayukig> so, I triaged around 10 bugs
09:43:10 <gmann> masayukig: nice
09:43:12 <masayukig> so, now there's 25 new bugs
09:43:23 <gmann> masayukig: any critical one we should focus
09:43:24 <masayukig> #link http://status.openstack.org/bugday/
09:44:15 <gmann> masayukig: your patch got merged for graph thing?
09:44:32 <masayukig> not yet... There're 3 critical bugs on launchpad..
09:44:35 <masayukig> https://bugs.launchpad.net/tempest
09:45:05 <masayukig> But they are a little bit old..
09:45:24 <gmann> masayukig: 2 are fix committed
09:45:31 <gmann> masayukig: and ssh one is yes old one
09:45:35 <masayukig> yeah, and, I'm not sure this status https://bugs.launchpad.net/tempest/+bug/1298472
09:45:35 <openstack> Launchpad bug 1298472 in tempest "SSHTimeout in tempest trying to verify that computes are actually functioning" [Critical,New] - Assigned to Matt Riedemann (mriedem)
09:46:04 <gmann> ok
09:46:25 <masayukig> that's it from my side
09:46:37 <gmann> and about weekly bug report, i did not get much idea about how many triaged or new came up from this- http://status.openstack.org/bugday/
09:47:05 <gmann> masayukig: should we start a etherpad where we can write weekly finding on bug triage liek we used to do previously
09:47:31 * oomichi is going back to get power
09:47:39 <dmellado> +1 on that, I think it'd make things clearer
09:47:57 <dmellado> oomichi: congrats on finding a power outlet!
09:48:04 <gmann> ok will check that
09:48:10 <masayukig> we can see the number from the json file, but the etherpad idea looks good to me :)
09:48:12 <oomichi> dmellado: thanks :)  congrats :)
09:48:32 <oomichi> yeah, nice to share current status of bugs
09:48:40 <oomichi> by the etherpad
09:48:42 <gmann> #action gmann to check weekly bug triage report machenism (etherpad may be)
09:48:47 <gmann> ok
09:48:54 <gmann> masayukig: Thanks for that.
09:48:56 <masayukig> fyi, curl http://status.openstack.org/bugday/tempest-bug-stats-daily.json | jq '.records[]["new"]'
09:49:17 <masayukig> something like thit
09:49:18 <gmann> next week seems skipped and then my turn
09:49:27 <masayukig> yes
09:49:29 <gmann> masayukig: nice. ll check
09:49:44 <gmann> so 10 min left
09:49:58 <gmann> we will skip devstack and grenade is nothing on those
09:50:07 <masayukig> ok
09:50:10 <gmann> #topic openstack-health
09:50:16 <gmann> masayukig: ^^
09:50:20 <oomichi> gmann: it would be nice to describe a new way(maybe etherpad) on https://etherpad.openstack.org/p/ocata-qa-bug-triage
09:50:26 <gmann> i saw you mapped all summit idea to bugs
09:50:29 * dmellado needs to rush to a meeting, o/ guys
09:50:39 <gmann> oomichi: sure, ll do that
09:50:42 <masayukig> actually, there's nothing about openstack-health specific things, but
09:50:45 <oomichi> gmann: cool, thanks
09:51:11 <masayukig> I'm thinking about to add a graph from coverage2sql data
09:51:20 <gmann> masayukig: cool
09:51:28 <oomichi> masayukig: cool, is that easy to do that?
09:51:43 <gmann> masayukig: ll get all coverage for all project UT ?
09:52:02 <masayukig> It's the best if we can\
09:52:11 <masayukig> but, it's hard to do it
09:52:38 <masayukig> And we need to collect coverage data like subunit2sql doing
09:52:38 <oomichi> masayukig: is it hard because of much data?
09:52:54 <gmann> yea, thats true
09:53:09 <masayukig> yes, and a lot of projects aren't getting the data now,
09:53:31 <oomichi> masayukig: ah, a nice point
09:53:46 <gmann> masayukig: ok, may be we can start with 6 core project and then others
09:53:57 <masayukig> yeah,
09:54:03 <oomichi> gmann: oh, good idea
09:54:24 <masayukig> and we may advertise it after that
09:54:31 <gmann> yea
09:54:44 <gmann> it will incourage other projects
09:54:51 <oomichi> masayukig: yeah, most projects tend to follow after core projects do
09:54:57 <gmann> 5 min left, sorry to jump further
09:55:06 <masayukig> np
09:55:07 <gmann> masayukig: thanks
09:55:10 <gmann> #topic Critical Reviews
09:55:18 <gmann> i think we talked on critical reviews
09:55:35 <gmann> but if anyone want to bring up more please do it
09:55:57 <oomichi> yep, it is nice to move on
09:56:02 <gmann> k
09:56:02 <gmann> #topic Open Discussion
09:56:08 <gmann> anything more to discuss
09:56:16 <gmann> masayukig: you have one
09:56:30 <masayukig> gmann : thanks
09:56:55 <masayukig> I added a new repo under QA https://launchpad.net/coverage2sql
09:57:09 <masayukig> (I already mentioned, though)
09:57:25 <masayukig> It's on very early stage,
09:57:55 <masayukig> if someone is interested in, any feedbacks are welcome :)
09:58:04 <oomichi> oh, that is registered April, that is older than I expected
09:58:06 <gmann> masayukig: cool
09:58:15 <masayukig> oomichi : heh
09:58:21 <masayukig> "coverage2sql is a tool for storing data of test coverage into a SQL database."
09:58:25 <oomichi> masayukig: do we have openstack repo already?
09:58:34 <masayukig> oomichi : yup
09:58:45 <masayukig> #link https://git.openstack.org/cgit/openstack/coverage2sql
09:58:55 <oomichi> masayukig: oh, cool :)
09:59:04 <gmann> yea
09:59:15 <gmann> 1 min left
09:59:24 <DavidPurcell> This definitely looks cool.  AT&T is trying to get test  coverage up for a lot of services, I'll see if I can get some people to help out with it.  :)
09:59:43 <masayukig> DavidPurcell : \o/
09:59:46 <gmann> DavidPurcell: great
09:59:52 <oomichi> DavidPurcell: awesome :)
09:59:56 <masayukig> DavidPurcell : welcome!
10:00:01 <gmann> let's move to qa
10:00:04 <gmann> thanks all
10:00:06 <gmann> #endmeeting