09:01:15 <gmann> #startmeeting qa
09:01:16 <openstack> Meeting started Thu Jan 12 09:01:15 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:19 <openstack> The meeting name has been set to 'qa'
09:01:42 <gmann> hi Who all here today?
09:03:15 <dmellado> gmann: o/
09:03:24 <gmann> dmellado: hi
09:04:07 <gmann> andreaf:  mkoderer___ ping if around
09:04:16 <gmann> dmellado:  let's wait for few min for more people
09:04:24 <dmellado> gmann: sure
09:04:27 <gmann> seems like we 2 today
09:05:36 <dmellado> gmann: hmm, then maybe we can just skip today's meeting
09:05:51 <dmellado> I don't have that many in my agenda, just added the cross-project session propsal to the PTG etherpad
09:06:14 * andreaf lurks in
09:06:20 <dmellado> hey andreaf
09:06:30 <andreaf> gmann: I'm only half here, caring for my son atm
09:06:39 <gmann> andreaf: hi, i see
09:06:40 <andreaf> dmellado: hi
09:07:12 <andreaf> I thought it was going to be an 17 UTC meeting today
09:07:34 <andreaf> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_January_12th_2017_.281700_UTC.29
09:07:36 <gmann> andreaf: actually there was confusion over time in wifi, i updated
09:07:59 <andreaf> ah I see
09:08:25 <andreaf> that may explain why not many are here :D
09:08:26 <gmann> anyways let's start and finish early
09:08:33 <gmann> hummm
09:08:54 <gmann> oomichi: fault as he did update 900UTC in last one :P
09:09:11 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_January_12th_2017_.280900_UTC.29
09:09:14 <dmellado> ouch, yep that could be it, heh
09:09:15 <gmann> ^^ today agenda
09:09:35 <gmann> #topic PTG
09:09:51 <gmann> #link https://etherpad.openstack.org/p/qa-ptg-pike
09:10:09 <gmann> so we have many ideas there and keep putting more
09:10:34 <gmann> main idea will be to keep ready with spec etc if there is any and we can do real progress in PTG with design discussion + coding
09:11:36 <gmann> I will jump to Tempest if nothing on spec etc(all specs are with same state seems)
09:11:49 <dmellado> yep, sounds fine for me
09:12:05 <gmann> #topic Tempest
09:12:10 <gmann> 1. Glance-related tempest patch
09:12:23 <gmann> rosmaita in case you around
09:12:46 <gmann> actually this is something in hot discussion in ML and api-wg meeting etc
09:13:07 <gmann> #link  http://lists.openstack.org/pipermail/openstack-dev/2017-January/109817.html
09:13:22 <gmann> for me it is backward incompatible change and tests should not be updated
09:13:54 <gmann> but you all can provide your opinion on this
09:15:12 <gmann> if nothing to discuss on this i would like to jump to bugs
09:15:52 <gmann> 2. Bug Triage
09:15:56 <gmann> #link https://etherpad.openstack.org/p/tempest-weekly-bug-report
09:16:16 <gmann> it was my turn this week and did some bugs clean up
09:16:20 <gmann> new bugs are 0
09:16:54 <gmann> 1 bug i noticed is about usage of test.idempotent_id
09:17:03 <gmann> #link https://bugs.launchpad.net/tempest/+bug/1616913
09:17:04 <openstack> Launchpad bug 1616913 in tempest "Tempest lib check-uuid enforces use of private tempest methods" [Medium,In progress] - Assigned to Kiall Mac Innes (kiall)
09:17:30 <gmann> all should use tempest.lib.decorators.idempotent_id instead of test.idempotent_id
09:17:50 <gmann> which is something we kept for migration and there are patches also for tempest changes
09:18:22 <gmann> but seems like there are lot of plugin use the same and we need to fix them all before tempest remove test.idempotent_id
09:18:30 <gmann> #link http://codesearch.openstack.org/?q=test.idempotent_id&i=nope&files=&repos=
09:19:03 <gmann> andreaf:  i suppose we can fix plugins for that and remove it from tempest as it is in unstable interface
09:19:51 <andreaf> gmann: sure one of the many...
09:20:52 <gmann> yea, i will see tomorrow how much effort it need(may be some script can do :))
09:21:32 <gmann> and next week bug triage is dmellado you
09:21:35 <gmann> #link https://etherpad.openstack.org/p/ocata-qa-bug-triage
09:21:41 <dmellado> gmann: ack
09:21:43 <dmellado> I'll take care
09:21:50 <gmann> dmellado: thanks
09:22:11 <gmann> we are really in good shape on bugs due to triage rotation
09:22:46 <gmann> let's jump to open
09:22:50 <gmann> #topic Open Discussion
09:23:12 <gmann> do we have anything specific to discuss or we can close the meeting
09:23:57 <andreaf> perhaps it would be good to have an owner in here
09:24:17 <andreaf> #link https://etherpad.openstack.org/p/qa-ptg-pike
09:24:18 <andreaf> for each of the topics
09:24:30 <andreaf> and a link to a dedicated etherpad
09:24:38 <gmann> andreaf:  ahh, nice point
09:24:40 <andreaf> like we usually have at the design summit
09:24:54 <gmann> yea, we should add
09:25:17 <dmellado> gmann: andreaf yeah
09:25:27 <dmellado> I can add myself as the owner for the crossprojects
09:25:33 <andreaf> thanks
09:25:35 <gmann> #action oomichi to ask everyone to add owner on ptg etherpad
09:25:35 <dmellado> althought I'd love seeing oomichi and mtreinish there too
09:25:41 <gmann> i will add on mine
09:26:44 <gmann> anything else to discuss
09:28:26 <gmann> ok let's close. Thanks andreaf dmellado
09:28:38 <andreaf> thank you
09:28:42 <dmellado> thanks gmann
09:28:47 <gmann> #endmeeting