17:00:36 <oomichi_> #startmeeting qa
17:00:37 <openstack> Meeting started Thu Jan 19 17:00:36 2017 UTC and is due to finish in 60 minutes.  The chair is oomichi_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:41 <openstack> The meeting name has been set to 'qa'
17:00:55 <oomichi_> hi who can join the meeting today?
17:01:03 <DavidPurcell> hello o/
17:01:05 <blancos> o/
17:01:12 <jhakimra> o/
17:02:02 <oomichi_> mtreinish: andreaf: ping
17:02:15 <andreaf> o/
17:02:20 <oomichi_> ok, lets get start
17:02:38 <sigmavirus> o/
17:02:50 <oomichi_> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_January_19th_2017_.281700_UTC.29 is today agenda
17:03:00 <oomichi_> #topic PTG
17:03:32 <oomichi_> we are gathering ideas for PTG on #link https://etherpad.openstack.org/p/qa-ptg-pike
17:04:02 <oomichi_> we have 2 full days for qa project
17:04:16 <oomichi_> and I think we can allocate more ideas for days
17:04:31 <oomichi_> it would be nice to put more ideas on that :)
17:05:00 <oomichi_> btw someone know who wrote "Discussion of Test Runners" ?
17:05:27 <oomichi_> we need to assign owner for each slot and the above is empty now
17:05:40 <andreaf> +1
17:05:54 <andreaf> I don't know but if no-one claims the ownership and we don
17:05:58 <andreaf> we don
17:06:05 <andreaf> can't type...
17:06:06 <oomichi_> ok, I will ask it again on the other way
17:06:25 <oomichi_> do we have more topics about PTG today?
17:06:26 <andreaf> and in case we don't have a real need to discuss it we can skip the idea
17:06:59 <oomichi_> andreaf: yeah, I agree. and we can spend remaining time for code sprint
17:07:23 <oomichi_> that would be also productive, and I prefer :)
17:07:53 <oomichi_> ok, lets move on
17:07:57 <andreaf> oomichi_: do we want to have standard sessions like "devstack and grenade"
17:08:09 <andreaf> or "priorities for pike"
17:08:19 <andreaf> as we used to have those discussions at the design summit
17:08:29 <oomichi_> andreaf: humm, nice ideas
17:08:35 <andreaf> I will add those
17:09:09 <andreaf> at least it's good to have the topic there, if there's not much to be said we can close it quickly
17:09:30 <oomichi_> andreaf: I wrote them on etherpad now as note, and we can arrange them later
17:09:39 <andreaf> thanks
17:10:00 <oomichi_> yeah, o-h also is nice topic
17:10:10 <oomichi_> DavidPurcell: how about policy testing ?
17:10:48 <oomichi_> don't we need to discuss the direction of patrole on PTG?
17:10:51 <DavidPurcell> oomichi_ Going well.  Framework added and we're starting to push up tests.
17:11:04 <DavidPurcell> We definitely could add it to the PTG discussions.
17:11:27 <oomichi_> DavidPurcell: cool, can you write your idea down on the etherpad?
17:11:35 <DavidPurcell> sure.
17:11:55 <oomichi_> DavidPurcell: thanks :)
17:12:18 <oomichi_> OK, lets move on
17:12:31 <oomichi_> #topic Specs Reviews
17:12:54 <oomichi_> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:13:24 <oomichi_> oh, new spec is comming* #link https://review.openstack.org/#/c/422170/
17:13:57 <oomichi_> do we have topics about specs today?
17:14:56 <oomichi_> ok, lets move on
17:15:03 <oomichi_> #topic Tempest
17:15:41 <oomichi_> this week, dmellado was bug triager
17:16:13 <oomichi_> bug triage itself seems on good progress
17:16:30 <oomichi_> #link https://github.com/oomichi/bug-counter#current-graph shows bug number progress
17:16:45 <oomichi_> the number still continues decreasing
17:17:11 <andreaf> yay!
17:17:46 <oomichi_> the next assignee is chandankumar, I am happy to see the progress next week :)
17:18:15 <oomichi_> Do we have more topics about Tempest?
17:18:22 <andreaf> yeah
17:18:37 <andreaf> the -ssh job is now voting on Tempest
17:18:51 <oomichi_> andreaf: yeah, thanks for making it on
17:19:09 <andreaf> the periodic job is running fine but we had a few failures on chack / gate (3 on check and 1 on gate)
17:19:10 <andreaf> related to AttachVolumeShelveTestJSON.test_attach_detach_volume
17:19:15 <oomichi_> the gate still seems stable now
17:19:40 <andreaf> it may be that this is picking up race condition with shelve / unshelve and floating IPs
17:19:54 <andreaf> I'll keep an eye on it, it's not severe enough for now to do anything
17:19:55 <oomichi_> andreaf: do we have LP report for them?
17:20:11 <andreaf> not yet, I was still looking at the issue
17:20:25 <andreaf> trying to make a decent lp report :)
17:20:34 <clarkb> also logstash/elasticsearch/elastic-recheck are mostly all working well right now. So if can get the classification rate up we should have a very good view into what is and isn't working
17:20:41 <clarkb> (right now it is at 43% which seems low)
17:21:09 <andreaf> clarkb: sure, that was going to be my next step after the bug
17:22:03 <oomichi_> andreaf: cool, thanks for that
17:22:36 <oomichi_> I dont have difficult patches to be reviewed now, so can we move on?
17:23:24 <oomichi_> #topic DevStack + Grenade
17:23:45 <oomichi_> do we have more topics about DevStack + Grenade today?
17:24:24 <andreaf> I don't know if sdague is around?
17:24:44 <andreaf> I think it's worth to mention that there's a new project in the QA program - devstack-tools
17:25:12 <oomichi_> andreaf: ah, nice point. That became under QA yesterday
17:25:43 <andreaf> it's a python port of a number of devstack functions, made by sdague
17:25:51 <oomichi_> #link https://review.openstack.org/#/c/421915/
17:26:11 <oomichi_> the original is #link https://github.com/sdague/devstack-tools
17:26:36 <sigmavirus> sdague: nice work :)
17:27:34 <oomichi_> IIUC, that makes devstack(bash) into python as possible
17:28:37 <oomichi_> it was best to introduce it by sdague , but now is not active
17:29:18 <oomichi_> lets move on if not having more discussion *)
17:29:39 <oomichi_> #topic openstack-health
17:30:08 <oomichi_> #link https://review.openstack.org/#/q/project:openstack/openstack-health+status:open
17:30:49 <oomichi_> most patches are under good reviws
17:31:23 <oomichi_> so do we have discussion points today
17:32:08 <oomichi_> ok, lets move on
17:32:12 <oomichi_> #topic Patrole
17:32:35 <oomichi_> I feel DavidPurcell already said its progress ;)
17:33:01 <DavidPurcell> haha, yes.
17:33:26 <oomichi_> DavidPurcell: are there any problem for it today ?
17:33:47 <DavidPurcell> Nothing huge.  We are mostly still migrating the AT&T code we wrote internally.
17:34:10 <DavidPurcell> Some extra eyes on the reviews would be nice :)
17:34:35 <oomichi_> DavidPurcell: oh, that is awesome. I wondered how to produce the code so quickly. I know the answer now :)
17:34:49 <oomichi_> yeah, it is nice to get more eyes
17:34:56 <dmellado> yep DavidPurcell, I'll have a look at the open reviews at the repo whenever I get the chance ;)
17:35:08 <DavidPurcell> oomichi_: Haha, yes.  We're good, but not that good ;)
17:35:12 * dmellado tries to get over a dreaded cold xD
17:36:19 <oomichi_> haha,
17:36:21 <DavidPurcell> But unless there are any questions, I don't have anything else for Patrole.
17:36:44 <andreaf> DavidPurcell: I haven't checked Patrole yet - do you have some CI in place already?
17:37:34 <DavidPurcell> andreaf: There are some unit tests
17:37:44 <andreaf> great :)
17:38:56 <oomichi_> Patrole seems good progress. OK, lets move on
17:39:10 <oomichi_> #topic Critical Reviews
17:39:33 <oomichi_> do we have patches which are necessary to be reviewed soon today?
17:40:41 <oomichi_> oh, nobody have. That is good :)
17:40:58 <oomichi_> #topic Voting permission for IBM PowerKVM CI on devstack (mmedvede)
17:41:14 <mmedvede> hi qa
17:41:19 <oomichi_> mmedvede: can you metion here ?
17:41:30 <oomichi_> mmedvede: please go ahead :)
17:41:38 <mmedvede> I wanted to follow up from the last meeting http://eavesdrop.openstack.org/meetings/qa/2017/qa.2017-01-05-17.00.log.html
17:41:59 <dmellado> mmedvede: could you pls summarize?
17:43:03 <oomichi_> IIUC, the IBM CI is voting on nova. and this is trying to make it voting on Tempest
17:43:13 <mmedvede> from that last meeting, and discussion in qa channel, It seemed like there were no big objections to enabling voting for IBM PowerKVM CI
17:43:28 <dmellado> can't we make it non-voting first?
17:43:33 <mmedvede> oomichi_: almost, voting on devstack
17:43:38 <mmedvede> not voting on tempest
17:44:07 <oomichi_> mmedvede: oh, sorry. And devstack one is stable now, right?
17:44:08 <mmedvede> dmellado: it is currently non-voting on devstack: http://ci-watch.tintri.com/project?project=devstack&time=7+days
17:44:24 <dmellado> oh, on devstack *not tempest*
17:44:27 <mmedvede> oomichi_: correct, it is stable on devstack patches
17:45:16 <oomichi_> mmedvede: oh, that seems to become more stable than I checked before
17:45:45 <dmellado> oomichi_: quoting you here "if that would be voting and give -1 on unrelated patches, that makes the review process slow"
17:45:45 <oomichi_> I dont have objections against the voting
17:45:57 <mmedvede> as you mention it, we do check tempest patches too, so I do not mind making it report on tempest as well :) but one thing at a time
17:46:01 <dmellado> but if it's stable enough, worst case it'd be just a '-1'
17:46:22 <oomichi_> dmellado: yeah, that is a point :)
17:46:37 <mmedvede> yes, concern was that -1 might make people less likely to review. But it would not block a patch from merging
17:46:51 * dmellado tends to fear third-party results in neutron...
17:47:10 <oomichi_> dmellado: haha, it is
17:47:51 <oomichi_> ok, if there is not objection here, I will make it voting
17:48:33 <oomichi_> Even after voting and facing issue, it is easy to make it non-voting again
17:48:42 <mmedvede> true :)
17:49:09 <mmedvede> so we would do our best so you would not have to
17:49:30 <oomichi_> #action oomichi makes IBM PowerKVM CI voting
17:50:08 <mmedvede> \o/
17:50:21 <oomichi_> ok, lets move on
17:50:36 <oomichi_> #topic Open Discussion
17:50:52 <oomichi_> do we have more topics today ?
17:51:09 <dmellado> I guess you already covered the PTG topics, didn't you?
17:51:26 <oomichi_> dmellado: yeah, that was the first topic today :)
17:51:43 <dmellado> then I'll check the history later ;)
17:51:48 <luzC> I'll take a look at PTG topics also...
17:51:50 <oomichi_> dmellado: we are gathering ideas on https://etherpad.openstack.org/p/qa-ptg-pike
17:52:02 <oomichi_> you have already put yours on that :)
17:52:24 <dmellado> oomichi_: yeah, I put it there to revisit the plugin stuff
17:52:44 <luzC> oomichi_ quick question can I add grenade items on it or should I take that conversation out?
17:53:12 <oomichi_> luzC: grenade topic for PTG is welcome :)  please write it down on the etherpad
17:53:31 <luzC> oomichi_ ok, I will thanks
17:53:50 <dmellado> luzC: if you can get it stable I'll get you some beers ( + help on the PTG ) xD
17:53:52 <oomichi_> luzC: happy to hear that
17:54:20 <luzC> hahaha
17:54:24 <luzC> +1 :)
17:55:13 <oomichi_> cool :)
17:55:29 <oomichi_> do we have more topics today ?
17:56:03 <oomichi_> thanks all :)
17:56:06 <oomichi_> #endmeeting