09:00:14 <gmann> #startmeeting qa
09:00:15 <openstack> Meeting started Thu Feb  9 09:00:14 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:18 <openstack> The meeting name has been set to 'qa'
09:00:28 <masayukig> o/
09:00:35 <gmann> hello, who all here today ?
09:00:37 <gmann> masayukig: hi
09:00:45 <zhufl> hi
09:01:20 <gmann> zhufl: hi, nice to see you in meeting
09:01:43 <zhufl> gmann:^-^
09:01:57 <gmann> let's wait for few more min to have more people
09:02:09 <DavidPurcell> o/ good morning
09:02:18 <gmann> DavidPurcell: morning
09:02:59 <gmann> dmellado chandankumar ..
09:03:14 <tosky> o/
09:03:29 <gmann> tosky:  hi
09:03:30 <blancos> o/
09:03:36 <gmann> blancos:  hi
09:03:44 <gmann> let's start as we enough people now
09:03:47 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_February_9th_2017_.280900_UTC.29
09:03:55 <gmann> ^^ today agenda
09:04:10 <chandankumar> dmellado: gmann \o/
09:04:53 <gmann> I really want to track ocata cycle items more precisely to avoid missing priority items after good plan
09:04:57 <gmann> chandankumar:  hi
09:05:15 <gmann> but let's do it from next meeting onwards as we have to plan for PTG
09:05:20 <gmann> #topic PTG
09:05:30 <gmann> #link https://etherpad.openstack.org/p/qa-ptg-pike
09:05:40 <gmann> etherpad link
09:05:52 <gmann> we have lot of ideas which is nice thing
09:06:22 <gmann> we still waiting for what all room(with capacity ) we will be allocated
09:06:45 <gmann> and depending on that we can plan each sessions
09:07:09 <gmann> but i think we should keep dividing the sessions with time slot based on priority
09:07:35 <gmann> i will check with andreaf how he want to process each sessions.
09:07:45 <gmann> time + parallel allocation of sessions
09:08:04 <gmann> #action gmann to check with andreaf  about time allocation of PTG sessions
09:08:22 <gmann> any feedback ideas about sessions discussions in PTG ?
09:08:27 <masayukig> gmann : yeah, and I think we have some interactive sessions with the other projects
09:08:56 <masayukig> I think we( andreaf? ) need to coordinate for it.
09:09:03 <gmann> masayukig: yea honestly saying i see very challenges in such sessions
09:09:15 <gmann> not sure how much people from required projects we will have there
09:09:23 <gmann> +1
09:09:28 <masayukig> heh, yea
09:10:08 <gmann> so we have interactive projects section in each one and let's take those and coordinate with other projects via ML or their PTL etc
09:10:30 <masayukig> +1
09:10:33 <chandankumar> +1
09:11:04 <gmann> #action andreaf to send notification/request to ask required projects representative from their PTL/Cores in cross project sessions
09:11:37 <gmann> i am putting AI for andreaf  but all team is there to help and he can divide the resp in case of overloaded :)
09:11:46 <dmellado> gmann: o/
09:11:52 <gmann> dmellado: hi
09:12:08 <gmann> hope you all join PTG
09:12:22 <gmann> zhufl: hope you get the visa things before PTG dates
09:12:28 <dmellado> gmann: yep, I'll be there. We couldn't get chandankumar visa in time, sadly
09:12:35 <gmann> oh
09:12:38 <gmann> dmellado: thanks
09:12:47 <masayukig> oh.. :(
09:12:58 <dmellado> gmann: masayukig
09:12:59 <zhufl> gmann:me may not:(
09:13:00 <dmellado> that said
09:13:04 <DavidPurcell> I can't, but other AT&T folks will be there :(
09:13:10 <dmellado> I'll be trying to put all things in etherpad/irc
09:13:13 <gmann> chandankumar: even lot of rejection from my india team but fortunately one member for in a week
09:13:16 <dmellado> so he can join online
09:13:30 <dmellado> and hopefully more folks would be able to, too
09:13:30 <gmann> chandankumar: you applying from channai or delhi ?
09:13:53 <gmann> DavidPurcell: oh, yea nice to have people
09:14:48 <gmann> chandankumar: let us know if we can help anything on visa things
09:15:22 <gmann> another things if you have any other topic to discus feel free to add on etherpad
09:15:31 * dmellado thought that India nationals could apply to ESTA
09:15:43 <dmellado> tbh I was quite surprised when I found out all this visa stuff...
09:16:10 <gmann> dmellado:  yea, its all complicated for me too
09:16:28 <gmann> zhufl: i added topic of coordinating company owned tests to upstream as you mentioned in mail
09:16:43 <gmann> and let's try to find the best way to do that
09:16:48 <dmellado> gmann: I'll try to join that discussion too
09:16:50 <zhufl> gmann: yes I see it ,thank you:)
09:17:00 <gmann> we really encourage people to upstream their tests/ideas
09:17:10 <chandankumar> gmann: i was going through mumbai
09:17:11 <gmann> dmellado: cool
09:17:12 <dmellado> there are quite a few folks working with me who I'm really trying to push upstream
09:17:27 <gmann> chandankumar: ohk, and they takes time or it is not approved ?
09:17:43 <gmann> dmellado: great, that is good news
09:17:51 <dmellado> gmann: chandankumar told me it'd just take too long to get it done
09:17:56 <chandankumar> gmann: the queue was very long.
09:17:57 <dmellado> and internally we were also a li'l bit late
09:18:00 <gmann> hummm
09:18:29 <gmann> anything else to discuss for PTG ?
09:18:46 <dmellado> gmann: I guess also for the PTG
09:18:54 <dmellado> we could try to do a bug smash session
09:19:16 <gmann> till next meeting at 17UTC we should be ready with all PTG preparation. mainly sessions allocation
09:19:39 <gmann> dmellado: nice idea, we can try that if we or some people have time
09:19:59 <gmann> may be worth to have a group working on that and people can join that
09:20:06 <dmellado> that's what I think too
09:20:10 <gmann> cool.
09:20:33 <gmann> dmellado: out that idea on etherpad till we just forget after meeting
09:20:41 * dmellado typing as we speak
09:21:00 <gmann> #action dmellado to add bug smash sessions on etherpad
09:21:09 <gmann> #topic Specs Reviews
09:21:19 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:21:57 <gmann> i can see new spec on grenade -
09:21:59 <gmann> #link https://review.openstack.org/#/c/422170/
09:22:08 <gmann> check this out if get time
09:22:22 <jordanP> (o/ Sorry I am late)
09:22:34 <gmann> jordanP: hi
09:22:56 <gmann> anyone want to discuss anything specific to current specs
09:23:38 <gmann> we should start spec writing for PTG sessions where ever applicable
09:23:55 <gmann> it will utilize our time in PTG more efficiently
09:24:11 <masayukig> yeah, good idea
09:24:18 <gmann> even etherpad preapration etc can be done as early as possible
09:24:29 <jordanP> yeah, if the "session owners" could fill the etherpad a much as possible that would be great
09:24:38 <gmann> jordanP: +1
09:24:47 * masayukig nods
09:24:48 <jordanP> so that we know what we want to achieve
09:25:23 <gmann> so let's iterate the eptherpad may be next early and start finishing all these TODO for each sessions
09:25:48 <jordanP> yeah
09:27:15 <dmellado> +1
09:27:25 <gmann> sorry guys nework issue
09:27:30 <dmellado> np gmann
09:27:34 <masayukig> :)
09:27:42 <dmellado> can you go ahead with the meeting? if you can't we can handle it ;)
09:27:45 <gmann> i will be able to spend more time this weekend as no cricket match for me
09:27:59 <gmann> let's move
09:28:07 <gmann> #topic Tempest
09:28:29 <zhufl> can we come to an agreement on when to use Nova's security group and when to use Neutron's security group in testcases?
09:28:36 <gmann> #link  https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:28:38 <zhufl> In ScenarioTest, create_server uses Neutron's security group, while _create_security_group uses Nova's, that will cause trouble
09:28:54 <gmann> zhufl: neutron one always for new tests
09:29:08 <zhufl> new tests?
09:29:10 <gmann> zhufl: we have deprecated security group and all kind of proxy in Nova
09:29:12 <dmellado> yeah, nova one is really legacy
09:29:34 <jordanP> yeah, new tests should use Neutron API for security grouos
09:29:44 <jordanP> old tests should be kept as is
09:29:45 <gmann> zhufl: we do not want to completely remove from existing tests as those are deprecated not removed yet
09:30:11 <gmann> even for image volume things also new tests should use direct API not nova proxy
09:30:27 <zhufl> oh, and if neutron's security group is not enabled?
09:30:43 <zhufl> if neutron's security group ext is not enabled
09:30:55 <gmann> zhufl: it means skip the tests as cloud is what with no sec group
09:31:05 <gmann> and on gate we make sure we have those enabled
09:31:11 <jordanP> yeah, probably skip the tests
09:31:37 <zhufl> ok, I see. that will be simple then
09:31:43 <gmann> but test should have logic to skip if required extension is not there
09:31:50 <zhufl> yes
09:31:58 <gmann> so that tempest can be able to run on a type of cloud
09:32:12 <dmellado> yep, that should be dealt with a skip decorator
09:32:22 <zhufl> and shall we change using Nova' security group to using Neutron's in old testtests?
09:32:40 <gmann> yea or in skip method if it depends on all tests in that class
09:33:18 <zhufl> I see
09:33:23 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:33:34 <gmann> these are open reviews in tempest ^^
09:33:59 <gmann> keep the good work as we are doing and keeping review frequency in good pace
09:34:53 <gmann> anything on tempest side before moving to bug things
09:35:39 <jordanP> nope from me
09:35:46 <gmann> ok let's move then
09:35:49 <gmann> Bug Triage.
09:36:03 <gmann> #link https://etherpad.openstack.org/p/ocata-qa-bug-triage
09:36:28 <gmann> #link https://etherpad.openstack.org/p/tempest-weekly-bug-report
09:36:28 <masayukig> #topic Bug Triage
09:36:38 <gmann> seems like andreaf had this week
09:36:42 <gmann> masayukig: thanks
09:36:54 <masayukig> gmann : but it doesn't work.. :-o
09:37:11 <dmellado> heh
09:37:25 <gmann> #topic Bug Triage
09:37:29 <gmann> :)
09:37:36 <masayukig> :)
09:37:41 <gmann> seems like we have 4 new bugs
09:37:51 <gmann> ll check those
09:37:59 <gmann> chandankumar: seems you have next week one ?
09:38:28 <gmann> the last rotation for Ocata
09:38:48 <gmann> and we will try to make  NEW as 0 before we release Ocata
09:39:24 <gmann> masayukig:  whats the deal with this - https://github.com/oomichi/bug-counter#current-graph
09:39:42 <gmann> i feel we should start a bug dashbaord like other team.
09:39:48 <gmann> what you guys thinks ?
09:40:12 <masayukig> gmann : bug dashboard?
09:40:13 <dmellado> I think it'd be a nice addition
09:40:23 <dmellado> on top of openstack-helath, of course ;)
09:40:28 <gmann> masayukig:  like review dashboard kindda
09:40:59 <dmellado> btw, masayukig if you get the time at the PTG I'd like to talk with you about some possible enhancements :D
09:41:00 <jordanP> what's a bug dashboard ?
09:41:08 <gmann> dmellado: not o-h, i was thinking which tells us weekly progress and critical bugs and imp one very clearly
09:41:09 <jordanP> a link ?
09:41:11 <dmellado> gmann: could you post an example of an existing one?
09:41:26 <gmann> let me check
09:41:27 <masayukig> like this http://status.openstack.org/bugday/ ?
09:42:35 <jordanP> we are at the bottom of the page already
09:42:41 <gmann> humm
09:43:09 <gmann> this is graph one, i was talking about other one
09:43:23 <gmann> but ll take time to have example link
09:43:37 <gmann> i will search and let you all know later
09:43:40 <dmellado> gmann: maybe we can follow up on this on the m-l?
09:43:45 <gmann> yea
09:43:53 <masayukig> ok
09:44:02 <gmann> #action gmann to check and ask bug dashboard feedback in team
09:44:14 <gmann> #topic DevStack + Grenade
09:44:21 <gmann> anything on devstack and grenade ?
09:44:47 <gmann> seems nothing
09:44:49 <gmann> #topic openstack-health
09:44:54 <gmann> masayukig:  please go ahead
09:45:14 <masayukig> the angular1.6 issue was resolved, so,
09:45:27 <jordanP> I asked myself yesterday 'when was the last devstack failure I faced on my laptop ?' And i can't remember, devstack is way more stable than 2 years ago
09:45:27 <masayukig> the gate is now healthy :)
09:45:51 <masayukig> jordanP : yeah
09:45:52 <gmann> jordanP: cool.
09:46:09 <gmann> masayukig: thanks for fixing and making gate good
09:46:21 <gmann> masayukig: we have session on o-h feedback for PTG ?
09:46:30 <gmann> i forgot if we have in list on etherpad
09:46:39 <masayukig> gmann : heh, I did nothing, though. ah, yeah,
09:46:58 <masayukig> gmann : looks good to me
09:47:09 <gmann> may be quick sessions will be good to see what extra people expect from o-h
09:47:15 <dmellado> jordanP: on devstack I guess there's more issue on the plugins than on the main devstack
09:47:18 <dmellado> ;)
09:47:26 <dmellado> I had an issue while using devstack + manila + sahara
09:47:36 <dmellado> but only if I had the two plugins
09:47:44 <jordanP> erf, yeah, I can imagine
09:47:52 <gmann> dmellado: plugins never be perfect :)
09:47:57 <gmann> we know tempest one also
09:48:07 <gmann> ok, anything else masayukig  ?
09:48:17 <masayukig> nope, thanks :)
09:48:22 * gmann reminds 12 min left
09:48:27 <gmann> masayukig: thanks
09:48:30 <gmann> #topic Patrole
09:48:39 <gmann> DavidPurcell: your turn..
09:49:05 <gmann> anything you want to discuss or highlight on Patrole
09:49:06 <DavidPurcell> I'm actually handing the reins to blancos.  I'm moving to a less active role in Patrole and she's taking over :)
09:49:24 <gmann> cool
09:49:32 <gmann> blancos: thanks
09:50:02 <gmann> i will also start reviewing those as in Nova we are discussing about providing more roles on policy side
09:50:03 <blancos> Glad to help contribute :)
09:50:25 <gmann> so that operator need not to have their own written roles
09:50:34 <gmann> and that will be good to tests in Patrole
09:51:14 <DavidPurcell> You can use Patrole with default roles or custom ones.
09:51:20 * dmellado needs to leave early today, looking forward to meeting you guys soon!
09:51:32 <jordanP> hehe
09:51:46 <gmann> trye
09:51:49 <gmann> true
09:52:00 <gmann> dmellado: thanks see u soon
09:52:08 * masayukig is waving to dmellado
09:52:15 <gmann> I really want to add HA project status here for fast progress
09:52:29 <gmann> and think many people on production testing  want that
09:53:02 <jordanP> HA is hard to test..
09:53:26 <gmann> yea, but let's see how much we can failure scenario we can cover
09:53:29 <jordanP> many people are testing that, good for them, if they want to start a new project upstream, good. But not in Tempest
09:53:52 <gmann> yea that we already decided not in tempest and new project got go ahead in barcelona
09:54:06 <gmann> but seems not much  progress after that
09:54:07 <masayukig> yeah
09:54:28 <gmann> ok let's move as 5 min left
09:54:34 <DavidPurcell> sure
09:54:34 <gmann> #topic Critical Reviews
09:54:46 <gmann> any critical imp review from anyone
09:55:55 <gmann> ok let's move on open discussion
09:55:57 <gmann> #topic Open Discussion
09:56:12 <gmann> anything else people want to discuss
09:56:16 <jlibosva> hi! o/ I'd like to raise awareness of this bug https://bugs.launchpad.net/tempest/+bug/1592345
09:56:16 <openstack> Launchpad bug 1592345 in tempest "Import of tempest.test has side-effect that config is parsed" [Undecided,Confirmed] - Assigned to chandan kumar (chkumar246)
09:56:21 <jordanP> I was happy to have 2 strong candidates for the PTL position
09:56:29 <jordanP> long time, valuable contributors
09:56:35 <gmann> jordanP: :) thanks
09:56:49 <gmann> jlibosva: sure i will check tomorrow for sure
09:56:53 <masayukig> jordanP : +++++++++
09:57:00 <jlibosva> basically it seems that importing tempest module parses CLI arguments and it blocks development of some in-tree tempest tests in Neutorn
09:57:01 <DavidPurcell> jordanP: agreed!
09:57:08 <jlibosva> gmann: thanks! it's been there for a while
09:57:41 <gmann> jlibosva: this seems confirmed ? any thing to discuss on this ?
09:58:11 <jlibosva> gmann: I just wanted to raise it here as it seems to lack attention :)
09:58:29 <jlibosva> discussion can happen on the launchpad I guess
09:58:49 <gmann> jlibosva: i see, ll check tomorrow and reply accordingly if anything needed otherwise push patch
09:59:00 <jlibosva> gmann: thanks
09:59:02 <gmann> we have 2 min left...
09:59:06 <gmann> 1
09:59:23 <jordanP> jlibosva, I've just commented on the bug report
09:59:37 <gmann> let's meet at Atlanta and all have safe flight.
09:59:50 <gmann> 3...
09:59:55 <jordanP> yep, see you there
09:59:57 <gmann> 2..
10:00:03 <gmann> 1.
10:00:04 <gmann> thanks all
10:00:15 * gmann #endmeeting
10:00:23 <gmann> #endmeeting