09:00:31 <gmann> #startmeeting qa
09:00:32 <openstack> Meeting started Thu May 18 09:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:35 <openstack> The meeting name has been set to 'qa'
09:00:49 <andreaf> o/
09:01:01 <zhufl> hello
09:01:03 <tosky> hi
09:01:11 <chandankumar> hello
09:01:11 <gmann> who all here today?
09:01:36 <martinkopec> hi
09:01:51 <gmann> let's start
09:01:53 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_May_18th_2017_.280900_UTC.29
09:02:07 <gmann> ^^ today agenda
09:02:26 <gmann> #topic Previous Meeting Action review
09:02:46 <gmann> no open action as of now #link http://eavesdrop.openstack.org/meetings/qa/2017/qa.2017-05-04-09.00.html
09:03:00 <gmann> #topic The Forum, Boston
09:03:14 <gmann> as you all know, we had summit last week.
09:03:24 <gmann> 1 onbaording and forum sessions
09:03:40 <gmann> Onboarding: May 8(Mon), 16:40- #link https://etherpad.openstack.org/p/BOS-QA-onboarding
09:03:58 <gmann> Forum: May 11(Thurs), 9:00- #link https://etherpad.openstack.org/p/BOS-forum-qa-tools-plugins
09:04:33 <gmann> we tried to capture all discussion on etherpad , who did not make in summit
09:05:05 <gmann> andreaf:  how you want to track discussion on forum etc ?
09:05:17 <gmann> i tried to add tags on each query/items
09:05:39 <andreaf> gmann: thanks I saw that - I plan to follow-up on the ML with a summary from the etherpad
09:05:57 <andreaf> gmann: there are few if no actionable items though
09:06:38 <andreaf> gmann: apart from a kind reminder of announcing big changes in devstack / tempest beforehand in the ML
09:06:58 <gmann> andreaf: yea few of them are long term things like coordinating with other community etc
09:07:16 <gmann> andreaf: +1, yea that was one of the pain point
09:07:26 <andreaf> gmann: exactly that's something good to keep in mind / in our vision in general
09:08:09 <andreaf> gmann: so if any of us already work in adjacent communities and you see there an issue that could be solved with an openstack tool
09:08:27 <andreaf> go ahead and share it to the other community
09:09:18 <gmann> yea, that will be nice collaboration and we can get more feedback about doing it in better way if any
09:10:05 <gmann> andreaf: thanks for plan to summarize on ML
09:10:10 <chandankumar> andreaf: gmann is it something related tempest plugin pike goal or other topic?
09:10:39 <gmann> chandankumar: goal is being agreed on other TC sessions.
09:11:00 <gmann> and had lot of voting also but not sure why it was updated :)
09:11:03 <andreaf> gmann: heh yeah - let's wait to see the votes though :)
09:11:16 <andreaf> gmann: because of a misunderstanding...
09:11:26 <gmann> hummm
09:11:28 <andreaf> gmann: it was updated because of  a misunderstanding
09:11:40 <andreaf> it was proposed to do an update in a follow up patch
09:11:45 <gmann> link could have been in follow up patch
09:11:47 <gmann> yea
09:11:47 <andreaf> instead a new patchset was proposed
09:11:56 <andreaf> meh
09:11:59 <andreaf> anyways
09:12:02 <gmann> mtreinish has to get all vote again :)
09:12:34 <gmann> #link https://review.openstack.org/#/c/369749/
09:12:34 <patchbot> patch 369749 - governance - Add Queens goal split out tempest plugins
09:12:57 <andreaf> chandankumar: one of the hot topics at the summit as well as in the TC vision is adjacent communities
09:13:15 <andreaf> chandankumar: such as k8s for instance
09:13:52 <chandankumar> andreaf: yes, do we talked there how tempest would fit there as a testing framework
09:14:08 <prateek> andreaf, and how do we plan to consume tempest in them ?
09:14:17 <andreaf> chandankumar: as an openstack community we want to work well with them share best practices, tools, do cross testing where it makes sense etc
09:14:28 <prateek> sounds good
09:14:44 <andreaf> prateek, chandankumar: it depends very much on the community
09:15:05 <gmann> yea, and can get their best practices too
09:15:09 <andreaf> we are not going to go and tell people "use this tool for testing"
09:15:25 <andreaf> but we can share success stories / best practices
09:15:48 <andreaf> and if someone has a problem that can be solved with tempest we should suggest it
09:16:22 <andreaf> or in future we could run integration tests in openstack gates which pull other components and drive them via Tempest for instance
09:16:39 <gmann> opencontrail seems using tempest plugin it think
09:17:34 <andreaf> gmann: https://github.com/Juniper/contrail-tempest?
09:17:51 <gmann> :)
09:17:59 <chandankumar> gmann: andreaf https://github.com/Juniper/contrail-test
09:18:01 <prateek> :)
09:18:02 <andreaf> the repo is rather empty :P
09:18:07 <gmann> not sure this but few guys told they use it
09:18:33 <chandankumar> https://github.com/Juniper/tempest
09:18:34 <prateek> maybe they might not have open sourced it
09:18:39 <chandankumar> https://github.com/Juniper/contrail-test/wiki/Running-Neutron-Tempest-Tests
09:18:41 <gmann> even in upstream training, ll check with them if i can reach
09:18:58 <gmann> anyways
09:19:15 <gmann> anything else on summit queries/discussion ?
09:19:32 <chandankumar> nope from myside!
09:19:53 <gmann> #topic Gate Stability - status update
09:20:02 <gmann> #link https://goo.gl/LV4kel
09:20:20 <andreaf> it looks pretty good :)
09:20:28 <gmann> i cannot see high peak recently
09:20:29 <gmann> yea
09:20:45 <gmann> #link http://status.openstack.org/elastic-recheck/gate.html
09:21:06 <andreaf> #link https://review.openstack.org/#/c/465487/ The patch to run migration tests now merged
09:21:06 <patchbot> patch 465487 - openstack-infra/project-config - Run migration tests along scenario ones (MERGED)
09:21:15 <andreaf> nova migration tests that is
09:21:43 <andreaf> so we now have a non-voting multi-node job which runs all scenario and nova migration tests with concurrency 2
09:21:47 <gmann> andreaf: but that need multinode
09:22:00 <gmann> ohk with scenario tests
09:22:20 <andreaf> if that is stable enough I will try to make it voting :)
09:22:28 <andreaf> it also runs with no identity v2
09:22:31 <andreaf> and test accounts
09:22:45 <gmann> you mean v3 + test account?
09:23:17 <andreaf> yes identity v2 disabled
09:23:24 <andreaf> v3 is not the default anyways
09:23:48 <gmann> andreaf: nova have separate job to run migration tests and i think not running new scenario job
09:24:09 <gmann> in case nova want to run scenario tests too?
09:24:58 <andreaf> gmann: maybe - mostly I wanted to have a job on Tempest side where we can see those kind of tests running
09:25:30 <gmann> yea, may be nova can add that as separate job, should not be harder
09:25:33 <andreaf> gmann: because otherwise I fear we may break them - especially since they are used in nova gates
09:26:00 <gmann> yea, everytime we have to tests those on nova side or experimental
09:26:15 <gmann> let's see how stable they are and good to make them voting
09:26:46 <andreaf> related to the gate, I also have another patch up to enable ssh by default in devstack (i.e. for master only)
09:26:56 <andreaf> #link https://review.openstack.org/#/c/458678/ turning ssh on in all jobs
09:26:57 <patchbot> patch 458678 - openstack-dev/devstack - Enable ssh validation by default
09:27:32 <gmann> andreaf: for all job. hummm
09:27:36 <andreaf> I think it would be good to have ssh validation on by default
09:27:51 <gmann> then we do not need separate ssh job
09:28:05 <andreaf> gmann: yes, indeed!
09:28:07 <gmann> that is kind of stable right
09:28:34 <andreaf> gmann: yes, however it only runs against tempest
09:28:47 <gmann> yea
09:28:55 <andreaf> and I fear that changes on nova / neutron side might introduce regressions
09:29:14 <andreaf> there are still one or two scenario tests in the integrated gate that do ssh validation
09:29:15 <gmann> andreaf: any tempest test patch with Depends-ON ?
09:29:37 <andreaf> so we are not fully exposed - but I think more tests with ssh checks would be good in the integrated gate
09:29:46 <andreaf> gmann: heh good point I will make one
09:29:53 <gmann> andreaf: thanks
09:31:26 <gmann> andreaf: will be good to see the scenario job behavior
09:32:40 <gmann> let's move next
09:32:42 <gmann> #topic Specs Reviews
09:32:57 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:33:44 <gmann> saw new spec #link https://review.openstack.org/#/c/461140/
09:33:44 <patchbot> patch 461140 - qa-specs - RBAC testing multiple policies
09:34:17 <andreaf> #link https://review.openstack.org/#/c/461140/  new spec
09:34:18 <patchbot> patch 461140 - qa-specs - RBAC testing multiple policies
09:34:21 <gmann> i need to check this. cannot find patrole team
09:34:31 <gmann> andreaf: yea
09:34:39 <chandankumar> gmann: this spec https://review.openstack.org/#/c/461140/ is for patrole na?
09:34:40 <patchbot> patch 461140 - qa-specs - RBAC testing multiple policies
09:34:52 <gmann> chandankumar: yes
09:35:02 <chandankumar> ack!
09:35:03 <blancos> Is there a question regarding the spec?
09:35:20 <chandankumar> not from myside.
09:35:20 <gmann> blancos: hi
09:35:27 <andreaf> blancos: I haven't read it yet, but I will :)
09:35:40 <gmann> blancos: we have not reviewed yet, any thing you want to bring before review
09:35:57 <blancos> gmann No I don't think so
09:36:14 <blancos> gmann Besides that spec :)
09:36:22 * gmann blancos seems changed irc name was searching with sblancos :)
09:36:29 <andreaf> blancos: but a NIT - I think we should have a patrole folder in there
09:36:32 <gmann> blancos: ok
09:36:42 <gmann> andreaf: good catch
09:36:56 <blancos> andreaf In the qa-specs repo?
09:37:05 <andreaf> yes
09:37:29 <andreaf> it's not really important, I though it would be nice to have
09:37:32 <gmann> blancos: yea like devstack has one- https://github.com/openstack/qa-specs/tree/master/specs
09:38:12 <blancos> andreaf gmann Okay, will do. And I agree, it keeps everything much neater
09:38:13 <chandankumar> that would be better, otherwise people will get confused whether the spec is for temepst or othere
09:38:43 <gmann> andreaf:  blancos: ok, we can do in same patch only. right
09:38:50 <gmann> chandankumar: yea
09:39:35 <gmann> #action blancos to propose new patrole spec with separate folder in qa-specs
09:39:49 <gmann> anything else on spec
09:39:54 <gmann> 20 min left
09:40:33 <gmann> #topic Tempest
09:40:35 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:41:00 <gmann> andreaf: thanks - https://review.openstack.org/#/c/465897/
09:41:00 <patchbot> patch 465897 - tempest - DNM Throughaway patch to test ssh validation
09:41:30 <gmann> i have 1 thing on tempest about cinder v3 tests and clients
09:41:49 <gmann> i saw some of the patches proposing the same client for v3 tests
09:42:29 <gmann> but we do not want to have duplicate clients
09:42:39 <gmann> i think we discussed it before also
09:42:52 <andreaf> right we need to connect the folks doing the work
09:43:06 <gmann> so what i want to know/track is how far are we from that merge
09:43:23 <andreaf> gmann: perhaps we could have an open etherpad for things like service clients or schemas
09:43:29 <gmann> andreaf: oomichi was working on that. but not sure the progress
09:43:57 <gmann> andreaf: yea, i have do for schema after simple spec. planed for next month
09:44:17 <andreaf> gmann: so that people sign up their name there and we can help avoiding conflict
09:44:18 <andreaf> that only works if it is advertised properly though
09:44:21 <gmann> oomichi: any etherpad you have for cinder client merge? where people can help
09:44:25 <andreaf> gmann: that would help thank you
09:44:34 <gmann> yea
09:45:10 <gmann> Bug Triage:
09:45:12 <gmann> #link https://etherpad.openstack.org/p/pike-qa-bug-triage
09:45:25 <gmann> andreaf: your turn this week
09:45:26 <andreaf> gmann: it was me this week
09:45:53 <andreaf> I've not done much tbh - I've not seen much coming in either, I will try to smash some bugs today and tomorrow
09:46:11 <andreaf> so nothing else to report
09:46:14 <gmann> andreaf: thanks
09:46:35 <gmann> next week is mine turn.
09:46:57 <gmann> #topic Patrole
09:47:08 <gmann> #link https://review.openstack.org/#/q/project:openstack/patrole
09:48:06 <gmann> seems like blancos is offline
09:48:19 <gmann> so there is first release going on for patrole
09:48:43 <gmann> #link https://review.openstack.org/#/c/463578/
09:48:44 <patchbot> patch 463578 - releases - Release Patrole 0.1.0
09:49:07 <gmann> and before that release notes were needed #link https://review.openstack.org/#/c/464072/
09:49:07 <patchbot> patch 464072 - patrole - Prepare release notes for release 0.1.0
09:49:34 <gmann> once patrole patch is merged, use that commit as release one
09:49:43 <andreaf> gmann: ah good, I will review those two
09:49:54 <gmann> andreaf: nice, that will help them. thanks
09:50:34 <gmann> anything else on patrole ?
09:51:15 <gmann> #topic DevStack
09:51:42 <andreaf> gmann: I think the 'not fully stable' was meant for the library part of patrole - that is not there yet :
09:51:43 <andreaf> :)
09:51:53 <andreaf> so as a message that there is no stable API yet
09:52:14 <andreaf> i.e. there is no guarantee of backward compatibility on patrole common classes yet
09:52:25 <andreaf> I think it would be good to clarify that in the release notes
09:52:52 <gmann> humm, but there is no lib things in patrole yet
09:53:25 <gmann> i mean the framework they have is stable. as they asked to add that in tempest lib initially
09:53:59 <gmann> felipe reply was "Not "fully stable" means that we're not done enhancing it"
09:54:39 <gmann> anyways let's review on patch, 5 min left
09:54:46 <andreaf> gmann: ok
09:54:54 <andreaf> can we jump to the last topic?
09:54:57 <gmann> on devstack, ssh things already discussed
09:55:11 <gmann> i will review that once tempest patch results
09:55:27 <gmann> andreaf: anything else on devstack ?
09:55:48 <andreaf> nope - I would like to skip the the last two bullets in the agenda if that's ok
09:56:08 <gmann> doc and open one ?
09:56:25 <andreaf> Metting changes proposal
09:56:42 <gmann> ok
09:56:51 <andreaf> I wanted to propose to move this meeting to either 8:00 or 8:30 UTC
09:56:55 <gmann> let's jump to Open
09:57:00 <gmann> andreaf: yea go ahead
09:57:26 <gmann> m +1 on 8 or 8.30
09:57:31 <andreaf> which will make it easier for contributors in China TZ to join
09:57:35 <gmann> andreaf: you want voting
09:57:55 <andreaf> I will send an email to the LM
09:57:57 <andreaf> ML
09:58:05 <chandankumar> andreaf: for us also this time suits for meeting
09:58:06 <andreaf> but I wanted to know if there is strong opposition
09:58:19 <andreaf> chandankumar: cool
09:58:22 <gmann> andreaf: cool, thatnks
09:58:26 <gmann> zhufl:  ?
09:58:42 <gmann> #action andreaf to propose new meeting time on ML
09:58:56 <andreaf> also you have seen on the ML the mail proposing zhufl for core
09:59:14 <gmann> yup.
09:59:29 <andreaf> afazekas, sdague and jordanP have not voted yet so I will keep the pool open a bit longer
09:59:40 <gmann> ok
09:59:48 <gmann> 1 min left anything else anyone want to discuss
10:00:06 <chandankumar> and tempest-plugin-sanity gate again failed
10:00:10 <andreaf> I look forward to having a new core member soon :)
10:00:16 <gmann> let's move to qa channel
10:00:21 <gmann> thanks all
10:00:24 <gmann> #endmeeting