17:00:29 <andreaf> #startmeeting qa
17:00:30 <openstack> Meeting started Thu Jun 8 17:00:29 2017 UTC and is due to finish in 60 minutes. The chair is andreaf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:33 <openstack> The meeting name has been set to 'qa'
17:00:57 <andreaf> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_Jun_8th_2017_.281700_UTC.29 Today's agenda
17:01:07 <andreaf> who's here for the meeting today?
17:01:19 <hogepodge> o/
17:01:19 <felipemonteiro__> o/
17:01:26 <blancos> o/
17:01:58 <dustins> \o
17:02:01 <raildo> o/
17:02:21 <chandankumar> \o/
17:02:52 <andreaf> nice we have a good attendance today :)
17:03:12 <andreaf> ok let's start
17:03:46 <andreaf> I just wanted to mention again that zhufl joined tempest core - welcome to the team!
17:03:58 <andreaf> #topic Meeting time
17:04:40 <andreaf> about the meeting I created a patch in irc-meetings to move the 9:00 UTC one to 8:00 UTC, mostly to help folks in APAC
17:04:54 <andreaf> Next week will be the first meeting on the new time
17:05:02 <andreaf> no change to this meeting at 17:00 UTC
17:05:37 <andreaf> #topic Previous Meeting Action review
17:05:40 <chandankumar> andreaf: new timing is going to early for me in afternoon :-)
17:06:15 <andreaf> chandankumar: hopefully that helps ^_^
17:07:25 <andreaf> The only action item from last meeting was to try and setup a rota for the categorization work on the recheck page
17:07:40 <andreaf> I haven'd done that yet, so I will set an action again
17:07:59 <andreaf> #action andreaf send an email about classification rota and mentoring
17:08:08 <andreaf> #topic PTG
17:09:17 <andreaf> For the PTG it's still some time to go, but I think the structure is pretty much going to be now to what Thierry proposed
17:09:50 <andreaf> If you see something does not work for you with the current plan please speak now, later it will become more and more difficult to change things
17:10:23 <dustins> Remind me, what are the dates for the PTG?
17:10:38 <andreaf> Sept 11 to 15 I believe?
17:10:43 <andreaf> in Denver
17:11:21 <andreaf> it's going to be 2 + 3, the initial 2 days for working groups and help rooms for horizontal teams
17:11:44 <andreaf> 3 days for project dedicated spaces, including QA
17:12:20 <dustins> andreaf: Awesome, thanks!
17:12:24 <andreaf> dustins: will you be there?
17:12:39 <dustins> I believe Manila is not attending the PTG, in favor of a virtual one this time around
17:12:53 <dustins> And the possibility of doing design sessions at the Summits in the future
17:13:00 <dustins> So I honestly don't know
17:13:07 <andreaf> ok
17:13:36 <chandankumar> same here.
17:13:55 <andreaf> design sessions at the summit sounds like the old model
17:14:03 <chandankumar> andreaf: but i will let you know my status in advance. :-)
17:14:34 <dustins> andreaf: Yeah... There are some good reasons, the big ones being overlap with Cinder sessions and including more of our APAC contributors
17:14:53 <andreaf> heh right makes sense
17:15:01 <dustins> Still kinda feels like going rogue, but at least there's a good reasoning :)
17:15:31 <andreaf> dustins: it's not so easy to get to Denver from outside the US I guess - it's going to take me to layovers to get there
17:16:05 <dustins> andreaf: Yeah, that's a haul for sure
17:16:40 <andreaf> ok moving on
17:16:48 <andreaf> #topic Gate stability
17:17:55 <andreaf> A couple of weeks ago the categorization rate was really low as clarkb pointed out - it's a bit better now but still below 50% for gate-tempest-dsvm-neutron-full-ubuntu-xenial
17:18:21 <andreaf> So that's something we need to get better at - I have to send out an email for that (see action point)
17:18:50 <andreaf> Otherwise I'm not aware of any major issue going on right now
17:19:31 <clarkb> I've been throwing patches at it. I think mriedem and sdague too which has helped
17:20:18 <andreaf> clarkb, mriedem, sdague: thanks!
17:20:34 <andreaf> clarkb: e-r patches?
17:20:55 <clarkb> yes
17:21:25 <clarkb> there have also been a few bugs that caused a bunch of gate fails that got fixed quickly (libssl-dev and a nova thing) that aren't being tracked properly IO don't think
17:21:56 <andreaf> #link https://review.openstack.org/#/c/471304/ sdague has a patch up to add a script to e-r to create a boiler plate for new bugs that looks handy to me
17:22:50 <andreaf> #link https://goo.gl/ptPgEw Gate failure rate
17:23:09 <andreaf> clarkb: there were a couple of spikes in the rolling avg, I guess the bugs you mentioned
17:24:09 <andreaf> ok anything else on gate stability?
17:24:32 <andreaf> #topic Spec reviews
17:24:47 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z open specs
17:25:59 <andreaf> I don't have anything specific on specs
17:26:23 <andreaf> ok I guess next topic
17:26:29 <andreaf> #topic Tempest
17:26:39 <andreaf> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open Open Patches
17:27:08 <andreaf> Anything on Tempest anyone?
17:27:58 <felipemonteiro__> minor question i was wondering whether test_change_admin_password is run anywhere, couldn't find a gate that didn't skip it
17:28:44 <andreaf> felipemonteiro__: not sure, I think it may require xen to work
17:28:54 <andreaf> felipemonteiro__: we can check in openstack-health
17:29:07 <felipemonteiro__> k ill do that, thanks
17:30:58 <andreaf> ok I don't have anything specific on Tempest this week, so let's move on
17:31:09 <andreaf> #topic Patrole
17:31:24 <andreaf> There are a few points here from you felipemonteiro__ - the floor is yours
17:31:57 <felipemonteiro__> few questions were reserved for gmann, i'll skip those.
17:32:30 <felipemonteiro__> was wondering qa's thoughts on backwards-compatible gates, i.e. for n-1 n-2 in patrole
17:33:40 <felipemonteiro__> which is what tempest currently does with its newton and ocata gates
17:33:56 <andreaf> felipemonteiro__: I think it would be good to have
17:34:12 <andreaf> felipemonteiro__: it might be a pain for the work policy in code, but it will help discover deviations in behaviour
17:34:50 <andreaf> felipemonteiro__: Patrole is branchless right?
17:35:05 <felipemonteiro__> andreaf: yes our 0.1.0 release is just a tag, not a branch
17:35:59 <andreaf> felipemonteiro__: so from my POV setting up those gates is the right thing to do
17:36:22 <felipemonteiro__> andreaf: regarding the n-1/n-2 gates, those were my thoughts, though it'd require a bit of research from our own to see how much policy has changed (i don't mean policy in code, just policy definitions/naming)
17:37:04 <felipemonteiro__> which i don't *think* has been too much
17:38:01 <andreaf> felipemonteiro__: right, well since patrole did not run on older release you may want to introduce those gates incrementally i.e. as soon as we start working on Queens setup the N-1 and when Rocky starts setup N-2
17:38:29 <andreaf> felipemonteiro__: but if it works as is I think it's fine to introduce them both now
17:39:07 <felipemonteiro__> andreaf: my management would prefer now just because they want to run patrole master against newton release, but wanted your input first
17:40:15 <andreaf> felipemonteiro__: well if it works as is I guess it will be fine, but you'll need to discuss this with the stable maintenance team as well since it would require adding the patrole job to stable/ocata and stable/newton
17:40:26 <andreaf> otherwise changes there might break patrole gate
17:40:43 <andreaf> unlikely as it is, I think it would be the right thing to do
17:40:47 <andreaf> felipemonteiro__: ^^^
17:41:16 <felipemonteiro__> andreaf: i see, thanks we'll look into that.
17:41:41 <felipemonteiro__> that's it from me, other items were targetted at ken'ichi/gmann but they're not here this week
17:41:56 <andreaf> felipemonteiro__: oh wait, Patrole tests run only in Tempest gate for now, right?
17:42:29 <andreaf> heh gmann will never be in the 17UTC meeting :)
17:42:29 <felipemonteiro__> andreaf: you alluding to symmetric testing? they only run in our repo right now
17:42:34 <felipemonteiro__> oh, i see
17:43:00 <andreaf> felipemonteiro__: right thst's what I meant
17:43:28 <andreaf> felipemonteiro__: so you will not necessarily need gates on stable branches
17:44:08 <andreaf> felipemonteiro__: however if something does not work as is you'll have to make a good case to get things changed in Newton :)
17:45:00 <felipemonteiro__> andreaf: thanks for the information, your other plan of incrementally introducing it in the future might be a better alternative, we'll have to do some research
17:45:24 <felipemonteiro__> i did add a nova spec for patrole gating targetted at queens release, i'll see how that goes
17:45:55 <andreaf> #link https://review.openstack.org/#/c/471145/ Nova spec for policy testing
17:46:00 <andreaf> felipemonteiro__: cool thanks
17:46:05 <andreaf> ok moving on
17:46:20 <andreaf> #topic outreachy
17:46:41 <raildo> it will be a quickly one :)
17:47:20 <raildo> so, I would like to introduce you folks, lwanderley, she is an intern in the outreachy cycle: https://wiki.gnome.org/Outreachy/2017/MayAugust#Accepted_Participants
17:47:26 <raildo> #link https://wiki.gnome.org/Outreachy/2017/MayAugust#Accepted_Participants
17:47:43 <lwanderley> hi, everyone :D
17:47:56 <andreaf> welcome lwanderley!
17:47:58 <raildo> and I'm and rodrigods( I think you know him, more than me :P) will be her mentors
17:48:17 <raildo> so the idea is to having a new job to test keystone with LDAP support
17:48:48 <raildo> we already have some functional tests for this case, but we need to fix a couple of things on devstack support for LDAP and creating this job
17:49:31 <raildo> so, she might be around the #openstack-qa asking for helping some times :)
17:50:19 <raildo> that's it
17:50:47 <andreaf> we have folks in a lot of different time-zones, so we should be able to help in the openstack-qa channel :)
17:51:01 <raildo> ++
17:51:26 <andreaf> devstack folks are mostly in the US so that should be a good fit
17:51:37 <lwanderley> that's great
17:51:53 <raildo> andreaf, yeah, it's closer to our time zone, so it will be great for us
17:52:57 <andreaf> ok, about 8 minutes left in the meeting
17:53:21 <andreaf> moving to the last few topics
17:53:24 <andreaf> #topic Critical reviews
17:53:55 <andreaf> any review that requires urgent attention?
17:54:45 <andreaf> #topic Open Discussion
17:56:05 <andreaf> ok I'll give you back five minutes of your life ^_^
17:56:13 <andreaf> thanks for joining the meeting today
17:56:20 <felipemonteiro__> ty
17:56:20 <andreaf> #endmeeting