08:00:17 <gmann> #startmeeting qa
08:00:18 <openstack> Meeting started Thu Jun 15 08:00:17 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:21 <openstack> The meeting name has been set to 'qa'
08:00:29 <chandankumar> gmann: hello
08:00:30 <gmann> who all here today?
08:00:39 <zhufl> hello
08:00:40 <blancos> o/
08:00:51 <pradeepkumarks> hello
08:01:41 <gmann> new time and happy to see more people :)
08:01:48 <masayukig> o/
08:01:49 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_Jun_15th_2017_.280800_UTC.29
08:01:50 <zhufl> thanks for making the meeting time an hour earlier, now it's 4 PM in China:)
08:01:56 <gmann> ^^ today agenda
08:02:17 <prateek> o/
08:02:28 <gmann> zhyes, 5 for me and i can join dinner with masayukig and mtreinish due to that :)
08:02:58 <gmann> #topic Previous Meeting Action review
08:03:21 <gmann> there was 1 action for andreaf  - #link http://eavesdrop.openstack.org/meetings/qa/2017/qa.2017-06-08-17.00.html
08:03:27 <gmann> and he sent mail for that
08:03:38 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118283.html
08:03:50 <gmann> nice idea about keep monitoring the gate issues
08:04:08 <gmann> hope everyone saw the mail
08:04:54 <masayukig> yeah, I had a glance, but re-read it later..
08:04:59 <gmann> there is rotation things for gate issue categorization like bug triage
08:05:07 <gmann> #link https://etherpad.openstack.org/p/pike-gate-issue-categotisation
08:06:07 <masayukig> gmann: ok, I'll put my names later
08:06:14 <gmann> no one yet assigned the slots but as andreaf mentioned we encourage new people to start taking those tasks and we can provide mentorship program also
08:06:20 <gmann> masayukig, thanks +1
08:06:55 <gmann> may be few initial week we can do to give a glance of what needs to be done and how to report
08:07:42 <zhufl> maybe I can have a try, and I need guidance:)
08:07:58 <gmann> zhufl, sure. it will be nice
08:08:34 <gmann> so start putting your name on etherpad for the slot you want
08:09:02 <zhufl> ok, I'll put my names later
08:09:11 <masayukig> cool!
08:09:16 <gmann> #topic PTG
08:09:37 <gmann> this is just reminder about PTG schedule out #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/117369.html
08:10:07 <gmann> start preparing about it (mainly budget from company :)).
08:10:29 <zhufl> I haven't got my visa still
08:10:55 <masayukig> :(
08:10:55 <gmann> zhufl, you applied and waiting for visa approval or it is rejected ?
08:11:22 <zhufl> 4 months passed, it is pending,' administrative processing'
08:11:36 <gmann> zhufl, ohh, thats not good
08:11:51 <masayukig> zhufl: you should ask the administrator(?) again..
08:12:18 <gmann> zhufl, one of my colleague had same issue and asked to return passport as travel was near and they issues 1 year visa for him
08:12:28 <chandankumar> gmann: masayukig for visa, we need letter from where can i get it for ptg?
08:12:34 <gmann> zhufl, masayukig yea may be checking with them again will help
08:12:48 <gmann> chandankumar, there is link in that mail to request IL
08:12:53 <zhufl> oh, I 'll try
08:13:13 <zhufl> one of my colleague has the same situation with me
08:13:22 <gmann> chandankumar, from india it is little bit difficult so try to make your application strong
08:13:35 <gmann> hope you all get visa.
08:13:59 <zhufl> maybe travel visa is better
08:14:03 <chandankumar> hope for best :-)
08:14:25 <gmann> zhufl, yea, i also have business visa and good for conf etc
08:14:29 <gmann> #topic Gate Stability - status update
08:14:40 * masayukig doesn't need visas, actually even if I go to China..
08:15:05 <gmann> gate seems stable now a days and did not find much issue if i have not missed any
08:15:22 <gmann> #link https://goo.gl/ptPgEw
08:16:08 <gmann> anyone aware of any critical issue?
08:16:51 <chandankumar> gmann: http://logs.openstack.org/74/473774/5/check/gate-tempest-python27-ubuntu-xenial/0af018f/console.html
08:16:52 <gmann> #link http://status.openstack.org/elastic-recheck/data/integrated_gate.html
08:17:06 <chandankumar> added recheck let me see if it agains fail
08:17:39 <gmann> chandankumar, humm
08:18:22 <chandankumar> sorry ignore
08:18:59 <gmann> chandankumar, means?
08:19:52 <chandankumar> gmann: on one of my review, it got failed, i added recheck, if it again fails, i will let you know
08:20:18 <masayukig> chandankumar: the test case looks not good..
08:20:19 <gmann> chandankumar, but strange failure. ok let's check it later
08:21:28 <gmann> let's move to next topic
08:21:30 <masayukig> yeah
08:21:32 <gmann> @topic Specs Reviews
08:21:36 <gmann> #topic Specs Reviews
08:22:09 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
08:22:51 <gmann> blancos, i need to check this, was away last week - #link https://review.openstack.org/#/c/461140/
08:22:51 <patchbot> patch 461140 - qa-specs - RBAC testing multiple policies
08:22:56 <gmann> ll try to check this
08:23:06 <blancos> gmann Okay, thank you :)
08:23:45 <gmann> masayukig, your spec is +A   :) #link https://review.openstack.org/#/c/471623/
08:23:46 <patchbot> patch 471623 - qa-specs - Update document theme
08:24:00 <masayukig> gmann: heh, thanks!
08:24:31 <gmann> we need to make HA testing moving as it seems stuck #link https://review.openstack.org/#/c/443504/
08:24:32 <patchbot> patch 443504 - qa-specs - Added spec for high availability testing
08:24:48 <gmann> i will check with samP if he need any help on this
08:24:49 <samP> gmann: hi..
08:25:11 <gmann> #action gmann to check with samP about HA testing spec
08:25:17 <samP> I will update it.. now working on it
08:25:19 <gmann> samP, hi, you are here
08:25:33 <samP> gmann: hi o/
08:25:38 <gmann> samP, thanks, i will review on revised version.
08:25:49 <samP> I was working with LCOO on this.
08:25:54 <samP> #link https://openstack-lcoo.atlassian.net/wiki/display/LCOO/Working+Space+for+Exteme+Testing+and+related+topics
08:25:57 * gmann do not know how to undo action
08:26:21 <samP> gmann: its ok, leve it..:)
08:26:45 <samP> gmann: you can mark it done on next meeting :)
08:27:01 <prateek> samP, can i help in implementing this ?
08:27:17 <samP> prateek: That will be great..
08:27:17 <blancos> (gmann: I think it's (#)undo action)
08:27:26 <prateek> samP, thanks
08:27:33 <gmann> samP, nice, what is that LCOO ?
08:27:43 <samP> ah..
08:27:58 <gmann> prateek, thanks. its great.
08:28:03 <masayukig> blancos: oh, I didn't know that :)
08:28:09 <samP> #link https://wiki.openstack.org/wiki/LCOO
08:28:40 <gmann> #undo action
08:28:41 <openstack> Removing item from minutes: #link https://wiki.openstack.org/wiki/LCOO
08:28:54 <gmann> oh no
08:28:57 <masayukig> heh
08:29:00 <gmann> #link https://wiki.openstack.org/wiki/LCOO
08:29:11 <gmann> samP, thanks a lot, i will check
08:29:54 <gmann> anything else on spec?
08:30:12 <samP> gmann: I will update the spc asap, so we can move forword
08:30:26 <gmann> samP, cool\, thanks.
08:30:35 <samP> gmann: np
08:30:43 <gmann> #topic Tempest
08:30:56 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
08:31:15 <zhufl> https://review.openstack.org/#/c/467483/
08:31:16 <zhufl> can we use resource_type defined in clients to assemble show method/delete method, like "show_" + resource_type?
08:31:16 <patchbot> patch 467483 - tempest - Refactor is_resource_deleted method
08:32:10 <gmann> zhufl, i did not get completely
08:32:31 <zhufl> masayukig: do you get it?
08:32:44 <masayukig> zhufl: you mean making a method dynamically?
08:32:52 <zhufl> yes
08:33:00 <gmann> zhufl, i see, i prefer not to do that, thats too much magic
08:33:23 <masayukig> zhufl; gmann: yeah, I agree with gmann.
08:33:30 <zhufl> but if not, we have to add a method in every client
08:33:31 <gmann> zhufl, we had in neutron clients which were hard to debug so we moved to plain method mapping
08:33:58 <blancos> I had a question about #link https://review.openstack.org/#/c/457876
08:33:58 <patchbot> patch 457876 - tempest - Add token related API to Keystone v3-ext/OS-OAUTH1...
08:34:00 <zhufl> gmann: no, I don't mean the same as neutron ever did
08:34:20 <chandankumar> I have moved tempest plugin sanity check code from project config to tempest https://review.openstack.org/474164
08:34:21 <patchbot> patch 474164 - tempest - Added script for doing tempest plugin sanity
08:34:33 <chandankumar> feedback are welcome to improve it
08:34:52 <masayukig> zhufl: gmann: but I can try to think that. Or zhufl, you can take over it, if you want :)
08:35:08 <gmann> zhufl, i think having explicit method in each client much better but i will check that patch tomorrow.
08:35:24 <gmann> blancos, go ahead
08:35:27 <blancos> Is this something that would belong in Tempest or Keystone's Tempest plugin?
08:35:35 <gmann> chandankumar, 1 min please, next turn yours
08:35:41 <chandankumar> ack
08:36:52 <gmann> blancos, is it for patrole testing?
08:37:17 <hemanth> it is for patrole as well as keystone tempest plugin funtional tests
08:37:39 <blancos> gmann: I believe there are 1 or 2 commits dependent on it (as hemanth mentioned)
08:38:08 <gmann> hemanth, ok, and no API test in tempest for that? as it can be covered in keystone plugin right?
08:38:46 <chandankumar> just one query if we have a tempest plugin for core project what tests will stay in tempest and what in tempest plugin?
08:38:48 <hemanth> gmann: another patch is submitted for tempest api as well
08:39:03 <gmann> blancos, hemanth ok, we can have in tempest like other keystone clients no issue as patrole need it
08:39:34 <hemanth> gmann: can core team review the patch.. since last one month i am just rebasing :-)
08:39:51 <gmann> blancos, can patrole consume clients from plugin?
08:40:16 <gmann> hemanth, ohk, apologies for that. i will check that.
08:40:43 <gmann> blancos, just a thought for future things but we can think later after meeting
08:40:46 <blancos> gmann: We talked with andreaf about it and he didn't really like the idea
08:41:06 <gmann> blancos, about consuming client from plugin?
08:41:11 <masayukig> chandankumar: I think scenario tests and defcore tests will stay at least.
08:41:13 <blancos> gmann: Correct
08:41:23 <gmann> blancos, ok, make sense.
08:41:29 <gmann> blancos, hemanth i will check that patch
08:41:31 <gmann> chandankumar, go ahead
08:41:43 <hemanth> gmann: thanks
08:41:47 <pradeepkumarks> gmann: on similar lines, we have federation APIs whose clients are implemented in plugin(keystone)
08:41:59 <gmann> hemanth, np!
08:42:00 <pradeepkumarks> and hence patrole won't be able to consume those clients
08:42:11 <chandankumar> i have moved tempest plugin sanity check code from project config to tempest with some more improvement, https://review.openstack.org/474164
08:42:12 <patchbot> patch 474164 - tempest - Added script for doing tempest plugin sanity
08:42:24 <gmann> pradeepkumarks, ok, i think we had federation APIs thing earlier also
08:42:31 <chandankumar> please have a look and more feedback to improve
08:42:52 <gmann> pradeepkumarks, it should be configured globally right from devstack side
08:43:31 <pradeepkumarks> gmann: https://review.openstack.org/#/c/473458/
08:43:31 <patchbot> patch 473458 - tempest - Implement tempest client for keystone v3 identity_...
08:43:44 <gmann> chandankumar, you are adding  script to intall plugins in tempest right?
08:43:56 <masayukig> chandankumar: thanks for the updating, I'll have a look tomorrow :)
08:43:58 <pradeepkumarks> i mean since the client is already implemented in keystone plugin, we can't let patrole consume it
08:44:24 <gmann> pradeepkumarks, do you have patch up for that?
08:44:33 <chandankumar> gmann: yes, install one project then run sanity then uninstall and again repeat for others
08:44:53 <chandankumar> if at any step it fails, the script will exist
08:44:59 <pradeepkumarks> gmann: patch up for?
08:45:01 <gmann> chandankumar, ok. make sense. thanks, i will add that in queue
08:45:18 <chandankumar> gmann: i have also improved tempest plugin list script
08:45:40 <gmann> pradeepkumarks, putting federation APIs client in tempest or you want feedback first
08:45:42 <chandankumar> gmann: related patch https://review.openstack.org/#/c/473774/
08:45:43 <patchbot> patch 473774 - tempest - Fixed project lists for retrieving tempest plugins
08:45:51 <chandankumar> that's it from myside
08:45:58 <chandankumar> masayukig: gmann thanks :-)
08:45:58 <gmann> chandankumar, i saw that, should be quick.thanks
08:46:44 <pradeepkumarks> gmann: https://github.com/openstack/keystone-tempest-plugin/blob/master/keystone_tempest_plugin/services/identity/v3/identity_providers_client.py
08:47:10 <masayukig> I have one thing: https://review.openstack.org/#/c/471352/
08:47:11 <patchbot> patch 471352 - tempest - Revert "Check image after unshelve"
08:47:20 <pradeepkumarks> this is the identity_providers_client which is already there in keystone_tempest_plugin. we wanted to implement patrole testcases for these APIs
08:47:31 <gmann> pradeepkumarks, if tests and usage only in plugin then client should be plugin side only but here as you mentioned patrole need it right?
08:47:44 <pradeepkumarks> gmann: yes
08:48:09 <pradeepkumarks> gmann: patrole testcases cannot be implemented otherwise
08:48:31 <gmann> pradeepkumarks, as blancos mentioned same case for other client also, we can take same approach for your case also
08:48:52 <gmann> blancos, hemanth are those clients present in plugin side also - https://review.openstack.org/#/c/457876
08:48:52 <patchbot> patch 457876 - tempest - Add token related API to Keystone v3-ext/OS-OAUTH1...
08:49:19 <pradeepkumarks> gmann: incase of blancos, client wasnt already implemented at all
08:49:20 <pradeepkumarks> gmann: not present in plugin either
08:49:56 <gmann> masayukig, thanks, interesting. i thought checking image is fine after unshelve from nova point of view
08:50:02 <gmann> masayukig, ll check this
08:50:11 <gmann> pradeepkumarks, ok.
08:50:30 <pradeepkumarks> gmann: in federation api case, we will need to add the same client (which is in keystone_tempest_plugin) into tempest as well
08:50:37 <pradeepkumarks> gmann: should we do that?
08:51:05 <blancos> pradeepkumarks: The consensus so far has been no Patrole tests for clients in plugins
08:51:09 <gmann> pradeepkumarks, it will be duplicate. if tempest going to have those then we can remove from plugin
08:51:23 <masayukig> gmann: thanks.
08:51:33 <masayukig> 9 mins
08:51:46 <pradeepkumarks> gmann: ok
08:52:06 <pradeepkumarks> gmann: we can remove those client from plugin instead of duplicating..if we have consensus
08:52:07 <gmann> pradeepkumarks, blancos let me think on this and we all can discuss the best way.
08:52:30 <gmann> pradeepkumarks, sure, ll let you know
08:52:38 <gmann> let's move
08:52:44 <pradeepkumarks> gmann: sure, thanks
08:52:51 <gmann> pradeepkumarks, np!
08:52:54 <gmann> Bug Triage & Integrated gate issue categorization:
08:53:06 <gmann> thsi we already discussed in starting.
08:53:13 <gmann> #topic Patrole
08:53:24 <gmann> #link https://review.openstack.org/#/q/project:openstack/patrole
08:53:37 <gmann> blancos, any updates or anything to discuss
08:53:46 <blancos> Not in the Patrole repo, but we currently have a spec in Nova for Patrole gates: #link https://review.openstack.org/#/c/471145
08:53:47 <patchbot> patch 471145 - nova-specs - Patrole (RBAC) Nova Gating
08:54:10 <blancos> Would appreciate QA's input/eyes :)
08:54:39 <gmann> blancos, i see, but not sure it need spec :). i will check. i like to gate patrole on nova.
08:55:12 <gmann> blancos, but need more feedback from johnthetubaguy
08:55:12 <blancos> gmann: Okay, thank you
08:55:20 <gmann> i will bring this on nova api meetin also
08:55:24 <gmann> meeting
08:55:49 <gmann> alex_xu, good for policy testing  - https://review.openstack.org/#/c/471145
08:55:50 <patchbot> patch 471145 - nova-specs - Patrole (RBAC) Nova Gating
08:56:05 <gmann> Keystone tempest clients porting to Tempest project
08:56:11 <gmann> pradeepkumarks, this is same we discussed right?
08:57:01 <gmann> Welcome lwarderley, an intern in the Outreachy program. ping us anytime for any help
08:57:03 <uk310y> gmann: Correct !That is what pradeep discussed now.
08:57:13 <gmann> uk310y, thanks.
08:57:30 <uk310y> gmann, thanks :)
08:57:47 <gmann> #action gmann to discuss plugin clients in tempest with team and get consensus
08:57:50 <gmann> let me put action item
08:57:55 <gmann> #topic Critical Reviews
08:58:00 <gmann> 3 min left
08:58:18 <gmann> any more critical review, i think discussed lot
08:58:36 <gmann> let's skip the documentation
08:58:41 <masayukig> heh, yeah
08:58:42 <gmann> #topic Open Discussion
08:58:51 <gmann> 2 min left for open discussion
08:58:59 <masayukig> 1 min..
08:59:05 <gmann> :)
08:59:14 <zhufl> it's first time for me to stay until the end of the meeting:)
08:59:26 <gmann> zhufl, good for us also :)
08:59:27 <masayukig> great!
08:59:44 * gmann really happy to see many people in meeting
08:59:54 <masayukig> gmann: +1
08:59:59 <gmann> thanks all for joining.
09:00:01 <gmann> #endmeeting