08:00:01 <gmann> #startmeeting qa
08:00:01 <openstack> Meeting started Thu Jun 29 08:00:01 2017 UTC and is due to finish in 60 minutes. The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:04 <openstack> The meeting name has been set to 'qa'
08:00:10 <gmann> hi, who all here today?
08:00:13 <prateek> o/
08:00:14 <afazekas> hi
08:00:14 <chandankumar> gmann: \o/
08:00:15 <blancos> o/
08:00:42 <zhufl> hi
08:01:20 <martinkopec> o/
08:01:20 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_June_29th_2017_.280800_UTC.29
08:01:25 <gmann> ^^ today agenda
08:01:26 <ltosky[m]> o/
08:01:55 <gmann> #topic Previous Meeting Action review
08:01:57 <masayukig> o/
08:02:06 <gmann> #link http://eavesdrop.openstack.org/meetings/qa/2017/qa.2017-06-15-08.00.html
08:02:24 <gmann> gmann to check with samP about HA testing spec
08:02:35 <gmann> we discussed this in last meeting only
08:02:42 <gmann> gmann to discuss plugin clients in tempest with team and get consensus
08:02:47 <gmann> this one i did not check yet
08:03:12 <gmann> anyone knows which patch moving keystone plugin service client to tempest ?
08:03:31 <gmann> we can take that example to decide the strategy on this
08:03:59 <masayukig> gmann: nope
08:04:10 <gmann> ok let me find later
08:04:16 <gmann> i am continuing on this AI
08:04:28 <gmann> #action gmann to discuss plugin clients in tempest with team and get consensus
08:04:37 <chandankumar> gmann: no idea but last night they have remove tempest plugin code from keystone project completely
08:04:38 <gmann> #topic PTG
08:04:55 <gmann> chandankumar, removed?
08:05:12 <chandankumar> gmann: https://review.openstack.org/#/c/471060/
08:05:35 <gmann> chandankumar, it is separate repo - http://git.openstack.org/cgit/openstack/keystone-tempest-plugin
08:05:41 <chandankumar> gmann: as tempest plugin moves to anew repo https://github.com/openstack/keystone-tempest-plugin
08:05:44 <gmann> which is nice
08:05:51 <gmann> yea
08:06:05 <gmann> on PTG
08:06:07 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/117369.html
08:06:45 <gmann> need to check with andreaf if any action item he has to do, room booking etc but we have time for that
08:07:16 <gmann> but all can plan their travel in advance and there is discount for hotel also (~149USD)
08:07:47 <gmann> anything else to discuss or query on PTG
08:08:20 <masayukig> is there any travel support for PTG?
08:08:30 <gmann> masayukig, yes
08:08:59 <gmann> masayukig, #link https://www.openstack.org/ptg#tab_travel
08:08:59 <masayukig> gmann: thanks, cool. I'm actually not sure I'll get the budget, yet.
08:09:08 <gmann> masayukig, you should fill soon
08:09:18 <gmann> i think last date is july 2nd for first round
08:09:39 <afazekas> Where can I see more info about travel support ?
08:09:46 <gmann> budget things is for everyone seems
08:09:56 <gmann> afazekas, here - #link https://www.openstack.org/ptg#tab_travel
08:09:57 <masayukig> gmann: oh, wow, I didn't know that..
08:10:13 <gmann> afazekas, masayukig there is form to fill for requesting travel suppoprt
08:10:38 <masayukig> "July 2, 2017: Final deadline to submit applications for Round One approvals"
08:10:55 <gmann> afazekas, are you planning to come so that i can finally meet you face to face :)
08:10:57 <masayukig> gmann: thanks, I need to do, probably.
08:11:03 <gmann> yea please
08:11:57 <gmann> #topic Gate Stability - status update
08:11:59 <afazekas> gmann, I am planning, I try to not miss the deadlines ..
08:12:10 <gmann> afazekas, nice.
08:12:30 <gmann> gate seems stable #link https://goo.gl/ptPgEw
08:12:43 <gmann> #link http://status.openstack.org/elastic-recheck/gate.html
08:12:59 <gmann> there was issue on newton job which andreaf fixed and merged
08:13:28 <gmann> other was for shelve tests where tests expect image to be deleted immediately after unshelve
08:14:18 <gmann> which failed on ceph but tests expectation was not right and written anywhere, so fixing that in https://review.openstack.org/#/c/477821/
08:15:01 <zhufl> yeah I've left comment on it, it's a good solution
08:15:11 <gmann> zhufl, not sure about yoour comment,
08:15:25 <gmann> anyways let';s discuss after meeting
08:15:31 <zhufl> yeah
08:15:52 <gmann> any other issue/things to discuss on gate stability ?
08:16:46 <gmann> ok, let's move next
08:17:06 <gmann> #topic Specs Reviews
08:17:15 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
08:17:36 <gmann> i did not get time to review spec
08:18:04 <gmann> may be next week i put some in my review queue
08:18:21 <gmann> please review and provide feedback
08:18:50 <masayukig> OK
08:19:25 <gmann> if anyone want to bring or discuss any spec, go ahead
08:20:29 <gmann> let's move if nothing
08:20:31 <gmann> #topic Tempest
08:20:45 <gmann> 2 mailing thread on tempest last week
08:21:33 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118427.html
08:21:50 <gmann> this was not generic issue, it is some tests failing on ceph
08:22:14 <gmann> this time unshelve tests which i mentioned earlier and its tests issue and fix is up
08:22:36 <gmann> but from that mail it seems ceph job still not happy with many tests
08:23:30 <gmann> in previous discussion we agreed on having ceph job skipping the tests which fail on ceph because either feature is not implemented or unstable
08:24:01 <gmann> which is in progress #link https://review.openstack.org/#/c/459774/
08:24:09 <gmann> but not yet merged
08:24:50 <gmann> but now ceph job is all n-v everywhere
08:25:30 <gmann> 2nd mail was tempest plugin scope from chandankumar #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118835.html
08:25:45 <gmann> hope it is clear now about what goes in plugin and what in tempest
08:26:03 <chandankumar> gmann: yes, Thanks for the input :-)
08:26:31 <gmann> i want to ask, do we have well document about Tempest scope (what all tests tempest should have and what all project side etc) ?
08:26:45 <gmann> or we just assume that as we all know the scope in our mind
08:27:00 <gmann> i remember i added the clear scope for microversion tests
08:27:34 <masayukig> gmann: probably, we should have that document.
08:27:34 <gmann> #link https://docs.openstack.org/developer/tempest/microversion_testing.html#tempest-scope-for-microversion-testing
08:27:51 <masayukig> gmann: but, I'm actually not sure that the DefCore test must be in Temepst repo.
08:28:12 <gmann> masayukig, ok, a very simple doc is needed which is always difficult
08:28:13 <chandankumar> gmann: i think we need a doc difference between tests in tempest and tempest plugin for core projects
08:28:53 <masayukig> chandankumar: ++
08:28:57 <chandankumar> gmann: this time there was a defcore thread also regarding tempest tests recently.
08:29:06 <gmann> masayukig, as per TC decision it should be in tempest but as defcore cover more projects as interop that is still undecided
08:29:28 <gmann> chandankumar, +1 that will be nice
08:29:38 <chandankumar> i will take AI on mine
08:29:49 <gmann> chandankumar, great, about to ask you :)
08:30:04 <chandankumar> #action chandankumar to add a doc stating difference between tests in tempest and tempest plugin for core projects
08:30:20 <gmann> chandankumar, thanks
08:30:38 <masayukig> gmann: my understanding is "in tempest" doesn't equal to "in tempest tree".
08:30:52 <gmann> masayukig, for defcore?
08:31:19 <masayukig> gmann: yeah, let me find the ml thread...
08:31:23 <gmann> masayukig, it is not yet decided
08:31:39 <gmann> masayukig, problem will be same either it is tempest tree or another plugin
08:32:11 <gmann> main thing is we need to solve the man power issue to own more and more projects tests under Tempest team
08:33:23 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/117756.html
08:33:31 <gmann> masayukig, this one ^^
08:33:57 <masayukig> gmann: yeah
08:34:01 <gmann> anyways that is future things
08:34:37 <gmann> next is : Bug Triage & Integrated gate issue categorization:
08:34:37 <masayukig> gmann: yeah, fyi, you may know, http://lists.openstack.org/pipermail/openstack-dev/2017-June/117808.html
08:34:56 <gmann> masayukig, yea
08:35:13 <chandankumar> gmann: just one update from tripleo ping test thread, we will be merging these some pieces of two scenario tests into new scenario test in tempest which will implement boot an instance from volume then attach flotaing ip ssh/ping ot it an ddestroy it
08:35:55 <chandankumar> https://github.com/openstack/tempest/blob/master/tempest/scenario/test_volume_boot_pattern.py and https://github.com/openstack/tempest/blob/master/tempest/scenario/test_network_advanced_server_ops.py
08:35:57 <gmann> chandankumar, ok, we do not have any tests doing that?
08:36:02 <masayukig> chandankumar: it seems like test_minimum_basic.py one.
08:36:10 <ltosky[m]> before we move away from the tempest topic: is it time to tag a new tempest, so that projects (plugins) can depend on it?
08:36:31 <chandankumar> gmann: nope, based on my investigation, we need a test for the same
08:36:45 <gmann> ltosky[m], need to check how much we have since 16.0.0
08:36:54 <ltosky[m]> for example there is a deprecation warning about test.attr moved to tempest.lib
08:37:11 <gmann> chandankumar, that can be extended in existing one or you are thinking new one?
08:37:29 <gmann> ltosky[m], i see, attr and related_bug are not yet tagged
08:37:34 <chandankumar> gmann: thinking of a new one,
08:37:47 <chandankumar> gmann: let me get the patch up and we can take it from thetre
08:38:03 <masayukig> chandankumar: ++
08:38:10 <gmann> chandankumar, only "attach flotaing ip ssh/ping" will be extra what we are already doing in volume pattern tests
08:38:19 <ltosky[m]> yep, patches for attr (seen one in the mistral plugin) can't be merged without a new tag
08:38:21 <gmann> chandankumar, yea that will be fine
08:38:28 <chandankumar> gmann: yes
08:39:03 <gmann> ltosky[m], i know i think i have also one for mistral
08:39:05 <gmann> #link https://review.openstack.org/#/c/456823/
08:39:23 <gmann> ltosky[m], ll check with andreaf if there is enough things for new tag
08:39:45 <gmann> #action gmann to check with andreaf about new tag
08:39:58 <ltosky[m]> thanks!
08:40:04 <gmann> let's discuss bug
08:40:26 <gmann> blancos, turn this week
08:40:35 <gmann> #link https://etherpad.openstack.org/p/pike-qa-bug-triage
08:40:52 <gmann> #link https://etherpad.openstack.org/p/tempest-weekly-bug-report
08:41:02 <blancos> I wasn't able to triage the one new bug as it came in a little later yesterday
08:41:03 <gmann> blancos, is this report up to date? ^^
08:41:06 <blancos> Yes
08:41:11 <gmann> blancos, ok
08:41:35 <blancos> There are a few incomplete bugs, but they're currently counting down to expire (except the one to remove Glance v1 tests) since no one is currently working on them
08:41:52 <prateek> we didnt have meeting last week, so bug triage for last week is also yet to be discussed
08:41:54 <gmann> blancos, ok
08:42:26 <gmann> blancos, glance v1 tests yes we need to wait more may be but need to check ML thread before that
08:42:42 <gmann> prateek, oh, please update if you have any key finding
08:43:56 <prateek> gmann, a cinder ceph issue https://bugs.launchpad.net/tempest/+bug/1687533
08:43:57 <openstack> Launchpad bug 1687533 in tempest "Regression issue of adding force delete backup support" [Undecided,Confirmed] - Assigned to Fei Long Wang (flwang)
08:44:15 <prateek> maybe this is the reason the ceph team was talking about failing tempest tests
08:44:58 <gmann> prateek, that is already reverted
08:44:59 <gmann> #link https://review.openstack.org/#/c/461625/
08:45:27 <gmann> mail thread also - #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/116172.html
08:45:33 <prateek> ok, do we have any decorator for skipping a specific test for a particular backend like ceph ?
08:45:35 <gmann> what is issue on this?
08:45:52 <gmann> prateek, not actually and honestly we do not want to do that
08:46:01 <prateek> gmann, ok
08:46:10 <prateek> that was all i wanted to ask with reference to this bug
08:46:40 <gmann> prateek, if you read that mailing thread we should mainly concentrate on mandatory features and if any backend does not implement those then their CI can skip those
08:46:52 <gmann> prateek, ok, thanks for bug triage
08:47:03 <gmann> blancos, thanks for this week triage
08:47:39 <gmann> we have 62 in-progress which is doubtable actually :) we should keep cleaning those
08:48:06 <gmann> mkopec turn next week
08:48:14 <blancos> gmann I noticed some of them are attached to patches that haven't been updated in >6 months
08:48:14 <martinkopec> gmann, ack
08:48:34 <gmann> martinkopec, thanks, you changed your irc name :)
08:49:10 <martinkopec> gmann, sorry, I always forgot that I have a different nic on freenode
08:49:16 <gmann> blancos, yea, not sure what we should do on those, some are really good fix but no progress
08:49:41 <gmann> may be we can unassign such bug so that people can take up even old patches
08:49:50 <gmann> martinkopec, no issue
08:50:03 <gmann> chandankumar, seems like you volunteered for https://etherpad.openstack.org/p/pike-gate-issue-categotisation
08:50:21 <chandankumar> gmann: i didnot worked on this week
08:50:26 <gmann> anything else on tempest (10 min left)
08:50:35 <gmann> chandankumar, your turn is next week
08:50:46 <chandankumar> gmann: i will working on gates this week will catch sdague and mtreinish
08:50:53 <chandankumar> for learning on how to do that.
08:50:59 <gmann> #topic Patrole
08:51:13 <gmann> blancos, your turn
08:51:16 <gmann> chandankumar, sure, thanks
08:51:29 <blancos> gmann Nothing new to report
08:51:31 <gmann> chandankumar, andreaf mentioned in mail about expectation on those
08:51:53 <chandankumar> will take a look gmann
08:51:59 <gmann> blancos, i reviewed the nova spec for gating patrole on nova #link https://review.openstack.org/#/c/471145/
08:52:11 <gmann> i am +1. ll ask matt to check this
08:52:11 <blancos> I saw, thank you :)
08:52:31 <gmann> i forgot to bring this in yesterday nova api meeting, ll add for next week
08:53:03 <gmann> #topic Critical Reviews
08:53:19 <gmann> any critical reviews to bring on priority
08:53:47 <chandankumar> gmann: https://review.openstack.org/477549 need +w
08:54:03 <chandankumar> and followed up https://review.openstack.org/474164
08:54:17 <chandankumar> i need this for speeding up tempest plugin sanity gate
08:54:37 <masayukig> https://review.openstack.org/#/c/478730/ I'd like to know your opinions.
08:54:39 <gmann> chandankumar, ok ll check. did not follow up those though
08:55:00 <gmann> masayukig, ll add my comment after meeting
08:55:09 <masayukig> gmann: thanks :)
08:55:24 <gmann> masayukig, not sure we need to keep release named dire as well release note name also
08:55:25 <prateek> gmann, https://review.openstack.org/#/c/445419/
08:55:51 <gmann> prateek, sure,
08:55:56 <masayukig> gmann: yeah, but I feel the directory is just a mess..
08:55:58 <prateek> gmann, thanks
08:56:13 <gmann> #topic Documentation
08:56:55 <gmann> anything specific to discuss on documentation. one we already covered about scope of tests in tempest and plugin
08:57:37 <gmann> #topic Open Discussion
08:57:40 <gmann> 3 min left
08:57:51 <gmann> anything more to discuss related to anything
08:58:26 <masayukig> related to documentation: https://review.openstack.org/#/c/472275/
08:58:43 <masayukig> https://review.openstack.org/#/c/478546/
08:59:17 <masayukig> We should change the doc directory.
08:59:38 <gmann> masayukig, yea that is global work going on
08:59:39 * asettle waves
08:59:40 <gmann> thanks
08:59:44 <asettle> If you have any questions about docs
08:59:45 <asettle> Lemme know :)
08:59:53 <gmann> asettle, sure, thanks for that
09:00:02 <masayukig> yeah
09:00:16 <gmann> thanks all for joining
09:00:21 <masayukig> Thanks!!
09:00:26 <gmann> it time to close
09:00:28 <gmann> #endmeeting